Subject: [BEHAVE] draft-jpdionne-behave-nat64-mib-00

From: Andrew Sullivan <[email-masked]>
Date: Tue, 29 Mar 2011 11:40:18 -0400

There was some suggestion today that
draft-jpdionne-behave-nat64-mib-00 would need a DNS64 MIB, which would
need a DNS MIB, I guess.

What is it that would be useful about a DNS64 MIB?  The only mention
of DNS64 in the document is that it needs to have the same
configuration as something that would be in the NAT64 MIB anyway.  Is
there some use case for the DNS64 side I'm not seeing?  (That's not a
rhetirical question.  I actually don't know.)

Thanks,

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 29 Mar 2011 17:51:19 +0200

Andrew,
  let rephrase the other way: if a DNS MIB existed and was in used, then 
we would have look at it to see to add the DNS64 specifics. Since no DNS 
MIB exist, then we don't know if there is any value. While we have seen 
support for the NAT64 mib from 2 operators and 3 vendors today, I 
haven't heard any specific support for DNS64. So I guess we will put the 
DNS64 MIB to sleep, unless someone requests it.

Marc.

-- 
=========
IPv6 book: Migrating to IPv6, Wiley. http://www.ipv6book.ca
Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
DTN Implementation: http://postellation.viagenie.ca
NAT64-DNS64 Opensource: http://ecdysis.viagenie.ca

---

From: Merike Kaeo <[email-masked]>
Date: Tue, 29 Mar 2011 08:59:33 -0700

That comment came from me and I really meant the NAT64 (apologies for mis-speaking).  While the environment I am in is doing DNS64/NAT64 I do need to specifically take a look at what MIB variables exist and what would be useful operationally.  I'll start with the existing NAT64 one.

And while I'm commenting, I would personally hate to see private extensions and then see where they all meet.  I still remember the FDDI MIB nightmares with a private one and the later standardized one and trying to figure out which version of the MIB different vendors supported.  Thankfully I met the authors of snmpwalk back then which saved me.  

I doubt I'll get to this in the current week but will try and get some comments on list next week.

- merike

On Mar 29, 2011, at 8:40 AM, Andrew Sullivan wrote:

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave