Subject: [BEHAVE] CGN REQ: Control NAT mappings for inbound communications

From: <[email-masked]>
Date: Tue, 15 Mar 2011 15:28:00 +0100

Re-,

Some applications will fail if port forwarding is not supported. Having a requirement to mandate the support of port forwarding feature would be valuable.

PCP can be listed as a RECOMMENDED solution.

Cheers,
Med

---

From: Benson Schliesser <[email-masked]>
Date: Tue, 15 Mar 2011 14:43:05 -0500

On 3/15/11 8:28 AM, "[email-masked]"
<[email-masked]> wrote:

> Some applications will fail if port forwarding is not supported. Having a
> requirement to mandate the support of port forwarding feature would be
> valuable.
>  

I'm not convinced that a port-forwarding feature ought to be a CGN
requirement.  I'm not opposed to it as a requirement, and I do agree that it
is a desired feature in many cases.  But it is not always a desired feature
for all deployments.  Thus, at this time I believe the requirements draft
ought to capture it as a MAY.

That said, I do agree that PCP should be recommended as the control protocol
for dynamically configured port-forwarding in the event that it is
implemented.

Cheers,
-Benson

---

From: <[email-masked]>
Date: Wed, 16 Mar 2011 07:12:36 +0100

Dear Benson,

I vote for SHOULD instead of MAY. 

If we want to avoid applications brokenness, we need to have this function supported.

Cheers,
Med

-----Message d'origine-----
De : Benson Schliesser [mailto:[email-masked]] 
Envoyé : mardi 15 mars 2011 20:43
À : BOUCADAIR Mohamed OLNC/NAD/TIP; [email-masked]
Cc : 'behave' <([email-masked])>
Objet : Re: [BEHAVE] CGN REQ: Control NAT mappings for inbound communications

Cheers,
-Benson

---

From: Simon Perreault <[email-masked]>
Date: Wed, 16 Mar 2011 09:10:39 -0400

> If we want to avoid applications brokenness, we need to have this function supported.

I would tend to agree. As said in the introduction:

   This document describes behavioural requirements that are to be
   expected of those ISP-controlled NAT devices.  Meeting this set of
   requirements will greatly increase the likelihood that subscribers'
   applications will function properly.

Making PCP a SHOULD would "greatly increase the likelihood that
subscribers' applications will function properly."

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Francis Dupont <[email-masked]>
Date: Wed, 16 Mar 2011 15:28:08 +0100

In your previous mail you wrote:

+1 (but *NOT* for PCP as the *only* RECOMMENDED solution)

Regards

[email-masked]