Subject: [BEHAVE] draft-ietf-behave-lsn-requirements-00

From: Nikolay Melnikov <[email-masked]>
Date: Mon, 14 Mar 2011 13:21:04 +0100

Hello everyone,

I bumped into several statements and (what I consider to be) typos at
my initial read of the document, so I decided not to postpone and
report them.

   "Each LSN occupies combination of LSN external IP address, LSN
external port and LSN external identifier exclusively."

It is not clear what "occupies" means in this case. Along with
"exclusively". Does it mean that each LSN forms a unique combination
of an
 external IP address, port and identifier?

   REQ-2: A LSN MUST allocate LSN external ports which is mapped for CPE
   ports of UDP.

"which are mapped to". Same in REQ-3 and REQ-4

   REQ-5: A LSN MAY have implementations that some specific applications
   can work well <with,> even if each CPE's usable number of LSN external ports
   ha<s> already <been> consumed.

In general, in requirements REQ-1 through REQ-5 "An LSN" combination
should be used as LSN abbreviation starts with a vowel-sounding "L"

   possibility among CPEs which <don's t> have LSN.

   a)It is RECOMMENDED that a NAT <has an><have> "Endpoint-Independent

      Filtering" behaviour.

nik
-- 
Nikolay Melnikov
School of Engineering and Science
Jacobs University Bremen

<http://www.jacobs-university.de/>

---

From: Simon Perreault <[email-masked]>
Date: Mon, 14 Mar 2011 11:35:15 -0400

I think all these have been fixed in the -01 revision that was posted a
few minutes ago...

Thanks,
Simon

On 2011-03-14 08:21, Nikolay Melnikov wrote:
> Hello everyone,
> 
> I bumped into several statements and (what I consider to be) typos at my initial read of the document, so I decided not to postpone and report them. 
> 
> 
> 
> 
> 
>    "Each LSN occupies combination of LSN external IP address, LSN external port and LSN external identifier exclusively."
> 
> It is not clear what "occupies" means in this case. Along with "exclusively". Does it mean that each LSN forms a unique combination of an
> In general, in requirements REQ-1 through REQ-5 "An LSN" combination should be used as LSN abbreviation starts with a vowel-sounding "L"
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca