Subject: [BEHAVE] CGN REQ: Planned maintenance operations

From: <[email-masked]>
Date: Thu, 17 Mar 2011 07:51:11 +0100

Dear all,
 
CGN is a stateful function which (to be) deployed in providers networks. The introduction of this function into operational networks induces constraints on the service availability and its robustness.
 
Because of the stateful nature of this function and in order to meet some operational requirements such as the ability to execute planned maintenance operations (e.g., "periodic" reboot, add a new interface, a new service card, etc.) without service interruption and ideally without the troubles must not be perceived by customers.

The CGN must be compliant with such requirement (i.e., support graceful shutdown, graceful restart).

(Planned maintenance operation can be seen as predictable failure events)

Cheers,
Med

---

From: Simon Perreault <[email-masked]>
Date: Fri, 25 Mar 2011 20:35:27 -0400

> shutdown, graceful restart).

Going by the chairs' guidelines for what the scope of this draft is, I think
this is out of scope. The reason is this requirement is not specific to CGNs.
Many other network functions have the same requirement. Therefore, it is out of
scope.

Thanks,
Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: <[email-masked]>
Date: Sun, 27 Mar 2011 13:51:04 +0200

Re-,

I'm in a full disagreement here.

Because of the stateful nature of the CGN, service availably is a MUST. CGN MUST be able to gracefully handover/etc.

If you take for instance BGP, there is a procedure how graceful restart is defined. For CGN, we need a specific procedure.

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Simon Perreault
Envoyé : samedi 26 mars 2011 01:35
À : [email-masked]
Objet : Re: [BEHAVE] CGN REQ: Planned maintenance operations

Thanks,
Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Shin Miyakawa <[email-masked]>
Date: Sun, 27 Mar 2011 22:44:50 +0900 (JST)

Mohamed,

Thank you for your comment of our draft,
as one of th eoriginal author of this draft, I'd like to respond to this...

Then....

From: <[email-masked]>
Subject: Re: [BEHAVE] CGN REQ: Planned maintenance operations
Date: Sun, 27 Mar 2011 13:51:04 +0200
> Because of the stateful nature of the CGN, service availably is a MUST. CGN MUST be able to gracefully handover/etc.

This depends on operators' choise. 

I have talked many operators on the earth who consider about CGN deployment.
There are certain amount of operators who do not think they need 
high-availability of CGN.
So we can not use MUST. It is too strong as a standard document.

Of course, I agree with SHOULD.

> If you take for instance BGP, there is a procedure how graceful restart is defined. For CGN, we need a specific procedure.

Also the graceful restart mechanism of CGN is quite implentation depended.
I do not think that we can define a general procedure between two CGNs
which comes from different vendors.

Best wishes,

Shin Miyakawa

---

From: <[email-masked]>
Date: Sun, 27 Mar 2011 18:19:05 +0200

Dear Shin,

Please see inline.

Cheers,
Med 

-----Message d'origine-----
De : Shin Miyakawa [mailto:[email-masked]] 
Envoyé : dimanche 27 mars 2011 15:45
À : BOUCADAIR Mohamed OLNC/NAD/TIP
Cc : [email-masked]; [email-masked]; [email-masked]
Objet : Re: [BEHAVE] CGN REQ: Planned maintenance operations

Mohamed,

Then....

Med: Putting aside the solution discussion and multi-vendor scenario, do you agree/disagree this is a valid requirement?

---

From: Shin Miyakawa <[email-masked]>
Date: Mon, 28 Mar 2011 04:54:19 +0900 (JST)

From: <[email-masked]>
Subject: Re: [BEHAVE] CGN REQ: Planned maintenance operations
Date: Sun, 27 Mar 2011 18:19:05 +0200

> Med: Putting aside the solution discussion and multi-vendor scenario, do you agree/disagree this is a valid requirement? 

OK. To make it clear, I disagree with that, at least as you proposed.

Cheers,

Shin