Subject: [BEHAVE] CGN REQ-1

From: <[email-masked]>
Date: Tue, 15 Mar 2011 15:03:41 +0100

Dear authors, 
 
The I-D states:
   REQ-1:  A CGN MUST have an "IP address pooling" behaviour of
      "Paired".

   Justification:  This is a stronger form of REQ-2 from [RFC4787 <http://tools.ietf.org/html/rfc4787> ].

      Note that this requirement applies regardless of the transport
      protocol.  In other words, a CGN must use the same external IP
      address mapping for all sessions associated with the same internal
      IP address, be they TCP, UDP, ICMP, something else, or a mix of
      different protocols.

Some comments about this req:

* The wording should be modified to mandate the address pooling per-subscriber and not per internal host basis. This should be the default behaviour.
* This requirement may be relaxed for some protocols such as DNS but this should be left to the taste of SPs (the use of the same external IP address is not mandatory: the server does not initiate connection towards the client, there is no referral to a third party, no need to correlate between several sessions (e.g., RTP/RTCP).

Cheers,
Med

---

From: Simon Perreault <[email-masked]>
Date: Tue, 15 Mar 2011 10:15:08 -0400

On 2011-03-15 10:03, [email-masked] wrote:
> Dear authors,
> 
> The I-D states: REQ-1:  A CGN MUST have an "IP address pooling"
> behaviour of "Paired".
> 
> address mapping for all sessions associated with the same internal IP
> address, be they TCP, UDP, ICMP, something else, or a mix of 
> different protocols.
> 
> * The wording should be modified to mandate the address pooling
> per-subscriber and not per internal host basis. This should be the
> default behaviour.

I don't understand the difference. The requirement is written in terms
of internal/external IP addresses, like it is in RFC 4787. What's
different with a CGN?

> * This requirement may be relaxed for some
> protocols such as DNS but this should be left to the taste of SPs
> (the use of the same external IP address is not mandatory: the server
> does not initiate connection towards the client, there is no referral
> to a third party, no need to correlate between several sessions
> (e.g., RTP/RTCP).

So are you suggesting s/MUST/SHOULD/ ?

Thanks,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: <[email-masked]>
Date: Tue, 15 Mar 2011 15:21:02 +0100

Re-,

Please see inline.

Cheers,
Med

-----Message d'origine-----
De : Simon Perreault [mailto:[email-masked]] 
Envoyé : mardi 15 mars 2011 15:15
À : BOUCADAIR Mohamed OLNC/NAD/TIP
Cc : [email-masked]; 'behave' <([email-masked])>
Objet : Re: CGN REQ-1

Med: A subscriber can be seen with multiple IP internal addresses (e.g., DS-Lite, L2-NAT). 

Med: Yes. State also this is should be the default behaviour.

Thanks,
Simon

---

From: Simon Perreault <[email-masked]>
Date: Tue, 15 Mar 2011 10:26:30 -0400

> Med: A subscriber can be seen with multiple IP internal addresses (e.g., DS-Lite, L2-NAT). 

So a subscriber's CPE would be assigned multiple internal IPv4
addresses, and all these addresses would need to map to the same
external address. Is that right?

If so, how can the CGN recognize that those multiple addresses are related?

> Med: Yes. State also this is should be the default behaviour.

Unless the WG disagrees, I'll make those changes in the next revision.

Thanks,
Simon

---

From: <[email-masked]>
Date: Tue, 15 Mar 2011 15:34:04 +0100

Re,

Please see inline.

Cheers,
Med

-----Message d'origine-----
De : Simon Perreault [mailto:[email-masked]] 
Envoyé : mardi 15 mars 2011 15:27
À : BOUCADAIR Mohamed OLNC/NAD/TIP
Cc : [email-masked]; 'behave' <([email-masked])>
Objet : Re: CGN REQ-1

Med: No IPv4 address is assigned to the WAN interface of the CPE. The CPE does not "touch" to the IPv4 packets as issued by internal hosts. The NAT table must include in addition to the internal IPv4 address, the de-multiplexer identifier (MAC address, IPv6 address, IPv6 prefix, etc.).

Med: For the DS-Lite case, the first bits of the IPv6 address (e.g., 56, 64) are used as a de-multiplexer. For the L2-NAT, this can rely on the PPP session, etc. 

Thanks,
Simon

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 15 Mar 2011 08:29:47 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Tuesday, March 15, 2011 7:04 AM
> To: [email-masked]
> Cc: 'behave' <([email-masked])>
> Subject: [BEHAVE] CGN REQ-1
> 
> Dear authors,
> 
> The I-D states:
> * The wording should be modified to mandate the address pooling per-
> subscriber and not per internal host basis. This should be the default
> behaviour.

Perhaps I am mis-understanding what is meant by 'per subscriber'.

Let's take the example of DS-Lite where a single subscriber has several 
IPv4 hosts in their home.  You're saying all of the hosts belonging to 
that user need to share the same public IPv4 address?  If that's what
you're saying, why do we need that requirement?

> * This requirement may be relaxed for some protocols such as DNS but
> this should be left to the taste of SPs (the use of the same external
> IP address is not mandatory: the server does not initiate connection
> towards the client, there is no referral to a third party, no need to
> correlate between several sessions (e.g., RTP/RTCP).

DNS could become sensitive to this, depending on how ideas such as
draft-vandergaast-edns-client-ip get deployed.

-d

> Cheers,
> Med
> 
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: Simon Perreault <[email-masked]>
Date: Wed, 16 Mar 2011 10:38:33 -0400

On 2011-03-15 10:34, [email-masked] wrote:
> Med: For the DS-Lite case, the first bits of the IPv6 address (e.g.,
> 56, 64) are used as a de-multiplexer. For the L2-NAT, this can rely
> on the PPP session, etc.

If this is specific to DS-Lite and L2-NAT, then I think it should go in
a document specific to them.

Simon

---

From: <[email-masked]>
Date: Wed, 16 Mar 2011 15:43:18 +0100

Dear Simon, Chairs, 

I thought the CGN requirement I-D is not specific to a given CGN flavour. IMO, it should cover in particular the DS-Lite CGN.

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Simon Perreault
Envoyé : mercredi 16 mars 2011 15:39
À : 'behave' <([email-masked])>
Objet : Re: [BEHAVE] CGN REQ-1

Simon