Subject: [BEHAVE] CGN REQ: NAT MIB

From: <[email-masked]>
Date: Tue, 15 Mar 2011 16:00:51 +0100

Re-,
 
A requirement to mention that appropriate MIB modules are to be supported by the CGN is needed.
 
At least RFC 4008 is needed. Tunnel MIB (RFC 4087) is to be supported for DS-Lite CGN.

Cheers,
Med

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 15 Mar 2011 10:55:17 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Tuesday, March 15, 2011 8:01 AM
> To: [email-masked]
> Cc: 'behave' <([email-masked])>
> Subject: [BEHAVE] CGN REQ: NAT MIB
> 
> Re-,
> 
> At least RFC 4008 is needed. 

FWIW, we have looked at RFC4008 for a CGN.  It seems inadequate for a CGN --
it lacks ability to alarm if a user is reaching or has exceeded things like
their port quota.  Also, walking that MIB would take a considerable amount
of time on a CGN, due to the table design.

> Tunnel MIB (RFC 4087) is to be supported for DS-Lite CGN.

Did SOFTWIRE require that MIB for Dual-Stack Lite?

-d

> Cheers,
> Med
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave

---

From: <[email-masked]>
Date: Wed, 16 Mar 2011 07:50:54 +0100

Re-,

Please see inline.

Cheers,
Med

-----Message d'origine-----
De : Dan Wing [mailto:[email-masked]] 
Envoyé : mardi 15 mars 2011 18:55
À : BOUCADAIR Mohamed OLNC/NAD/TIP; [email-masked]
Cc : [email-masked]
Objet : RE: [BEHAVE] CGN REQ: NAT MIB

Med: Yes, I'm aware if this but there is no better reference to quote (this is why I said "at least"). For sure, the modules need be adapted to CGN context to cover a set of operational requirements. There are various proprietary CGN MIB modules in the nature but there is no standard one. BTW, YANG CGN modules may be needed to for those using NETCONF. 

BTW, a close topic is to log/notify important events. http://tools.ietf.org/html/draft-sivakumar-behave-nat-logging-00 tried to captures a set of useful information to log. The events are not complete and the structure should be updated to cover the DS-Lite and L2-NAT.

Med: No "management" or manageability considerations are discussed in SOFTWIRE.

---

From: Simon Perreault <[email-masked]>
Date: Wed, 16 Mar 2011 09:20:18 -0400

On 2011-03-16 02:50, [email-masked] wrote:
> FWIW, we have looked at RFC4008 for a CGN.  It seems inadequate for a
> CGN -- it lacks ability to alarm if a user is reaching or has
> exceeded things like their port quota.  Also, walking that MIB would
> take a considerable amount of time on a CGN, due to the table
> design.
> 
> Med: Yes, I'm aware if this but there is no better reference to quote
> (this is why I said "at least"). For sure, the modules need be
> adapted to CGN context to cover a set of operational requirements.
> There are various proprietary CGN MIB modules in the nature but there
> is no standard one. BTW, YANG CGN modules may be needed to for those
> using NETCONF.

OK so I'm interpreting this as "yes for RFC4008, until we have something
better to quote".

> Med: No "management" or manageability considerations are discussed in

I think that should go in a document that would be specific to DS-Lite.

Thanks,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 16 Mar 2011 08:13:44 -0700

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Tuesday, March 15, 2011 11:51 PM
> To: Dan Wing; [email-masked]; draft-
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [BEHAVE] CGN REQ: NAT MIB/YANG
> 
> Re-,
> 
> Please see inline.
> 
> Cheers,
> Med
> 
> CGN --
> (this is why I said "at least").

If it's known to be inadequate, what is the purpose to include
it in a Requirements document?

> For sure, the modules need be adapted
> to CGN context to cover a set of operational requirements. There are
> various proprietary CGN MIB modules in the nature but there is no
> standard one. BTW, YANG CGN modules may be needed to for those using
> NETCONF.
> 
> BTW, a close topic is to log/notify important events.
> http://tools.ietf.org/html/draft-sivakumar-behave-nat-logging-00 tried
> to captures a set of useful information to log. The events are not
> complete and the structure should be updated to cover the DS-Lite and
> L2-NAT.
> 
> Med: No "management" or manageability considerations are discussed in
> SOFTWIRE.=

DS-Lite CGN requirements don't feel appropriate for BEHAVE.  We do
CGN.  The fact that a tunnel is sticking out one side of the CGN
(which is what a DS-Lite CGN is) doesn't seem in BEHAVE's scope.

-d

---

From: <[email-masked]>
Date: Wed, 16 Mar 2011 17:41:50 +0100

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Simon Perreault
Envoyé : mercredi 16 mars 2011 14:20
À : [email-masked]
Objet : Re: [BEHAVE] CGN REQ: NAT MIB/YANG

Med: Yes.