Subject: [BEHAVE] CGN REQ: Shared address pool

From: <[email-masked]>
Date: Wed, 16 Mar 2011 15:49:14 +0100

Re-,

I don't know how this should be covered in the I-D, but I see a value to have a section to elaborate on the configured address pool to be used in the external interface of the CGN. In particular, the CGN should:

* support contiguous address pool
* support non-contiguous addresses

As for the size of the address pool, this is deployment-specific.

Cheers,
Med

---

From: Simon Perreault <[email-masked]>
Date: Wed, 16 Mar 2011 11:05:34 -0400

On 2011-03-16 10:49, [email-masked] wrote:
> I don't know how this should be covered in the I-D, but I see a value to
> have a section to elaborate on the configured address pool to be used in
> the external interface of the CGN. In particular, the CGN should:
>  

Why?

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: <[email-masked]>
Date: Wed, 16 Mar 2011 17:39:01 +0100

Re-,

Because we want to avoid CGN implementations assuming that only contiguous address pools can be configured as shared addresses. Address pools at our disposable may not be "aggregatable"...

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Simon Perreault
Envoyé : mercredi 16 mars 2011 16:06
À : [email-masked]
Objet : Re: [BEHAVE] CGN REQ: Shared address pool

Why?

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca
_______________________________________________
Behave mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/behave

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 17 Mar 2011 16:15:03 -0500

On 3/16/11 11:39 AM, "[email-masked]"
<[email-masked]> wrote:

> Because we want to avoid CGN implementations assuming that only contiguous
> address pools can be configured as shared addresses. Address pools at our
> disposable may not be "aggregatable"...

That may be true in some cases (marginal today, perhaps more of an issue in
the future), and therefore it's not a bad feature.

But I see no reason to make the pool size and/or composition a requirement
for CGN.  The only requirement is that pools can be routed.  I believe that
what you describe is an implementation topic, perhaps appropriate in a RFI
but not the requirements draft.

Cheers,
-Benson

---

From: <[email-masked]>
Date: Sun, 27 Mar 2011 14:01:12 +0200

Dear Benson,

I don't think this is a marginal case. Imagine an SP who want to have an efficient use of its available IP addresses, small pools will be provisioned in the CGNs as external IP addresses; once the address usage reaches a given threshold (e.g., 90%), a new pool can be added, etc. 

This is why CGNs must not have any assumption on the size of the address pool neither its structure.

Cheers,
Med

-----Message d'origine-----
De : Benson Schliesser [mailto:[email-masked]] 
Envoyé : jeudi 17 mars 2011 22:15
À : BOUCADAIR Mohamed OLNC/NAD/TIP; Simon Perreault; [email-masked]
Objet : Re: [BEHAVE] CGN REQ: Shared address pool

Cheers,
-Benson