Subject: [BEHAVE] I-D Action: draft-ietf-behave-nat64-discovery-heuristic-01.txt

From: [email-masked]
Date: Mon, 20 Jun 2011 06:40:12 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Behavior Engineering for Hindrance Avoidance Working Group of the IETF.

	Title           : Discovery of a Network-Specific NAT64 Prefix using a Well-Known Name
	Author(s)       : Teemu Savolainen
                          Jouni Korhonen
	Filename        : draft-ietf-behave-nat64-discovery-heuristic-01.txt
	Pages           : 8
	Date            : 2011-06-20

   This document describes a method for detecting presence of DNS64 and
   for learning IPv6 prefix used for protocol translation on an access
   network without explicit support from the access network.  The method
   depends on existence of a known IPv4-only domain name.  The
   information learned enables applications and hosts to perform local
   IPv6 address synthesis and on dual-stack accesses avoid traversal
   through NAT64.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-behave-nat64-discovery-heuristic-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-behave-nat64-discovery-heuristic-01.txt

---

From: <[email-masked]>
Date: Mon, 20 Jun 2011 18:53:43 +0000

Hi all,

Here's updated version to stir up some discussion. Now included e.g. exit strategy = queries for well-known name, A and AAAA records, resulting in NXDOMAIN result once tool is disabled. Host may check with A record query if the well-known name is out-of-use.

What would be good TTL for well-known name? Week, month, year?

And I still wonder for this global solution, where it is possible to obtain a name and a global IPv4 address?

Best regards,

	Teemu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of ext [email-masked]
> Sent: 20. kesäkuuta 2011 16:40
> To: [email-masked]
> Cc: [email-masked]
> Subject: [BEHAVE] I-D Action: draft-ietf-behave-nat64-discovery-heuristic-01.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Behavior Engineering for Hindrance Avoidance
> Working Group of the IETF.
> 
> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave