Subject: [BEHAVE] [Technical Errata Reported] RFC5780 (2844)

From: RFC Errata System <[email-masked]>
Date: Sat, 25 Jun 2011 23:17:41 -0700 (PDT)

The following errata report has been submitted for RFC5780,
"NAT Behavior Discovery Using Session Traversal Utilities for NAT (STUN)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5780&eid=2844

--------------------------------------
Type: Technical
Reported by: John Selbie <[email-masked]>

Section: 7.5

Original Text
-------------
RESPONSE-PORT is a 16-bit unsigned integer in network byte order followed by 2 bytes of padding. Allowable values of RESPONSE-PORT are 0-65536.

Corrected Text
--------------
RESPONSE-PORT is a 16-bit unsigned integer in network byte order followed by 2 bytes of padding. Allowable values of RESPONSE-PORT are 0-65535.

Notes
-----
The 16-bit unsigned int range is 0-65535 (0x0000 - 0xffff).  65536 can't be represented inside a a 16-bit.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5780 (draft-ietf-behave-nat-behavior-discovery-08)
--------------------------------------
Title               : NAT Behavior Discovery Using Session Traversal Utilities for NAT (STUN)
Publication Date    : May 2010
Author(s)           : D. MacDonald, B. Lowekamp
Category            : EXPERIMENTAL
Source              : Behavior Engineering for Hindrance Avoidance
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Bruce Lowekamp <[email-masked]>
Date: Sun, 26 Jun 2011 11:19:31 -0400

Should be verified

Bruce