Subject: [BEHAVE] Protocol Action: 'An FTP ALG for IPv6-to-IPv4 translation' to Proposed Standard (draft-ietf-behave-ftp64-12.txt)

From: The IESG <[email-masked]>
Date: Mon, 15 Aug 2011 10:53:30 -0700

The IESG has approved the following document:
- 'An FTP ALG for IPv6-to-IPv4 translation'
  (draft-ietf-behave-ftp64-12.txt) as a Proposed Standard

This document is the product of the Behavior Engineering for Hindrance
Avoidance Working Group.

The IESG contact persons are David Harrington and Wesley Eddy.

A URL of this Internet Draft is:
http://datatracker.ietf.org/doc/draft-ietf-behave-ftp64/

Technical Summary

This document describes middlebox behavior to reduce the problem of 
IPv6 FTP clients connecting to IPv4 FTP servers on the Internet.

Working Group Summary

There was controversy around requirements for already-
deployed FTP clients and FTP servers. This text has been removed and
will appear in a separate document.

IPR has been disclosed and announced to the mailing list,
https://datatracker.ietf.org/ipr/search/?option=document_search&document_search=draft-ietf-behave-ftp64
and there has been no subsequent WG discussion about this IPR disclosure.

Document Quality

No existing implementations have been announced, but  several vendors are actively implementing the specification.
Reviewers are listed in the document's contributors section. No expert reviews were needed.

Personnel

Dan Wing, [email-masked] is the Document Shepherd for this document.
David Harrington, [email-masked] is the Responsible Area Director.
The document doesn't require IANA experts

RFC Editor Note

#1) expand ALG in the title: Application Layer Gateway. 
#2) Section 4 includes: As such, it is recommended to update FTP clients and servers as required for IPv6-to-IPv4 translation support where possible, to allow proper operation of the FTP protocol without the need for ALGs. r/recommended/RECOMMENDED? 
#3) Section 5: missing right parenthesis: ([RFC4217] 
#4) needs normative reference for UTF-8.

---

From: "David Harrington" <[email-masked]>
Date: Tue, 16 Aug 2011 08:39:55 -0400

Congratulations on a job well done!

dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of The IESG
> Sent: Monday, August 15, 2011 1:54 PM
> To: IETF-Announce
> Cc: behave mailing list; behave chair; RFC Editor
> Subject: Protocol Action: 'An FTP ALG for IPv6-to-IPv4 
> translation' toProposed Standard (draft-ietf-behave-ftp64-12.txt)
> 
> https://datatracker.ietf.org/ipr/search/?option=document_searc
> h&document_search=draft-ietf-behave-ftp64
> No existing implementations have been announced, but  several 
> vendors are actively implementing the specification.
> #2) Section 4 includes: As such, it is recommended to update 
> FTP clients and servers as required for IPv6-to-IPv4 
> translation support where possible, to allow proper operation 
> of the FTP protocol without the need for ALGs. 
> r/recommended/RECOMMENDED? 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
>