Subject: Re: [BEHAVE] [v6ops] Home NAPT44 - How many ports?

From: ivan c <[email-masked]>
Date: Mon, 17 Jun 2013 00:25:06 +0200

On Jun 6, 2013, at 5:41 PM, "Rajiv Asati (rajiva)"  wrote:

> Hi Dan,

>> and so on. I am surprised you conclude that "500 seems ok" when such
a
>> limit would interfere with your network use on those days.
> 
> I
based that statement ("...seems ok,") on the very fact that the number of
times the NAT utilization exceeded 500 mappings (equating to 500 ports, in
my setup) in the sample period (~2 months) was relatively quite low. So, if
the NAT device was limited to only 500 mappings, then the experience would
have been ok for 99% of the time and degraded 1% of the time. This is an
important consideration, IMO.
> 
> For ex, in the last 2 weeks, the number
of times NAT mappings exceeded 500 were:
> June 3 - 1 time
> May 29 - 1
time
> May 28 - 3 times
> May 26 - 1 time
> May 23 - 1 time
> May 22 - 2
times
> May 21 - 3 times
> 
> Of course, 1000 ports (resulting in 1000+
mappings) would have been more than enough to accommodate the times when
the mappings exceeded 500, but stayed within 1000 (except once).
What is the maximum number of mappings supported by your NAPT device?
Some residential-class NATs have a limit of 1024 mappings.
> My NAPT
device seemingly can use upto 64K ports. :)
> Cheers,
> Rajiv

I'm not
sure whether observing traffic on your local personal internet correction
and then extrapolating this behavior for the worldwide internet as a whole
is a very scientific method, especially when the purpose is the redaction
of normalization and interoperability documents. But it's surely an
interesting exercise. I noticed that in your experiment you leave out
popular protocols like bittorrent, which makes up most of the internet
world traffic and would surely gain to be integrated in such data series.

On the other hand, some people on this mailing list (who work at large
ISPs, or core network routers manufacturers) have access to would look more
like real-world statistical data and we should probably turn to them to get
proper information about what is currently happening on the inter networks.

-- 
_Ivan C._

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Tue, 18 Jun 2013 20:24:55 +0000

>I'm not sure whether observing traffic on your local personal internet correction 
>and then extrapolating this behavior for the worldwide internet as a whole is a very
>scientific method, 

It is not. I agree. 
It is meant to be just a sample (as I stated in my very first email).

> especially when the purpose is the redaction of normalization and
> interoperability documents. But it's surely an interesting exercise. 

Indeed. Something is better than nothing. 

> I noticed that in your experiment you leave out popular protocols like bit torrent, 
> which makes up most of the internet world traffic and would surely gain to be
>  integrated in such data series.

Interesting enough, many of the recent measurements suggest that the torrent' like p2p applications are no longer the bandwidth consumers the way they once used to be. In fact, they are now perceived to be 10-20% (and declining) of internet bandwidth. The largest internet world traffic consumer is HTTP (and HTTP video).

http://www.cisco.com/en/US/solutions/collateral/ns341/ns525/ns537/ns705/ns827/images/VNI_Hyperconnectivity_WP-12.jpg

http://www.michaelsinsight.com/2009/10/sandvine-traffic-study-confirms-the-decline-of-p2p.html

http://www.research.att.com/export/sites/att_labs/techdocs/TD_100193.pdf

Nonetheless, I do think about the number of ports that these p2p applications can consume/exhaust, since that could be in 100s (or in 1000s). Thankfully, many home router implementations may provide capabilities to restrict the exhaustion by the p2p apps.

>On the other hand, some people on this mailing list (who work at large ISPs, or core network routers manufacturers) have access to would look more like real-world statistical data and we should probably turn to them to get proper information about what is currently happening on the inter networks.

I hope so. Having said that, most wireline ISPs didn't use CGN until now, so port usage data is not difficult to get by.

Cheers,
Rajiv

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of ivan c
> Sent: Sunday, June 16, 2013 6:25 PM
> To: [email-masked]
> Cc: Rajiv Asati (rajiva)
> Subject: Re: [BEHAVE] [v6ops] Home NAPT44 - How many ports?
> 
> On Jun 6, 2013, at 5:41 PM, "Rajiv Asati (rajiva)" <rajiva at cisco.com> wrote:
> 
> > Hi Dan,
> >
> >> a limit would interfere with your network use on those days.
> >
> > I based that statement ("...seems ok,") on the very fact that the number of
> the NAT device was limited to only 500 mappings, then the experience
> would have been ok for 99% of the time and degraded 1% of the time. This
> is an important consideration, IMO.
> >
> > For ex, in the last 2 weeks, the number of times NAT mappings exceeded
> 500 were:
> >
> > June 3 - 1 time
> > May 29 - 1 time
> > May 28 - 3 times
> > May 26 - 1 time
> > May 23 - 1 time
> > May 22 - 2 times
> > May 21 - 3 times
> >
> > Of course, 1000 ports (resulting in 1000+ mappings) would have been more
> than enough to accommodate the times when the mappings exceeded 500,
> but stayed within 1000 (except once).
> >
> >
> > My NAPT device seemingly can use upto 64K ports. :)
> >
> > Cheers,
> > Rajiv
> 
> 
> 
> 
> 
> I'm not sure whether observing traffic on your local personal internet
> correction and then extrapolating this behavior for the worldwide internet
> as a whole is a very scientific method, especially when the purpose is the
> redaction of normalization and interoperability documents. But it's surely
> an interesting exercise. I noticed that in your experiment you leave out
> On the other hand, some people on this mailing list (who work at large ISPs,
> or core network routers manufacturers) have access to would look more like
> real-world statistical data and we should probably turn to them to get
> Ivan C.

---

From: ivan c <[email-masked]>
Date: Tue, 18 Jun 2013 23:56:04 +0200

On Tue, 18 Jun 2013 20:24:55 +0000, "Rajiv Asati (rajiva)"
<[email-masked]> wrote:

> 
> Interesting enough, many of the recent measurements suggest that the
> torrent' like p2p applications are no longer the bandwidth consumers the
> way they once used to be. In fact, they are now perceived to be 10-20%
(and
> declining) of internet bandwidth. The largest internet world traffic
> consumer is HTTP (and HTTP video).
> 
>
> Nonetheless, I do think about the number of ports that these p2p
> applications can consume/exhaust, since that could be in 100s (or in
> 1000s). Thankfully, many home router implementations may provide
> capabilities to restrict the exhaustion by the p2p apps.
> 

Interesting links. I wish we had access to more studies like the third
one.
However these documents seem to refer to the situation in North America,
who has Netflix, Hulu, Youtube, and is back in 2009. Apparently after the
Megavideo debacle in 2011, there was a significant drop of traffic towards
video streaming services.

It is difficult to get information about internet usage per
continent/countries.
Europe: Netflix and Hulu are not available. Netflix actually just came to
the UK. They make a large chunk of the US traffic. Youtube is heavily
throttled in France. From studies done by Orange, P2P still seems the
dominant usage.
China: P2P live streaming appears to be massively used.
Japan, India, South America: i have little information

-- 
_Ivan Chollet_