Subject: [BEHAVE] FW: New Version Notification for draft-reddy-behave-turn-auth-02.txt

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 18 Jun 2013 04:53:32 +0000

We have published the revision of this draft. This has changes to
following text of "Problems with STUN Authentication" section

<snip>
5.  Hosting multiple realms on a single IP address is challenging
       with TURN.  When a TURN server needs to send the REALM attribute
       in response to an unauthenticated request, it has no useful
       information for determining which realm it should send, except
       the source transport address of the TURN request.  Note this is a
       problem with multi-tenant scenarios only.  This is not a problem
       when deployed in Enterprise.

</snip>

Please review and provide any inputs/comments on this draft.

Authors

> On 12/06/13 4:03 PM, "[email-masked]"
><[email-masked]> wrote:

>
>A new version of I-D, draft-reddy-behave-turn-auth-02.txt
>has been successfully submitted by Tirumaleswar Reddy and posted to the
>IETF repository.
>
>Filename:	 draft-reddy-behave-turn-auth
>Revision:	 02
>Title:		 Problems with STUN Authentication for TURN
>Creation date:	 2013-06-12
>Group:		 Individual Submission
>Number of pages: 7
>URL:             
>http://www.ietf.org/internet-drafts/draft-reddy-behave-turn-auth-02.txt
>Status:          
>http://datatracker.ietf.org/doc/draft-reddy-behave-turn-auth
>Htmlized:        
>http://tools.ietf.org/html/draft-reddy-behave-turn-auth-02
>Diff:            
>http://www.ietf.org/rfcdiff?url2=draft-reddy-behave-turn-auth-02
>
>Abstract:
>   This document discusses some of the issues with STUN authentication
>   for TURN messages.
>
>                  
>        
>
>
>The IETF Secretariat
>
>

---

From: chen wilson <[email-masked]>
Date: Fri, 21 Jun 2013 10:48:54 +0800

Good point, If the TURN server is configured with multiple realms, it might
want to respond all realms it supports (multiple realm attributes), or it
might respond some special meaningful realm then the client can get help
out of band, or just randomly pick one, etc...
The problem 1 and 2, listed in the draft is very common. Implementers are
easy to get missed without a clear guidance.

Thanks,
Wilson Chen

On Tue, Jun 18, 2013 at 12:53 PM, Ram Mohan R (rmohanr)
<[email-masked]>wrote:

> _______________________________________________
> Behave mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>