Subject: [BEHAVE] [Technical Errata Reported] RFC6145 (4090)

From: RFC Errata System <[email-masked]>
Date: Wed, 20 Aug 2014 09:48:53 -0700 (PDT)

The following errata report has been submitted for RFC6145,
"IP/ICMP Translation Algorithm".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6145&eid=4090

--------------------------------------
Type: Technical
Reported by: Fernando Gont <[email-masked]>

Section: 6

Original Text
-------------
   1.  In the IPv4-to-IPv6 direction: if the MTU value of ICMPv4 Packet
       Too Big (PTB) messages is less than 1280, change it to 1280.
       This is intended to cause the IPv6 host and IPv6 firewall to
       process the ICMP PTB message and generate subsequent packets to
       this destination with an IPv6 Fragment Header.

Corrected Text
--------------
   1.  In the IPv4-to-IPv6 direction: if the MTU value of ICMPv4 Packet
       Too Big (PTB) messages is less than 1280, change it to 1280.
       This is intended to cause the IPv6 host and IPv6 firewall to
       process the ICMP PTB message.

Notes
-----
An ICMPv6 PTB message reporting an MTU equal to 1280 does not trigger IPv6 atomic fragments. Only ICMPv6 PTB < 1280 do.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6145 (draft-ietf-behave-v6v4-xlate-23)
--------------------------------------
Title               : IP/ICMP Translation Algorithm
Publication Date    : April 2011
Author(s)           : X. Li, C. Bao, F. Baker
Category            : PROPOSED STANDARD
Source              : Behavior Engineering for Hindrance Avoidance
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 20 Aug 2014 17:57:48 +0000

I think I understand where Fernando is going with this. I have two comments.

(1) Considering the sentence he proposes to change to be "in error" presumes that draft-gont-6man-deprecate-atomfrag-generation has been ratified. It has just been posted yesterday, and has had only preliminary mailing list discussion in 6man. I think Fernando may have a reasonable instinct here, but is ahead of himself. I would recommend "verifying" the erratum when the draft is approved.

(2) If we're going to "correct" the text, we need to correct the text. It is either "an ICMPv4 Packet Too Big message" (singular), in which case the verb form is "is", or *they* are "ICMPv4 Packet Too Big messages" (plural), in which case the verb form is is "are". Since the RFC describes how to translate a single packet (which would be the word RFC 2460 would prefer, not "message") from IPv4 to IPv6 or IPv6 to IPv4, I would prefer the singular form.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 20 Aug 2014 19:34:23 +0000

On Aug 20, 2014, at 11:38 AM, Fernando Gont <[email-masked]> wrote:

> Hi, Fred,
> 
> On 08/20/2014 02:57 PM, Fred Baker (fred) wrote:
>> (1) Considering the sentence he proposes to change to be "in error"
>> presumes that draft-gont-6man-deprecate-atomfrag-generation has been
>> ratified. 
> 
> Nope. My erratum essentially notes that what RFC6145 does not comply
> with RFC2460. IPv6 atomic fragments are generated in response to ICMPv6
> PTB < 1280... *not* ICMPv6 <= 1280.

The text in question says “less than”, not “less than or equal”.

Original Text
-------------
                                ^^^^^^^^^

If your argument is that the text should not say “less than or equal”, it doesn’t, and I would therefore recommend rejecting the erratum.

> When the reported MTU is 1280, you just adapt your assumed Path-MTU
> accordingly.
> 
> P.S.: If draft-gont-6man-deprecate-atomfrag-generation were published as
> an RFC, atomic fragments would *never* be generated.
> -- 
> Fernando Gont
> SI6 Networks
> e-mail: [email-masked]
> PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492
> 
> 
> 
>

---

From: Fernando Gont <[email-masked]>
Date: Wed, 20 Aug 2014 15:38:04 -0300

Hi, Fred,

---

From: Fernando Gont <[email-masked]>
Date: Wed, 20 Aug 2014 17:01:04 -0300

> The text in question says “less than”, not “less than or equal”.

The text says "if less than 1280, change it to 1280". Then the resulting
packet will have an MTU field of 1280.

The text then goes on and says "this is intended to....generate
subsequent packets....with an IPv6 Fragment Header".

But an ICMPv6 PTB == 1280 should not generate packets with a FH.

Thanks,