Subject: [bess] Comments about draft-gmsm-bess-evpn-bfd-01

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 5 Nov 2018 09:44:49 +0000

Dear authors,

I couldn’t make it to the BESS meeting, so my apologies if some of these things have been discussed.
 
Some comments/questions:

- In the last IETF, I suggested the use of BGP and the BGP-BFD attribute to exchange discriminators, as in section 3.1.6 of draft-ietf-bess-mvpn-fast-failover. The idea seemed to be accepted, but it is not in the new version. This would allow the signaling of the discriminators along with MAC/IP routes, IMET routes, AD per-EVI routes, IP-Prefix routes, etc. without the burden of having to support the EVPN LSP-ping draft.

- The draft describes an encapsulation and an alternative encapsulation. Is the intend to keep both? Wouldn't be better to leave only one to ease implementations and interoperability?

Thank you.
Jorge

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 5 Nov 2018 08:48:00 -0500

Hi Jorge,

On Mon, Nov 5, 2018 at 4:44 AM Rabadan, Jorge (Nokia - US/Mountain
> I couldn’t make it to the BESS meeting, so my apologies if some of these things have been discussed.

Thanks for sending comments.

> - In the last IETF, I suggested the use of BGP and the BGP-BFD attribute to exchange discriminators, as in section 3.1.6 of draft-ietf-bess-mvpn-fast-failover. The idea seemed to be accepted, but i…

There is a draft version -02 in the works intended to include
distribution of BFD discriminators in BGP but this revision was not
completed to the agreement of the authors in time to posted before
this meeting.

> - The draft describes an encapsulation and an alternative encapsulation. Is the intend to keep both? Wouldn't be better to leave only one to ease implementations and interoperability?

Currently, the candidate version -02 draft dispenses with with the
alternative encapsulation.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 1424 Pro Shop Court, Davenport, FL 33896 USA
 [email-masked]

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 6 Nov 2018 02:12:21 +0000

Hi Donald,

Thank you for this.
For the second question, I get from your answer that you will keep both encapsulations for the time being? 

Thanks.
Jorge

-----Original Message-----
From: Donald Eastlake <[email-masked]>
Date: Monday, November 5, 2018 at 8:48 PM
To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Comments about draft-gmsm-bess-evpn-bfd-01

    Hi Jorge,

    

    
    
    Thanks,
    Donald

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 6 Nov 2018 06:59:19 -0500

Hi Jorge,

On Mon, Nov 5, 2018 at 9:12 PM Rabadan, Jorge (Nokia - US/Mountain
> For the second question, I get from your answer that you will keep both encapsulations for the time being?

Well, once a draft is posted, it can't be changed, so the currently
posted -01 won't change but the -02 version that is being worked on
and is not yet posted eliminates the alternative encapsulation.

Thanks,
Donald

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 6 Nov 2018 12:05:38 +0000

Hi Donald,

-----Original Message-----
From: Donald Eastlake <[email-masked]>
Date: Tuesday, November 6, 2018 at 6:59 PM
To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Comments about draft-gmsm-bess-evpn-bfd-01

    Hi Jorge,

[JORGE] :-) of course. I misunderstood your answer. Sounds good then. Thank you!
    
    Thanks,
    Donald