Subject: Re: [bess] Comparing using the SD-WAN Overlay SAFI specified by draft-dunbar-idr-bgp-sdwan-overlay-ext with the EVPN approach described by draft-sajassi-bess-secure-evpn-00

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Sun, 4 Nov 2018 15:02:01 +0000

Just finished reading your draft and I don’t think the two drafts are complimentary. Frankly, I don’t see any advantages for using a separate SAFI for this purpose but many disadvantages such as:

  1.  Resurrecting the approach in RFC 5512 that is being deprecated – i.e., send a separate route for the tunnel and then color the other routes to associated with the tunnel (using indirection) and opposed the current common practice in Tunnel Encap attribute that sends the attribute directly with the corresponding route.
  2.  When establishing IPsec tunnel at a more granular level (e.g., per pair of VPN MAC or IP addresses), you need to advertise twice as many routes !!
  3.  The overhead associated with a new SAFI as opposed to use exiting attribute
  4.  NAT can be handled without the new SAFI

The secure tunnel between each PE and the RR (e.g., IPsec) for the BGP session is common between the two drafts as mentioned first by the controller-ike draft. This is needed because you want to make sure that the BGP session goes over a tunnel that is authenticated between the peers (and encrypted). Intuitively the use of tunnel encap attribute for IPsec should be clear as IPsec is another tunnel type and key exchange parameter, transfer function, DH groups, etc. are attributes/properties of such tunnel and thus to be advertised in this new tunnel type TLV.

Let’s start with EVPN because that is the technology/solution being used predominately in DCs, DCIs, and enterprise inter-site connectivity. I listed the disadvantages of using a separate SAFI above, can you list the advantages of using a separate SAFI for EVPN?

Cheers,
Ali

From: BESS <[email-masked]> on behalf of Linda Dunbar <[email-masked]>
Date: Tuesday, October 30, 2018 at 9:19 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [bess] Comparing using the SD-WAN Overlay SAFI specified by draft-dunbar-idr-bgp-sdwan-overlay-ext with the EVPN approach described by draft-sajassi-bess-secure-evpn-00

IDR group, BESS group,

https://datatracker.ietf.org/doc/draft-dunbar-idr-bgp-sdwan-overlay-ext/ specifies a new BGP SAFI (=74) in order to advertise a SD-WAN edge node’s capabilities in establishing SD-WAN overlay tunnels with other SD-WAN nodes through third party untrusted networks.

draft-sajassi-bess-secure-evpn-00 describes an EVPN solution for PE nodes to exchange key and policy to create private pair-wise IPsec Security Associations without IKEv2 point-to-point signaling or any other direct peer-to-peer session establishment messages.

I think those two solutions are not conflicting with each other. Actually they are compliment to each other to some degree. For example,

  *   the Re-key mechanism described by draft-sajassi-bess-secure-evpn-00 can be utilized by draft-dunbar-idr-bgp-sdwan-overlay-ext
  *   The SD-WAN Overlay SAFI can be useful to simplify the process on RR to re-distribute the Tunnel End properties to authorized peers.
  *   When SD-WAN edge nodes use private address, or no IP address, NAT properties for the end points distribution described draft-dunbar-idr-bgp-sdwan-overlay-ext is necessary.
  *   The secure channel between SD-WAN edge nodes and RR described by draft-dunbar-idr-bgp-sdwan-overlay-ext is necessary.

Any thoughts?

Thank you very much.

Linda Dunbar

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 5 Nov 2018 09:35:42 +0000

Ali,

About that granularity, I have a couple of questions about the table in page 17, and the corresponding sections.
 
a) per PE granularity, EVPN case: wouldn't make sense to use an EVPN route? EVPN is the only AFI/SAFI deployed in many networks, so I would really use an EVPN route for this. We could use the AD per-ES route with ESI=0, as we did in RFC8317.

b) per tenant, EVPN case: in a Layer-3 tenant, a given BD may not be attached to all the PEs of the L3 tenant domain, hence the IMET route may not work. An alternative for L3 tenants is to use an SBD in all the PEs and use an IMET on the SBD.  

And a last comment: I think section 9 is a copy paste error from another draft ;-)

Thank you.
Jorge

From: Idr <[email-masked]> on behalf of "Ali Sajassi (sajassi)" <[email-masked]>
Date: Monday, November 5, 2018 at 12:11 AM
To: Linda Dunbar <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Idr] [bess] Comparing using the SD-WAN Overlay SAFI specified by draft-dunbar-idr-bgp-sdwan-overlay-ext with the EVPN approach described by draft-sajassi-bess-secure-evpn-00

Linda,
 
You should read my draft again as it explains IPsec tunnels needed at different level of granularity and how this can be achieved with existing routes. The traffic does not get sent till the IPsec tunnel is established between a pair of endpoints and the draft specifies 6 different types of endpoints for different level of granularity – i.e., per PE, per tenant, per subnet, per IP, per MAC, and per AC.
 
Cheers,
Ali
 
From: Linda Dunbar <[email-masked]>
Date: Sunday, November 4, 2018 at 7:00 AM
To: Cisco Employee <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [bess] Comparing using the SD-WAN Overlay SAFI specified by draft-dunbar-idr-bgp-sdwan-overlay-ext with the EVPN approach described by draft-sajassi-bess-secure-evpn-00
 
Ali, 
 
Your draft-sajassi-bess-secure-evpn-00 defines two new Tunnel Types along with its associated sub-TLVs for The Tunnel Encapsulation Attribute [TUNNEL-ENCAP]. 
 
[Tunnel-Encap] cannot be effectively used for SD-WAN overlay network because a SD-WAN Tunnel needs to be established before data arrival. There is no routes to be associated with the SD-WAN Tunnel.
 
How do you address those issues? 
 
Linda
 
From: Ali Sajassi (sajassi) [mailto:[email-masked]] 
Sent: Wednesday, October 31, 2018 12:04 PM
To: Linda Dunbar <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [bess] Comparing using the SD-WAN Overlay SAFI specified by draft-dunbar-idr-bgp-sdwan-overlay-ext with the EVPN approach described by draft-sajassi-bess-secure-evpn-00
 
Hi Linda,
 
I haven’t read your draft yet. I am traveling now but will plan to read your draft over next couple of days and respond to your questions.
 
Cheers,
Ali
 
From: BESS <mailto:[email-masked]> on behalf of Linda Dunbar <mailto:[email-masked]>
Date: Tuesday, October 30, 2018 at 9:19 AM
To: "mailto:[email-masked]" <mailto:[email-masked]>, "mailto:[email-masked]" <mailto:[email-masked]>
Subject: [bess] Comparing using the SD-WAN Overlay SAFI specified by draft-dunbar-idr-bgp-sdwan-overlay-ext with the EVPN approach described by draft-sajassi-bess-secure-evpn-00
 
IDR group, BESS group,

 
I think those two solutions are not conflicting with each other. Actually they are compliment to each other to some degree. For example, 
- the Re-key mechanism described by draft-sajassi-bess-secure-evpn-00 can be utilized by draft-dunbar-idr-bgp-sdwan-overlay-ext  
- The SD-WAN Overlay SAFI can be useful to simplify the process on RR to re-distribute the Tunnel End properties to authorized peers. 
- When SD-WAN edge nodes use private address, or no IP address, NAT properties for the end points distribution described draft-dunbar-idr-bgp-sdwan-overlay-ext is necessary. 
- The secure channel between SD-WAN edge nodes and RR described by draft-dunbar-idr-bgp-sdwan-overlay-ext is necessary. 
 
Any thoughts? 
 
Thank you very much. 
 
Linda Dunbar