Subject: Re: [bess] Last call comment to draft-ietf-bess-evpn-inter-subnet-forwarding-05

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 31 Jan 2019 02:24:24 +0000

Hi Linda,

Please refer to my reply inline marked with “AS>”

From: BESS <[email-masked]> on behalf of Linda Dunbar <[email-masked]>
Date: Thursday, October 4, 2018 at 9:30 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [bess] Last call comment to draft-ietf-bess-evpn-inter-subnet-forwarding-05

Ali, et al:

Sorry for the late comments. I remember reviewing/contributing to this draft many years ago. Happy to see it is finally moving to IESG Last Call.

The draft describes the mechanism to allow TSs belonging to different subnets attached to same PE to be communicated by the PE (instead hair pinned to the L3GW). Very good optimization.

However, not every PE has the needed policies for any two subnet communication (that is why the traffic was to be sent to L3GW).. Therefore, the draft needs a section to describe how the PEs determine if it has the needed policies for specific inter subnets communication.
In addition, when subnets are scatted among many different PEs, it requires the L3GW to maintain all the mappings. In Data center when there are many VMs or Containers, the number of mappings for L3GW to maintain is huge (it practically becomes host routing for tens of thousands of VMs or Containers). It doesn’t scale well. Therefore, the mechanism should allow some PEs to maintain some of the mappings, i.e. becoming a designated L3GW for some subnets..

AS> The discussion of policy and mapping them to subnet configuration is outside of the scope of this document. If the subnets are configured in a central GW, then that becomes the traditional DC use case of having a L2-domain terminated by centralized L3GW. This document deals with distributed GW where TS default GW functionality is pushed all the way to the edge of the overlay network  - i.e., to the NVEs.

Cheers,
Ali

If you are willing to accept this comment, I can provide the text on “Inter-subnet communication Policy on PE”.

Thank you.

Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 31 Jan 2019 03:46:39 +0000

Ali,

It is very possible that One NVE can do inter-subnet forwarding for X, but can’t do inter-subnet forwarding for Y. Therefore, the NVE must have a policy on which Subnets it can forward.
Therefore a NVE cannot behave properly if it doesn’t a policy on which subnets it can forward.

Ø  The discussion of policy and mapping them to subnet configuration is outside of the scope of this document.
Linda

From: Ali Sajassi (sajassi) [mailto:[email-masked]]
Sent: Wednesday, January 30, 2019 8:24 PM
To: Linda Dunbar <[email-masked]>; [email-masked]
Subject: Re: [bess] Last call comment to draft-ietf-bess-evpn-inter-subnet-forwarding-05

Hi Linda,

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 4, 2018 at 9:30 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] Last call comment to draft-ietf-bess-evpn-inter-subnet-forwarding-05

Ali, et al:

Cheers,
Ali

Thank you.

Linda Dunbar

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 31 Jan 2019 06:10:49 +0000

I am guessing by X and Y, you are referring to VLAN X and Y. Surely the reason that one NVE can do inter-subnet forwarding for X but not Y, is not because of the NVE’s capabilities !!  Again, what it matters is whether a VLAN/BD is configured for inter-subnet forwarding or not. If a VLAN/BD is configured for inter-subnet forwarding on an NVE then it has an IRB interface and the procedure of this draft get exercised. If it doesn’t, then it is good old RFC 7432 or RFC 8365 wrt that NVE and with respect to the centralized L3GW, it is the good old router on the stick which is simply the degenerate case of the distributed GW and doesn’t require any new procedure.

-Ali

From: Linda Dunbar <[email-masked]>
Date: Wednesday, January 30, 2019 at 7:46 PM
To: Cisco Employee <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [bess] Last call comment to draft-ietf-bess-evpn-inter-subnet-forwarding-05

Ali,

  *   The discussion of policy and mapping them to subnet configuration is outside of the scope of this document.
Linda

Hi Linda,

Ali, et al:

Cheers,
Ali

Thank you.

Linda Dunbar