Subject: Re: [bess] REG: https://datatracker.ietf.org/doc/draft-ietf-bmwg-evpntest/

From: Luc André Burdet <[email-masked]>
Date: Wed, 7 Aug 2019 15:15:47 +0000

Thanks for the head’s up Sudhin.

I got as far as the TOC and associated document flow. I would suggest this needs work before WGLC.
A few suggestions based on cursory reading.

  1.  Section 2, Test topologies   (Nit: plural since you define 3...)

  *   Looks like you are defining only Single-Active?    (Nit:SHPE3 appears twice in its/box)
  *   You have only Figure1 and there are 3 topologies in there. Why not define 3 figures, one per topology ?
  *   The paging makes this section hard to read. Consider shrinking your diagrams.
  *   In fact, these are all the SAME Topology. All you are changing is the traffic pattern. Putting the details of traffic flow “per topology” and especially hiding those details in a one-liner behind “Traffic Generator” is not clear & concise.
  *   I would suggest:
     *   1 Figure detailing the physical network diagram defining node names, DUT, etc. ;
     *   A section defining “Test Topologies” overlayed onto that shared network diagram:
        *   Nit: by “different VLANs” do you mean “Multiple” here or that CE and SHPE3 have different VLANS from one another?)
        *   All-Active,  traffic SHPE3 -> CE direction
        *   All-Active,  traffic CE -> SHPE3 direction
        *   All-Active,  traffic SHPE3 <-> CE bidirectional
        *   Single-Active,  traffic SHPE3 -> CE direction
        *   Single-Active,  traffic CE -> SHPE3 direction
        *   Single-Active,  traffic SHPE3 <-> CE bidirectional
     *   That could fit nicely in a Table...

  1.  Repeating “How long it takes to learn” is redundant and makes the TOC needlessly unreadable.
This is a benchmarking draft, isn’t timing and timing-verification implied?
If you MUST then just add a simple section/sentence at the top of document specifying that and do away with the repetition and long titles

  1.  You have PBB-EVPN in titles that basically repeat the previous one (presumably for EVPN?)
Maybe just have one section, and unnumbered subsections for EVPN and PBB-EVPN ?
or better yet: Section 3 EVPN, Section 4 PBB-EVPN and repeat same TCs concisely per technology. Context switching as one reads through the document hinders readability and flow.

   3<https://tools.ietf.org/html/draft-ietf-bmwg-evpntest-02#section-3>.  EVPN Test Cases

     3.1<https://tools.ietf.org/html/draft-ietf-bmwg-evpntest-02#section-3.1>.  Local MAC learning

     3.2<https://tools.ietf.org/html/draft-ietf-bmwg-evpntest-02#section-3.3>.  Remote MAC learning

     3.3.  Local MAC Flush, due to PE-CE link flap

        3.3.1 MAC Re-learning rate

     3.4.  Remote MAC Flush, due to remote link failure

   4<https://tools.ietf.org/html/draft-ietf-bmwg-evpntest-02#section-3>.  PBB-EVPN Test Cases

     4.1<https://tools.ietf.org/html/draft-ietf-bmwg-evpntest-02#section-3.1>.  Local MAC learning

     4.2<https://tools.ietf.org/html/draft-ietf-bmwg-evpntest-02#section-3.3>.  Remote MAC learning

     4.3.  Local MAC Flush, due to PE-CE link flap

        4.3.1 MAC Re-learning rate

     4.4.  Remote MAC Flush, due to remote link failure

Regards,
Luc André

Luc André Burdet |  Cisco  |  [email-masked]  |  Tel: +1 613 254 4814

From: BESS <[email-masked]> on behalf of Sudhin Jacob <sjacob=[email-masked]>
Date: Wednesday, August 7, 2019 at 02:01
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [bess] REG: https://datatracker.ietf.org/doc/draft-ietf-bmwg-evpntest/

Hi All,

Our draft is going to be WGLC in BMWG workgroup. Could you please let us know any comments.

Regards,
Sudhin

Juniper Business Use Only

---

From: Sudhin Jacob <[email-masked]>
Date: Thu, 8 Aug 2019 03:44:47 +0000

Hi Luc,

Thanks for the comments. Appreciate it. I will get back.

Regards,
Sudhin

Juniper Business Use Only
From: Luc André Burdet <[email-masked]>
Sent: Wednesday, August 7, 2019 8:46 PM
To: Sudhin Jacob <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [bess] REG: https://datatracker.ietf.org/doc/draft-ietf-bmwg-evpntest/

Thanks for the head's up Sudhin.

  *   Looks like you are defining only Single-Active?    (Nit:SHPE3 appears twice in its/box)
  *   You have only Figure1 and there are 3 topologies in there. Why not define 3 figures, one per topology ?
  *   The paging makes this section hard to read. Consider shrinking your diagrams.
  *   In fact, these are all the SAME Topology. All you are changing is the traffic pattern. Putting the details of traffic flow "per topology" and especially hiding those details in a one-liner behind "Traffic Generator" is not clear & concise.
  *   I would suggest:
     *   1 Figure detailing the physical network diagram defining node names, DUT, etc. ;
     *   A section defining "Test Topologies" overlayed onto that shared network diagram:
        *   Nit: by "different VLANs" do you mean "Multiple" here or that CE and SHPE3 have different VLANS from one another?)
        *   All-Active,  traffic SHPE3 -> CE direction
        *   All-Active,  traffic CE -> SHPE3 direction
        *   All-Active,  traffic SHPE3 <-> CE bidirectional
        *   Single-Active,  traffic SHPE3 -> CE direction
        *   Single-Active,  traffic CE -> SHPE3 direction
        *   Single-Active,  traffic SHPE3 <-> CE bidirectional
     *   That could fit nicely in a Table...

  1.  Repeating "How long it takes to learn" is redundant and makes the TOC needlessly unreadable.
This is a benchmarking draft, isn't timing and timing-verification implied?
If you MUST then just add a simple section/sentence at the top of document specifying that and do away with the repetition and long titles

   3<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf..org_html_draft-2Dietf-2Dbmwg-2Devpntest-2D02-23section-2D3&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=6467957JFOdmNjfKujkufIeAE-AdkLRewB-QhIU_Srw&m=KEdAQSnRSS33yC4oLGFN_oPFqpDbbKcDu7Mfvvk-DjI&s=NKvru-PiLhvvEAuqtcnC7TMWxb6UCSx-orKOo4qMAH4&e=>.  EVPN Test Cases

     3.1<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dbmwg-2Devpntest-2D02-23section-2D3.1&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=6467957JFOdmNjfKujkufIeAE-AdkLRewB-QhIU_Srw&m=KEdAQSnRSS33yC4oLGFN_oPFqpDbbKcDu7Mfvvk-DjI&s=2NavS2cWAMnbCRNGfoOuY-NgQIw81CusOZyFmcHCWs4&e=>.  Local MAC learning

     3.2<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dbmwg-2Devpntest-2D02-23section-2D3.3&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=6467957JFOdmNjfKujkufIeAE-AdkLRewB-QhIU_Srw&m=KEdAQSnRSS33yC4oLGFN_oPFqpDbbKcDu7Mfvvk-DjI&s=1FWoMqMdKZszJzPU9kXBGNITrTAsbf8wY35AhfaZ1Yw&e=>.  Remote MAC learning

   4<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf..org_html_draft-2Dietf-2Dbmwg-2Devpntest-2D02-23section-2D3&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=6467957JFOdmNjfKujkufIeAE-AdkLRewB-QhIU_Srw&m=KEdAQSnRSS33yC4oLGFN_oPFqpDbbKcDu7Mfvvk-DjI&s=NKvru-PiLhvvEAuqtcnC7TMWxb6UCSx-orKOo4qMAH4&e=>.  PBB-EVPN Test Cases

     4.1<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dbmwg-2Devpntest-2D02-23section-2D3.1&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=6467957JFOdmNjfKujkufIeAE-AdkLRewB-QhIU_Srw&m=KEdAQSnRSS33yC4oLGFN_oPFqpDbbKcDu7Mfvvk-DjI&s=2NavS2cWAMnbCRNGfoOuY-NgQIw81CusOZyFmcHCWs4&e=>.  Local MAC learning

     4.2<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dbmwg-2Devpntest-2D02-23section-2D3.3&d=DwMF-g&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=6467957JFOdmNjfKujkufIeAE-AdkLRewB-QhIU_Srw&m=KEdAQSnRSS33yC4oLGFN_oPFqpDbbKcDu7Mfvvk-DjI&s=1FWoMqMdKZszJzPU9kXBGNITrTAsbf8wY35AhfaZ1Yw&e=>.  Remote MAC learning

Regards,
Luc André

Luc André Burdet |  Cisco  |  [email-masked]<mailto:[email-masked]>  |  Tel: +1 613 254 4814

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Sudhin Jacob <sjacob=[email-masked]<mailto:sjacob=[email-masked]>>
Date: Wednesday, August 7, 2019 at 02:01
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "bmwg@ietf..org<mailto:bmwg@ietf..org>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] REG: https://datatracker.ietf.org/doc/draft-ietf-bmwg-evpntest/

Hi All,

Regards,
Sudhin

---

From: Sudhin Jacob <[email-masked]>
Date: Fri, 9 Aug 2019 03:53:16 +0000

Hi Luc,

Kindly find the answers inline. Appreciate your comments.

Regards,
Sudhin

Sudhin>>>>>>>>>  We will change it.

Sudhin>>>>>>>>>>> we will remove it.

Sudhin>>>>>>>>> Sure will make it 3 figures and 3 topologies.

Sudhin>>>>>>>>  Sure

Sudhin>>> Traffic generator in the context means either IXIA or Spirent, we cant name one. We have to follow a generic naming pattern.

  *   I would suggest:

Sudhin>>>> Sure we noted this point.

Sudhin>>>>>> yes multiple vlans. We will address as multiple vlans.

Sudhin>>>> thanks for the comment. Sure will address this in table format under topologies section.

  1.  Repeating "How long it takes to learn" is redundant and makes the TOC needlessly unreadable.
This is a benchmarking draft, isn't timing and timing-verification implied?
Sudhin>>>>>>>> Measuring the duration for learning the macs. You are correct, it is the timing measurement.

Sudhin>>>>> we will address it in the next version.

Sudhin>>>>>>>>> Sure

Regards,
Luc André

Hi All,

Regards,
Sudhin

---

From: Sudhin Jacob <[email-masked]>
Date: Wed, 21 Aug 2019 14:29:51 +0000

Hi Luc,

I addressed your comments. Kindly find the latest draft.

https://www.ietf.org/id/draft-ietf-bmwg-evpntest-03.txt

Regards,
Sudhin

Juniper Business Use Only
From: Sudhin Jacob
Sent: Friday, August 9, 2019 9:23 AM
To: Luc André Burdet <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: RE: [bess] REG: https://datatracker.ietf.org/doc/draft-ietf-bmwg-evpntest/

Hi Luc,

Regards,
Sudhin

Juniper Business Use Only
From: Luc André Burdet <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, August 7, 2019 8:46 PM
To: Sudhin Jacob <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] REG: https://datatracker.ietf.org/doc/draft-ietf-bmwg-evpntest/

Sudhin>>>>>>>>  Sure

  *   I would suggest:

Sudhin>>>>>>>>> Sure

Regards,
Luc André

Hi All,

Regards,
Sudhin