Subject: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

From: Stephane Litkowski <[email-masked]>
Date: Mon, 19 Aug 2019 16:32:14 +0200

Hi,

This email begins a two-weeks WG adoption poll
for draft-rabadan-bess-vendor-evpn-route-07 [1]

Please review the draft and post any comments to the BESS working group
list.

We are also polling for knowledge of any undisclosed IPR that applies to
this Document, to ensure that IPR has been disclosed in compliance with
IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as an author or a contributor of this document, please
respond to this email and indicate whether or not you are aware of any
relevant undisclosed IPR, copying the BESS mailing list. The document won't
progress without answers from all the authors and contributors.

Currently, there are no IPR disclosures against this document.

If you are not listed as an author or a contributor, then please explicitly
respond only if you are aware of any IPR that has not yet been disclosed in
conformance with IETF rules.

This poll for adoption closes on 2nd September 2019.

Regards,

Stephane and Matthew

[1] https://datatracker.ietf.org/doc/draft-rabadan-bess-vendor-evpn-route/

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 20 Aug 2019 13:24:25 -0400

In general I support the adoption.

Could the authors please clarify how a company that doesn’t have OUI assigned should populate the OUI field and how interdependency between IEEE registration and EVPN implementation would be handled.

Informal references for IEEE OUI handling process would be useful too, perhaps this one - https://standards.ieee.org/products-services/regauth/tut/index.html

Cheers,
Jeff
On Aug 20, 2019, 5:15 AM -0400, Stephane Litkowski <[email-masked]>, wrote:
> Hi,
>
> This email begins a two-weeks WG adoption poll for draft-rabadan-bess-vendor-evpn-route-07 [1]
> Please review the draft and post any comments to the BESS working group list.
>
> We are also polling for knowledge of any undisclosed IPR that applies to this Document, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
>
> If you are listed as an author or a contributor of this document, please respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR, copying the BESS mailing list. The document won't progress without answers from all the authors and contributors.
> If you are not listed as an author or a contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.
>
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Tue, 20 Aug 2019 18:43:35 +0000

Could the authors provide further insight on the following..

“   The intend of this new Type is to allow operators and vendors to
   design rapidly new EVPN applications/prototypes and experiment with
   them in deployed networks before standardizing the specific
   application. Software Defined Networks (SDN) are evolving fast and
   the flexibility allowed by this new Route Type will contribute to the
   SDN control plane evolution.”

Thanks,
              Jim Uttaro

From: BESS <[email-masked]> On Behalf Of Jeff Tantsura
Sent: Tuesday, August 20, 2019 1:24 PM
To: [email-masked]; Stephane Litkowski <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Informal references for IEEE OUI handling process would be useful too, perhaps this one - https://standards.ieee.org/products-services/regauth/tut/index.html<https://urldefense.proofpoint.com/v2/url?u=https-3A__standards.ieee.org_products-2Dservices_regauth_tut_index.html&d=DwQFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=MYuiLReJlALiFwDrRezkBWP2u4ggWRWeN0eIP5w7al8&s=XUVcfVx2JQIwaW8F6JwTZo3uoNsUuvw6Eh80onubSKg&e=>

Cheers,
Jeff
On Aug 20, 2019, 5:15 AM -0400, Stephane Litkowski <[email-masked]<mailto:[email-masked]>>, wrote:

Hi,

If you are listed as an author or a contributor of this document, please respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR, copying the BESS mailing list. The document won't progress without answers from all the authors and contributors.
Currently, there are no IPR disclosures against this document..

Regards,
Stephane and Matthew

[1] https://datatracker.ietf.org/doc/draft-rabadan-bess-vendor-evpn-route/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Drabadan-2Dbess-2Dvendor-2Devpn-2Droute_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=MYuiLReJlALiFwDrRezkBWP2u4ggWRWeN0eIP5w7al8&s=3J4-0GVkpzaHtSWBVIB1M27NrF9hWg4vgc00q896Bvo&e=>
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bess&d=DwQFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=MYuiLReJlALiFwDrRezkBWP2u4ggWRWeN0eIP5w7al8&s=7DyN6_vPh_Mrdl3tDhi4_pFpdiiKFTL8LBLzX38CLDs&e=>

---

From: <[email-masked]>
Date: Wed, 21 Aug 2019 08:29:40 +0000

Hi,

Speaking as individual, what is the goal of the vendor key ? Is it to allow a vendor to encode multiple “sub-types” with different vendor specific info ?  Or is it a security key ? That would be great to mention how a vendor should use it.

Thanks !

From: BESS [mailto:[email-masked]] On Behalf Of Stephane Litkowski
Sent: Monday, August 19, 2019 16:32
To: [email-masked]
Subject: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi,

Regards,
Stephane and Matthew

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Sat, 24 Aug 2019 10:40:57 +0000

Hi Stephane,

It is not a security key. As you say it could be used to encode multiple sub-types with different vendor specific info, but we wanted to define it flexible/open enough for the individual vendor to decide. We can add a sentence stating that..

Thank you!
Jorge

From: BESS <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Wednesday, August 21, 2019 at 10:29 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi,

Thanks !

Hi,

Regards,
Stephane and Matthew

Thank you.

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Sat, 24 Aug 2019 10:40:59 +0000

Hi Jim,

The route type value is an “scarce” resource, with 11 values currently allocated and more described in drafts. With the success of EVPN in the industry and its use for multiple applications, we wanted to reserve a value that can be used for applications that are specific to a vendor, or even for experimental use. Reserving the last value of an IANA registry for this, is not uncommon in IETF, is it?

Besides that, we want to define a generic key and format for this type 255, so that RRs that don’t understand the specific application can still compare routes and reflect them accordingly.

Thank you.
Jorge

From: BESS <[email-masked]> on behalf of "UTTARO, JAMES" <[email-masked]>
Date: Tuesday, August 20, 2019 at 8:44 PM
To: Jeff Tantsura <[email-masked]>, "[email-masked]" <[email-masked]>, Stephane Litkowski <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Thanks,
              Jim Uttaro

Cheers,
Jeff

Hi,

Regards,
Stephane and Matthew

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Sat, 24 Aug 2019 10:41:00 +0000

Hi Jeff,

Thank you very much for your feedback.

The idea was that a vendor using this route type could use a value unique to them. In case of not having an OUI, the registration of a new one with the IEEE should be pretty straight forward. We’ll add the informal reference that you mention, thanks.

If needed, we are also open to use a generic OUI value that anyone can use.

Thanks.
Jorge

From: BESS <[email-masked]> on behalf of Jeff Tantsura <[email-masked]>
Date: Tuesday, August 20, 2019 at 7:24 PM
To: "[email-masked]" <[email-masked]>, Stephane Litkowski <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Cheers,
Jeff

Hi,

Regards,
Stephane and Matthew

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Sat, 24 Aug 2019 10:41:04 +0000

As a co-author, I support this document for WG adoption.
I’m not aware of any IPR relevant to this document.

Thanks.
Jorge

From: BESS <[email-masked]> on behalf of Stephane Litkowski <[email-masked]>
Date: Tuesday, August 20, 2019 at 11:15 AM
To: "[email-masked]" <[email-masked]>
Subject: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi,

Regards,
Stephane and Matthew

---

From: Siddhesh Dindorkar <[email-masked]>
Date: Mon, 26 Aug 2019 10:04:40 -0700

As a co-author, I am not aware of any IPR against this document.

Thanks,
Siddhesh

On Tue, Aug 20, 2019 at 3:40 AM <[email-masked]> wrote:

> FYI,
>
>
>
> Please reply to the IPR poll on the BESS list.
>
>
>
> Brgds,
>
>
>
>
>
> *From:* BESS [mailto:[email-masked]] *On Behalf Of *Stephane
> Litkowski
> *Sent:* Monday, August 19, 2019 16:32
> *To:* [email-masked]
> *Subject:* [bess] WG adoption call and IPR poll for
> draft-rabadan-bess-vendor-evpn-route-07
>
>
>
> Hi,
>
>
>
> If you are not listed as an author or a contributor, then please
> explicitly respond only if you are aware of any IPR that has not yet been
> disclosed in conformance with IETF rules.
>
>
>

---

From: "Vigoureux, Martin (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Mon, 26 Aug 2019 19:13:17 +0000

Not aware of any undisclosed IPR.

-m

Le 2019-08-19 à 16:32, Stephane Litkowski a écrit :
> relevant undisclosed IPR, copying the BESS mailing list. The document 
> won't progress without answers from all the authors and contributors.
> 
> explicitly respond only if you are aware of any IPR that has not yet 
> been disclosed in conformance with IETF rules.
>

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 27 Aug 2019 07:59:16 +0000

Support to adopt.
I think this work is useful for the WG and the industry to progress.

Brgds,
G/

From: BESS <[email-masked]> On Behalf Of Stephane Litkowski
Sent: Monday, August 19, 2019 21:32
To: [email-masked]
Subject: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi,

Regards,
Stephane and Matthew

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Tue, 27 Aug 2019 15:33:58 +0000

Support for WG adoption..

Thanks,
              Jim Uttaro

From: BESS <[email-masked]> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Saturday, August 24, 2019 6:41 AM
To: Stephane Litkowski <[email-masked]>; [email-masked]
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Thanks.
Jorge

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Stephane Litkowski <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, August 20, 2019 at 11:15 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi,

Regards,
Stephane and Matthew

[1] https://datatracker.ietf.org/doc/draft-rabadan-bess-vendor-evpn-route/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Drabadan-2Dbess-2Dvendor-2Devpn-2Droute_&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=FCsSBcbdid_AXLD6cjr7WEpXXkEnUUioaejhrgt2vfk&s=-yheh5LqW8rMhLTXFWAyBEee1YJLMR4pE-odvL1toDQ&e=>

---

From: "Oya Luengo, Roberto (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 27 Aug 2019 16:11:40 +0000

Support

Thanks
Roberto

From: BESS <[email-masked]> on behalf of "UTTARO, JAMES" <[email-masked]>
Date: Tuesday, August 27, 2019 at 8:37 AM
To: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>, Stephane Litkowski <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Thanks,
              Jim Uttaro

Thanks.
Jorge

Hi,

Regards,
Stephane and Matthew

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Tue, 27 Aug 2019 22:27:26 +0000

Hi Jorge,

I will support this draft if it is modified to specify the routes for SD-WAN application specifically as opposed to have an opaque route. My concerns are the following:

  1.  The main idea of standardization is interoperability among vendors and this draft doesn’t give us that.
  2.  Also I don’t think having such a draft can facilitate prototyping. This draft has been around for several years and your prototyping should have been independent of this draft since I am not aware of any other major vendor implemented or deployed this draft.
  3.  Even if this draft becomes an RFC, there is no guarantee that in a given network the RR will be compliant with it as we have experienced such things first hand in the field
  4.  Making dependency of an IETF draft on IEEE process is not a good thing – i.e., an new vendor that wants to implement it now needs to apply for an IEEE OUI.  OUI gets allocated to the vendor with Ethernet PHY for MAC addresses and not as route distinguisher. I am not sure how IEEE will look at this. Have you discussed your application with them (e.g., OUI for non-related Ethernet PHY/MAC)
  5.  RR can be used as store and forward mechanism for data that didn’t use BGP before. I have already seen that some people want to use BGP for passing configuration, stats, diagnostics info, etc. With now defining an opaque route, there will be no check on the contents of the route and anyone can put anything they want even if it is not best suited to do them in BGP.

So, frankly, I don’t see any positives here but just negatives. Can you replace the opaque route with the actual routes. At the end of the day, we have to do it for multi-vendor interop anyway. So, the sooner, the better. If single-vendor deployment is sufficient which is typically the case for Enterprises, then there is no need to standardize such draft.

Cheers,
Ali

From: BESS <[email-masked]> on behalf of Stephane Litkowski <[email-masked]>
Date: Tuesday, August 20, 2019 at 2:16 AM
To: "[email-masked]" <[email-masked]>
Subject: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi,

Regards,
Stephane and Matthew

---

From: Siddhesh Dindorkar <[email-masked]>
Date: Wed, 28 Aug 2019 14:42:48 -0700

Hi Ali, thanks for the detailed comments. We understand your view and those
were the discussion points within us as well. However, in reference to your
RR point #3, one of the reason for a vendor specific evpn route type is to
be able to do prototyping within small scale deployements which use other
vendor RRs. Even if we have RFCs for new route types, other vendors may not
implement them if they dont need those usecases and/or is not a release
priority. Hence again comes the restriction in using other vendor RR until
the new route type is implemented by the RR vendor.

Best,
Siddhesh

On Tue, Aug 27, 2019 at 3:27 PM Ali Sajassi (sajassi) <[email-masked]>
wrote:

> Hi Jorge,
>
>
>
> I will support this draft if it is modified to specify the routes for
> SD-WAN application specifically as opposed to have an opaque route. My
> concerns are the following:
>
>
>
>    2. Also I don’t think having such a draft can facilitate prototyping.
>    This draft has been around for several years and your prototyping should
>    have been independent of this draft since I am not aware of any other major
>    vendor implemented or deployed this draft.
>    3. Even if this draft becomes an RFC, there is no guarantee that in a
>    given network the RR will be compliant with it as we have experienced such
>    things first hand in the field
>    4. Making dependency of an IETF draft on IEEE process is not a good
>    thing – i.e., an new vendor that wants to implement it now needs to apply
>    for an IEEE OUI.  OUI gets allocated to the vendor with Ethernet PHY for
>    MAC addresses and not as route distinguisher. I am not sure how IEEE will
>    look at this. Have you discussed your application with them (e.g., OUI for
>    non-related Ethernet PHY/MAC)
>    5. RR can be used as store and forward mechanism for data that didn’t
>    use BGP before. I have already seen that some people want to use BGP for
>    passing configuration, stats, diagnostics info, etc. With now defining an
>    opaque route, there will be no check on the contents of the route and
>    anyone can put anything they want even if it is not best suited to do them
>    in BGP.
>
>
>
> So, frankly, I don’t see any positives here but just negatives. Can you
> replace the opaque route with the actual routes. At the end of the day, we
> have to do it for multi-vendor interop anyway. So, the sooner, the better.
> If single-vendor deployment is sufficient which is typically the case for
> Enterprises, then there is no need to standardize such draft.
>
>
>
> Cheers,
>
> Ali
>
>
>
>
>
> *From: *BESS <[email-masked]> on behalf of Stephane Litkowski <
> [email-masked]>
> *Date: *Tuesday, August 20, 2019 at 2:16 AM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[bess] WG adoption call and IPR poll for

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 29 Aug 2019 19:02:31 +0000

Hi Siddhesh,  wrt point #3, my point is that there is no guarantee that a given RR vendor implement/support this opaque route. Even if they do, it will take an update to get this feature. For the update of RR, the provider (cloud, sp, Enterprise) has a process in place. This same process that is used for RR upgrade to support this opaque route, can be used to support new routes. I understand that with the opaque route, you upgrade once and the subsequent new routes can be supported transparently but how often do you we introduce new routes. Furthermore, it is better to have a new routes that has multi-vendor interop support than the one that doesn’t have. Do you know of any providers that says I am OK with vendor lock-in?

If you look at the history here, we have done pretty well with collaborating together and coming up with the new routes that has multiple vendor support from the beginning. All EVPN route types from RT-5 onward fall into this category. With SD-WAN related stuff, you can come with a single extensible route that is future proof (in terms of RR).

I am just concern that introduction of opaque route will open a Pandora’s box that cannot be closed.

Cheers,
Ali

From: Siddhesh Dindorkar <[email-masked]>
Date: Wednesday, August 28, 2019 at 2:43 PM
To: Cisco Employee <[email-masked]>
Cc: Stephane Litkowski <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi Ali, thanks for the detailed comments. We understand your view and those were the discussion points within us as well. However, in reference to your RR point #3, one of the reason for a vendor specific evpn route type is to be able to do prototyping within small scale deployements which use other vendor RRs. Even if we have RFCs for new route types, other vendors may not implement them if they dont need those usecases and/or is not a release priority. Hence again comes the restriction in using other vendor RR until the new route type is implemented by the RR vendor.

Best,
Siddhesh

On Tue, Aug 27, 2019 at 3:27 PM Ali Sajassi (sajassi) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Jorge,

Cheers,
Ali

Hi,

Regards,
Stephane and Matthew