Subject: [bess] L2VPN YANG model

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 8 Aug 2019 12:55:55 -0700

Hi,

-10 version of draft-ietf-bess-l2vpn-yang contains two YANG models:
  - [email-masked]
  - [email-masked]

-09 version of the same draft contains the same two YANG models, but with these dates:
  - [email-masked]
  - [email-masked] <mailto:[email-masked]>

In essence, the newer draft has an older version of ietf-pseudowires module, while the older draft has a newer version. Is this intentional?

The effect of this is that even if there are changes made to ietf-pseudowires module in the -10 draft, because of its date, and in a repository with both modules, the older one (in -09) will be picked up, unless there is an explicit reference by date.

Please clarify what was the intention of backdating the model.

Thanks

Mahesh Jethanandani
[email-masked]

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 13 Aug 2019 17:53:40 +0000

Thanks for bringing attention to this.
Will fix..

Thanks,
Himanshu

From: BESS <[email-masked]> on behalf of Mahesh Jethanandani <[email-masked]>
Date: Thursday, August 8, 2019 at 3:56 PM
To: "[email-masked]" <[email-masked]>
Subject: [**EXTERNAL**] [bess] L2VPN YANG model

Hi,

-10 version of draft-ietf-bess-l2vpn-yang contains two YANG models:
  - [email-masked]<mailto:[email-masked]>
  - [email-masked]<mailto:[email-masked]>

-09 version of the same draft contains the same two YANG models, but with these dates:
  - [email-masked]<mailto:[email-masked]>
  - [email-masked]<mailto:[email-masked]>

Thanks

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>