Subject: [bess] EVPN VPWS BDF forwarding behavior at MH site

From: gangadhara reddy chavva <[email-masked]>
Date: Fri, 9 Aug 2019 19:01:02 +0530

HI All,

i have one question on EVPN VPWS BDF forwarding behavior at MH site.
when PE is selected as BDF, it will communicate the EAD EVI route with B
bit set to remote PE. so remote PE will install the FRR route with primary
path towards DF PE and secondary path towards BDF.
when ever primary path get disconnected it will switch the path to
secondary path quickly at remote PE. because of this data from the remote
PE will reach to BDF very quickly, but if BDF is not programmed its path
towards multi homed segment then traffic will be get dropped until control
plane convergence and it will be elected as DF.

for faster convergence if we can install the route such that BDF can allow
the traffic from remote PE towards to multi homed segment, we can forward
the traffic received from the remote PE.

at the same time we shouldn't allow the traffic from multi homed site this
leads to duplicate traffic on the remote PE. to achieve this we should not
program the path from multi home site towards remote PE until this PE
elected as DF for that VPWS instance.

can you please let me know if there are any problems with this kind of
approach.

Regards,
Gangadhar

---

From: "Thirumavalavan Periyannan (thiperiy)" <[email-masked]>
Date: Fri, 9 Aug 2019 21:20:34 +0000

Hello Gangadhara,

How remote PE detect the DF failure? It’s based on EVI/AD Withdraw message from DF PE if so then NDF PE also received this route and changed its DF status at the same time Remote PE changed its nexthop to NEW DF PE.

The below info is not clear, could you please help me to understand.

for faster convergence if we can install the route such that BDF can allow the traffic from remote PE towards to multi homed segment, we can forward the traffic received from the remote PE.

at the same time we shouldn't allow the traffic from multi homed site this leads to duplicate traffic on the remote PE. to achieve this we should not program the path from multi home site towards remote PE until this PE elected as DF for that VPWS instance.

Thanks,
Thiru

On 09-Aug-2019, at 19:02, gangadhara reddy chavva <[email-masked]<mailto:[email-masked]>> wrote:

HI All,

i have one question on EVPN VPWS BDF forwarding behavior at MH site.
when PE is selected as BDF, it will communicate the EAD EVI route with B bit set to remote PE. so remote PE will install the FRR route with primary path towards DF PE and secondary path towards BDF.
when ever primary path get disconnected it will switch the path to secondary path quickly at remote PE. because of this data from the remote PE will reach to BDF very quickly, but if BDF is not programmed its path towards multi homed segment then traffic will be get dropped until control plane convergence and it will be elected as DF.

for faster convergence if we can install the route such that BDF can allow the traffic from remote PE towards to multi homed segment, we can forward the traffic received from the remote PE.

at the same time we shouldn't allow the traffic from multi homed site this leads to duplicate traffic on the remote PE. to achieve this we should not program the path from multi home site towards remote PE until this PE elected as DF for that VPWS instance.

can you please let me know if there are any problems with this kind of approach..

Regards,
Gangadhar

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: gangadhara reddy chavva <[email-masked]>
Date: Sat, 10 Aug 2019 16:59:12 +0530

Hi Thiru,

here is the clarifications for your questions.

this is basically primary PE reach ability /  availability can be
determined through BFD/Multihop BFD, in this case FRR switch can happen
very quickly at the remote PE, control plane convergence later.

please see in line answers for the below questions:

Gangadhar >> this explains the route programming at multi homed site, if
elected PE is BDF, program the label path, so that traffic received from
remote PE will be send to multi homed CE.

Gangadhar >> again this is at BDF, we shouldn't allow the traffic from
multi homed site CE to remote PE, for this BDF should not program the path
towards remote PE, so at BDF if there is any traffic from CE will be get
dropped at BDF.

I hope this will clarify your question.

Regards,
Gangadhar

On Sat, Aug 10, 2019 at 2:50 AM Thirumavalavan Periyannan (thiperiy) <
[email-masked]> wrote:

> Hello Gangadhara,
>
> How remote PE detect the DF failure? It’s based on EVI/AD Withdraw message
> from DF PE if so then NDF PE also received this route and changed its DF
> status at the same time Remote PE changed its nexthop to NEW DF PE.
>
> On 09-Aug-2019, at 19:02, gangadhara reddy chavva <
> [email-masked]> wrote:
>
> HI All,
>
> approach..
> [email-masked]

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Mon, 12 Aug 2019 13:15:28 +0000

I assume this discussion applies to FXC ( Flexible Cross Connect )..

Thanks,
              Jim Uttaro

From: BESS <[email-masked]> On Behalf Of gangadhara reddy chavva
Sent: Saturday, August 10, 2019 7:29 AM
To: Thirumavalavan Periyannan (thiperiy) <[email-masked]>
Cc: [email-masked]
Subject: Re: [bess] EVPN VPWS BDF forwarding behavior at MH site

Hi Thiru,

this is basically primary PE reach ability /  availability can be determined through BFD/Multihop BFD, in this case FRR switch can happen very quickly at the remote PE, control plane convergence later.

Gangadhar >> this explains the route programming at multi homed site, if elected PE is BDF, program the label path, so that traffic received from remote PE will be send to multi homed CE.

Gangadhar >> again this is at BDF, we shouldn't allow the traffic from multi homed site CE to remote PE, for this BDF should not program the path towards remote PE, so at BDF if there is any traffic from CE will be get  dropped at BDF.

Regards,
Gangadhar

On Sat, Aug 10, 2019 at 2:50 AM Thirumavalavan Periyannan (thiperiy) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Gangadhara,

Thanks,
Thiru

Regards,
Gangadhar

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bess&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=dw_cbEJEFGb2ttG_aLztLllgQ6WbTf5f6YdWdNY3Sgo&s=VYEDWxQx9AA9mJMDxJ8_BoKV0xANI0ORk2zfcb3cfF4&e=>

---

From: gangadhara reddy chavva <[email-masked]>
Date: Mon, 12 Aug 2019 19:15:43 +0530

Yes, Jim Uttaro, it is related to FXC, please let me know your comments on
the below proposal.

Regards,
Gangadhar

On Mon, Aug 12, 2019 at 6:45 PM UTTARO, JAMES <[email-masked]> wrote:

> *I assume this discussion applies to FXC ( Flexible Cross Connect )..*
>
>
>
> *Thanks,*
>
> *              Jim Uttaro*
>
>
>
> *From:* BESS <[email-masked]> *On Behalf Of * gangadhara reddy
> chavva
> *Sent:* Saturday, August 10, 2019 7:29 AM
> *To:* Thirumavalavan Periyannan (thiperiy) <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [bess] EVPN VPWS BDF forwarding behavior at MH site
>
>
>
> Hi Thiru,
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bess&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=s7ZzB4JbPv3nYuoSx5Gy8Q&m=dw_cbEJEFGb2ttG_aLztLllgQ6WbTf5f6YdWdNY3Sgo&s=VYEDWxQx9AA9mJMDxJ8_BoKV0xANI0ORk2zfcb3cfF4&e=>
>
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Tue, 13 Aug 2019 01:24:06 +0000

Just so that we all are on same page –

You have PE1 & PE2 as MH peers with PE1 as primary while PE2 as backup for certain EVI with PE3 as remote PE.
The problem you describe is, what if PE3 quickly changes over the path to PE2, and PE2 has not yet changed to primary role.
The solution you propose is – Let PE2 be unidirectionally active (remote->local) even when in standby role.
This will prevent one way traffic loss. However, local to remote is delayed until PE2 becomes primary via EVPN means (DF election, etc)

You mentioned MH-IPBFD between PE1<->PE3 and BGP-PIC to activate path between PE3<->PE2.

So followings need to be considered –

  *   PE1 and PE3 path is broken : meaning PE1 is alive but MH-IPBFD triggers
     *   If path between PE1 and PE2 is not broken, withdraw of ES route by PE1 would cause DF reelection trigger,

may/may not be within BGP-PIC based resumption

  *   PE1 has died – MH-IPBFD triggers
     *   If PE1 & PE2 also had MH-IPBFD for liveliness check then PE2 can react faster
     *   The danger with this scheme is that if path between PE1 and PE2 is broken but from both to PE3 is fine,

PE2 will elect itself as primary which results in both being active, EAD/EVI will conflict with EAD/ES which is still single-active.

     *   There may be other complication on CE side with LACP becoming active and CE doing load-balancing.

All in all – Optimizing packet loss for one way communication may not necessarily be beneficial (if TCP, missing ACK will cause re-send anyway).
What would be important is to avoid sustained service blackouts.

Thanks,
Himanshu

From: BESS <[email-masked]> on behalf of gangadhara reddy chavva <[email-masked]>
Date: Monday, August 12, 2019 at 5:53 PM
To: "UTTARO, JAMES" <[email-masked]>
Cc: "Thirumavalavan Periyannan (thiperiy)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [**EXTERNAL**] Re: [bess] EVPN VPWS BDF forwarding behavior at MH site

Yes, Jim Uttaro, it is related to FXC, please let me know your comments on the below proposal.

Regards,
Gangadhar

On Mon, Aug 12, 2019 at 6:45 PM UTTARO, JAMES <[email-masked]<mailto:[email-masked]>> wrote:
I assume this discussion applies to FXC ( Flexible Cross Connect )..

Thanks,
              Jim Uttaro

From: BESS <[email-masked]<mailto:[email-masked]>> On Behalf Of gangadhara reddy chavva
Sent: Saturday, August 10, 2019 7:29 AM
To: Thirumavalavan Periyannan (thiperiy) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] EVPN VPWS BDF forwarding behavior at MH site

Hi Thiru,

Regards,
Gangadhar

Thanks,
Thiru

Regards,
Gangadhar

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Wed, 14 Aug 2019 15:14:49 +0000

Gangadhar,

              Do you have a picture describing the desired behavior..

Thanks,
              Jim Uttaro

From: gangadhara reddy chavva <[email-masked]>
Sent: Monday, August 12, 2019 9:46 AM
To: UTTARO, JAMES <[email-masked]>
Cc: Thirumavalavan Periyannan (thiperiy) <[email-masked]>; [email-masked]
Subject: Re: [bess] EVPN VPWS BDF forwarding behavior at MH site

Regards,
Gangadhar

Thanks,
              Jim Uttaro

Hi Thiru,

Regards,
Gangadhar

Thanks,
Thiru

Regards,
Gangadhar

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Fri, 16 Aug 2019 22:54:19 +0000

Note that RFC8584’s AC-DF capability is also supported by EVPN VPWS. Hence, in case of failure on the primary, the very same A-D per EVI route withdraw that causes the remote PE to switch to the backup PE, should make the BDF to take over as DF right away.

My two cents.

Thx
Jorge

From: BESS <[email-masked]> on behalf of "Shah, Himanshu" <[email-masked]>
Date: Monday, August 12, 2019 at 6:24 PM
To: gangadhara reddy chavva <[email-masked]>, "UTTARO, JAMES" <[email-masked]>
Cc: "Thirumavalavan Periyannan (thiperiy)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] [**EXTERNAL**] Re: EVPN VPWS BDF forwarding behavior at MH site

-       PE1 and PE3 path is broken : meaning PE1 is alive but MH-IPBFD triggers

o   If path between PE1 and PE2 is not broken, withdraw of ES route by PE1 would cause DF reelection trigger,

-       PE1 has died – MH-IPBFD triggers

o   If PE1 & PE2 also had MH-IPBFD for liveliness check then PE2 can react faster

o   The danger with this scheme is that if path between PE1 and PE2 is broken but from both to PE3 is fine,

o   There may be other complication on CE side with LACP becoming active and CE doing load-balancing.

Thanks,
Himanshu

Regards,
Gangadhar

Thanks,
              Jim Uttaro

Hi Thiru,

Regards,
Gangadhar

Thanks,
Thiru

Regards,
Gangadhar