Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 3 Sep 2019 17:45:37 +0000

Hi Ali,

Thanks for your comments.
Please see some more comments and questions in-line with [JORGE].

Thx
Jorge

From: BESS <[email-masked]> on behalf of "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thursday, August 29, 2019 at 9:02 PM
To: Siddhesh Dindorkar <[email-masked]>
Cc: Stephane Litkowski <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi Siddhesh,  wrt point #3, my point is that there is no guarantee that a given RR vendor implement/support this opaque route. Even if they do, it will take an update to get this feature. For the update of RR, the provider (cloud, sp, Enterprise) has a process in place. This same process that is used for RR upgrade to support this opaque route, can be used to support new routes. I understand that with the opaque route, you upgrade once and the subsequent new routes can be supported transparently but how often do you we introduce new routes. Furthermore, it is better to have a new routes that has multi-vendor interop support than the one that doesn’t have. Do you know of any providers that says I am OK with vendor lock-in?

[JORGE] the use of vendor specific types or extensions is not new in IETF. For instance, see ORF vendor specific types, or LDP TLV types, etc. Also, as you mention, the benefit is a single upgrade on RRs to be able to propagate these routes. We can discuss the details of the route format itself, regardless, reserving type 255 is a good practice.

If you look at the history here, we have done pretty well with collaborating together and coming up with the new routes that has multiple vendor support from the beginning. All EVPN route types from RT-5 onward fall into this category.

[JORGE] Sure, and this is not against the process of standardizing new route types. New routes that are relevant to multiple vendors and for the industry in general should get a new type.

With SD-WAN related stuff, you can come with a single extensible route that is future proof (in terms of RR).

[JORGE] Can you please elaborate on this?

I am just concern that introduction of opaque route will open a Pandora’s box that cannot be closed.

[JORGE] Could you please elaborate on the issues you see? Please see more below along your first email.

Cheers,
Ali

From: Siddhesh Dindorkar <[email-masked]>
Date: Wednesday, August 28, 2019 at 2:43 PM
To: Cisco Employee <[email-masked]>
Cc: Stephane Litkowski <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi Ali, thanks for the detailed comments. We understand your view and those were the discussion points within us as well. However, in reference to your RR point #3, one of the reason for a vendor specific evpn route type is to be able to do prototyping within small scale deployements which use other vendor RRs. Even if we have RFCs for new route types, other vendors may not implement them if they dont need those usecases and/or is not a release priority. Hence again comes the restriction in using other vendor RR until the new route type is implemented by the RR vendor.

Best,
Siddhesh

On Tue, Aug 27, 2019 at 3:27 PM Ali Sajassi (sajassi) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Jorge,

I will support this draft if it is modified to specify the routes for SD-WAN application specifically as opposed to have an opaque route. My concerns are the following:

1.      The main idea of standardization is interoperability among vendors and this draft doesn’t give us that.

2.      Also I don’t think having such a draft can facilitate prototyping. This draft has been around for several years and your prototyping should have been independent of this draft since I am not aware of any other major vendor implemented or deployed this draft.

[JORGE] As discussed, our view is that standardization is still relevant since there are BGP speakers that do not need to understand the content of the route, but do need to make basic checks before propagating the route.

3.      Even if this draft becomes an RFC, there is no guarantee that in a given network the RR will be compliant with it as we have experienced such things first hand in the field

[JORGE] Sure, however standardizing this will help.

4.      Making dependency of an IETF draft on IEEE process is not a good thing – i.e., an new vendor that wants to implement it now needs to apply for an IEEE OUI.  OUI gets allocated to the vendor with Ethernet PHY for MAC addresses and not as route distinguisher. I am not sure how IEEE will look at this. Have you discussed your application with them (e.g., OUI for non-related Ethernet PHY/MAC)

[JORGE] Requesting an OUI to IEEE is pretty straight forward and a lot of vendors have OUIs that can reuse here since this is NOT used in the data plane. The OUI is an easy way to avoid clashing among vendors, but as discussed with Jeff, we are open to add a generic or “wildcard OUI” or any other identifier here if the use of an OUI is not possible.

5.      RR can be used as store and forward mechanism for data that didn’t use BGP before. I have already seen that some people want to use BGP for passing configuration, stats, diagnostics info, etc. With now defining an opaque route, there will be no check on the contents of the route and anyone can put anything they want even if it is not best suited to do them in BGP.

[JORGE] Our view is that it is better to define a new route type with a minimum standardized format that BGP speakers can check, rather than having existing route types used with proprietary path attributes, which is what some vendors are doing. In any case, again, we are open to discuss the format. Yet I think reserving type 255 for this is a good thing that will help the evolution of EVPN.

So, frankly, I don’t see any positives here but just negatives. Can you replace the opaque route with the actual routes. At the end of the day, we have to do it for multi-vendor interop anyway. So, the sooner, the better. If single-vendor deployment is sufficient which is typically the case for Enterprises, then there is no need to standardize such draft.

Cheers,
Ali

From: BESS <[email-masked]<mailto:[email-masked]>> on behalf of Stephane Litkowski <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, August 20, 2019 at 2:16 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi,

This email begins a two-weeks WG adoption poll for draft-rabadan-bess-vendor-evpn-route-07 [1]
Please review the draft and post any comments to the BESS working group list.

We are also polling for knowledge of any undisclosed IPR that applies to this Document, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).

If you are listed as an author or a contributor of this document, please respond to this email and indicate whether or not you are aware of any relevant undisclosed IPR, copying the BESS mailing list. The document won't progress without answers from all the authors and contributors.
Currently, there are no IPR disclosures against this document.

If you are not listed as an author or a contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

This poll for adoption closes on 2nd September 2019.

Regards,
Stephane and Matthew

[1] https://datatracker.ietf.org/doc/draft-rabadan-bess-vendor-evpn-route/
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: <[email-masked]>
Date: Wed, 4 Sep 2019 21:56:02 +0000

Hi WG,

The poll has ended.
Some concerns have been raised on having this opaque route. More discussion is required before adopting the document.

Stephane

From: BESS [mailto:[email-masked]] On Behalf Of Stephane Litkowski
Sent: Monday, August 19, 2019 16:32
To: [email-masked]
Subject: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi,

Regards,
Stephane and Matthew

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Fri, 6 Sep 2019 01:59:41 +0000

Hi Jorge,

Please see my replies below with [Ali].

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tuesday, September 3, 2019 at 10:45 AM
To: Cisco Employee <[email-masked]>, Siddhesh Dindorkar <[email-masked]>
Cc: Stephane Litkowski <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] WG adoption call and IPR poll for draft-rabadan-bess-vendor-evpn-route-07

Hi Ali,

Thx
Jorge

[Ali] Wrt ORF, are you aware of any ORF vendor specific type interoperability between a PE and a RR from different vendors? I am not!
Wrt LDP TLV types, no RR is involved and if it is targeted LDP, it is purely between two PEs that have implemented proprietary feature and understand each other – i.e., no other devices is involved.
There is a difference between reserving a type for a feature confined to two devices from the same vendor versus reserving a type for a feature between two devices from different vendors. What you are asking is unprecedented AFAIK. If you think otherwise, please give specific example.

[Ali] So, you don’t plan to ever standardize these routes. If so, then RR is only the first hurdle. All providers and customers that I know, they don’t want vendor lock-in for PEs. If you know of someone who wants vendor lock-in, then it would be good for them to chime-in. But if your intention is to eventually standardize the routes, then the sooner is the better as we have done in the past.

[Ali] Instead of having complete opaque route, one can define a route with fixed portion and variable portion; where fixed portion is part of the BGP route key processing and variable portion is extensible. However, we get into the some basic fundamental here as to why not use existing tunnel attribute for this purpose? What info are you trying to pass that you think it is better suited as BGP route as opposed to BGP attribute?

[Ali] Having an opaque route makes our process opaque as well! We don’t know what and why a vendor wants to use this route for and whether the use of BGP machinery is the best option. I much prefer we do things based on technical merit and have complete transparency.

[Ali] Currently when a BGP speaker doesn’t understand a route, it ignores the route and does NOT store it. What you now asking is that a BGP speaker (RR) that doesn’t understand a route, allocates its resources for it (store it) and process it just like a regular route regardless whether such info is fit for BGP or not. As I said above, we need to have transparency to see whether such info first is suiteable for BGP and if it is suitable for BGP, whether to pass it as route or attribute.

[Ali] Currently the vendors that have OUI, have gotten it because they are Ethernet vendors. Now we are talking about a new IP vendor that has nothing to do with PHY/MAC layer, to go and ask IEEE for an OUI. I am not sure if IEEE will give away OUIs as candies ☺

[Ali] It is very difficult to have technical discussions without knowing any details about the kind of info that is being passed, frequency of it, granularity levels, scope, etc.

Cheers,
Ali

Hi,

Regards,
Stephane and Matthew