Subject: [bess] RFC or Draft that lists all standards track rfc’s of all mvpn profiles

From: Gyan Mishra <[email-masked]>
Date: Sat, 28 Sep 2019 11:58:50 -0400

BESS WG / All

I am trying to find a list of all MVPN profiles that are supported by Cisco and Juniper and Huawei SP router vendors.

Below link shows what CISCO supports most of which I believe are a CISCO proprietary and non standard so won’t work between vendors.

https://www.cisco.com/c/en/us/support/docs/ip/multicast/200512-Configure-mVPN-Profiles-within-Cisco-IOS.html

Thank you

Gyan Mishra 
Verizon Communications 
Cell 301 502-1347

Sent from my iPhone

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 28 Sep 2019 14:05:53 -0400

I did some research and theseare the main RFCs for MVPN and how based they map to CISCO profiles and you do the same for Juniper and Huawei.

The 1st two are for mLDP w/ BGP-AD pim (in band) or bgp (out of band)c-signaling 

UI-PMSI (uni directional inclusive provider multicast service instance) Cisco Default MDT for PIM SM or SSM 

MI-PMSI (multi directional provider multicast service instance)  CISCO Default MDT for PIM SM or SSM

S-PMSI (Selective Provider multicast service instance) CISCO Data MDT for PIM SM or SSM

PIM dense mode MVPN  not supported - I don’t think anyone uses dense these days 

https://tools.ietf.org/html/rfc6513 MVPN

https://tools.ietf.org/html/rfc6514 MVPN

https://tools.ietf.org/html/rfc6037. Rosen PIM GRE

https://tools.ietf.org/html/rfc4875 P2MP TE

Sent from my iPhone

> On Sep 28, 2019, at 11:58 AM, Gyan Mishra <[email-masked]> wrote:
> 
> BESS WG / All
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 28 Sep 2019 18:58:20 +0000

Hi Gyan,
See one inline.

From: BESS <[email-masked]> on behalf of Gyan Mishra <[email-masked]>
Date: Saturday, September 28, 2019 at 2:06 PM
To: Gyan Mishra <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [bess] RFC or Draft that lists all standards track rfc’s of all mvpn profiles

That is mostly true. However, it is used for PIM auto-rp advertisements (groups 224.0.1.39 and 224.0.1.40).

Thanks,
Acee

On Sep 28, 2019, at 11:58 AM, Gyan Mishra <[email-masked]<mailto:[email-masked]>> wrote:
BESS WG / All

Thank you

Gyan Mishra
Verizon Communications
Cell 301 502-1347
Sent from my iPhone

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Mon, 30 Sep 2019 19:04:26 +0000

Hi Gyan,
Is there any specific OS mVPN profile implementation you are looking for ?

Thanks
Mankamana

From: BESS <[email-masked]> on behalf of Gyan Mishra <[email-masked]>
Date: Saturday, September 28, 2019 at 8:59 AM
To: "[email-masked]" <[email-masked]>
Subject: [bess] RFC or Draft that lists all standards track rfc’s of all mvpn profiles

BESS WG / All

https://www.cisco..com/c/en/us/support/docs/ip/multicast/200512-Configure-mVPN-Profiles-within-Cisco-IOS.html<https://www.cisco.com/c/en/us/support/docs/ip/multicast/200512-Configure-mVPN-Profiles-within-Cisco-IOS.html>

Thank you

Gyan Mishra
Verizon Communications
Cell 301 502-1347
Sent from my iPhone

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 30 Sep 2019 16:35:54 -0400

Hi Mankamana

Let’s take this discussion off line from Bess.

Thank you 

Gyan

Sent from my iPhone

> On Sep 30, 2019, at 3:04 PM, Mankamana Mishra (mankamis) <[email-masked]> wrote:
> 
> Hi Gyan,
> https://www.cisco..com/c/en/us/support/docs/ip/multicast/200512-Configure-mVPN-Profiles-within-Cisco-IOS.html
>  
> Thank you
>  
> Gyan Mishra 
> Verizon Communications 
> Cell 301 502-1347
> 
> Sent from my iPhone

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 1 Oct 2019 03:01:55 +0000

Another way to look at different flavors/profiles of MVPN is to consider the following two aspects:

  1.  How are C-multicast state (customer (s,g)/(*,g) or mLDP FEC signaled on PC-CE interfaces) are signaled over provider core
  2.  How are C-multicast traffic transported through the provider core

For #1, you have the choice of PIM (Rosen/PIM-MVPN and its later variants), BGP (BGP-MVPN), and mLDP (mLDP inband signaling).
For #2, your provider tunnel choice can be PIM ASM/SSM, RSVP-TE/mLDP P2MP, Ingress Replication, BIER, … and more could be defined (e.g. SR P2MP).

The two aspects together will give you many combinations and they’re referred to as different “profiles” of MVPN by a certain vendor (😊) but I personally find it easier to look at those two aspects (e.g. “BGP-MVPN with mLDP tunnel”) 😊

BTW the same applies to EVPN BUM as well.

Jeffrey

From: BESS <[email-masked]> On Behalf Of Gyan Mishra
Sent: Saturday, September 28, 2019 2:06 PM
To: Gyan Mishra <[email-masked]>; [email-masked]
Subject: Re: [bess] RFC or Draft that lists all standards track rfc’s of all mvpn profiles

https://tools.ietf.org/html/rfc6513<https://urldefense.com/v3/__https:/tools.ietf.org/html/rfc6513__;!8WoA6RjC81c!XrBWTOGj5DVLcAKHFynu0Xz-drszhVTpNKy34DkjXA0ilBykj5ljx0DKdQEKZP27$> MVPN

https://tools.ietf.org/html/rfc6514<https://urldefense.com/v3/__https:/tools.ietf.org/html/rfc6514__;!8WoA6RjC81c!XrBWTOGj5DVLcAKHFynu0Xz-drszhVTpNKy34DkjXA0ilBykj5ljx0DKdbmRB91B$> MVPN

https://tools.ietf.org/html/rfc6037<https://urldefense.com/v3/__https:/tools.ietf.org/html/rfc6037__;!8WoA6RjC81c!XrBWTOGj5DVLcAKHFynu0Xz-drszhVTpNKy34DkjXA0ilBykj5ljx0DKdUliuPcJ$>. Rosen PIM GRE

https://tools.ietf.org/html/rfc4875<https://urldefense.com/v3/__https:/tools.ietf.org/html/rfc4875__;!8WoA6RjC81c!XrBWTOGj5DVLcAKHFynu0Xz-drszhVTpNKy34DkjXA0ilBykj5ljx0DKdQeNDgRo$> P2MP TE
Sent from my iPhone

https://www.cisco.com/c/en/us/support/docs/ip/multicast/200512-Configure-mVPN-Profiles-within-Cisco-IOS.html<https://urldefense.com/v3/__https:/www.cisco.com/c/en/us/support/docs/ip/multicast/200512-Configure-mVPN-Profiles-within-Cisco-IOS.html__;!8WoA6RjC81c!XrBWTOGj5DVLcAKHFynu0Xz-drszhVTpNKy34DkjXA0ilBykj5ljx0DKdZzUn3UQ$>

Thank you

Gyan Mishra
Verizon Communications
Cell 301 502-1347
Sent from my iPhone