Subject: [bess] Comments on draft-ietf-bess-evpn-pref-df

From: <[email-masked]>
Date: Fri, 27 Sep 2019 19:57:19 -0700

Hi Authors,

I had a look on your draft and I have some concerns/questions that I would
like to discuss.

I like the fact of being able to tune the pref DF election per VLAN range,
however:

*	Don't you think that using a local configuration may open to
inconsistent configurations resulting in issues ?
*	How does the high_or_low works if I have more than 2 links in the ES
? (multihoming with 4 links with 4 levels of preference ?)

Thanks,

Stephane

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Sun, 29 Sep 2019 11:09:44 +0000

Hi Stephane,

Please see in-line.

If you think we should add some text making my comments below more explicit, I’d be happy to do it.
Thank you.
Jorge

From: "[email-masked]" <[email-masked]>
Date: Saturday, September 28, 2019 at 4:57 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Comments on draft-ietf-bess-evpn-pref-df
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Saturday, September 28, 2019 at 4:57 AM

Hi Authors,

I had a look on your draft and I have some concerns/questions that I would like to discuss.
I like the fact of being able to tune the pref DF election per VLAN range, however:

-          Don’t you think that using a local configuration may open to inconsistent configurations resulting in issues ?
[JORGE] We discussed quite a few times whether we should signal the vlan ranges for which you desire high_pref or low_pref. We ended up coming to the conclusion that it is better/simpler (and already supported) to define virtual ethernet segments for ranges of vlans and then have the default high_pref that is defined in the spec. That is less prone to errors. E.g. on a given port, define two ranges: vlan (1-2k) --> vES-1 and [(2k+1)-4k] -->vES-2. On a given PE, vES-1 and vES-2 have different pref values.

-          How does the high_or_low works if I have more than 2 links in the ES ? (multihoming with 4 links with 4 levels of preference ?)
[JORGE] if you want 4 levels of preference so that each of the 4 PEs is DF for a range of vlans, the easiest way as discussed above is to define 4 vESes. The high_or_low is an easy way of having load balancing if you have only 2 PEs in the ES and you really want to define only one ES.

Thanks,

Stephane

---

From: "Satya Mohanty (satyamoh)" <[email-masked]>
Date: Mon, 30 Sep 2019 17:28:25 +0000

Hi Stephane,

An alternative way to guarantee precedence per vlan (i.e. the most granular) rather than the vlan-range in the vlan-based service models, could be by using the DF extcom in the per EVI AD route instead of the procedures in Section 4.2 relevant to the vlan range.

But this may not be required in a real deployment and specification of precedence per a vlan-range is probably sufficient.

So, I agree with Jorge regarding his observation of vES.

Best,
--Satya

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Sunday, September 29, 2019 at 4:10 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Comments on draft-ietf-bess-evpn-pref-df
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, "[email-masked]" <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Sunday, September 29, 2019 at 4:09 AM

Hi Stephane,

Please see in-line.

Hi Authors,

Thanks,

Stephane