Subject: [bess] EVPN- PMSI Tunnel Identifier.

From: TULASI RAM REDDY <[email-masked]>
Date: Fri, 22 Jan 2021 11:38:20 +0530

Hi All,

If I understand correctly, the AFI of the below Tunnel identifier will be
same as BGP Nexthop AFI in MP_REACH.
Can we assume the BGP Nexthop IP address carrying this P-Tunnel attribute
and Tunnel Identifier address always the same ? If this can be different,
can you please throw some light on the scenario?

11.2 <https://tools.ietf.org/html/rfc7432#section-11.2>.  P-Tunnel
Identification

 PMSI Tunnel attribute with the Tunnel Type set to Ingress
 Replication and the Tunnel Identifier set to a routable address of
 the PE.

Thanks,
TULASI RAMI REDDY N

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Fri, 22 Jan 2021 08:34:54 +0000

Hi Tulasi,

I don’t think you can assume that.
In inter-as model B scenarios, the bgp next-hop will keep changing along the way, while the tunnel identifier in the PTA, or the originating-ip in the IMET NLRI will be kept as set by the advertising PE.

Thanks.
Jorge

From: BESS <[email-masked]> on behalf of TULASI RAM REDDY <[email-masked]>
Date: Friday, January 22, 2021 at 7:08 AM
To: [email-masked] <[email-masked]>
Subject: [bess] EVPN- PMSI Tunnel Identifier.
Hi All,

If I understand correctly, the AFI of the below Tunnel identifier will be same as BGP Nexthop AFI in MP_REACH.
Can we assume the BGP Nexthop IP address carrying this P-Tunnel attribute and Tunnel Identifier address always the same ? If this can be different, can you please throw some light on the scenario?
11.2<https://tools.ietf.org/html/rfc7432#section-11.2>.  P-Tunnel Identification

 the PE.

Thanks,
TULASI RAMI REDDY N