Subject: [bess] Last mile for WGLC on draft-ietf-bess-evpn-ipvpn-interworking-04 => need IDR review

From: <[email-masked]>
Date: Mon, 4 Jan 2021 12:23:36 +0100

Hi IDR WG,

We are in the last mile for the WGLC of
draft-ietf-bess-evpn-ipvpn-interworking-04 in BESS WG.

https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-ipvpn-interworking

Couple of comments from our groups have been already addressed.

As BESS WG co-chair, I would like to get your feedback on the document.

There are couple of point that need to be looked at:

*	The draft defines a new path attributes DPATH for loop prevention
across "domains" (domain does not mean AS here).
*	It defines some propagation / non propagation rules of attributes by
the gateway PE (in uniform mode). I would like to spot your attention here.
One consequence is that for any new attribute defined in BESS or IDR, we'll
have to define the propagation rules by gateway PEs. I would like to hear
the opinion of the IDR group and IDR chairs on that point.
*	It defines aggregation rules of attributes in the context of the IP
VRF. I would like also to hear opinion from the group and chair on this.  

Thanks to provide your feedback as soon as possible (pls cross post in IDR
and BESS).

Brgds,

Stephane

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Mon, 4 Jan 2021 15:30:08 +0000

Jorge,

              When we first began specifying this draft we had three models. The composite PE ( Ships in the Night ), Inter-Working PE and exchange of state using RRs where the set of PEs supporting EVPN, L3VPN and IP share a common reachability domain i.e BGP LU ( 3107 ). Currently the draft does not specify the RR model as we decided that would not be in the original version. As this draft is moving quickly would a subsequent revision/bis specify the RR model?  IMO the RR model is quite desirable as there are traffic can follow the "best path" with that is lowest cost, performance, availability, geo-political concerns etc.. There are broad implications for network slicing when traffic has to traverse discreet gateways in the network. The same reasons operators like Option C as opposed to A or B apply here. I have attached a few slides where we discussed this..

Thanks,
              Jim Uttaro

From: BESS <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, January 04, 2021 6:24 AM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] Last mile for WGLC on draft-ietf-bess-evpn-ipvpn-interworking-04 => need IDR review

Hi IDR WG,

We are in the last mile for the WGLC of draft-ietf-bess-evpn-ipvpn-interworking-04 in BESS WG.
https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-ipvpn-interworking<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bess-evpn-ipvpn-interworking__;!!BhdT!xbIM5_c0J3-GuSHDrQlLm4v7batDnrDlmsTU9EryGl65wjWlrugLwQiVgVo$>

  *   The draft defines a new path attributes DPATH for loop prevention across "domains" (domain does not mean AS here).
  *   It defines some propagation / non propagation rules of attributes by the gateway PE (in uniform mode). I would like to spot your attention here. One consequence is that for any new attribute defined in BESS or IDR, we'll have to define the propagation rules by gateway PEs. I would like to hear the opinion of the IDR group and IDR chairs on that point.
  *   It defines aggregation rules of attributes in the context of the IP VRF. I would like also to hear opinion from the group and chair on this.

Thanks to provide your feedback as soon as possible (pls cross post in IDR and BESS).

Brgds,

Stephane

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Mon, 4 Jan 2021 16:15:01 +0000

Hi Jim,

Happy New Year!
I think what you say should be discussed offline, outside the context of this Last Call, since it is new work.
We don’t want to delay the progress of the evpn-ipvpn-interworking draft, which has been implemented by some vendors and it is being implemented by others.

Would you agree?

Thanks,
Jorge

From: Idr <[email-masked]> on behalf of UTTARO, JAMES <[email-masked]>
Date: Monday, January 4, 2021 at 8:31 AM
To: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [Idr] [bess] Last mile for WGLC on draft-ietf-bess-evpn-ipvpn-interworking-04 => need IDR review
Jorge,

              When we first began specifying this draft we had three models. The composite PE ( Ships in the Night ), Inter-Working PE and exchange of state using RRs where the set of PEs supporting EVPN, L3VPN and IP share a common reachability domain i.e BGP LU ( 3107 ). Currently the draft does not specify the RR model as we decided that would not be in the original version. As this draft is moving quickly would a subsequent revision/bis specify the RR model?  IMO the RR model is quite desirable as there are traffic can follow the “best path” with that is lowest cost, performance, availability, geo-political concerns etc.. There are broad implications for network slicing when traffic has to traverse discreet gateways in the network. The same reasons operators like Option C as opposed to A or B apply here. I have attached a few slides where we discussed this..

Thanks,
              Jim Uttaro

Hi IDR WG,

-          The draft defines a new path attributes DPATH for loop prevention across “domains” (domain does not mean AS here).

-          It defines some propagation / non propagation rules of attributes by the gateway PE (in uniform mode). I would like to spot your attention here. One consequence is that for any new attribute defined in BESS or IDR, we’ll have to define the propagation rules by gateway PEs. I would like to hear the opinion of the IDR group and IDR chairs on that point.

-          It defines aggregation rules of attributes in the context of the IP VRF. I would like also to hear opinion from the group and chair on this.

Brgds,

Stephane

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Mon, 4 Jan 2021 16:53:43 +0000

Jorge,

              Happy New Years to you and yours. I agree that this effort should not get in the way of last call. The work is quite important to next generation VPNs.. My concern revolves around the differences in behavior when leaking state, assignment of D-PATH, attribute aggregation and propagation etc... are done in-line (  Control/Data on inter-Working PE ) as opposed to the control plane being orthogonal to the inter-working in the data plane. As an example the optimization that was just done to assign the D-Path attribute prior to advertising would not seem to work in the RR model..

Thanks,
              Jim Uttaro

From: BESS <[email-masked]> On Behalf Of Rabadan, Jorge (Nokia - US/Mountain View)
Sent: Monday, January 04, 2021 11:15 AM
To: UTTARO, JAMES <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [bess] Last mile for WGLC on draft-ietf-bess-evpn-ipvpn-interworking-04 => need IDR review

Hi Jim,

Happy New Year!
I think what you say should be discussed offline, outside the context of this Last Call, since it is new work.
We don't want to delay the progress of the evpn-ipvpn-interworking draft, which has been implemented by some vendors and it is being implemented by others.

Would you agree?

Thanks,
Jorge

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of UTTARO, JAMES <[email-masked]<mailto:[email-masked]>>
Date: Monday, January 4, 2021 at 8:31 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] [bess] Last mile for WGLC on draft-ietf-bess-evpn-ipvpn-interworking-04 => need IDR review
Jorge,

Thanks,
              Jim Uttaro

From: BESS <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Monday, January 04, 2021 6:24 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [bess] Last mile for WGLC on draft-ietf-bess-evpn-ipvpn-interworking-04 => need IDR review

Hi IDR WG,

-          The draft defines a new path attributes DPATH for loop prevention across "domains" (domain does not mean AS here).

-          It defines some propagation / non propagation rules of attributes by the gateway PE (in uniform mode). I would like to spot your attention here. One consequence is that for any new attribute defined in BESS or IDR, we'll have to define the propagation rules by gateway PEs. I would like to hear the opinion of the IDR group and IDR chairs on that point.

Brgds,

Stephane

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 5 Jan 2021 03:21:44 +0000

Hi Jim,

Let’s discuss offline among the authors to understand your concerns, please.

Thanks!
Jorge

From: UTTARO, JAMES <[email-masked]>
Date: Monday, January 4, 2021 at 9:54 AM
To: Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: RE: [bess] Last mile for WGLC on draft-ietf-bess-evpn-ipvpn-interworking-04 => need IDR review
Jorge,

              Happy New Years to you and yours. I agree that this effort should not get in the way of last call. The work is quite important to next generation VPNs.. My concern revolves around the differences in behavior when leaking state, assignment of D-PATH, attribute aggregation and propagation etc… are done in-line (  Control/Data on inter-Working PE ) as opposed to the control plane being orthogonal to the inter-working in the data plane. As an example the optimization that was just done to assign the D-Path attribute prior to advertising would not seem to work in the RR model..

Thanks,
              Jim Uttaro

Hi Jim,

Happy New Year!

Would you agree?

Thanks,
Jorge

Thanks,
              Jim Uttaro

Hi IDR WG,

Brgds,

Stephane