Subject: [bess] Tsvart last call review of draft-ietf-bess-evpn-optimized-ir-08

From: Michael Tüxen via Datatracker <[email-masked]>
Date: Tue, 07 Sep 2021 12:57:33 -0700

Reviewer: Michael Tüxen
Review result: Ready with Nits

This document has been reviewed as part of the transport area review team's
ongoing effort to review key IETF documents. These comments were written
primarily for the transport area directors, but are copied to the document's
authors and WG to allow them to address any issues raised and also to the IETF
discussion list for information.

When done at the time of IETF Last Call, the authors should consider this
review as part of the last-call comments they receive. Please always CC
[email-masked] if you reply to or forward this review.

I have not found issues related to transport.
However, I have two questions:

Section 5.2
What is the timer value for AR-REPLICATOR-activation-timer?
Are there dependencies to other parameters?

Section 6.2
What is the timer value for timer t?
Are there dependencies to other parameters?

Nits:

Abstract
Resolve BUM, resolve acronyms on first occurrence

Section 1
BUM resolved after being used.

Section 10
A implementation following -> An implementation following

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 23 Sep 2021 10:30:28 +0000

Hi Michael,

Thanks for the review. Just published revision 09 addressing your comments.
Please see in-line with [jorge].
Thanks!
Jorge

From: Michael Tüxen via Datatracker <[email-masked]>
Date: Tuesday, September 7, 2021 at 9:57 PM
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Tsvart last call review of draft-ietf-bess-evpn-optimized-ir-08
Reviewer: Michael Tüxen
Review result: Ready with Nits

Section 5.2
What is the timer value for AR-REPLICATOR-activation-timer?
Are there dependencies to other parameters?
[jorge] We clarified bullet ‘e’ as per the above questions. The new text in revision 9 reads:

   e.  The use of an AR-REPLICATOR-activation-timer (in seconds, default

       value is 3) on the AR-LEAF nodes is RECOMMENDED.  Upon receiving

       a new Replicator-AR route where the AR-REPLICATOR is selected,

       the AR-LEAF will run a timer before programming the new AR-

       REPLICATOR.  In case of a new added AR-REPLICATOR, or in case the

       AR-REPLICATOR reboots, this timer will give the AR-REPLICATOR

       some time to program the AR-LEAF nodes before the AR-LEAF sends

       BM traffic.  The AR-REPLICATOR-activation-timer SHOULD be

       configurable in seconds, and its value account for the time it

       takes for the AR-LEAF Regular-IR inclusive multicast route to get

       to the AR-REPLICATOR and be programmed.  While the AR-REPLICATOR-

       activation-time is running, the AR-LEAF node will use regular

       ingress replication.

Section 6.2
What is the timer value for timer t?
Are there dependencies to other parameters?
[jorge] We clarified the use of the timers in 6.2. The new text reads:

   b.  The AR-LEAF MAY advertise a Regular-IR route if there are RNVEs

       in the BD.  The Selective AR-LEAF MUST advertise a Leaf A-D route

       after receiving a Replicator-AR route with L=1.  It is

       RECOMMENDED that the Selective AR-LEAF waits for a AR-LEAF-join-

       wait-timer (in seconds, default value is 3) before sending the

       Leaf A-D route, so that the AR-LEAF can collect all the

       Replicator-AR routes for the BD before advertising the Leaf A-D

       route.

<snip>

       o  In case of a failure on the selected AR-REPLICATOR, another

          AR-REPLICATOR will be selected and a new Leaf A-D update will

          be issued for the new AR-REPLICATOR.  This new route will

          update the selective list in the new Selective AR-REPLICATOR.

          In case of failure on the active Selective AR-REPLICATOR, it

          is RECOMMENDED for the Selective AR-LEAF to revert to IR

          behavior for a timer AR-REPLICATOR-activation-timer (in

          seconds, default value is 3) to speed up the convergence.

          When the timer expires, the Selective AR-LEAF will resume its

          AR mode with the new Selective AR-REPLICATOR.  The AR-

          REPLICATOR-activation-timer MAY be the same configurable

          parameter as in Section 5.2.

Nits:

Abstract
[jorge] done, thanks.

Section 1
BUM resolved after being used.
[jorge] fixed it. Thanks.

Section 10
A implementation following -> An implementation following
[jorge] fixed it. Thanks.

---

From: [email-masked]
Date: Thu, 23 Sep 2021 14:06:28 +0200

> On 23. Sep 2021, at 12:30, Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]> wrote:
> 
> Hi Michael,
>  
Thanks for addressing the issues. I'm fine with the changes.

Best regards
Michael
> _______________________________________________
> Tsv-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tsv-art