Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Wed, 1 Sep 2021 15:11:29 +0000

Ali’s reasoning makes sense to me too.
Thanks.
Jorge

From: BESS <[email-masked]> on behalf of [email-masked] <[email-masked]>
Date: Tuesday, August 31, 2021 at 11:37 PM
To: jdrake=[email-masked] <jdrake=[email-masked]>
Cc: Bocci, Matthew (Nokia - GB) <[email-masked]>, sajassi=[email-masked] <sajassi=[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

Hi Matthew,

my apologies for the belated response:

1.       I am still awaiting a response from our product team on whether any part of the draft is supported.

2.       I concur with Ali. LSP Ping is a broadly used OAM tool detecting and localizing failures, including discrepancies between the data and control planes. The document defines necessary Target FEC sub-TLVs for EVPN and MVPN cases.

Regards,

Greg Mirsky

Sr. Standardization Expert
预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product R&D Institute/Wireline Product Operation Division

E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<http://www.zte.com.cn/>
Original Mail
Sender: JohnEDrake
To: Ali Sajassi (sajassi);Bocci, Matthew (Nokia - GB);[email-masked];[email-masked];
Date: 2021/08/31 11:34
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
_______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess
Hi,

I agree with Ali.

Yours Irrespectively,

John

Juniper Business Use Only
From: BESS <[email-masked]> On Behalf Of Ali Sajassi (sajassi)
Sent: Friday, August 27, 2021 9:54 PM
To: Bocci, Matthew (Nokia - GB) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

[External Email. Be cautious of content]

Hi Matthew,

Some of the co-authors are on PTO and I couldn’t reach them (typical of the month of August). So, I’d like to get a bit more extension.

Regarding the two questions below:

1.       My company hasn’t implemented it.

2.       I do think that we should process with the publication as it describes how LSP ping can be used to detect data-plane failures for various EVPN functionality including aliasing, split-horizon filtering using ESI label, multicast, l2-unicast, l3-unicast, IRB, etc. For MPLS transport tunnel, I am not aware of any other tool/draft that allows us to do data-plane failure detection. Thus, I think it is important to proceed with its publications.

Still I’d like to hear from other co-authors and other people in this community.

Regards,
Ali

From: Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>>
Date: Monday, August 9, 2021 at 6:25 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
WG and Authors

Unfortunately I have not seen any responses indicating that there are any known implementations of this draft. I also did not see any responses to Stephane's question if we should proceed regardless.

As per the BESS WG implementation policy (https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4v8nM3No$>), please can you respond to this email indicating either:

- That you are aware of any implementations (ideally providing some details)
- If you are not aware of any, if you think the WG should proceed with the draft's publication and why.

I will close this poll on 25th August 2021.

Regards

Matthew

On 14/06/2021, 17:38, "BESS on behalf of [email-masked]<mailto:[email-masked]>" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

    A New Internet-Draft is available from the on-line Internet-Drafts directories.
    This draft is a work item of the BGP Enabled ServiceS WG of the IETF.

            Title           : LSP-Ping Mechanisms for EVPN and PBB-EVPN
            Authors         : Parag Jain
                              Samer Salam
                              Ali Sajassi
                              Sami Boutros
                              Greg Mirsky
         Filename        : draft-ietf-bess-evpn-lsp-ping-05.txt
         Pages           : 15
         Date            : 2021-06-14

    Abstract:
       LSP-Ping is a widely deployed Operation, Administration, and
       Maintenance (OAM) mechanism in MPLS networks.  This document
       describes mechanisms for detecting data-plane failures using LSP Ping
       in MPLS based EVPN and PBB-EVPN networks.

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4CFZvJAM$>

    There is also an htmlized version available at:
    https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4RLT2-5Q$>

    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05<https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli44UwE5yg$>

    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/<https://urldefense.com/v3/__ftp:/ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4trDqUTY$>

    _______________________________________________
    BESS mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/bess<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bess__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4YoTqkAc$>

---

From: "Dikshit, Saumya" <[email-masked]>
Date: Wed, 1 Sep 2021 16:06:37 +0000

I have following queries regarding this draft:

>>>> Do we intend-to-use/call-out-usage-of “wild-card/don’t-care” values for attributes carried in the sub-TLVs ?
For example, If the admin intends  to check the reachability to host (MAC_X/IP_X) published (in route-type-2)  by remote PE.
The remote PE learnt it locally over ESI_X against Vlan X (mapped to BD_XYZ).

Is it possible, that the “EVPN MAC sub-tlv”  can carry the “Route Distinguisher” and “Ethernet Segment Identifier” as don’t care.

>>>> Another caseto handle would be test the reachability to tenant-VRF VRF_X (with EVPN mapped EVI) configured on the remote PE, PE1.
VRF_X has no active IP/IPv6 interface configured and its sole usage is to obtain the leaked (via IVRL) routes from other VRFs (non-EVPN) and PE1 published this to other peers via EVPN control plane. Till the first prefix (learnt ) route is published (Route Type 5) by PE1 for the EVI (mapped to VRF_X), the tunnels will not be provisioned on other PEs.
In order to test the reachability to VRF_X (on PE1) from another PEs, let’s say, PE2 or a centralized-controller (which can emulate/supports MPLS),

It may need to carry all/subset-of attributes with “don’t-care/wild-card” in “EVPN IP Prefix Sub-TLV”.

Please let know your thoughts on above.

Thanks
Saumya.

From: BESS [mailto:[email-masked]] On Behalf Of Gyan Mishra
Sent: Wednesday, September 1, 2021 11:26 AM
To: [email-masked]
Cc: [email-masked]; sajassi=[email-masked]; [email-masked]; jdrake=[email-masked]; [email-masked]
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

As a WG member providing operators  feedback, I agree with Ali that we should proceed with publication.  I support progression of this draft.

As Greg has noted that LSP OAM ping has been utilized as a critical tool for operations in data plane troubleshooting of control plane against data plane failures.

This document describes a critical mechanism for operators to detect data plane failures using the same LSP ping widely used, now being applied to MPLS or SR-MPLS based  NG L2 VPN EVPN & PBB-EVPN using 4 new FEC Stack Sub TLVs, EVPN MAC/IP Sub TLV for EVPN Type 2 advertisements, EVPN I-PMSI inclusive P-Tree for EVPN Type 3 advertisement, EVPN Auto discovery Sub TLV for EVPN Type 1 AD advertisement and finally EVPN IP Prefix Sub TLV for EVPN Type 5 advertisement.

Kind Regards

Gyan
Verizon

On Tue, Aug 31, 2021 at 5:36 PM <[email-masked]<mailto:[email-masked]>> wrote:

Hi Matthew,

Regards,

Greg Mirsky

E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<http://www.zte.com.cn/>
Original Mail
Sender: JohnEDrake
To: Ali Sajassi (sajassi);Bocci, Matthew (Nokia - GB);[email-masked]<mailto:[email-masked]>;[email-masked]<mailto:[email-masked]>;
Date: 2021/08/31 11:34
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://www.ietf.org/mailman/listinfo/bess>
Hi,

I agree with Ali.

Yours Irrespectively,

John

Juniper Business Use Only
From: BESS <[email-masked]<mailto:[email-masked]>> On Behalf Of Ali Sajassi (sajassi)
Sent: Friday, August 27, 2021 9:54 PM
To: Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

Hi Matthew,

Regards,
Ali

As per the BESS WG implementation policy (https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/<https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/>), please can you respond to this email indicating either:

Regards

Matthew

    Abstract:

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/<https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/>

    There is also an htmlized version available at:
    https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05<https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05>

    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05<https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05>

    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/<ftp://ftp.ietf.org/internet-drafts/>

    _______________________________________________
    BESS mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/bess<https://www.ietf.org/mailman/listinfo/bess>

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://www.ietf.org/mailman/listinfo/bess>
--

[Image removed by sender.]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 3 Sep 2021 07:40:50 -0700

Hi Matthew and BESS WG,
I was informed that our product does support using most of the sub-TLVs
defined in the draft. Please let me know if you have any further questions
regarding the implementation.

Regards,
Greg

On Tue, Aug 31, 2021 at 2:36 PM <[email-masked]> wrote:

>    1.
>    I am still awaiting a response from our product team on whether any
>    part of the draft is supported.
>    2.
>
>    I concur with Ali. LSP Ping is a broadly used OAM tool detecting and
>    localizing failures, including discrepancies between the data and control
>    planes. The document defines necessary Target FEC sub-TLVs for EVPN and
>    MVPN cases.
>
>
> Regards,
>
> Greg Mirsky
>
>
> 预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product R&D
> Institute/Wireline Product Operation Division
>
>
>
> E: [email-masked]
> www.zte.com.cn
> Original Mail
> *Sender: *JohnEDrake
> *To: *Ali Sajassi (sajassi);Bocci, Matthew (Nokia - GB);[email-masked];
> [email-masked];
> *Date: *2021/08/31 11:34
> *Subject: **Re: [bess] Implementation poll for
> draft-ietf-bess-evpn-lsp-ping-05*
> *From:* BESS <[email-masked]> *On Behalf Of * Ali Sajassi (sajassi)
> *Sent:* Friday, August 27, 2021 9:54 PM
> *To:* Bocci, Matthew (Nokia - GB) <[email-masked]>; [email-masked];
> [email-masked]
> *Subject:* Re: [bess] Implementation poll for
> draft-ietf-bess-evpn-lsp-ping-05
>
>
>
> *[External Email. Be cautious of content]*
>
>
>
> Hi Matthew,
>
>
>
> Some of the co-authors are on PTO and I couldn’t reach them (typical of
> the month of August). So, I’d like to get a bit more extension.
>
>
>
>    1.
>    My company hasn’t implemented it.
>    2.
>
>    I do think that we should process with the publication as it describes
>    how LSP ping can be used to detect data-plane failures for various EVPN
>    functionality including aliasing, split-horizon filtering using ESI label,
>    multicast, l2-unicast, l3-unicast, IRB, etc. For MPLS transport tunnel, I
>    am not aware of any other tool/draft that allows us to do data-plane
>    failure detection. Thus, I think it is important to proceed with its
>    publications.
>
>
>
> *From: *Bocci, Matthew (Nokia - GB) <[email-masked]>
> *Date: *Monday, August 9, 2021 at 6:25 AM
> *To: [email-masked] <[email-masked]>,
> [email-masked] <
> [email-masked]>
> *Subject: *Implementation poll for draft-ietf-bess-evpn-lsp-ping-05
>
> WG and Authors
>
> Unfortunately I have not seen any responses indicating that there are any
> known implementations of this draft. I also did not see any responses to
> Stephane's question if we should proceed regardless.
>
> As per the BESS WG implementation policy (
> https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/
> <https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4v8nM3No$>),
> please can you respond to this email indicating either:
>
> On 14/06/2021, 17:38, "BESS on behalf of [email-masked]" <[email-masked]
> on behalf of [email-masked]> wrote:
>
>
>     https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4CFZvJAM$>
>
>     https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4RLT2-5Q$>
>
>     https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05
> <https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli44UwE5yg$>
>
>
>     ftp://ftp.ietf.org/internet-drafts/
> <https://urldefense.com/v3/__ftp:/ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4trDqUTY$>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bess__;!!NEt6yMaO-gk!RoQdN1xrngG7wEPSC6AqHesQtzGvBMP82cosyeO0PYZjTGA5JLyFmli4YoTqkAc$>
>
>
>