Subject: Re: [bess] [**EXTERNAL**] Re: Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

From: "Boutros, Sami" <[email-masked]>
Date: Fri, 3 Sep 2021 17:01:52 +0000

Ciena has partial implementation of the draft.

Thanks,

Sami
On 9/2/21, 10:11 AM, "Parag Jain (paragj)" <[email-masked]> wrote:

    Hi Matthew,

    Cisco does not have a shipping implementation of the draft.

    As Ali and many other experts replied, LSP ping is widely used for detecting data plane failures in mpls network. This draft defines necessary Target FEC sub-TLVs for EVPN and  I think this is an important draft that should proceed with publication.

    Thanks
    Parag

    On 2021-08-09, 9:25 AM, "Bocci, Matthew (Nokia - GB)" <[email-masked]> wrote:

        WG and Authors

        Unfortunately I have not seen any responses indicating that there are any known implementations of this draft. I also did not see any responses to Stephane's question if we should proceed regardless.

        As per the BESS WG implementation policy (https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/__;!!OSsGDw!crAJkIi1kHy2Ajd2wCB0xa-qLJKj4JADp7yG_WEuHLF5_Ni6MlBlJjcfP9Zhow$ [mailarchive[.]ietf[.]org]), please can you respond to this email indicating either:

        - That you are aware of any implementations (ideally providing some details)
        - If you are not aware of any, if you think the WG should proceed with the draft's publication and why.

        I will close this poll on 25th August 2021.

        Regards

        Matthew

        On 14/06/2021, 17:38, "BESS on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

            A New Internet-Draft is available from the on-line Internet-Drafts directories.
            This draft is a work item of the BGP Enabled ServiceS WG of the IETF.

                    Title           : LSP-Ping Mechanisms for EVPN and PBB-EVPN
                    Authors         : Parag Jain
                                      Samer Salam
                                      Ali Sajassi
                                      Sami Boutros
                                      Greg Mirsky
            	Filename        : draft-ietf-bess-evpn-lsp-ping-05.txt
            	Pages           : 15
            	Date            : 2021-06-14

            Abstract:
               LSP-Ping is a widely deployed Operation, Administration, and
               Maintenance (OAM) mechanism in MPLS networks.  This document
               describes mechanisms for detecting data-plane failures using LSP Ping
               in MPLS based EVPN and PBB-EVPN networks.

            The IETF datatracker status page for this draft is:
            https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/__;!!OSsGDw!crAJkIi1kHy2Ajd2wCB0xa-qLJKj4JADp7yG_WEuHLF5_Ni6MlBlJjf4Ap3t4A$ [datatracker[.]ietf[.]org]

            There is also an htmlized version available at:
            https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05__;!!OSsGDw!crAJkIi1kHy2Ajd2wCB0xa-qLJKj4JADp7yG_WEuHLF5_Ni6MlBlJjdpKNhZPQ$ [datatracker[.]ietf[.]org]

            A diff from the previous version is available at:
            https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05__;!!OSsGDw!crAJkIi1kHy2Ajd2wCB0xa-qLJKj4JADp7yG_WEuHLF5_Ni6MlBlJjfSrZodHg$ [ietf[.]org]

            Internet-Drafts are also available by anonymous FTP at:
            https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-drafts/__;!!OSsGDw!crAJkIi1kHy2Ajd2wCB0xa-qLJKj4JADp7yG_WEuHLF5_Ni6MlBlJjcOdGM0Mw$ [ftp[.]ietf[.]org]

            _______________________________________________
            BESS mailing list
            [email-masked]
            https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bess__;!!OSsGDw!crAJkIi1kHy2Ajd2wCB0xa-qLJKj4JADp7yG_WEuHLF5_Ni6MlBlJjeEfb56SQ$ [ietf[.]org]

---

From: "Boutros, Sami" <[email-masked]>
Date: Fri, 3 Sep 2021 17:35:02 +0000

Hi Matthew,

Ciena has a shipping product with the draft implemented, that are being deployed by service providers. As such, as a co-author we need the publication to proceed.

Thanks,

Sami
On 9/3/21, 10:01 AM, "Boutros, Sami" <[email-masked]> wrote:

    Thanks,

    Sami

        Hi Matthew,

        Thanks
        Parag

            WG and Authors

            Regards

            Matthew

                Abstract: