Subject: Re: [bess] Implementation poll for draft-ietf-bess-evpn-lsp-ping-05

From: "Parag Jain (paragj)" <[email-masked]>
Date: Thu, 2 Sep 2021 17:11:16 +0000

Hi Matthew,

Cisco does not have a shipping implementation of the draft.

As Ali and many other experts replied, LSP ping is widely used for detecting data plane failures in mpls network. This draft defines necessary Target FEC sub-TLVs for EVPN and  I think this is an important draft that should proceed with publication.

Thanks
Parag

On 2021-08-09, 9:25 AM, "Bocci, Matthew (Nokia - GB)" <[email-masked]> wrote:

    WG and Authors
    
    Unfortunately I have not seen any responses indicating that there are any known implementations of this draft. I also did not see any responses to Stephane's question if we should proceed regardless.
    
    As per the BESS WG implementation policy (https://mailarchive.ietf.org/arch/msg/bess/cG3X1tTqb_vPC4rg56SEdkjqDpw/), please can you respond to this email indicating either:
    
    - That you are aware of any implementations (ideally providing some details)
    - If you are not aware of any, if you think the WG should proceed with the draft's publication and why.
    
    I will close this poll on 25th August 2021.
    
    Regards
    
    Matthew

    On 14/06/2021, 17:38, "BESS on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

        A New Internet-Draft is available from the on-line Internet-Drafts directories.
        This draft is a work item of the BGP Enabled ServiceS WG of the IETF.
    
                Title           : LSP-Ping Mechanisms for EVPN and PBB-EVPN
                Authors         : Parag Jain
                                  Samer Salam
                                  Ali Sajassi
                                  Sami Boutros
                                  Greg Mirsky
        	Filename        : draft-ietf-bess-evpn-lsp-ping-05.txt
        	Pages           : 15
        	Date            : 2021-06-14
    
        Abstract:
           LSP-Ping is a widely deployed Operation, Administration, and
           Maintenance (OAM) mechanism in MPLS networks.  This document
           describes mechanisms for detecting data-plane failures using LSP Ping
           in MPLS based EVPN and PBB-EVPN networks.

        The IETF datatracker status page for this draft is:
        https://datatracker.ietf.org/doc/draft-ietf-bess-evpn-lsp-ping/
    
        There is also an htmlized version available at:
        https://datatracker.ietf.org/doc/html/draft-ietf-bess-evpn-lsp-ping-05
    
        A diff from the previous version is available at:
        https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-evpn-lsp-ping-05

        Internet-Drafts are also available by anonymous FTP at:
        ftp://ftp.ietf.org/internet-drafts/

        _______________________________________________
        BESS mailing list
        [email-masked]
        https://www.ietf.org/mailman/listinfo/bess

---

From: "Samer Salam (ssalam)" <[email-masked]>
Date: Fri, 3 Sep 2021 06:44:52 +0000

Hi Matthew,

As others have indicated, this draft defines necessary mechanisms to apply LSP-Ping to EVPN, and provides much needed OAM capabilities. I believe we should proceed with publication.

Thank you,
Samer

On 8/9/21, 4:25 PM, "Bocci, Matthew (Nokia - GB)" <[email-masked]> wrote:

    WG and Authors

    Regards

    Matthew

        Abstract: