Subject: [bess] IPR call for draft-dskc-bess-bgp-car-03 (3/4 to 3/10) - Prior to adoption of CAR/CT solutions

From: "Susan Hares" <[email-masked]>
Date: Thu, 3 Mar 2022 14:53:54 -0500

Greetings Bess and IDR:

The IDR chairs request that each of the authors of 

draft-dskc-bess-bgp-car-03.txt. 

submit an IPR statement in response to this email.  

The motivation for this IPR call is below. 

We expect IPR responses from the authors: 

Dhananjaya Rao, Swadesh Agrawal, Clarence Filsfils, 

 Ketan Talaulikar, Dirk Steinberg, Luay Jalil,

Yuanchao Su, Bruno Decraene, Jim Guichard,

Keyur Patel, Haibo Wang

There is one  IPR filed against this draft: 

https://datatracker.ietf.org/ipr/4844/

Motivation for IPR call 

==========================

Why are the IDR calling for IPR statements? 

The authors of draft-kaliraj-idr-bgp-classful-transport-planes-13.txt 

have asked for WG Adoption.  

We have two drafts that are discussing embedded NLRI (color). 

draft-dskc-bess-bgp-car-03.txt 

https://datatracker.ietf.org/doc/draft-dskc-bess-bgp-car/

and 

draft-kaliraj-idr-bgp-classful-transport-planes-13.txt 

https://datatracker.ietf.org/doc/draft-kaliraj-idr-bgp-classful-transport-pl
anes/

Since the IDR chairs know these drafts may overlap,   

we expect to work closely with the bess-chairs, spring-chairs,  

IDR WG, and BESS WG any WG adoption  and WG LC.    

Other Discussions 

==================

IDR WG held an interim on 1/24/2022 that discussed these two drafts:  

The minutes are at: 

https://datatracker.ietf.org/meeting/interim-2022-idr-02/materials/minutes-i
nterim-2022-idr-02-202201241000-01

Jeff has started two mail threads for CAR/CT drafts based on 2 Questions: 

Question 1: BGP routes with color, Question 1: How does route resolution
work with your feature?

https://mailarchive.ietf.org/arch/msg/idr/OaNnE5epcaK7GtcV8OlAVdD3ZbI/

Question 2: BGP routes with color, Question 2: Route origination and
propagation

https://mailarchive.ietf.org/arch/msg/idr/4MYIFyHWITj8-Kk38AmKlkhh5b8/

Kaliraj began discussion on this email on IDR: 

https://mailarchive.ietf.org/arch/msg/idr/_RB9Md01RXUPQ5g-8hzOfJPhT7k/

The BESS email discussion regarding CAR (11/18/2021 to 1/24/2022) can be
found at:

https://mailarchive.ietf.org/arch/msg/bess/_9oTLaod7z9o_1SYEai0tN5b0EM/

Sue Hares 

IDR chair 

Document Shepherd

---

From: "Dhananjaya Rao (dhrao)" <[email-masked]>
Date: Mon, 7 Mar 2022 12:02:37 +0000

Hello Sue,

I’m not aware of any IPR.

On a related note, we had requested adoption of the BGP CAR draft at the IDR interim on Jan 24. Would you want us to send another email for it, or would this note suffice ?

Regards,
-Dhananjaya

From: BESS <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Friday, March 4, 2022 at 1:24 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [bess] IPR call for draft-dskc-bess-bgp-car-03 (3/4 to 3/10) - Prior to adoption of CAR/CT solutions

Greetings Bess and IDR:

https://datatracker.ietf.org/doc/draft-kaliraj-idr-bgp-classful-transport-planes/

Other Discussions
==================
IDR WG held an interim on 1/24/2022 that discussed these two drafts:
The minutes are at:
https://datatracker.ietf.org/meeting/interim-2022-idr-02/materials/minutes-interim-2022-idr-02-202201241000-01

Jeff has started two mail threads for CAR/CT drafts based on 2 Questions:
Question 1: BGP routes with color, Question 1: How does route resolution work with your feature?
https://mailarchive.ietf.org/arch/msg/idr/OaNnE5epcaK7GtcV8OlAVdD3ZbI/

Question 2: BGP routes with color, Question 2: Route origination and propagation
https://mailarchive.ietf.org/arch/msg/idr/4MYIFyHWITj8-Kk38AmKlkhh5b8/

The BESS email discussion regarding CAR (11/18/2021 to 1/24/2022) can be found at:

Sue Hares
IDR chair
Document Shepherd

---

From: Ketan Talaulikar <[email-masked]>
Date: Mon, 7 Mar 2022 18:09:41 +0530

Hi Sue/All,

I am not aware of any undisclosed IPR related to this document.

Thanks,
Ketan

On Fri, Mar 4, 2022 at 1:24 AM Susan Hares <[email-masked]> wrote:

> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess
>

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 7 Mar 2022 08:46:51 -0500

Dhananjaya:

Your request at the IDR interim is sufficient.  

Thank you for your query. 

Sue 

From: BESS [mailto:[email-masked]] On Behalf Of Dhananjaya Rao (dhrao)
Sent: Monday, March 7, 2022 7:03 AM
To: Susan Hares; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [bess] IPR call for draft-dskc-bess-bgp-car-03 (3/4 to 3/10) - Prior to adoption of CAR/CT solutions

Hello Sue,

Regards,

-Dhananjaya

Greetings Bess and IDR:

Keyur Patel, Haibo Wang

Motivation for IPR call 

and 

Other Discussions 

==================

The minutes are at: 

 

 

Sue Hares 

IDR chair 

Document Shepherd

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 7 Mar 2022 09:14:44 -0500

IDR and BESS: 

In  my message to DJ, I used IETF “slang” 

in the phrase “candidate for adoption in IDR”. 

The translation of this phrase is: IDR WG is discussing the draft

draft-dskc-bess-bgp-car-03.txt for adoption in IDR.  

The IDR WG is also discussing the draft draft-kaliraj-idr-bgp-classful-transport-planes 

for adoption in IDR. 

This slang comes from the status line you will now see posted next to each draft. 

and 

I am the shepherd during the adoption process for both drafts. 

Our discussion regarding these two drafts is on the IDR list. 

Jeff posed two questions to the authors on behalf of the IDR chairs 

to kick off this adoption call discussion. 

Question 1: BGP routes with color, How does route resolution work with your feature?

Kaliraj also added to this discussion on this email on IDR: 

DJ and his co-authors may also send information prior to IETF. 

The IDR agenda for IETF 113 includes time for a discussion on these drafts. 

After all IPR statements have been submitted and the IETF 113 discussion, 

we will start the formal adoption call. 

Cheers, Sue 

From: Susan Hares [mailto:[email-masked]] 
Sent: Monday, March 7, 2022 8:33 AM
To: 'Dhananjaya Rao (dhrao)'
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [bess] IPR call for draft-dskc-bess-bgp-car-03 (3/4 to 3/10) - Prior to adoption of CAR/CT solutions

DJ:

IDR is process the adoption of the BGP CAR draft.  

And your adoption request at the interim is sufficient.  

I have listed draft-dskc-bess-bgp-car-03.txt as a candidate for adoption in IDR. 

Since you first denoted as a BESS draft, it is polite to send email 

last Friday to BESS and IDR WGs, and wait a few days. 

I’m sure both WG will be interested in the reviewing these drafts. 

Sue 

From: Dhananjaya Rao (dhrao) [mailto:[email-masked]] 

Hello Sue,

Regards,

-Dhananjaya

Greetings Bess and IDR:

Keyur Patel, Haibo Wang

Motivation for IPR call 

and 

Other Discussions 

==================

The minutes are at: 

 

 

Sue Hares 

IDR chair 

Document Shepherd

---

From: "Jalil, Luay" <[email-masked]>
Date: Mon, 7 Mar 2022 09:58:30 -0600

Sure,
I’m not aware of any IPR related to this draft

Regards,
*Luay*

On Thu, Mar 3, 2022 at 1:54 PM Susan Hares <[email-masked]> wrote:

> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_ipr_4844_&d=DwQFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=ok5VVpUlFuZnkMBFta8cXv6ZWeRmDcNz2csY8fGN3uc&e=>
>
> Motivation for IPR call
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Ddskc-2Dbess-2Dbgp-2Dcar_&d=DwMFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=953KVFveOcQTpUzPhWHe8pCzo__gf8aQEC4Xp_xt2ag&e=>
>
> and
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dkaliraj-2Didr-2Dbgp-2Dclassful-2Dtransport-2Dplanes_&d=DwMFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=z0F7R-tV9tjk0fU4ELao-gXir3zakuyCJa_VDi-Lzws&e=>
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_interim-2D2022-2Didr-2D02_materials_minutes-2Dinterim-2D2022-2Didr-2D02-2D202201241000-2D01&d=DwMFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=RmoiIueWjkLfdFZ6wKck23mbEK-dKqeQn6vEBR53ZBY&e=>
>
>
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_idr_OaNnE5epcaK7GtcV8OlAVdD3ZbI_&d=DwMFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=E2nHkaUryPsYpLFd1qnS0uB4G07PNc5giR8EdeG1FG8&e=>
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_idr_4MYIFyHWITj8-2DKk38AmKlkhh5b8_&d=DwMFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=jVIDZH763ZyqA9Scj61eRpNxH189Tbdkd-NrRjXXhYA&e=>
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_idr_-5FRB9Md01RXUPQ5g-2D8hzOfJPhT7k_&d=DwMFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=qzcjvGm_fJgjEZrxUaD4D-uJOnpBZtuk9KVUV_yYklw&e=>
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_bess_-5F9oTLaod7z9o-5F1SYEai0tN5b0EM_&d=DwMFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=-Gyk8Z9h1eO6z5kcVWSIyz8g0cYwv1Hubn_XzYUjC0E&e=>
>
>
>
>
>
> Sue Hares
>
> IDR chair
>
> Document Shepherd
>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bess&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=k0DrrBeS0St-D1jEwNQ_u1ZyHQXQly5fgCsWF0VTh7o&m=vADRNKnLya8UCd6xx0CIFBdA8daYUkGiDL9mHbeCtbAmOAjh3KZNiud1FZDbSt4L&s=CE1jx53p6-eIjOgiMT1nsyEz-UFzBH5gRkGYo1SGDpo&e=
>

---

From: <[email-masked]>
Date: Mon, 7 Mar 2022 16:07:12 +0000

Hi all,

I'm not aware of non-disclosed IPR.

Regards,
--Bruno

Orange Restricted
From: Susan Hares <[email-masked]>
Sent: Thursday, March 3, 2022 8:54 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: IPR call for draft-dskc-bess-bgp-car-03 (3/4 to 3/10) - Prior to adoption of CAR/CT solutions

Greetings Bess and IDR:

Other Discussions
==================

Sue Hares
IDR chair
Document Shepherd

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Swadesh Agrawal (swaagraw)" <[email-masked]>
Date: Tue, 8 Mar 2022 00:03:23 +0000

Hello Sue,

Regards
Swadesh

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Thursday, March 3, 2022 at 11:54 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Idr] IPR call for draft-dskc-bess-bgp-car-03 (3/4 to 3/10) - Prior to adoption of CAR/CT solutions

Greetings Bess and IDR:

Other Discussions
==================

Sue Hares
IDR chair
Document Shepherd

---

From: "Wanghaibo (Rainsword)" <[email-masked]>
Date: Tue, 8 Mar 2022 06:45:30 +0000

Hello Sue,

I'm not aware of any IPR.

Regards
Haibo

From: BESS [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, March 4, 2022 3:54 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [bess] IPR call for draft-dskc-bess-bgp-car-03 (3/4 to 3/10) - Prior to adoption of CAR/CT solutions

Greetings Bess and IDR:

Other Discussions
==================

Sue Hares
IDR chair
Document Shepherd