Subject: [bess] I-D Action: draft-ietf-bess-rfc7432bis-04.txt

From: [email-masked]
Date: Mon, 07 Mar 2022 10:37:11 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the BGP Enabled ServiceS WG of the IETF.

        Title           : BGP MPLS-Based Ethernet VPN
        Authors         : Ali Sajassi
                          Luc Andre Burdet
                          John Drake
                          Jorge Rabadan
	Filename        : draft-ietf-bess-rfc7432bis-04.txt
	Pages           : 70
	Date            : 2022-03-07

Abstract:
   This document describes procedures for BGP MPLS-based Ethernet VPNs
   (EVPN).  The procedures described here meet the requirements
   specified in RFC 7209 -- "Requirements for Ethernet VPN (EVPN)".

Note to Readers

   _RFC EDITOR: please remove this section before publication_

   The complete and detailed set of all changes between this version and
   RFC7432 may be found as an Annotated Diff (rfcdiff) here
   (https://tools.ietf.org/rfcdiff?url1=https://www.rfc-
   editor.org/rfc/rfc7432.txt&url2=https://www.ietf.org/archive/id/
   draft-ietf-bess-rfc7432bis-04.txt).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-bess-rfc7432bis/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-rfc7432bis-04

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: "Dikshit, Saumya" <[email-masked]>
Date: Wed, 23 Mar 2022 10:20:43 +0000

Hello Authors of draft-ietf-bess-rfc7432bis-04

I have a query regarding the following text in the section "https://datatracker.ietf.org/doc/html/draft-ietf-bess-rfc7432bis#section-1"5:
"If two (or more) PEs advertise the same MAC
   address with the same sequence number but different Ethernet segment
   identifiers, a PE that receives these routes selects the route
   advertised by the PE with the lowest IP address as the best route."

How do we deal with scenario's like DCI (inter-fabric scenarios), 
where-in the next-hop can change values in the control plane intermediate hop(s), 
Let's say, via route-maps, a fabric border router sets the  next-hop to self and republishes 
to local peers, hence the originating routers IP address is lost. We should call this out explicitly.
Consider the following diagram, with Fabric-1 consisting of Bgp1 and Border_bgp1 peers. Same semantics for Fabric-2.
Border-Bgp1 and Border_Bgp2 can very well change the next-hop values before the routes reaches the other end (bgp1 or bgp2)

Host_MAC----[Bgp1]-----(ibgp)-------[Border_Bgp1]=====(ebgp)=====[Boder_bgp2]--------(ibgp)----------[Bgp2]----Host_MAC

Bgp1 originates the Host_MAC route with local ip-address Next-hop-IP1. Border_Bgp1 and Boder_Bgp2 peers may alter the Next-hop IP to self (or anything else).
Bgp2 may receive it with Next-Hop-IP-Border. Bgp2 also originates the same Host_MAC route with Next-hop-IP2 as local-ip-address.

Let's say the following configuration prevails:
If (Next-hop-IP1 > Next-Hop-IP-Border) AND  
     (Next-Hop-IP2 > Next-Hop-IP-Border) AND
     (Next-Hop-IP2 > Next-Hop-IP1)

Then both Bgp1 and Bgp2 end up selecting the remote routes as best, ending up in inconsistent states.
This needs to be called out or a mechanism to be added to ebb it's impact.

I might be missing some literature in other drafts which are already solving this problem. If yes, in please help with the pointers.

Thanks
Saumya.

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, March 8, 2022 12:07 AM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] I-D Action: draft-ietf-bess-rfc7432bis-04.txt

Abstract:

Note to Readers

_______________________________________________
BESS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bess

---

From: "Rabadan, Jorge (Nokia - US/Sunnyvale)" <[email-masked]>
Date: Wed, 23 Mar 2022 10:37:55 +0000

Hi Saumya,

Best path selection for EVPN routes is something that indeed we will clarify in rfc7432bis, as mentioned at the BESS session during the presentation of draft-sr-bess-evpn-dpath-01. We will update the draft in next version, Luc and the rest of the authors will take the action. Luc may comment as well.

Thanks.
Jorge

From: Dikshit, Saumya <[email-masked]>
Date: Wednesday, March 23, 2022 at 11:21 AM
To: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: RE: [bess] I-D Action: draft-ietf-bess-rfc7432bis-04.txt
Hello Authors of draft-ietf-bess-rfc7432bis-04

Thanks
Saumya.

-----Original Message-----
From: BESS [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, March 8, 2022 12:07 AM
To: [email-masked]
Cc: [email-masked]
Subject: [bess] I-D Action: draft-ietf-bess-rfc7432bis-04.txt

Abstract:

Note to Readers