Subject: Re: [bfcpbis] Review of draft-ram-bfcpbis-sdp-ws-uri-01.txt

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 3 Feb 2016 12:20:17 +0000

Hi Christer, 

Thanks for the feedback. All the below comments has been take care and a
new revision is published. Please look at the diffs here:
https://www.ietf.org/rfcdiff?url2=draft-ram-bfcpbis-sdp-ws-uri-02

Link to draft  - 
https://tools.ietf.org/html/draft-ram-bfcpbis-sdp-ws-uri-02

Regards,
Ram

From:  bfcpbis <[email-masked]> on behalf of Christer Holmberg
<[email-masked]>
Date:  Wednesday, 21 October 2015 at 12:23 AM
To:  "[email-masked]" <[email-masked]>
Subject:  [bfcpbis] Review of draft-ram-bfcpbis-sdp-ws-uri-01.txt

Hi,
 
I have reviewed draft-ram-bfcpbis-sdp-ws-uri-01.txt.
 
I think the draft needs some editorial work, and there is also technical
procedures (related to SDP Offer/Answer) missing.
 
Q3_1:    I suggest to remove ³Media² from the section titles. Instead the
text should indicate that the attributes are media-level attributes. Also,
in the text you should say something like ³This section defines a new SDP
media-level attribute,
 <attribute-name>,Š.² instead of the current text which says ³The new
attribute MUST be a media levelŠ².
 
Q3_2:    Sections 3.1 and 3.2 start with text saying:
 
³Applications that use SDP for negotiation and also use WebSocket as a
              transport protocol MAY indicate the connection URI for the
WebSocketŠ²
 
I don¹t think this text belongs in the attribute definition sections.
Instead I suggest to add a section ³3.1 General² where you describe the
need for the attributes.

Also, instead of saying ³Applications that use SDP for negotiationŠ² I
would say ³Applications that use the SDP Offer/Answer mechanism [RFC3264]
for negotiating mediaŠ².
 
Q3_3:    There is no port information in c= lines.
 
Q3_4:    There should be an ŒSDP Offer/Answer¹ section, describing the
usage of the attributes. The structure should be:
 
   X.  SDP Offer/Answer Procedures
     X.1.  General
     X.2.  Generating the Initial SDP Offer
     X.3.  Generating the SDP Answer
     X.4.  Offerer Processing of the SDP Answer
     X.5.  Modifying the Session
 
For example, in section X.5 you need to describe what it means to NOT
include the attributes in a subsequent offer. Does it mean that the
websocket connection shall be terminated? Etc.
 
Regards,
 
Christer

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 9 Feb 2016 19:45:53 +0000

Ram and other draft authors,

Thanks for updating and posting the revised draft.
I would like to poll the working group to see if people think this draft
is now ready to be adopted as a bfcpbis working group draft.

Thanks,
Charles

On 2/3/16, 4:20 AM, "bfcpbis on behalf of Ram Mohan R (rmohanr)"
<[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>bfcpbis mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Feb 2016 05:10:43 +0000

Hi,

I think the draft is ready for adoption.

Regards.

Christer

Sent from my Windows Phone
________________________________
From: Charles Eckel (eckelcu)<mailto:[email-masked]>
Sent: ‎09/‎02/‎2016 21:45
To: Ram Mohan R (rmohanr)<mailto:[email-masked]>; Christer Holmberg<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bfcpbis] Review of draft-ram-bfcpbis-sdp-ws-uri-01.txt

Thanks,
Charles

---

From: Victor Pascual Avila <[email-masked]>
Date: Mon, 15 Feb 2016 10:36:23 +0100

I support adoption

On Mon, Feb 15, 2016 at 6:10 AM, Christer Holmberg
<[email-masked]> wrote:
> From: Charles Eckel (eckelcu)
> To: Ram Mohan R (rmohanr); Christer Holmberg; [email-masked]

-- 
Victor Pascual Ávila

---

From: "Suhas Nandakumar (snandaku)" <[email-masked]>
Date: Mon, 15 Feb 2016 19:53:16 +0000

?I support adopting this draft

Thanks

Suhas

From: Victor Pascual Avila <[email-masked]<mailto:[email-masked]>>
Date: February 15, 2016 at 4:36:23 AM EST
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Cc: "Ram Mohan R \(rmohanr\)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Charles Eckel \(eckelcu\)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bfcpbis] Review of draft-ram-bfcpbis-sdp-ws-uri-01.txt

I support adoption

On Mon, Feb 15, 2016 at 6:10 AM, Christer Holmberg
<[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards.

Christer

Sent from my Windows Phone
________________________________
From: Charles Eckel (eckelcu)
Sent: ?09/?02/?2016 21:45
To: Ram Mohan R (rmohanr); Christer Holmberg; [email-masked]<mailto:[email-masked]>
Subject: Re: [bfcpbis] Review of draft-ram-bfcpbis-sdp-ws-uri-01.txt

Thanks,
Charles

On 2/3/16, 4:20 AM, "bfcpbis on behalf of Ram Mohan R (rmohanr)"
<[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi Christer,

Link to draft  -

Regards,
Ram

From:  bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg
<[email-masked]<mailto:[email-masked]>>
Date:  Wednesday, 21 October 2015 at 12:23 AM
To:  "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject:  [bfcpbis] Review of draft-ram-bfcpbis-sdp-ws-uri-01.txt

Hi,

Q3_1:    I suggest to remove ³Media² from the section titles. Instead the
text should indicate that the attributes are media-level attributes. Also,
in the text you should say something like ³This section defines a new SDP
media-level attribute,
<attribute-name>,S.² instead of the current text which says ³The new
attribute MUST be a media levelS².

WebSocketS²

Also, instead of saying ³Applications that use SDP for negotiationS² I
would say ³Applications that use the SDP Offer/Answer mechanism [RFC3264]
for negotiating mediaS².

Q3_4:    There should be an OESDP Offer/Answer¹ section, describing the
usage of the attributes. The structure should be:

Regards,

Christer

_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

--
Victor Pascual Ávila

_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis