Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-bfcp-websocket-05.txt

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Wed, 3 Feb 2016 08:20:37 +0000

Hi Charles / WG,

We have published a new revision of draft-ietf-bfcpbis-bfcp-websocket and
also draft-ram-bfcpbis-sdp-ws-uri which addresses the comments given by
Christer 
(https://mailarchive.ietf.org/arch/msg/bfcpbis/S_MlYOJz-kkE3yLu5IANL93ndmM)

Regards,
Ram

-----Original Message-----
From: bfcpbis <[email-masked]> on behalf of Cisco Employee
<[email-masked]>
Date: Saturday, 14 November 2015 at 10:12 AM
To: "Charles Eckel (eckelcu)" <[email-masked]>, "Gonzalo Salgueiro
(gsalguei)" <[email-masked]>, "[email-masked]" <[email-masked]>,
"[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-bfcp-websocket-05.txt

>Hi Charles,
>
>I will get back with responses and updated diffs to
>draft-ram-bfcpbis-sdp-ws-uri soon. I agree that we should wait till this
>is resolved before looking to start WGLC.
>
>Regards,
>Ram
>
>-----Original Message-----
>From: "Charles Eckel (eckelcu)" <[email-masked]>
>Date: Saturday, 14 November 2015 12:14 am
>To: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>,
>"[email-masked]" <[email-masked]>, "[email-masked]"
><[email-masked]>
>Cc: "[email-masked]" <[email-masked]>, Cisco
>Employee <[email-masked]>
>Subject: Re: [bfcpbis] I-D Action:
>draft-ietf-bfcpbis-bfcp-websocket-05.txt
>
>>Christer reviewed draft-ram-bfcpbis-sdp-ws-uri and recommended
>>substantial
>>changes to it. The authors have not yet responded to that.
>>
>>Regarding draft-ietf-bfcpbis-bfcp-websocket, I¹d like to see this
>>response
>>and potential impacts on either/both drafts before starting WGLC for
>>draft-ietf-bfcpbis-bfcp-websocket.
>>
>>
>>Cheers,
>>Charles
>>
>>On 10/13/15, 10:02 AM, "bfcpbis on behalf of Gonzalo Salgueiro
>>(gsalguei)"
>><[email-masked] on behalf of [email-masked]> wrote:
>>
>>>New version of the draft has been published and addresses all open
>>>comments raised by Christer.  At this point authors feel this is ready
>>>for WGLC.
>>>
>>>There is a pending request for Christer to review the complementary
>>>draft
>>>he requested
>>>(draft-ram-bfcpbis-sdp-ws-uri-00) be split off from the original
>>>document. Once this is done, we ask the chairs for guidance on how best
>>>to progress this spin-off draft.
>>>
>>>Thanks,
>>>
>>>Gonzalo
>>>
>>>> On Oct 13, 2015, at 12:43 PM, [email-masked] wrote:
>>>> 
>>>> 
>>>> A New Internet-Draft is available from the on-line Internet-Drafts
>>>>directories.
>>>> This draft is a work item of the Binary Floor Control Protocol Bis
>>>>Working Group of the IETF.
>>>> 
>>>>        Title           : The WebSocket Protocol as a Transport for the
>>>>Binary Floor Control Protocol (BFCP)
>>>>        Authors         : Victor Pascual
>>>>                          Antón Román
>>>>                          Stéphane Cazeaux
>>>>                          Gonzalo Salgueiro
>>>>                          Ram Mohan Ravindranath
>>>>                          Sergio Garcia Murillo
>>>> 	Filename        : draft-ietf-bfcpbis-bfcp-websocket-05.txt
>>>> 	Pages           : 14
>>>> 	Date            : 2015-10-13
>>>> 
>>>> Abstract:
>>>>   The WebSocket protocol enables two-way realtime communication
>>>>between
>>>>   clients and servers.  This document specifies a new WebSocket sub-
>>>>   protocol as a reliable transport mechanism between Binary Floor
>>>>   Control Protocol (BFCP) entities to enable usage of BFCP in new
>>>>   scenarios.
>>>> 
>>>> 
>>>> The IETF datatracker status page for this draft is:
>>>> https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-bfcp-websocket/
>>>> 
>>>> There's also a htmlized version available at:
>>>> https://tools.ietf.org/html/draft-ietf-bfcpbis-bfcp-websocket-05
>>>> 
>>>> A diff from the previous version is available at:
>>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-bfcpbis-bfcp-websocket-05
>>>> 
>>>> 
>>>> Please note that it may take a couple of minutes from the time of
>>>>submission
>>>> until the htmlized version and diff are available at tools.ietf.org.
>>>> 
>>>> Internet-Drafts are also available by anonymous FTP at:
>>>> ftp://ftp.ietf.org/internet-drafts/
>>>> 
>>>> _______________________________________________
>>>> bfcpbis mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/bfcpbis
>>>
>>>_______________________________________________
>>>bfcpbis mailing list
>>>[email-masked]
>>>https://www.ietf.org/mailman/listinfo/bfcpbis
>>
>
>_______________________________________________
>bfcpbis mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 9 Feb 2016 19:43:30 +0000

Ram and other draft authors,

Thanks for updating and posting the revised draft ( https://tools.ietf.org/html/draft-ietf-bfcpbis-bfcp-websocket-06 ).
I would like to poll the working group to see if people think this draft is now ready for WGLC.

Thanks,
Charles

On 2/3/16, 12:20 AM, "Ram Mohan R (rmohanr)" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Charles / WG,

Regards,
Ram

-----Original Message-----
From: bfcpbis <[email-masked]<mailto:[email-masked]>> on behalf of Cisco Employee
<[email-masked]<mailto:[email-masked]>>
Date: Saturday, 14 November 2015 at 10:12 AM
To: "Charles Eckel (eckelcu)" <[email-masked]<mailto:[email-masked]>>, "Gonzalo Salgueiro
(gsalguei)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,
"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-bfcp-websocket-05.txt

Hi Charles,

Regards,
Ram

-----Original Message-----
From: "Charles Eckel (eckelcu)" <[email-masked]<mailto:[email-masked]>>
Date: Saturday, 14 November 2015 12:14 am
To: "Gonzalo Salgueiro (gsalguei)" <[email-masked]<mailto:[email-masked]>>,
"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>"
<[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Cisco
Employee <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bfcpbis] I-D Action:
draft-ietf-bfcpbis-bfcp-websocket-05.txt

Cheers,
Charles

On 10/13/15, 10:02 AM, "bfcpbis on behalf of Gonzalo Salgueiro
(gsalguei)"
<[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Thanks,

Gonzalo

On Oct 13, 2015, at 12:43 PM, [email-masked]<mailto:[email-masked]> wrote:
[email-masked]<mailto:[email-masked]>

_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

_______________________________________________
bfcpbis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bfcpbis

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Tue, 9 Feb 2016 19:50:06 +0000

Thanks, Charles.

We’re awaiting sign-off from Christer that his points on both drafts are properly addressed.  Once that happens there are no more open issues.

Two comments:

- We think draft-ietf-bfcpbis-bfcp-websocket is ready for WGLC
- We’d appreciate some direction from the chairs on how to move forward the new draft (draft-ram-bfcpbis-sdp-ws-uri) that was spawned from this effort, which we also believe is ready for WGLC.

Thanks,

Gonzalo

> On Feb 9, 2016, at 2:43 PM, Charles Eckel (eckelcu) <[email-masked]> wrote:
> 
> On 2/3/16, 12:20 AM, "Ram Mohan R (rmohanr)" <[email-masked]> wrote:
> 
>> Hi Charles / WG,
>>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 9 Feb 2016 20:08:04 +0000

Hi,

In general I am fine with the latest versions of the draft.

However, in draft-ram-bfcpbis-sdp-ws-uri I think the mux category needs to be specified for the new SDP attributes.

Now, as I assume the attributes will never be used in a mux scenario, the question is which category shall be used. Suhas/Paul? NOT RECOMMENDED?

Regards,

Christer

-----Original Message-----
From: Gonzalo Salgueiro (gsalguei) [mailto:[email-masked]] 
Sent: 09 February 2016 21:50
To: Charles Eckel (eckelcu) <[email-masked]>
Cc: Ram Mohan R (rmohanr) <[email-masked]>; [email-masked]; Christer Holmberg <[email-masked]>; [email-masked]
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-bfcp-websocket-05.txt

Thanks, Charles.

Two comments:

Thanks,

Gonzalo

>> We have published a new revision of draft-ietf-bfcpbis-bfcp-websocket 
>> and also draft-ram-bfcpbis-sdp-ws-uri which addresses the comments 
>> given by Christer
>> (gsalguei)" <[email-masked]>, "[email-masked]" 
>> <[email-masked]>, "[email-masked]" 
>>> draft-ram-bfcpbis-sdp-ws-uri soon. I agree that we should wait till 
>>> this is resolved before looking to start WGLC.
>>> 
>>> Regards,
>>> Ram
>>> 
>>> Cc: "[email-masked]" <[email-masked]>, 
>>> Cisco Employee <[email-masked]>
>>>> substantial changes to it. The authors have not yet responded to 
>>>> that.
>>>> 
>>>> response and potential impacts on either/both drafts before 
>>>> starting WGLC for draft-ietf-bfcpbis-bfcp-websocket.
>>>> 
>>>> 
>>>> Cheers,
>>>> Charles
>>>> 
>>>>> comments raised by Christer.  At this point authors feel this is 
>>>>> ready for WGLC.
>>>>> 
>>>>> There is a pending request for Christer to review the 
>>>>> complementary draft he requested
>>>>> document. Once this is done, we ask the chairs for guidance on how 
>>>>> best to progress this spin-off draft.
>>>>> 
>>>>> Thanks,
>>>>> 
>>>>> Gonzalo
>>>>> 
>>>>>> A New Internet-Draft is available from the on-line 
>>>>>> Internet-Drafts directories.
>>>>>> This draft is a work item of the Binary Floor Control Protocol 
>>>>>> Bis Working Group of the IETF.
>>>>>> https://datatracker.ietf.org/doc/draft-ietf-bfcpbis-bfcp-websocke
>>>>>> t/ There's also a htmlized version available at:
>>>>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-bfcpbis-bfcp-websock
>>>>>> et-05 Please note that it may take a couple of minutes from the 
>>>>>> time of submission until the htmlized version and diff are 
>>>>>> available at tools.ietf.org.

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Wed, 10 Feb 2016 18:33:40 +0000

Paul/Suhas - 

Could you share your thoughts on this so we know what document updates are required.

Thanks,

Gonzalo

> On Feb 9, 2016, at 3:08 PM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 10 Feb 2016 14:35:15 -0500

> Could you share your thoughts on this so we know what document updates are required.

I guess the question is whether there is any case where a websocket 
makes sense in a bundle. My first thought was No. But on further 
thinking, ISTM that *in principle* it would be possible to run RTP over 
websocket. And then, since it makes sense to bundle RTP, it could also 
be possible to bundle websocket.

Of course to do this would first require a binding of RTP to websockets. 
Since you can already run RTP over TCP, it should be possible. (And 
easier, since the websocket provides the framing.)

Whether anybody would find reason to do so is another question. I doubt 
we will see it any time soon, and probably never.

*For now* I don't think there are any cases where it makes sense to use 
websocket in a bundle.

I'll leave it to Suhas to figure out what classification applies in this 
case.

	Thanks,
	Paul

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Mon, 15 Feb 2016 19:15:37 +0000

Hi Suhas - 

I think that is a reasonable approach. We'll add the categorization and associated text.

Thanks!

Gonzalo

Sent from my iPhone

> On Feb 15, 2016, at 2:10 PM, Suhas Nandakumar (snandaku) <[email-masked]> wrote:
> 
> Thanks Paul for bringing out the thinking of RTP over WebSockets. 
> I did had similar thoughts of a future possibility but wasn't sure if anyone would want to do though (given rtp over tcp itself is not a great user experience)
> 
> I am inclined towards NOT_RECOMMENDED as the mux category but adding note to explain something similar to Paul's explanation below shouldn't hurt either.
> This would ensure that the implementors of this draft are aware that the mux-category has been assigned due to lack of any use-cases in the foreseeable future
> 
> Please let me know your thoughts 
> 
> Thanks
> Suhas
> 
> 
> ________________________________________
> From: Paul Kyzivat <[email-masked]>
> Sent: Wednesday, February 10, 2016 11:35 AM
> To: Gonzalo Salgueiro (gsalguei); Suhas Nandakumar (snandaku)
> Cc: Christer Holmberg; Charles Eckel (eckelcu); Ram Mohan R (rmohanr); [email-masked]; [email-masked]

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Feb 2016 19:37:03 +0000

Hi,

In my opinion there should be a NOT APPLICABLE or NOT SPECIFIED category. But, that is of course not something this WG can specify.

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Suhas Nandakumar (snandaku)<mailto:[email-masked]>
Sent: ‎15/‎02/‎2016 21:10
To: Paul Kyzivat<mailto:[email-masked]>; Gonzalo Salgueiro (gsalguei)<mailto:[email-masked]>
Cc: Christer Holmberg<mailto:[email-masked]>; Charles Eckel (eckelcu)<mailto:[email-masked]>; Ram Mohan R (rmohanr)<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-bfcp-websocket-05.txt

Thanks
Suhas

        Thanks,
        Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Feb 2016 14:46:29 -0500

WFM

---

From: "Suhas Nandakumar (snandaku)" <[email-masked]>
Date: Mon, 15 Feb 2016 19:10:20 +0000

Thanks
Suhas

        Thanks,
        Paul

---

From: "Suhas Nandakumar (snandaku)" <[email-masked]>
Date: Mon, 15 Feb 2016 19:43:03 +0000

Hello Christer

  We do have TBD category to postpone the assignments. However, I am not comfortable with draft authors using that category as a means to not analyze the multiplexing behavior :)

Hence i thought NOT_RECOMMENDED made sense with a note.

Does TBD with a explanation instead be more logical ??

Excerpt from the MUX Draft

"

4.9<https://tools.ietf.org/html/draft-ietf-mmusic-sdp-mux-attributes-12#section-4.9>.  Category: TBD

   Attributes that have not been analyzed under the proposed
   multiplexing framework.  For the purposes of implementations it is
   advised to consider "NOT RECOMMENDED" as the category when
   multiplexing these attributes.

"

​

Thanks

Suhas

________________________________
From: Christer Holmberg <[email-masked]>
Sent: Monday, February 15, 2016 11:37 AM
To: Suhas Nandakumar (snandaku); Paul Kyzivat; Gonzalo Salgueiro (gsalguei)
Cc: Charles Eckel (eckelcu); Ram Mohan R (rmohanr); [email-masked]; [email-masked]
Subject: RE: [bfcpbis] I-D Action: draft-ietf-bfcpbis-bfcp-websocket-05.txt

Hi,

Regards,

Christer

Thanks
Suhas

        Thanks,
        Paul

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 16 Feb 2016 08:51:10 +0000

Thanks Paul/Suhas for your feedback.

We have published a new revision with the changes-
https://tools.ietf.org/html/draft-ram-bfcpbis-sdp-ws-uri-03

Regards,
Ram

-----Original Message-----
From: Paul Kyzivat <[email-masked]>
Date: Tuesday, 16 February 2016 at 1:16 AM
To: "Suhas Nandakumar (snandaku)" <[email-masked]>, "Gonzalo Salgueiro
(gsalguei)" <[email-masked]>
Cc: Christer Holmberg <[email-masked]>, "Charles Eckel
(eckelcu)" <[email-masked]>, Cisco Employee <[email-masked]>,
"[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [bfcpbis] I-D Action: draft-ietf-bfcpbis-bfcp-websocket-05.txt

>> I did had similar thoughts of a future possibility but wasn't sure if
>>anyone would want to do though (given rtp over tcp itself is not a great
>>user experience)
>>
>> I am inclined towards NOT_RECOMMENDED as the mux category but adding
>>note to explain something similar to Paul's explanation below shouldn't
>>hurt either.
>> This would ensure that the implementors of this draft are aware that
>>the mux-category has been assigned due to lack of any use-cases in the
>>foreseeable future
>>
>> Cc: Christer Holmberg; Charles Eckel (eckelcu); Ram Mohan R (rmohanr);
>>[email-masked]; [email-masked]
>>>> However, in draft-ram-bfcpbis-sdp-ws-uri I think the mux category
>>>>needs to be specified for the new SDP attributes.
>>>>
>>>> Now, as I assume the attributes will never be used in a mux scenario,
>>>>the question is which category shall be used. Suhas/Paul? NOT
>>>>RECOMMENDED?
>>>>
>>>> Regards,
>>>>
>>>> Christer
>>>>
>>>> Cc: Ram Mohan R (rmohanr) <[email-masked]>; [email-masked];
>>>>Christer Holmberg <[email-masked]>;
>>>>[email-masked]
>>>> We’re awaiting sign-off from Christer that his points on both drafts
>>>>are properly addressed.  Once that happens there are no more open
>>>>issues.
>>>>
>>>> Two comments:
>>>>
>>>> - We’d appreciate some direction from the chairs on how to move
>>>>forward the new draft (draft-ram-bfcpbis-sdp-ws-uri) that was spawned
>>>>from this effort, which we also believe is ready for WGLC.
>>>>
>>>> Thanks,
>>>>
>>>> Gonzalo
>>>>
>>>>
>>>>
>>>>> Thanks for updating and posting the revised draft (
>>>>>https://tools.ietf.org/html/draft-ietf-bfcpbis-bfcp-websocket-06 ).