Subject: [bfcpbis] WGLC comments on draft-ietf-bfcpbis-rfc4583bis-17

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 17 Jul 2017 11:23:09 +0000

(as an individual)

I have reviewed the draft. I do not have any technical or major issues with it.
I do have some editorial comments and suggestions.

Globally
Use reestablish or re-establish but not both.

Pg 1. 
s/ Changes from RFC 4583 are summarized in Section 14/ Changes from RFC 4583 are summarized in Section 15

Pg 4.
s/ both the offerer and the answerer act/ both endpoints act

Pg 6.
s/ When this attribute appears in an answer, it only carries one role/ When a “floorctrl” attribute appears in an answer, it MUST include one and only role

Pg 9.
s/ the answerer which may be the client or the floorcontrol server acts/ the answerer, which may be the client or the floorcontrol server, acts

Pg 10.
s/ same BFCP session and DTLS associations/ same BFCP session and DTLS association

Pg 11.
s/ the SDP 'fingerprint' attribute [7], if the endpoint supports, and is willing to use, a cipher suite with an associated certificate./ the SDP 'fingerprint' attribute [10].

Pg 14.
s/ If the BFCP connection is carried on top of TCP, and unless the offerer wants to re-establish an existing TCP connection, the offerer MUST associate an SDP connection attribute, with an 'existing' value, with the 'm' line/ If the BFCP connection is carried on top of TCP and the offerer does not want to re-establish an existing TCP connection, the offerer MUST associate an SDP connection attribute with an 'existing' value with the 'm' line

Cheers,
Charles

---

From: "Tom Kristensen (tomkrist)" <[email-masked]>
Date: Tue, 18 Jul 2017 13:57:19 +0000

Yes, I agree with all of the editorial fixes, language clarifications and also the MUST added on page 6.

Is incorporated if no objections or other input are received here.

-- Tom
________________________________________
Fra: bfcpbis <[email-masked]> på vegne av Charles Eckel (eckelcu)
Sendt: 17. juli 2017 13:23
Til: [email-masked]
Emne: [bfcpbis] WGLC comments on draft-ietf-bfcpbis-rfc4583bis-17

(as an individual)

Globally

Pg 1.

Pg 4.

Pg 6.

Pg 9.

Pg 10.

Pg 11.

Pg 14.

Cheers,
Charles

_______________________________________________
bfcpbis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bfcpbis