Subject: [Bgp-autoconf] assumptions

From: Randy Bush <[email-masked]>
Date: Mon, 24 Feb 2020 19:23:53 -0800

some underlying assumptions:

  o with a datacenter, not inter-datacenter

  o we are not changing bgp

  o we will not force major change on the operator's architecture

  o attempt to be minimal

randy

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 25 Feb 2020 12:21:43 +0000

Hi Randy, 

On 2/24/20, 10:24 PM, "Bgp-autoconf on behalf of Randy Bush" <[email-masked] on behalf of [email-masked]> wrote:

    

This would disqualify LDP-esque mechanisms being added to BGP and we'd have one less draft to consider __

Thanks,
Acee

      o attempt to be minimal
    
    randy
    
    -- 
    Bgp-autoconf mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/bgp-autoconf

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 25 Feb 2020 15:38:10 +0000

Hi Randy, 

Please see some comments inline:

> -----Original Message-----
> From: Bgp-autoconf [mailto:[email-masked]] On Behalf Of
> Randy Bush
> Sent: Tuesday, February 25, 2020 11:24 AM
> To: bgp autoconf <[email-masked]>
> Subject: [Bgp-autoconf] assumptions
> 

[Jie] Not sure we discussed this during the conference call or not. My understanding is we will identify the list of functional requirement first, whether it requires changes to BGP or not could be discussed later. 

>   o we will not force major change on the operator's architecture

[JIe] I agree with your other assumptions.

Best regards,
Jie

---

From: Randy Bush <[email-masked]>
Date: Tue, 25 Feb 2020 11:49:17 -0800

hi jie,

> [Jie] Not sure we discussed this during the conference call or not.

actually, i made the assertion three times.  there was no response.
so i have made it again :)

> have one less draft to consider __

is that a bug or a feature?

randy

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 25 Feb 2020 15:13:53 -0500

> On Feb 25, 2020, at 2:49 PM, Randy Bush <[email-masked]> wrote:
> 
> hi jie,
> 

Actually, I had commented on the possible need to push some of this stuff into BGP depending on where we drew our lines on some of the layering.

I'd like to avoid unnecessary changes.  I'm not willing to rule them out.

I believe that sticking with as close to base BGP as possible is a feature: It means that auto-discovery features can be lightly strapped on top of boring BGP implementations that have modest support for programmatic neighbor setup.

-- Jeff

---

From: Randy Bush <[email-masked]>
Date: Tue, 25 Feb 2020 13:15:19 -0800

> I believe that sticking with as close to base BGP as possible is a
> feature: It means that auto-discovery features can be lightly strapped
> on top of boring BGP implementations that have modest support for
> programmatic neighbor setup.

i can support this position

randy

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 25 Feb 2020 14:43:23 -0800

+1

Regards,
Jeff

> On Feb 25, 2020, at 12:14, Jeffrey Haas <[email-masked]> wrote:
> 
> 
>

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 25 Feb 2020 14:45:40 -0800

Acee,

I disagree, there’s a difference between changing BGP semantics and adding lightweighted AD function on top.

Regards,
Jeff

> On Feb 25, 2020, at 04:21, Acee Lindem (acee) <acee=[email-masked]> wrote:
> 
> Hi Randy, 
>

---

From: Randy Bush <[email-masked]>
Date: Tue, 25 Feb 2020 14:47:20 -0800

> there’s a difference between changing BGP semantics and adding
> lightweighted AD function on top.

e.g. see l3dl-uldp for very clear separation

randy

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 25 Feb 2020 22:56:25 +0000

On 2/25/20, 5:46 PM, "Bgp-autoconf on behalf of Jeff Tantsura" <[email-masked] on behalf of [email-masked]> wrote:

    Acee,

Both are modifications to the BGP protocol - the statement was unqualified. 

Acee
    
    Regards,
    Jeff

---

From: "徐小虎(义先)" <[email-masked]>
Date: Wed, 26 Feb 2020 07:10:40 +0800

Hi all,

I'm fine with those assumptions except item 2.  I think we need some clarification. It's sure that we are not changing the current BGP mechanism. However, as for which protocol should be used for BGP peer autodiscovery, we should not exclude BGP on purpose.

Best regards,
Xiaohu 

------------------------------------------------------------------
From:Randy Bush <[email-masked]>
Send Time:2020年2月25日(星期二) 11:24
To:bgp autoconf <[email-masked]>
Subject:[Bgp-autoconf] assumptions

  o attempt to be minimal

randy

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 25 Feb 2020 18:13:37 -0500

> On Feb 25, 2020, at 6:10 PM, 徐小虎(义先) <[email-masked]> wrote:
> 

Let's not get over-wrought about what needs to change for what reason.  Most of the details will likely come naturally from the functional requirements.

-- Jeff

---

From: "徐小虎(义先)" <[email-masked]>
Date: Wed, 26 Feb 2020 07:19:30 +0800

Sound reasonable.

Best regards,
Xiaohu

------------------------------------------------------------------
From:Jeff Tantsura <[email-masked]>
Send Time:2020年2月26日(星期三) 06:45
To:Acee Lindem (acee) <acee=[email-masked]>
Cc:Randy Bush <[email-masked]>; bgp autoconf <[email-masked]>
Subject:Re: [Bgp-autoconf] assumptions

Acee,

Regards,
Jeff