Subject: [Bgp-autoconf] "BGP Logical Link Discovery Protocol (LLDP) Peer Discovery" Requirements

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 27 Feb 2020 19:11:43 +0000

As I see them, the primary requirement driving our draft are:

1.       Make use of a currently implemented and deployed DC switch protocol to reduce the cost and complexity of the draft. Adoption of this draft would certainly not preclude adopting more elaborate procedures for other requirements.

2.       Allow discovery of BGP IPv4 or IPv6 peering addresses and ASes for directly connected switches in a data center.

3.       Allow discovery of the switches session group-id which could be leverage to determine the role that Jeff alluded to in the conference call. This would also be used to self-configure and verify the fabric topology.

The secondary requirements fulfilled by the draft are:

1.       Discovery of the neighbor’s BGP identifier for possible consistency checking or to avoid connection collisions.

2.       Discovery of BGP authentication parameters.

3.       Discovery parameters relating to the BGP peer session (e.g., the local address Sub-TLV).

I’d like to stress the first requirement that our draft fulfills that differentiates it from all of the other proposals. A minimal solution that meets the requirements is better than an over-engineered solution that isn’t required.

Thanks,
Acee

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 28 Feb 2020 14:21:46 +0000

Hi Acee,

Thanks a lot for your summary. It is good to classify the requirements into primary and secondary ones.

Best regards,
Jie

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Friday, February 28, 2020 3:12 AM
To: Dongjie (Jimmy) <[email-masked]>; [email-masked]
Subject: "BGP Logical Link Discovery Protocol (LLDP) Peer Discovery" Requirements

Thanks,
Acee