Subject: Re: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto Session Setup

From: Jeff Tantsura <[email-masked]>
Date: Sat, 1 Feb 2020 08:45:03 -0800

+1

Regards,
Jeff

> On Jan 31, 2020, at 22:17, Dongjie (Jimmy) <[email-masked]> wrote:
> 
> 
> Hi Robert and Jeff,
>  
> Yes I also think we’ve agreed to treat them separately. Then the next question is which scenario(s) would be the first target for this design team? My personal feeling is there may be more interests to work on the DC case first. What do you think?
>  
> Best regards,
> Jie
>  
> From: Bgp-autoconf [mailto:[email-masked]] On Behalf Of Robert Raszuk
> Sent: Thursday, January 30, 2020 8:14 PM
> To: Jeff Tantsura <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto Session Setup
>  
> Cool - then we accomplished first design team milestone :) 
>  
> On Thu, Jan 30, 2020 at 1:12 PM Jeff Tantsura <[email-masked]> wrote:
> A statement with a question mark ;-)
> To rephrase - I think we have already agreed. 
> 
> Regards,
> Jeff
> 
> > On Jan 30, 2020, at 13:08, Robert Raszuk <[email-masked]> wrote:
> > 
> > 
> > 
> > >  To my feeling we have already agreed to treat them separately?  
> > 
> > Is that a question or a statement ?
> > 
> > 
> >

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 1 Feb 2020 19:15:34 +0000

I agree as well. We already have a partial solution for DC where implementations are using IPv6 ND RA messages to ascertain the link-local address on P2P fabric addresses. The BGP speakers then peer on the link-local addresses. RFC 5549 is then used for IPv4 routes. Of course, we can do a lot better than that.
Thanks,
Acee

From: Bgp-autoconf <[email-masked]> on behalf of Jeff Tantsura <[email-masked]>
Date: Saturday, February 1, 2020 at 11:45 AM
To: Jie Dong <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Robert Raszuk <[email-masked]>
Subject: Re: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto Session Setup

+1
Regards,
Jeff

Best regards,
Jie

On Thu, Jan 30, 2020 at 1:12 PM Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
A statement with a question mark ;-)
To rephrase - I think we have already agreed.

Regards,
Jeff

> On Jan 30, 2020, at 13:08, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:
>
>
>

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 1 Feb 2020 20:50:09 +0100

Hi Acee,

Sure we can do better, but the question to state is *better* really
required ?

In other words what cases are not solved by using link local addresses for
p2p peering ?

Just FYI ... Even Google GCP is using link local addresses to establish
private BGP peering to your VPC :).

Thx,
R.

On Sat, Feb 1, 2020 at 8:15 PM Acee Lindem (acee) <[email-masked]> wrote:

> I agree as well. We already have a partial solution for DC where
> implementations are using IPv6 ND RA messages to ascertain the link-local
> address on P2P fabric addresses. The BGP speakers then peer on the
> link-local addresses. RFC 5549 is then used for IPv4 routes. Of course, we
> can do a lot better than that.
>
> Thanks,
> Acee
>
>
>
> *From: *Bgp-autoconf <[email-masked]> on behalf of Jeff
> Tantsura <[email-masked]>
> *Date: *Saturday, February 1, 2020 at 11:45 AM
> *To: *Jie Dong <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, Robert Raszuk <
> [email-masked]>
> *Subject: *Re: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto
> Session Setup
>
>
>
> +1
>
> Regards,
>
> Jeff
>
>
>
> Yes I also think we’ve agreed to treat them separately. Then the next
> question is which scenario(s) would be the first target for this design
> team? My personal feeling is there may be more interests to work on the DC
> case first. What do you think?
>
>
>
> Best regards,
>
> Jie
>
>
>
> *From:* Bgp-autoconf [mailto:[email-masked]] *On Behalf Of
> *Robert Raszuk
> *Sent:* Thursday, January 30, 2020 8:14 PM
> *To:* Jeff Tantsura <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto
> Session Setup
>
>
>

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Sat, 1 Feb 2020 21:28:24 +0000

Agree to this point , that it may be worth thinking in direction about “Can be done better” and “is it really required” . Or may be explore what does it bring overall.

Mankamana

On Feb 1, 2020, at 11:50 AM, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:

Hi Acee,

Sure we can do better, but the question to state is *better* really required ?

In other words what cases are not solved by using link local addresses for p2p peering ?

Just FYI ... Even Google GCP is using link local addresses to establish private BGP peering to your VPC :).

Thx,
R.

On Sat, Feb 1, 2020 at 8:15 PM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
I agree as well. We already have a partial solution for DC where implementations are using IPv6 ND RA messages to ascertain the link-local address on P2P fabric addresses. The BGP speakers then peer on the link-local addresses. RFC 5549 is then used for IPv4 routes. Of course, we can do a lot better than that.
Thanks,
Acee

From: Bgp-autoconf <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Saturday, February 1, 2020 at 11:45 AM
To: Jie Dong <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto Session Setup

+1
Regards,
Jeff

On Jan 31, 2020, at 22:17, Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Robert and Jeff,

Best regards,
Jie

From: Bgp-autoconf [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Robert Raszuk
Sent: Thursday, January 30, 2020 8:14 PM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Bgp-autoconf] Fwd: BGP Auto Discovery and BGP Auto Session Setup

Regards,
Jeff

--
Bgp-autoconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bgp-autoconf