Subject: [Bier] BIER Encapsulation..

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Sat, 27 Sep 2014 19:02:06 +0000

Regarding *draft-wijnands-mpls-bier-encapsulation-00*

Given that  BIER packets packets are MPLS encapsulated (SI is identified based on the Label), how would forwarding take place in a pure IGP domain (where MPLS is not configured/supported)?

Regards
Somasundaram

---

From: Xuxiaohu <[email-masked]>
Date: Sun, 28 Sep 2014 03:48:46 +0000

This is a very good question. Since BIER introduces a totally new forwarding paradigm, why not make the BIER encapsulation transport-independent? In other words, the BIER header is allowed to be contained in an Ethernet header, an MPLS header, an IP header and etc. Furthermore, the transport is only intended for delivering the BIER-encapsulated packet to the BFR Neighbors while the SI and MTID could be directly derived from the BIER header.

Best regards,
Xiaohu

From: BIER [mailto:[email-masked]] On Behalf Of S, Somasundaram (Somasundaram)
Sent: Sunday, September 28, 2014 3:02 AM
To: [email-masked]
Subject: [Bier] BIER Encapsulation..

Regards
Somasundaram

---

From: IJsbrand Wijnands <[email-masked]>
Date: Sun, 28 Sep 2014 12:42:24 +0200

Hi Somasundaram,

> Given that  BIER packets packets are MPLS encapsulated (SI is identified based on the Label), how would forwarding take place in a pure IGP domain (where MPLS is not configured/supported)?

There always needs to be some sort of encapsulation to encode the BitString. So I don’t expect BIER to be supported on a native IP packets. But you raise a good point, the BIER procedures are agnostic to any sort of encapsulation. With MPLS we use the top label to identify the SI, which is a nice way to encode it and prevents an additional lookup in the forwarding plane. 

Thx,

Ice.

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 29 Sep 2014 01:31:56 +0000

Hi Ice,

> -----Original Message-----
> From: BIER [mailto:[email-masked]] On Behalf Of IJsbrand Wijnands
> Sent: Sunday, September 28, 2014 6:42 PM
> To: S, Somasundaram (Somasundaram)
> Cc: [email-masked]
> Subject: Re: [Bier] BIER Encapsulation..
> 
> Hi Somasundaram,
> 
> > Given that  BIER packets packets are MPLS encapsulated (SI is identified based
> on the Label), how would forwarding take place in a pure IGP domain (where
> MPLS is not configured/supported)?
> 
> There always needs to be some sort of encapsulation to encode the BitString. So
> I don't expect BIER to be supported on a native IP packets. But you raise a good
> point, the BIER procedures are agnostic to any sort of encapsulation. With MPLS
> we use the top label to identify the SI, which is a nice way to encode it and
> prevents an additional lookup in the forwarding plane.

If I understand it correctly, the additional lookup for the MT-ID and SI could not be prevented by using the BIER MPLS label.

Best regards,
Xiaohu

> Thx,
> 
> Ice.
> 
> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Mon, 29 Sep 2014 06:35:43 +0000

Hi Xiahou,

	BIER-MPLS label indirectly denotes the SI and MTID (Refer to section 4 point 5d in "BIER MPLS Encapsulation"). So by doing a BIER-MPLS label look up, a BFR can make out what the SI and the corresponding MTID it advertised to its peer.. 

	BTW, Given that ASICs do line rate processing, should we really talk about preventing additional lookups as a major advantage? Am assuming that by talking about preventing lookups, you guys are referring to the possible impact in the forwarding performance.

Regards
Somasundaram

-----Original Message-----
From: Xuxiaohu [mailto:[email-masked]] 
Sent: Monday, September 29, 2014 7:02 AM
To: IJsbrand Wijnands; S, Somasundaram (Somasundaram)
Cc: [email-masked]
Subject: RE: [Bier] BIER Encapsulation..

Hi Ice,

> on the Label), how would forwarding take place in a pure IGP domain 
> (where MPLS is not configured/supported)?
> 
> There always needs to be some sort of encapsulation to encode the 
> BitString. So I don't expect BIER to be supported on a native IP 
> packets. But you raise a good point, the BIER procedures are agnostic 
> to any sort of encapsulation. With MPLS we use the top label to 
> identify the SI, which is a nice way to encode it and prevents an additional lookup in the forwarding plane.

Best regards,
Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 29 Sep 2014 07:08:41 +0000

> From: S, Somasundaram (Somasundaram)
> [mailto:[email-masked]]
> Sent: Monday, September 29, 2014 2:36 PM
> To: Xuxiaohu; IJsbrand Wijnands
> Cc: [email-masked]
> 	BIER-MPLS label indirectly denotes the SI and MTID (Refer to section 4 point
> 5d in "BIER MPLS Encapsulation"). So by doing a BIER-MPLS label look up, a BFR
> can make out what the SI and the corresponding MTID it advertised to its peer..

Exactly:)

> 	BTW, Given that ASICs do line rate processing, should we really talk about
> preventing additional lookups as a major advantage? Am assuming that by
> talking about preventing lookups, you guys are referring to the possible impact
> in the forwarding performance.

Ice had said "... With MPLS we use the top label to
> > identify the SI, which is a nice way to encode it and prevents an additional
> lookup in the forwarding plane...."

According to the above statement, it seems that preventing an additional lookup is deemed as one benefit of using BIER-MPLS labels. I just want to point out that the use of the BIER-MPLS labels introduces rather than prevent an additional lookup (whether or not that lookup has any significant impact on the forwarding performance), compared to the approach of encoding the MT-ID and SI in the BIER header.

Best regards,
Xiaohu

> If I understand it correctly, the additional lookup for the MT-ID and SI could not
> be prevented by using the BIER MPLS label.
> 
> Best regards,
> Xiaohu
> 
> > Thx,
> >
> > Ice.
> >

---

From: IJsbrand Wijnands <[email-masked]>
Date: Mon, 29 Sep 2014 11:01:47 +0200

Hi Xiaohu,

> According to the above statement, it seems that preventing an additional lookup is deemed as one benefit of using BIER-MPLS labels. I just want to point out that the use of the BIER-MPLS labels int…

As long as we use MPLS, there will always be a MPLS label lookup, even if we encode the SI and MT-ID in the BIER Header. So why not make that lookup count for something? 

Thx,

Ice.

>> lookup in the forwarding plane.
>>

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 29 Sep 2014 09:10:22 +0000

Hi Ice,

See my comment inline.

-----Original Message-----
From: IJsbrand Wijnands [mailto:[email-masked]] 
Sent: Monday, September 29, 2014 5:02 PM
To: Xuxiaohu
Cc: S, Somasundaram (Somasundaram); [email-masked]
Subject: Re: [Bier] BIER Encapsulation..

Hi Xiaohu,

[Xiaohu] in that case, you only need a way to indicate the MPLS payload is a BIER header. BTW, this draft (https://tools.ietf.org/html/draft-xu-mpls-payload-protocol-identifier-00) describes a very straightforward way to do that:)

Best regards,
Xiaohu

Thx,

Ice.

>>> packets. But you raise a good point, the BIER procedures are 
>>> agnostic to any sort of encapsulation. With MPLS we use the top 
>>> label to identify the SI, which is a nice way to encode it and 
>>> prevents an additional
>> If I understand it correctly, the additional lookup for the MT-ID and 
>> SI could not be prevented by using the BIER MPLS label.
>> 
>> Best regards,
>> Xiaohu
>> 
>>> Thx,
>>> 
>>> Ice.
>>>

---

From: IJsbrand Wijnands <[email-masked]>
Date: Mon, 29 Sep 2014 11:29:37 +0200

Xiaohu,

> [Xiaohu] in that case, you only need a way to indicate the MPLS payload is a BIER header. BTW, this draft (https://tools.ietf.org/html/draft-xu-mpls-payload-protocol-identifier-00) describes a very…

Using a special purpose label to indicate the BIER header is an other way of doing it, but, its not adding any value. It is still a label lookup that you need to do first, even if this is a special purpose label. Its likely this will be from the extended type, so you need two labels. I think the problem is much easier solved with a downstream assigned label that immediately provides the SI and MT-ID context.

Thx,

Ice.