Subject: [Bier] Fwd: I-D Action: draft-psenak-ospf-bier-extensions-00.txt

From: IJsbrand Wijnands <[email-masked]>
Date: Sat, 27 Sep 2014 13:37:00 +0200

FYI.

Begin forwarded message:

> From: <[email-masked]>
> Subject: I-D Action: draft-psenak-ospf-bier-extensions-00.txt
> Date: 27 Sep 2014 13:33:32 GMT+2
> To: <[email-masked]>
> Reply-To: <[email-masked]>
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : OSPF Extensions For BIER
>        Authors         : Peter Psenak
>                          Nagendra Kumar
>                          IJsbrand Wijnands
>                          Andrew Dolganow
> 	Filename        : draft-psenak-ospf-bier-extensions-00.txt
> 	Pages           : 6
> 	Date            : 2014-09-27
> 
> Abstract:
>   Bit Index Explicit Replication (BIER) is an architecture that
>   provides optimal multicast forwarding through a "BIER domain" without
>   requiring intermediate routers to maintain any multicast related per-
>   flow state.  BIER also does not require any explicit tree-building
>   protocol for its operation.  A multicast data packet enters a BIER
>   domain at a "Bit-Forwarding Ingress Router" (BFIR), and leaves the
>   BIER domain at one or more "Bit-Forwarding Egress Routers" (BFERs).
>   The BFIR router adds a BIER header to the packet.  The BIER header
>   contains a bit-string in which each bit represents exactly one BFER
>   to forward the packet to.  The set of BFERs to which the multicast
>   packet needs to be forwarded is expressed by setting the bits that
>   correspond to those routers in the BIER header.
> 
>   This document describes the OSPF protocol extension required for BIER
>   with MPLS encapsulation.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-psenak-ospf-bier-extensions/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-psenak-ospf-bier-extensions-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Xuxiaohu <[email-masked]>
Date: Sun, 28 Sep 2014 09:47:00 +0000

Hi co-authors,

I wonder what's the major motivation of advertising the BIER-MPLS-label range and BFR-ID information within a single sub-TLV, especially the sub-TLV of the Extended Prefix TLV. IMHO, the BFR-ID information could be carried either within a sub-TLV of the Extended Prefix TLV or within a TLV of the OSPF RI LSA. The irreplaceable use case for the former approach is to allow a mapping server to advertise BFR-ID to BFR-prefix mappings on behalf of all BFERs. No matter which approach would be used, it seems no need to carry the MT-ID field together since the BFR-ID is MT-irrelevant. As for the BIER-MPLS-label range, even assume it is proved to be useful in the end (for more details, see my previous emails of today in another thread), it seems better to advertise that label range within a TLV of the OSPF RI LSA rather than within a sub-TLV of the Extended Prefix TLV due to the fact that a non-egress BFR (i.e., transit BFR or BFIR) does not need to be assigned with a routable IP address acting as BIER-prefix (this is especially true in the ISIS case). In other words, this label range information is node-specific, rather than prefix-specific. 

Best regards,
Xiaohu

> -----Original Message-----
> From: BIER [mailto:[email-masked]] On Behalf Of IJsbrand Wijnands
> Sent: Saturday, September 27, 2014 7:37 PM
> To: [email-masked]
> Subject: [Bier] Fwd: I-D Action: draft-psenak-ospf-bier-extensions-00.txt
> 
> FYI.
> 
> Begin forwarded message:
> 
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > Internet-Draft directories: http://www.ietf.org/shadow.html or
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier

---

From: IJsbrand Wijnands <[email-masked]>
Date: Sun, 28 Sep 2014 13:13:04 +0200

Xuxiaohu,

> the ISIS case). In other words, this label range information is node-specific, rather than prefix-specific. 

Why limit your self? I may be beneficial to have two different MT-ID’s (on the same node) to be associated with two different BFR-Prefix’s. The reachability of the BFR’s is strictly based on an BFR-Prefix address, so it makes a lot of sense (IMO), if you have the flexibly to choose the address you like to associate with it.

Thx,

Ice.

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Mon, 29 Sep 2014 17:22:57 +0000

Hi Ice,
	Why do we only refer to RFC 4915 for MT-ID but not RFC 5120 where the MT-ID is 12 bits?

Regards
Somasundaram

-----Original Message-----
From: BIER [mailto:[email-masked]] On Behalf Of IJsbrand Wijnands
Sent: Saturday, September 27, 2014 5:07 PM
To: [email-masked]
Subject: [Bier] Fwd: I-D Action: draft-psenak-ospf-bier-extensions-00.txt

FYI.

---

From: "S, Somasundaram (Somasundaram)" <[email-masked]>
Date: Tue, 30 Sep 2014 02:52:54 +0000

I take my word back.. I see that there is a Draft submitted for ISIS to take care of this.. However, I don't see the draft related to ISIS in the Bof and hence the confusion..

-----Original Message-----
From: BIER [mailto:[email-masked]] On Behalf Of S, Somasundaram (Somasundaram)
Sent: Monday, September 29, 2014 10:53 PM
To: IJsbrand Wijnands; [email-masked]
Subject: Re: [Bier] Fwd: I-D Action: draft-psenak-ospf-bier-extensions-00.txt

Hi Ice,

Regards
Somasundaram

-----Original Message-----
From: BIER [mailto:[email-masked]] On Behalf Of IJsbrand Wijnands
Sent: Saturday, September 27, 2014 5:07 PM
To: [email-masked]
Subject: [Bier] Fwd: I-D Action: draft-psenak-ospf-bier-extensions-00.txt

FYI.

---

From: Greg Shepherd <[email-masked]>
Date: Mon, 29 Sep 2014 20:02:59 -0700

I'll update the BoF Wiki, thanks.

Greg

On Mon, Sep 29, 2014 at 7:52 PM, S, Somasundaram (Somasundaram) <
[email-masked]> wrote:

> I take my word back.. I see that there is a Draft submitted for ISIS to
> take care of this.. However, I don't see the draft related to ISIS in the
> Bof and hence the confusion..
>

---

From: Antoni Przygienda <[email-masked]>
Date: Tue, 30 Sep 2014 03:43:05 +0000

Somasundaram, you are perfectly correct, the BIER ISIS I submitted shows 8 bits while ISIS MT-ID ended up being 12 bits finally in RFC5120 (more embarrassing given I’m on author’s list of the said RFC ;-) Moreover, another person pointed out that the type/len fields ended up being 16 bits long which won’t work in router capabilities. I’ll correct both and re-submit before BOF.  The discussion whether BIER should be placed in extended TLVs and possibly something else that router cap is something that is probably worth having once and if BIER is tad further along.

thanks  for comments

--- tony

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: Monday, September 29, 2014 8:03 PM
To: S, Somasundaram (Somasundaram)
Cc: [email-masked]; IJsbrand Wijnands
Subject: Re: [Bier] Fwd: I-D Action: draft-psenak-ospf-bier-extensions-00.txt

Greg

On Mon, Sep 29, 2014 at 7:52 PM, S, Somasundaram (Somasundaram) <[email-masked]<mailto:[email-masked]>> wrote:
I take my word back.. I see that there is a Draft submitted for ISIS to take care of this.. However, I don't see the draft related to ISIS in the Bof and hence the confusion..

-----Original Message-----
From: BIER [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of S, Somasundaram (Somasundaram)
Sent: Monday, September 29, 2014 10:53 PM
To: IJsbrand Wijnands; [email-masked]<mailto:[email-masked]>
Subject: Re: [Bier] Fwd: I-D Action: draft-psenak-ospf-bier-extensions-00.txt

Hi Ice,

Regards
Somasundaram

-----Original Message-----
From: BIER [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of IJsbrand Wijnands
Sent: Saturday, September 27, 2014 5:07 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Bier] Fwd: I-D Action: draft-psenak-ospf-bier-extensions-00.txt

FYI.

Begin forwarded message:

> From: <[email-masked]<mailto:[email-masked]>>
> To: <[email-masked]<mailto:[email-masked]>>
> Reply-To: <[email-masked]<mailto:[email-masked]>>
>
>
> submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier