Subject: [Bier] How to use BIER as the underlay technology for NVO3 network

From: Haoweiguo <[email-masked]>
Date: Thu, 24 Sep 2015 05:58:17 +0000

Hi Folks,

BIER can eliminate explicit multicast-specific tree building protocol and per-flow multicast forwarding state. If we want to use BIER as underlay technology for VXLAN network, i am wondering what's the suitable encapsulation? The possible solutions are as follows:

1. Encap: Ethernet header+BIER header+VXLAN header+Payload.

 BIER header is used as outer tunnel header, the next part is VXLAN header(including VN ID), then the payload is inner most.  The BIER header is used to carry overlay BUM traffic, the regular VXLAN outer IP header is used to carry Unicast traffic.

At least one bit should be added to BIER header to identify the next part is VXLAN header.

2. Encap:Ethernet header+BIER header+Payload. Each VN ID corresponds to one network topology, each NVE in one topology has one unique Bitstring index. When egress NVE receives BIER header encapsulated traffic, it can find the VN ID corresponds to the Bitstring.

I also want to know are there any other possible solutions? What's the suggested encapsulation for NVO3 BIER application?

Your comments and discussions are appreciated.

Thanks,

weiguo

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 24 Sep 2015 06:29:20 +0000

Hi Weiguo,

It seems straightforward to use the protocol field within the BIER header to indicate the payload type of a BIER packet (e.g., MPLS, IP, VXLAN, VXLAN-GPE, GRE/NVGRE, GENEVE, GUE).

Best regards,
Xiaohu

From: BIER [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Thursday, September 24, 2015 1:58 PM
To: [email-masked]
Subject: [Bier] How to use BIER as the underlay technology for NVO3 network

Hi Folks,

Thanks,

weiguo

---

From: Haoweiguo <[email-masked]>
Date: Thu, 24 Sep 2015 06:50:27 +0000

Thanks Xiaohu. Your suggested solution is similar to the first solution.  However, this solution seems to be not consistent with BIER over MPLS solution. If using same thinking, BIER over MPLS seems to be not needed, directly using BIER over Ethernet also can be suitable for MPLS network.

Another related question, for BIER Over Ethernet, one unique Ethernet type is needed to identify BIER header is included. However,currently we don't have the Ethernet Type.

weiguo

________________________________

From: Xuxiaohu
Sent: Thursday, September 24, 2015 14:29
To: Haoweiguo; [email-masked]
Subject: RE: How to use BIER as the underlay technology for NVO3 network

Hi Weiguo,

Best regards,
Xiaohu

Hi Folks,

Thanks,

weiguo

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 24 Sep 2015 07:15:48 +0000

Hi Weiguo,

From: Haoweiguo
Sent: Thursday, September 24, 2015 2:50 PM
To: Xuxiaohu; [email-masked]
Subject: RE: How to use BIER as the underlay technology for NVO3 network

[Xiaohu] Agree. You may be interested to read this draft (https://tools.ietf.org/html/draft-xu-bier-encapsulation-02) which describes a non-MPLS encapsulation for BIER.

[Xiaohu] As for the non-MPLS encapsulation, I agree with you that we need an Ethertype code for BIER (see section 4 of https://tools.ietf.org/html/draft-xu-bier-encapsulation-02#page-4). As for the MPLS-based encapsulation, the EtherType code for MPLS is enough.

Best regards,

Xiaohu

weiguo

________________________________
From: Xuxiaohu
Sent: Thursday, September 24, 2015 14:29
To: Haoweiguo; [email-masked]<mailto:[email-masked]>
Subject: RE: How to use BIER as the underlay technology for NVO3 network
Hi Weiguo,

Best regards,
Xiaohu

From: BIER [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Thursday, September 24, 2015 1:58 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Bier] How to use BIER as the underlay technology for NVO3 network

Hi Folks,

Thanks,

weiguo