Subject: [Bier] WGLC: draft-ietf-bier-ping-03

From: Greg Shepherd <[email-masked]>
Date: Thu, 1 Feb 2018 07:06:31 -0800

Recent rev was published last week.

This starts WGLC. Please read and respond.

https://datatracker.ietf.org/doc/draft-ietf-bier-ping/

Thanks,
Chairs

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 1 Feb 2018 23:43:46 +0800

support ... read a while ago but it was very tight and clean ...

--- tony

On Thu, Feb 1, 2018 at 11:06 PM, Greg Shepherd <[email-masked]> wrote:

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>
>

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 1 Feb 2018 18:09:21 -0800

Dear All,
I support publication of the document. Please consider my comments (and
nits) as non-blocking WGLC comments:

   - "When the payload is BIER OAM, the "Proto" field will be set to 5 as
   defined in [RFC8296]" The strange fact is that the IANA BIER registry
   <https://www.iana.org/assignments/bier/bier.xhtml#bier-next-protocol-identifiers>
refers
   to the BIER Ping draft, not to RFC 8296.
   - perhaps renaming Proto field in BIER OAM Header to Next Proto will
   remove ambiguity when describing process of sending BIER Echo request/reply
   and referring to Proto field (there are Proto field in BIER header as well
   as in BIER OAM header)
   - consider adding more details about new registries to be created by
   IANA for the Message Type and Reply mode (should it be Reply Mode to make
   consistent with, e.g., Return Code?). For example, for the Message Type
   make values 0 and 255 reserved, define experimental range, and specify how
   the new values to be allocated;
   - reference to passive OAM in relation to the Proto field is not
   entirely accurate. If the OAM control message followed by another protocol,
   e.g. the data packet, then, according to RFC 7799, that is example of
   hybrid OAM;
   - do we need registry for Q/R-TF? And why not start from value 1?
   - in 3.2 s/inorder/in order/
   - in 3.3.1 s/set of BFER/set of BFERs/
   - in 4.5 Perhaps better to use 'set the Proto to OAM packet value',
   rather then 'set the Proto to 5' (and to note that this is being done in
   the BIER header, not in BIER OAM header);
   - in 4.5 I agree with the statement but formatting using '/* ... */'
   should be changed
   - in 5.2 Type value registry may be defined in more details, e.g. values
   0 and 65535 - reserved, and experimental range defined. Also, what is the
   process of assigning new Type values?

Regards,
Greg

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 1 Feb 2018 18:53:12 -0800

Ooops, too wide distribution. Meant for my co-authors. We'll work on the
comments to address all in the next update.

Regards,
Greg

On Thu, Feb 1, 2018 at 6:09 PM, Greg Mirsky <[email-masked]> wrote:

>    <https://www.iana.org/assignments/bier/bier.xhtml#bier-next-protocol-identifiers> refers
>    - in 5.2 Type value registry may be defined in more details, e.g.
>    values 0 and 65535 - reserved, and experimental range defined. Also, what
>    is the process of assigning new Type values?
>
> Regards,
> Greg
>

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 02 Feb 2018 03:18:19 +0000

Yes/support

---

From: Senthil Dhanaraj <[email-masked]>
Date: Fri, 2 Feb 2018 11:30:52 +0000

Support !

Thanks,
Senthil

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: 01 February 2018 20:37
To: BIER WG <[email-masked]>
Subject: [Bier] WGLC: draft-ietf-bier-ping-03

Thanks,
Chairs

---

From: Mach Chen <[email-masked]>
Date: Sat, 3 Feb 2018 06:55:47 +0000

Support.

Best regards,
Mach

From: BIER [mailto:[email-masked]] On Behalf Of Greg Shepherd
Sent: Thursday, February 01, 2018 11:07 PM
To: BIER WG <[email-masked]>
Subject: [Bier] WGLC: draft-ietf-bier-ping-03

Thanks,
Chairs

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Sun, 4 Feb 2018 22:32:13 +0000

Hi Greg,

Thanks for the comments. I will check the same and will revert back.

Thanks,
Nagendra

From: BIER <[email-masked]> on behalf of Greg Mirsky <[email-masked]>
Date: Thursday, February 1, 2018 at 9:09 PM
To: Greg Shepherd <[email-masked]>
Cc: BIER WG <[email-masked]>
Subject: Re: [Bier] WGLC: draft-ietf-bier-ping-03

Dear All,
I support publication of the document. Please consider my comments (and nits) as non-blocking WGLC comments:

  *   "When the payload is BIER OAM, the "Proto" field will be set to 5 as defined in [RFC8296]" The strange fact is that the IANA BIER registry<https://www.iana.org/assignments/bier/bier.xhtml#bier-next-protocol-identifiers> refers to the BIER Ping draft, not to RFC 8296.
  *   perhaps renaming Proto field in BIER OAM Header to Next Proto will remove ambiguity when describing process of sending BIER Echo request/reply and referring to Proto field (there are Proto field in BIER header as well as in BIER OAM header)
  *   consider adding more details about new registries to be created by IANA for the Message Type and Reply mode (should it be Reply Mode to make consistent with, e.g., Return Code?). For example, for the Message Type make values 0 and 255 reserved, define experimental range, and specify how the new values to be allocated;
  *   reference to passive OAM in relation to the Proto field is not entirely accurate. If the OAM control message followed by another protocol, e.g. the data packet, then, according to RFC 7799, that is example of hybrid OAM;
  *   do we need registry for Q/R-TF? And why not start from value 1?
  *   in 3.2 s/inorder/in order/
  *   in 3.3.1 s/set of BFER/set of BFERs/
  *   in 4.5 Perhaps better to use 'set the Proto to OAM packet value', rather then 'set the Proto to 5' (and to note that this is being done in the BIER header, not in BIER OAM header);
  *   in 4.5 I agree with the statement but formatting using '/* ... */' should be changed
  *   in 5.2 Type value registry may be defined in more details, e.g. values 0 and 65535 - reserved, and experimental range defined. Also, what is the process of assigning new Type values?
Regards,
Greg

On Thu, Feb 1, 2018 at 7:06 AM, Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Recent rev was published last week.

Thanks,
Chairs

_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 21 Feb 2018 17:19:04 -0800

Greg,

Can you rev the doc with these changes?

Thanks,
Greg

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 21 Feb 2018 17:38:04 -0800

Call for doc shepherd for the bier-ping draft. Please step up and help. If
you're looking for an easy way to learn a bit about the doc process, being
a shepherd is a great first toe in the water.

Thanks,
Chairs
(Greg)

On Wed, Feb 21, 2018 at 5:19 PM, Greg Shepherd <[email-masked]> wrote:

>>    - "When the payload is BIER OAM, the "Proto" field will be set to 5
>>    as defined in [RFC8296]" The strange fact is that the IANA BIER
>>    registry