Subject: [Bier] updated proposed BIER charter

From: Alia Atlas <[email-masked]>
Date: Wed, 21 Feb 2018 00:27:14 -0500

The recharter for BIER is on the telechat this Thursday.  This is for
internal (IESG)
initial review; then it will go out to other SDOs and the IETF community
for notification
and feedback.  I am, of course, getting feedback from other ADs.

Based upon that and my evolving understanding, I have updated the charter.
This may
happen multiple times and rapidly this week.  This change is significant
enough that I'd
like the WG to look at it as well.

The most recent version can be found at
https://datatracker.ietf.org/doc/charter-ietf-bier/.

Regards,
Alia

---

From: "Dolganow, Andrew (Nokia - SG/Singapore)" <[email-masked]>
Date: Wed, 21 Feb 2018 05:41:58 +0000

Alia,

Thank you. One extra comment atop of the charter: we are talking about Working with IDR on extensions and we should also add working with PCE on extensions to program BIER forwarding on BFIR.

Andrew

Sent from my iPhone

On Feb 21, 2018, at 4:27 PM, Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:

The recharter for BIER is on the telechat this Thursday.  This is for internal (IESG)
initial review; then it will go out to other SDOs and the IETF community for notification
and feedback.  I am, of course, getting feedback from other ADs.

Based upon that and my evolving understanding, I have updated the charter.  This may
happen multiple times and rapidly this week.  This change is significant enough that I'd
like the WG to look at it as well.

The most recent version can be found at https://datatracker.ietf.org/doc/charter-ietf-bier/.

Regards,
Alia
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier

---

From: Alia Atlas <[email-masked]>
Date: Wed, 21 Feb 2018 00:49:33 -0500

Andrew,

Thanks for the rapid review.  That may be a better way of concretely
describing how to handle
the controller-based architecture and the management APIs that I took out.

Would you be happy with removing the bit about controller-based
architecture from (5) with that
correlation?

Thanks,
Alia

On Wed, Feb 21, 2018 at 12:41 AM, Dolganow, Andrew (Nokia - SG/Singapore) <
[email-masked]> wrote:

> Alia,
>
> Thank you. One extra comment atop of the charter: we are talking about
> Working with IDR on extensions and we should also add working with PCE on
> extensions to program BIER forwarding on BFIR.
>
> Andrew
>
> Sent from my iPhone
>
> On Feb 21, 2018, at 4:27 PM, Alia Atlas <[email-masked]> wrote:
>
> [email-masked]

---

From: "Dolganow, Andrew (Nokia - SG/Singapore)" <[email-masked]>
Date: Wed, 21 Feb 2018 06:16:26 +0000

Yes, adding PCE instead of sentence in group 5 makes sense to me.

Andrew

From: Alia Atlas <[email-masked]>
Date: Wednesday, February 21, 2018 at 4:49 PM
To: Andrew Dolganow <[email-masked]>
Cc: BIER WG <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Bier] updated proposed BIER charter

Andrew,

Thanks for the rapid review.  That may be a better way of concretely describing how to handle
the controller-based architecture and the management APIs that I took out.

Would you be happy with removing the bit about controller-based architecture from (5) with that
correlation?

Thanks,
Alia

On Wed, Feb 21, 2018 at 12:41 AM, Dolganow, Andrew (Nokia - SG/Singapore) <[email-masked]<mailto:[email-masked]>> wrote:
Alia,

Sent from my iPhone

Regards,
Alia

---

From: Alia Atlas <[email-masked]>
Date: Wed, 21 Feb 2018 01:50:16 -0500

Ok - done.

On Wed, Feb 21, 2018 at 1:16 AM, Dolganow, Andrew (Nokia - SG/Singapore) <
[email-masked]> wrote:

> *From: *Alia Atlas <[email-masked]>
> *Date: *Wednesday, February 21, 2018 at 4:49 PM
> *To: *Andrew Dolganow <[email-masked]>
> *Cc: *BIER WG <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [Bier] updated proposed BIER charter
>
>
>
> Andrew,
>
>
>

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 21 Feb 2018 05:49:17 -0500

Alia,

Section 6 provides an unnecessarily specific example, and doesn’t read as a sentence.

Is:
Additional extensions may be needed - for example, to support signaling additional constraints that prune the topologies on which the computation for BIER for a particular sub-domain.

Suggestion:
Additional extensions may be needed - for example, to support constraining the topology on which a particular BIER sub-domain operates.
Greg

Sent from my iPhone

> On Feb 21, 2018, at 01:50, Alia Atlas <[email-masked]> wrote:
> 
> Ok - done.
> 
>> On Wed, Feb 21, 2018 at 1:16 AM, Dolganow, Andrew (Nokia - SG/Singapore) <[email-masked]> wrote:
>> On Wed, Feb 21, 2018 at 12:41 AM, Dolganow, Andrew (Nokia - SG/Singapore) <[email-masked]> wrote:
>> 
>> Alia,
>> 
>>  
>>

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 21 Feb 2018 10:54:42 -0800

comments from my side, nothing revolutionary, just adding points where
we're specific but miss in the specificity

The BIER (Bit Index Explicit Replication) Working Group has defined
> an architecture [RFC 8279] for  multicast forwarding that uses an
> encapsulation [RFC 8296] that can be used on MPLS or Ethernet transport.
> The BIER-WG is now chartered to produce Standards Track RFCs, including
> RFCs 8279 and 8296.
>
> The focus of the BIER-WG is on deployment: transition, partial deployments,
> applicability and management.
>
> First and primarily, the BIER-WG will complete its work on:
>
>   1) Transition Mechanisms and Partial Deployments: The WG will
>      describe how BIER can be introduced in existing multicast
>      networks to shift multicast delivery either end-to-end or in part
>      of a network from mechanisms such as PIM, ng-MVPN, etc. BIER
>      operation in networks where not all routers are BIER capable
>
>
suggest adding "or other BIER support constraints"

>      should be addressed. How to handle routers supporting BIER with
>      different BitStringLengths
>
> and encapsulations ?

> should be addressed.  Each new
>      mechanism should include an applicability statement that clearly
>      describes its utility and distinctions from already standardized
>      mechanisms.
>
>   2) Applicability Statements: The WG will continue to work on
>      documents describing how BIER can be applied, as has been done
>      for MVPN. A document describing applicability to EVPN should be
>      published.
>
>   3) Use Case: The WG will produce one use-case document that clearly
>      articulates the potential benefits of BIER for different use-cases.
>
> Don't we have that already or we talk overflow from
https://datatracker.ietf.org/doc/draft-ietf-bier-use-cases/ here ?

> The BIER-WG is additionally chartered to start Standards Track work on:
>   7) BIER in IPv6 :  A mechanism to use BIER natively in IPv6 may be
>      standardized if coordinated with the 6MAN WG and with understood
>      applicability.
>   8) BIER Traffic Engineering:  An architecture for BIER-TE is being defined
>      in draft-ietf-bier-te-arch; associated fundamental technology is included.
>
> The BIER-WG will serve as a forum to discuss how BIER can be applied.
> The BIER-WG will coordinate and collaborate with other WGs as needed.  Specific
> expected interactions include:
>   * mpls on the associated MPLS-based OAM mechanisms,
>   * lsr on OSPF and ISIS extensions to flood BIER-related information,
>   * babel on Babel extensions to support BIER,
>
> Is BIER in BABEL a BIER WG thing or a BABEL WG thing?

---

From: Alia Atlas <[email-masked]>
Date: Wed, 21 Feb 2018 16:08:52 -0500

Done - thanks.

---

From: Alia Atlas <[email-masked]>
Date: Wed, 21 Feb 2018 16:10:23 -0500

> suggest adding "or other BIER support constraints"

done

>>      different BitStringLengths

 done

> https://datatracker.ietf.org/doc/draft-ietf-bier-use-cases/ here ?

 Just finishing up that draft.  Milestones need updating.

>> Is BIER in BABEL a BIER WG thing or a BABEL WG thing?

BABEL WG - b/c how to extend it and the details are too confined now.

Regards,
Alia

---

From: Xiejingrong <[email-masked]>
Date: Thu, 22 Feb 2018 11:44:21 +0000

In charter-ietf-bier-01-06 point 2):

The WG will continue to work on documents describing how BIER can be applied, as has been done for MVPN in draft-ietf-bier-mvpn.
====>My Suggestion:
This draft has been IETF LC’ed, then should it be treated as [already done] work, like the IGP extension work described in 6) ?
And what is the [continue to work] then ?
Can alternative applicability be accepted as the [continue work], if it can help to deploy and thus verify the encapsulation that is still on paper ?
We seems to lack actual deployment to verify the data plane encapsulation and forwarding efficiency, as Alissa comment on IESG review.
And I would like to present how <draft-xie-bier-mvpn-mpls-p2mp> can be helpful to deploy on existing network and legacy hardware at London.

A document describing applicability to EVPN should be published.
====>My Suggestion:
[A] changed to [At least one]. For the rich use-case and huge difference of EVPN in DC-network and EVPN in SP-network.

Regards,
XieJingrong

From: BIER [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Wednesday, February 21, 2018 1:27 PM
To: BIER WG <[email-masked]>; [email-masked]
Subject: [Bier] updated proposed BIER charter

Regards,
Alia