Subject: [Bier] Genart telechat review of draft-ietf-bier-ospf-bier-extensions-12

From: Robert Sparks <[email-masked]>
Date: Mon, 19 Feb 2018 10:59:26 -0800

Reviewer: Robert Sparks
Review result: Almost Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-bier-ospf-bier-extensions-12
Reviewer: Robert Sparks
Review Date: 2018-02-19
IETF LC End Date: 2018-02-22
IESG Telechat date: 2018-02-22

Summary: Almost ready for publication as a standards track RFC

Major issue:
The security considerations section is essentially empty (what it currently
says reduces to "don't let malformed packets crash your implementation". Surely
there's more to say here. Is there an assumption that, in any given deployment,
the administrators of the bier layer and the ospf layer are the same people,
and have the same authority? If so, it's probably worth saying so. If not, are
there edges to discuss? If this document really doesn't introduce any new
security considerations, it should argue why that's the case.

Minor issues:
Is there a reason not to use the example/documentation IPV4 address ranges?
(See the shepherd writeup). The author count is above the current
RFC-Editor/IESG recommendations. Work that out with your ADs.

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 21 Feb 2018 20:48:14 -0800

Robert, thanks for your review. It appears that your concerns have been addressed in -20 (thanks, authors!). I have entered a No Objection ballot.

Alissa

> On Feb 19, 2018, at 10:59 AM, Robert Sparks <[email-masked]> wrote:
> 
> Reviewer: Robert Sparks
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art