Subject: [Bier] Comments on draft-ietf-bier-bier-yang

From: Xiejingrong <[email-masked]>
Date: Sat, 28 Jul 2018 12:35:31 +0000

Hi folks,

I have the following comments and on draft-ietf-bier-bier-yang.
--should the bier load-balance-number/ipa/bar be added to rt:routing/bier-global/sub-domain (like below)? I think they are some basic items.

augment /rt:routing:
   +--rw bier
   |  +--rw bier-global
   |     +--rw encapsulation-type?   identityref
   |     +--rw bitstringlength?      bsl
   |     +--rw bfr-id?               bfr-id
   |     +--rw ipv4-bfr-prefix?   inet:ipv4-prefix
   |     +--rw ipv6-bfr-prefix?   inet:ipv6-prefix
   |     +--rw sub-domain* [sub-domain-id]
   |        +--rw sub-domain-id      sub-domain-id
   |        +--rw igp-type?          igp-type
   |        +--rw mt-id?             mt-id
   |        +--rw bfr-id?            bfr-id
   |        +--rw bitstringlength?   bsl
   |        +--rw multi-bift-number? load-balance-number
   |        +--rw igp-algorithm?     ipa
   |        +--rw bier-algorithm?    bar

--should the bier-mpls-label-range-size be changed to 'max si' or not ? The type is uint8 and thus seems having to change the meaning.

Thanks
Jingrong

---

From: Xiejingrong <[email-masked]>
Date: Sat, 28 Jul 2018 13:01:13 +0000

some more comments:
1. one sub-domain should allow miltiple {BSL and the according label block}s as encapsulations, see the igp sub-sub-TLV.
2. should the igp-type change to underlay-protocol-type to allow bgp?
From:Xiejingrong
To:BIER WG,
Cc:[email-masked],
Date:2018-07-28 20:36:25
Subject:[Bier] Comments on draft-ietf-bier-bier-yang

Hi folks,

augment /rt:routing:
   +--rw bier
   |  +--rw bier-global

--should the bier-mpls-label-range-size be changed to ‘max si’ or not ? The type is uint8 and thus seems having to change the meaning.

Thanks
Jingrong