Subject: Re: [Bier] BIER WGLC: draft-ietf-bier-php

From: Greg Shepherd <[email-masked]>
Date: Fri, 20 Sep 2019 14:21:49 -0700

We're long past Aug 13th and not one response. PLEASE read and respond or
we'll just let this expire.

Thanks,
Greg

On Tue, Jul 30, 2019 at 11:23 AM Greg Shepherd <[email-masked]> wrote:

> Please read and respond to this thread:
>
> https://datatracker.ietf.org/doc/draft-ietf-bier-php/
>
> EOTWT: Aug 13th.
>
> Thanks,
> Shep
> (chairs)
>

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Tue, 24 Sep 2019 01:49:14 +0000

Hmm … this is embarrassing - I as the author did not respond either.

I hope this is just because everyone was in vacation mode for too long too much.

I strong believe this is a valuable tool for brownfield deployment/transition and it is ready to move forward – please read, comment, and voice your support (or objection).

Thanks!
Jeffrey

From: BIER <[email-masked]> On Behalf Of Greg Shepherd
Sent: Friday, September 20, 2019 5:22 PM
To: BIER WG <[email-masked]>
Subject: Re: [Bier] BIER WGLC: draft-ietf-bier-php

We're long past Aug 13th and not one response. PLEASE read and respond or we'll just let this expire.

Thanks,
Greg

On Tue, Jul 30, 2019 at 11:23 AM Greg Shepherd <[email-masked]<mailto:[email-masked]>> wrote:
Please read and respond to this thread:

https://datatracker.ietf.org/doc/draft-ietf-bier-php/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bier-php/__;!8WoA6RjC81c!QpjToXavismjVCsTp9r3SMskdaYaim4F9-DMcqCnp1co0-Y0kEA5j6ZbyXjpYAwO$>

EOTWT: Aug 13th.

Thanks,
Shep
(chairs)

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 23 Sep 2019 20:27:28 -0700

Dear All,
I've read the draft and support it to be progressed as it addresses the
real scenario in a very elegant manner.
Please consider my notes below as WGLC comments (all are editorial):

   - Would expect [To be added] note replaced by the list of terms,
   acronyms.
   - Expand acronyms on the first use (except for those that are part of
   well-known terms.
   - Perhaps s/BIER capable/BIER-capable/ and s/BIER
   incapable/BIER-incapable/

Regards,
Greg

On Fri, Sep 20, 2019 at 2:22 PM Greg Shepherd <[email-masked]> wrote:

> _______________________________________________
> BIER mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bier
>

---

From: IJsbrand Wijnands <[email-masked]>
Date: Tue, 24 Sep 2019 09:29:35 +0200

Dear WG,

I like to see this draft progress to IESG, this is a very useful mechanism to make deployment of BIER easier.

The draft is good to go, no comments.

Thx,

Ice.

> On 30 Jul 2019, at 20:23, Greg Shepherd <[email-masked]> wrote:
>

---

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 24 Sep 2019 07:34:31 +0000

This is useful work. It should progress.
Support.

Thx
Jorge

From: BIER <[email-masked]> on behalf of Greg Shepherd <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Friday, September 20, 2019 at 11:22 PM
To: BIER WG <[email-masked]>
Subject: Re: [Bier] BIER WGLC: draft-ietf-bier-php

Thanks,
Greg

EOTWT: Aug 13th.

Thanks,
Shep
(chairs)

---

From: <[email-masked]>
Date: Tue, 24 Sep 2019 15:54:50 +0800 (CST)

Hi Greg,

I think this draft is useful in extending BIER deployment.

I do support the progess of this draft.

And I have some comments on this version of draft:

1. [I-D.ietf-bier-ospf-bier-extensions] should be replaced by RFC8444.

2. In section 3, the "Label Range Base" should be modified to "Label". 

3. With the "Implicit Null Label" advertisement, the associated "BS Len" should be set to 0 to avoid confusion.

4. A nit in section 5, the "OSPFv2" should be "OSPFv3".

Thanks,

Sandy

原始邮件

发件人：GregShepherd <[email-masked]>
收件人：BIER WG <[email-masked]>;
日 期 ：2019年07月31日 03:19
主 题 ：[Bier] BIER WGLC: draft-ietf-bier-php

EOTWT: Aug 13th.

Thanks,
Shep
(chairs)

---

From: Linda Wang <[email-masked]>
Date: Tue, 24 Sep 2019 17:55:08 +1000

It's a really good point to have PHP in BIER.

Support:)

BRs,
Linda

On Tue, Sep 24, 2019 at 5:34 PM Rabadan, Jorge (Nokia - US/Mountain View) <
[email-masked]> wrote:

> *From: *BIER <[email-masked]> on behalf of Greg Shepherd <
> [email-masked]>
> *Reply-To: *"[email-masked]" <[email-masked]>
> *Date: *Friday, September 20, 2019 at 11:22 PM
> *To: *BIER WG <[email-masked]>
> *Subject: *Re: [Bier] BIER WGLC: draft-ietf-bier-php
>
>
>

---

From: Michael Menth <[email-masked]>
Date: Tue, 24 Sep 2019 13:49:46 +0200

Useful work - support.

Michael

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---
Diese E-Mail wurde von Avast Antivirus-Software auf Viren geprüft.
https://www.avast.com/antivirus

---

From: "Bidgoli, Hooman (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 24 Sep 2019 11:52:29 +0000

Useful concept support

Regards

Hooman

Thanks,
Greg

EOTWT: Aug 13th.

Thanks,
Shep
(chairs)

---

From: <[email-masked]>
Date: Thu, 26 Sep 2019 21:53:07 +0000

This is an interesting approach and useful for brownfield deployments and as such I would like to see it progress.

Support =)
Viele Grüße / Kind regards,
Nils Warnke
Von: BIER <[email-masked]> Im Auftrag von Greg Shepherd
Gesendet: Freitag, 20. September 2019 23:22
An: BIER WG <[email-masked]>
Betreff: Re: [Bier] BIER WGLC: draft-ietf-bier-php

Thanks,
Greg

EOTWT: Aug 13th.

Thanks,
Shep
(chairs)

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Fri, 27 Sep 2019 11:19:03 +0000

Hi,

Support.

I have a couple of comments as below:

  1.  Based on the Introduction section, the upstream BFR that pops the BIER header can be directly to PE (BIER incapable) or through a tunnel. In case of non-directly connected BFR, Is it really “PHP” or is it BIER to LSP stitching?.
  2.  In addition to the assumption/limitation mentioned in the start of Section 3, I think this draft assumes the presence of LSP tunnel between the upstream BFR and BIER-incapable PE. If it is non-MPLS network, does it expect to encapsulate with IP/UDP?. Either way, I think it is better to clarify the same in the draft.
  3.  The introduction says the below:
“
While the above text uses MVPN/EVPN as example, BIER PHP is
   applicable to any scenario where the multicast flow overlay edge
   router does not support BIER.”

The above appears to contradict with section 3 that says, BIER PHP is applicable only when BIER NH =1.

Regards,
Nagendra

Date: Friday, September 20, 2019 at 5:22 PM

Thanks,
Greg

EOTWT: Aug 13th.

Thanks,
Shep
(chairs)

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Sat, 28 Sep 2019 19:54:42 +0000

Hi Nagendra,

Please see zzh> below.

From: Nagendra Kumar Nainar (naikumar) <[email-masked]>
Sent: Friday, September 27, 2019 7:19 AM
To: [email-masked]; BIER WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [Bier] BIER WGLC: draft-ietf-bier-php

Hi,

Support.

Zzh> From BIER point of view, it is indeed PHP, because it happens on the BFR upstream of the edge router (the BFER if it did support BIER).

  1.  In addition to the assumption/limitation mentioned in the start of Section 3, I think this draft assumes the presence of LSP tunnel between the upstream BFR and BIER-incapable PE. If it is non-MPLS network, does it expect to encapsulate with IP/UDP?. Either way, I think it is better to clarify the same in the draft.

Zzh> Any tunnel is fine. Please also see below for the restriction mentioned in the start of Section 3 (where IP tunnels may be used in case of EVPN-vxlan/gre).

  1.  The introduction says the below:
“
While the above text uses MVPN/EVPN as example, BIER PHP is
   applicable to any scenario where the multicast flow overlay edge
   router does not support BIER.”

Zzh> Good catch. It does apply to the following scenario as well, as described in the earlier version of the spec (https://tools.ietf.org/html/draft-zzhang-bier-php-01):

   The procedures in this section can be applied only if, by means
   outside the scope of this document, it is known that one of the
   following conditions is met.

   o  The payload after BIER header is IPv4 or IPv6 (i.e., the Proto
      field in the BIER header is 4 or 6).
      Notice that in this case the Destination Address in the IPv4/IPv6
      header must be in the address space for the BIER layer.

Zzh> It was taken out per advices given during WG adoption I think, but the introduction section was not changed accordingly. The reason for taking it out is that for the “BFER” to route IP (multicast) packets it needs to know the RPF interface, so it’s likely to use GTM [RFC7716] with a DCB label [bess-mvpn-evpn-aggregation-label], which is covered by the condition in section 3.

Zzh> On the other hand, when BIER is used for EVPN-overlay (https://tools.ietf.org/html/draft-ietf-bier-evpn-01), since the vxlan/nvgre header uses global VNI/VSID to identify broadcast domains, it will also work.

Zzh> In short, as long as the BFER does not rely on knowing the BFIR, it will work.

Zzh> So I plan to add “as long as the edge router does not need to know the transmitting BFIR” to the text you quoted, and add the vxlan/nvgre scenario to section 3.
Zzh> Thanks!
Zzh> Jeffrey

Regards,
Nagendra

From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Greg Shepherd <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Friday, September 20, 2019 at 5:22 PM
To: BIER WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] BIER WGLC: draft-ietf-bier-php

Thanks,
Greg

https://datatracker.ietf.org/doc/draft-ietf-bier-php/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bier-php/__;!8WoA6RjC81c!U17M0xuXqFjEd95HNxPeY_ujEfDmpbM2lywc1ZmclPy6K3fz8WnBGIfTfgpee9ht$>

EOTWT: Aug 13th.

Thanks,
Shep
(chairs)

---

From: <[email-masked]>
Date: Sun, 29 Sep 2019 09:19:43 +0800 (CST)

Support for the further progress of this draft.

Best regards,

Corona Wei

原始邮件

发件人：[email-masked] <[email-masked]>
收件人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年09月27日 05:54
主 题 ：Re: [Bier] BIER WGLC: draft-ietf-bier-php

 

Support =)

Nils Warnke

 

 

Thanks,

Greg

 

 

EOTWT: Aug 13th.

Thanks,

Shep

(chairs)

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 30 Sep 2019 18:37:44 +0000

Hi Sandy,

Thanks for your comments.
Please see zzh> below.

From: [email-masked] <[email-masked]>
Sent: Tuesday, September 24, 2019 3:55 AM
To: [email-masked]; Jeffrey (Zhaohui) Zhang <[email-masked]>
Cc: [email-masked]
Subject: Re:[Bier] BIER WGLC: draft-ietf-bier-php

Hi Greg,

Zzh> Yes.

  1.  In section 3, the "Label Range Base" should be modified to "Label".

Zzh> Yes.

  1.  With the "Implicit Null Label" advertisement, the associated "BS Len" should be set to 0 to avoid confusion.

Zzh> That is for a particular BSL, so BS Len should not be 0. If one wants a simple signaling for “I don’t support BIER at all but please do PHP”, then it should just use the PHP sub-TLV w/o advertising encap sub-TLV.

Zzh> This is indeed OSPFv2. OSPFv3 signaling draft is newer, so unless this PHP draft is delayed, I’d rather mention PHP in the OSPFv3 draft.

Zzh> Thanks! I will post a revision soon.

Zzh> Jeffrey

Thanks,

Sandy

原始邮件
发件人：GregShepherd <[email-masked]<mailto:[email-masked]>>
收件人：BIER WG <[email-masked]<mailto:[email-masked]>>;
日 期 ：2019年07月31日 03:19
主 题 ：[Bier] BIER WGLC: draft-ietf-bier-php
_______________________________________________
BIER mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bier
Please read and respond to this thread:
https://datatracker.ietf.org/doc/draft-ietf-bier-php/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bier-php/__;!8WoA6RjC81c!T-D6x62ghQ6W-dEjKoMgaXKMtLv0ymQr7wUODBs86UBabhZ2ZjZeruPyg5U5sNy4$>

EOTWT: Aug 13th.

Thanks,
Shep
(chairs)