Subject: [Bier] Pls "vote" on name (draft-ietf-bier-te-arch)

From: Toerless Eckert <[email-masked]>
Date: Thu, 27 Feb 2020 21:40:38 +0100

Dear WG

Please chime in with opinions about the following or any new name you
like as the new name for BIER-TE. Timeout is deadline for submission
of draft before IETF107, when i'll post an update. If you propose a
new name try to avoid re-using abbreviations that may be misinterpreted.

5 = best name ever, ... 1 = lame name, no number assigned means 0
votes are just added up and maximum sum option wins.
Explanations if you haven't followed thread at the end.

BIER-PE  - Path Engineering
BIER-ET  - Explicit Trees
BIER-EET - Explicit Engineered Trees
BIER-BET - Bit Engineered Trees
BIER-BST - Bit Steered Trees
BIER-TrE - Tree engineering
BIER-ET  - Engineered Trees
BIER-ST  - Steered Trees

BIER-ASB - Adjacency Steering Bits   (adjacencies are how bits in BIER-PE are defined)
BIER-AB  - Adjacency Bits
BIER-SB  - Steering Bits             (overloads with "Source Block" - never heard)

Thanks,
    Toerless

Explanations: If you have read through the threads with Lou and Deborah, and my
understanding is correct:

Lou desired there to be a new name so BIER-TE the forwarding/steering
mechanism (this document) is named differently from BIER-TE the larger
framework utilizing TEAS/PCE definition (separate future draft).

Lou did not like my "Path Engineering" proposal as the name in the
last version of the doc and felt we should pick a name with
Steering/routing-policy in it. I think usn only steering/routing
would be misleading (confused with unicast approaches).

Deborah pointed to avoiding confusions in the name with
pre-established named (e.g.: "PE" meaning Provider Edge).
Said we should finalize on the name before we as the WG should
pass the document to IESG. And she asked chairs to extend last-call
by one more week (unrelated). Hence timeout end of next week.

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 27 Feb 2020 21:43:57 +0100

2 BIER-PE  - Path Engineering
5 BIER-ET  - Explicit Trees
3 BIER-EET - Explicit Engineered Trees
4 BIER-BET - Bit Engineered Trees
3 BIER-BST - Bit Steered Trees
2 BIER-TrE - Tree engineering
3 BIER-ET  - Engineered Trees
2 BIER-ST  - Steered Trees

2 BIER-ASB - Adjacency Steering Bits   (adjacencies are how bits in BIER-PE are defined)
  BIER-AB  - Adjacency Bits
  BIER-SB  - Steering Bits             (overloads with "Source Block" - never heard)

I prefer Explixit Trees because it is indicative of what is
signalled(trees), and it nicely doubles down as a name
  Bit Indexed Explicit Replication, Explixit Trees

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 28 Feb 2020 07:54:07 +0000

Toerless, all,

May I add to the mix (which might not help) with the proposal for 'path-based routing' (or BIER-PBR) or 'path-based steering' (or BIER-PST)? If you want to keep a two letter acronym, I'd add 'path steering' (rather than path engineering) to the mix. From the below, without considering any alternatives, I'd go for BIER-PE but it comes with the issues like many two letter acronyms, namely the higher 'collision rate' with others.

Best,

Dirk

-----Original Message-----
From: BIER [mailto:[email-masked]] On Behalf Of Toerless Eckert
Sent: 27 February 2020 21:41
To: [email-masked]
Cc: Lou Berger <[email-masked]>; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; [email-masked]
Subject: [Bier] Pls "vote" on name (draft-ietf-bier-te-arch)

Dear WG

Please chime in with opinions about the following or any new name you like as the new name for BIER-TE. Timeout is deadline for submission of draft before IETF107, when i'll post an update. If you propose a new name try to avoid re-using abbreviations that may be misinterpreted.

5 = best name ever, ... 1 = lame name, no number assigned means 0 votes are just added up and maximum sum option wins.
Explanations if you haven't followed thread at the end.

Thanks,
    Toerless

Explanations: If you have read through the threads with Lou and Deborah, and my understanding is correct:

Lou desired there to be a new name so BIER-TE the forwarding/steering mechanism (this document) is named differently from BIER-TE the larger framework utilizing TEAS/PCE definition (separate future draft).

Lou did not like my "Path Engineering" proposal as the name in the last version of the doc and felt we should pick a name with Steering/routing-policy in it. I think usn only steering/routing would be misleading (confused with unicast approaches).

Deborah pointed to avoiding confusions in the name with pre-established named (e.g.: "PE" meaning Provider Edge).
Said we should finalize on the name before we as the WG should pass the document to IESG. And she asked chairs to extend last-call by one more week (unrelated). Hence timeout end of next week.

_______________________________________________
BIER mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bier

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 28 Feb 2020 15:22:54 +0100

Sure, Just reply wth the ones you like whether existing or added and
give them the weiht you like, e.g.: from your email something like:

5  BIER-PBR    (Path Based Routing)
5  BIER-PST    (Path based STeering)
3  BIER-PE     (Path Engineering)

-- 
---
[email-masked]

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 28 Feb 2020 14:26:59 +0000

Indeed, I'd go for 5 BIER-PBR, 5 BIER-PBS (or BIER-PST) and 2 for BIER-PE. The last one is the only one really I like with 'engineering' although I follow the argument that the work is less about the engineering itself but the enablement of it. 

Dirk

-----Original Message-----
From: Toerless Eckert [mailto:[email-masked]] 
Sent: 28 February 2020 15:23
To: Dirk Trossen <[email-masked]>
Cc: [email-masked]; Lou Berger <[email-masked]>; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; [email-masked]
Subject: Re: [Bier] Pls "vote" on name (draft-ietf-bier-te-arch)

Sure, Just reply wth the ones you like whether existing or added and give them the weiht you like, e.g.: from your email something like:

On Fri, Feb 28, 2020 at 07:54:07AM +0000, Dirk Trossen wrote:
> Cc: Lou Berger <[email-masked]>; [email-masked]; BRUNGARD, 
> DEBORAH A <[email-masked]>; [email-masked]

--
---
[email-masked]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 28 Feb 2020 15:31:08 +0000

If you go with PBR, you could continue the BIER WG traditional of selecting brew-based acronyms. Hence, that would be my vote. It could be confused with Policy Based Routing but only if someone actually implements it.
Thanks,
Acee

On 2/28/20, 9:23 AM, "BIER on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    -- 
    ---
    [email-masked]

---

From: Greg Shepherd <[email-masked]>
Date: Fri, 28 Feb 2020 08:00:21 -0800

My vote: BIER-TE
Call it Tree Engineering. If we were so concerned with acronym overuse the
IETF would grind to a halt. I've been involved in other WGs where I felt
the name missed the mark describing the ideas in the draft, but felt
reading the draft was how someone got their heads around the proposed
solution, rather than miss-read the title and run away confused. ie -
Vlex-Algo. No, it's Flex-Topo, but what's to be gained from arguing for a
name at this point?

Yes, we should strive to be as 'correct' as possible. But the IETF is full
of baggage that engineers have managed to wade through, make sense of, and
implement successfully. Get the spec right, No #1 priority. If you don't
like the name, read on. It will grow on you. :)

Shep (w/o chair hat)

On Fri, Feb 28, 2020 at 7:31 AM Acee Lindem (acee) <[email-masked]> wrote:

> If you go with PBR, you could continue the BIER WG traditional of
> selecting brew-based acronyms. Hence, that would be my vote. It could be
> confused with Policy Based Routing but only if someone actually implements
> it.
> Thanks,
> Acee
>
> On 2/28/20, 9:23 AM, "BIER on behalf of Toerless Eckert" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     > May I add to the mix (which might not help) with the proposal for
> 'path-based routing' (or BIER-PBR) or 'path-based steering' (or BIER-PST)?
> If you want to keep a two letter acronym, I'd add 'path steering' (rather
> than path engineering) to the mix. From the below, without considering any
> alternatives, I'd go for BIER-PE but it comes with the issues like many two
> letter acronyms, namely the higher 'collision rate' with others.
>     >
>     > Best,
>     >
>     > Dirk
>     >
>     >
>     >
>     > Please chime in with opinions about the following or any new name
> you like as the new name for BIER-TE. Timeout is deadline for submission of
> draft before IETF107, when i'll post an update. If you propose a new name
> try to avoid re-using abbreviations that may be misinterpreted.
>     >
>     > Explanations: If you have read through the threads with Lou and
> Deborah, and my understanding is correct:
>     >
>     > Lou desired there to be a new name so BIER-TE the
> forwarding/steering mechanism (this document) is named differently from
> BIER-TE the larger framework utilizing TEAS/PCE definition (separate future
> draft).
>     >
> Steering/routing-policy in it. I think usn only steering/routing would be
> misleading (confused with unicast approaches).
>     >
>     > Said we should finalize on the name before we as the WG should pass
> the document to IESG. And she asked chairs to extend last-call by one more
> week (unrelated). Hence timeout end of next week.
>     >

---

From: Tony Przygienda <[email-masked]>
Date: Fri, 28 Feb 2020 08:01:24 -0800

Yepp, I concur with Greg ... tony

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 28 Feb 2020 17:33:18 +0100

Votes only count when you attach a number 5..1 to them.

On Fri, Feb 28, 2020 at 03:31:08PM +0000, Acee Lindem (acee) wrote:
> If you go with PBR, you could continue the BIER WG traditional of selecting brew-based acronyms.
> Hence, that would be my vote. It could be confused with Policy Based Routing but only
> if someone actually implements it.

Do you mean the beer brand name PBR ?

Yes, i had a long rant to Lou against using terms that could be confused with unicast mechanisms
because he was suggesting to use those terms as they are used in e.g.:
explaining how SR steers traffic (policy, routing, steering).

Given how you also feel it would be confusing,
If you like to have a beer themed name, could i instead upsell you into something larger:

  BIER-VAT  Vertex Adjacency-bit Trees

Its a pretty accurate description of what we do (the bits are for
adjacencies, which are the vertices of the tree they describe).

Cheers
    Toerless

> Thanks,
> Acee
> 
> ???On 2/28/20, 9:23 AM, "BIER on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 28 Feb 2020 17:34:39 +0100

Ok. Sigh.. i'll relax the rules to simply count all proposed names
without number as 5.

On Fri, Feb 28, 2020 at 08:00:21AM -0800, Greg Shepherd wrote:
> > ???On 2/28/20, 9:23 AM, "BIER on behalf of Toerless Eckert" <

-- 
---
[email-masked]

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Fri, 28 Feb 2020 16:39:03 +0000

I was not going to vote (it's for the wg to decide) but on this one - Toerless - it's really good - can not resist -as I was thinking also to put adjacency in but couldn't think of something - my vote should be weighted lower than the rest of the working group -

5  BIER-VAT

Thanks!
Deborah

-----Original Message-----
From: Toerless Eckert <[email-masked]> 
Sent: Friday, February 28, 2020 11:33 AM
To: Acee Lindem (acee) <[email-masked]>
Cc: Dirk Trossen <[email-masked]>; [email-masked]; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; Lou Berger <[email-masked]>; [email-masked]
Subject: Re: [Bier] Pls "vote" on name (draft-ietf-bier-te-arch)

Cheers
    Toerless

>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bier&d=DwIBAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=NUaI2_KsSPm66ASmDykx9_GSjXJLODLJWuqtzo0Z3-U&s=gf1IBPqsSCWpA77_Nd1uxa7HR_2e5TcAYRDChmbSLxw&e= 
>     > 
>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bier&d=DwIBAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=NUaI2_KsSPm66ASmDykx9_GSjXJLODLJWuqtzo0Z3-U&s=gf1IBPqsSCWpA77_Nd1uxa7HR_2e5TcAYRDChmbSLxw&e= 
>     
>     -- 
>     ---
>     [email-masked]
>     
>     https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bier&d=DwIBAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=NUaI2_KsSPm66ASmDykx9_GSjXJLODLJWuqtzo0Z3-U&s=gf1IBPqsSCWpA77_Nd1uxa7HR_2e5TcAYRDChmbSLxw&e= 
>     
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 28 Feb 2020 18:55:23 +0100

Haha, thanks. Deb. You know, the name also doubles
in being upfront about the main cost of the design:

Vertexvalue Added bit Tax ;-)

-- 
---
[email-masked]

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Fri, 28 Feb 2020 18:00:21 +0000

+1

From: BIER <[email-masked]> On Behalf Of Greg Shepherd
Sent: Friday, February 28, 2020 11:00 AM
To: Acee Lindem (acee) <[email-masked]>
Cc: Dirk Trossen <[email-masked]>; [email-masked]; [email-masked]; BRUNGARD, DEBORAH A <[email-masked]>; Toerless Eckert <[email-masked]>; Lou Berger <[email-masked]>; [email-masked]
Subject: Re: [Bier] Pls "vote" on name (draft-ietf-bier-te-arch)

My vote: BIER-TE
Call it Tree Engineering. If we were so concerned with acronym overuse the IETF would grind to a halt.. I've been involved in other WGs where I felt the name missed the mark describing the ideas in the draft, but felt reading the draft was how someone got their heads around the proposed solution, rather than miss-read the title and run away confused. ie - Vlex-Algo. No, it's Flex-Topo, but what's to be gained from arguing for a name at this point?

Yes, we should strive to be as 'correct' as possible. But the IETF is full of baggage that engineers have managed to wade through, make sense of, and implement successfully. Get the spec right, No #1 priority. If you don't like the name, read on. It will grow on you. :)

Shep (w/o chair hat)

On Fri, Feb 28, 2020 at 7:31 AM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
If you go with PBR, you could continue the BIER WG traditional of selecting brew-based acronyms. Hence, that would be my vote. It could be confused with Policy Based Routing but only if someone actually implements it.
Thanks,
Acee

On 2/28/20, 9:23 AM, "BIER on behalf of Toerless Eckert" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

    On Fri, Feb 28, 2020 at 07:54:07AM +0000, Dirk Trossen wrote:
    > From: BIER [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Toerless Eckert
    > To: [email-masked]<mailto:[email-masked]>
    > Cc: Lou Berger <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; BRUNGARD, DEBORAH A <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
    > [email-masked]<mailto:[email-masked]>
    > https://www.ietf.org/mailman/listinfo/bier<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!XTqwts2-5zdo1IkQC5-U-AOGK6YXe64GuD7ppyaEDLLk6yF2DFJG39Z3gWAQ_f2K$>
    >
    > [email-masked]<mailto:[email-masked]>
    > https://www.ietf.org/mailman/listinfo/bier<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!XTqwts2-5zdo1IkQC5-U-AOGK6YXe64GuD7ppyaEDLLk6yF2DFJG39Z3gWAQ_f2K$>

    --
    ---
    [email-masked]..de<mailto:[email-masked]>

    _______________________________________________
    BIER mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/bier<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/bier__;!!NEt6yMaO-gk!XTqwts2-5zdo1IkQC5-U-AOGK6YXe64GuD7ppyaEDLLk6yF2DFJG39Z3gWAQ_f2K$>

---

From: Lou Berger <[email-masked]>
Date: Fri, 28 Feb 2020 18:13:14 -0500

Chairs/all

Rather than play games with the name why not just add the one section 
that's missing to support traffic engineering and then you can legitimately 
call it TE? (Some may have noted that this was my preference in my mail 
that kicked off this discussion.). I'm even happy to contribute text.

Doesn't this make the most sense?

Lou

----------
On February 28, 2020 11:03:04 AM Tony Przygienda <[email-masked]> wrote:

> ----------

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 29 Feb 2020 01:31:35 +0100

I do not think we are playing games, we are i think just following the
advice a least as i understand it from the feedback received from you and Deb.

I added a section 1.1 after your first feedback explaining how this
BIER-PE draft relates to traffic engineering the best way i understand it,
but then you suggested that i should remove it again or else it would
require mayor changes (which i still expressed interest in seeing).

If you think traffic engineering support would only require an additional section
(without changes to the rest of the document ?) then i would happy to 
understand what that section would need to say and of course you are
more than welcome to contribute text.

I can not say yet if that solution makes more sense unless i understand
better what you are proposing. But i think it would be great if it did
(make more sense).

And no, i am sorry, but i did not read your preference to extend this
document to be able to claim traffic engineering from the feedback i
have seen from you so far.

Cheers
    Toerless

On Fri, Feb 28, 2020 at 06:13:14PM -0500, Lou Berger wrote:
> Chairs/all
> 
> Rather than play games with the name why not just add the one section that's
> missing to support traffic engineering and then you can legitimately call it
> TE? (Some may have noted that this was my preference in my mail that kicked
> off this discussion.). I'm even happy to contribute text.
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 29 Feb 2020 01:52:00 +0100

Pressed :wq (send button) too fast, quick amendment:

If i think of a larger "Traffic Engineering" with BIER framework (BIER-TE ?)
i think that could also include BIER (not BIER-PE) combined with PCE,
combined with same bandwdith/buffering addons, but now we have no
explicit per-tree path steering but could only combine with what i called
unicast policy routing (e.g.: (flex-)topologies, which of course more
limited in path steering than BIER-PE.

[ If thats too confusing, think of IPv6 multicast to make the question easier:
  PIM-SM plus RSVP (NOT RSVP-TE) plus e.g.: optional (flex)topologies plus PCE. ]

I do not know if such options could rightfully be called
"Traffic Engineering" (which i think is a term wholly owned by TEAS).
If it would, and if it would be desirable for TEAS to also document such an
option, and have that be covered under the larger umbrella of BIER
Traffic Engineering (together of course with the option of BIER-PE),
then we would have the fact that we are back to the naming overlap
where we started:

  BIER-TE(1) as this documents Tree Engineering method , but called "Traffic Engineering"
  BIER-TE(2) as a larger framework with the option to include BIER-TE(1)
             and BIER, and also called "Traffic Engineering".

WG seems to like calling BIER-TE(1) "Tree Engineering", so we'd end up
with the same abbreviation, but at least two different meanings between
(1) and (2).

But i'll withhold my opinion about what i'd ultimately think is
least confusing until i hear back from you about what you think the
section you claim missing in the doc would exactly have to entail.

Just wanted to add what i missed to say in the first mail.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Loa Andersson <[email-masked]>
Date: Sat, 29 Feb 2020 17:37:01 +0800

Working Group,

Of the proposals below I feel most comfortable with BIER-ET.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64