Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Thu, 1 Apr 2021 16:53:21 +0000

Agree, I am editor of many drafts in other working group,  But I am not in author list.  As part of WG , I think our intention is to produce document which can be used across vendor for implementation.

From: BIER <[email-masked]> on behalf of Greg Shepherd <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Wednesday, March 31, 2021 at 8:57 AM
To: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Cc: "Jeffrey (Zhaohui) Zhang" <[email-masked]>, "[email-masked]" <[email-masked]>, BIER WG <[email-masked]>, Huaimo Chen <[email-masked]>, BIER WG Chairs <[email-masked]>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

Editor is not Author.

On Tue, Mar 30, 2021 at 7:04 PM Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

I agree that Jeffery has quite rich experience in BIER WG and participates in ML discussions actively. However, I still think the answer of “who should be the author of the document” depends mostly on “who raises the idea and brings it to IETF”. This is a basic respect for the originality of the author.
Of course, if anyone is interested in this topic, he/she could contribute and co-author the document, when the existing authors would like to.

Best
Xuesong

From: BIER [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Shepherd
Sent: Wednesday, March 31, 2021 12:11 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>>
Cc: BIER WG <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Huaimo Chen <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

I agree with Jeffrey. The two drafts should be merged into a new draft, which we will then call to adopt. I suggest that the authors of each of the two docs:

https://tools.ietf.org/html/draft-merling-bier-frr-00
https://datatracker.ietf.org/doc/draft-chen-bier-frr

..contribute two authors to the merged doc effort, and have Jeffrey hold the pen as editor/author.

All agreed?

Thanks,
Greg
(Chairs)

On Mon, Mar 29, 2021 at 7:26 PM Jeffrey (Zhaohui) Zhang <[email-masked]<mailto:[email-masked]>> wrote:
Shouldn’t it be the other way around – expand/merge first and then adopt?

In fact, the essence of draft-chen is the multiple per-nbr FRR BIFTs, which I don’t think should be included in the merged draft at all, for the following problems:

  1.  Scaling – we need one extra BIFT for each <neighbor, BIFT>. This not only means extra memory, but also additional processing overhead including downloading the tables to the forwarding plane.
  2.  If two neighbors fail simultaneously yet both can be protected by a 3rd neighbor, per-nbr FRR BIFTs can only give protection for one of the first two neighbors. This is not an unusual situation – you could have two neighbors reached by the same link or the same line card, and the link/card fails.
  3.  Exactly when to switch back from a per-nbr FRR BIFT to the regular BIFT?

The draft says the following about #3:

   In general, when the routing protocol has re-converged on the new
   topology taking into account the failure of X, the BIRT is re-
   computed using the updated LSDB and the BIFT is re-derived from the
   BIRT.  Once the BIFT is installed ready for activation, it is
   activated to forward packets with BIER headers and the FRR-BIFT for X
   is de-activated.

Does that mean for each computation, you need to know and mark which failed neighbor that it takes care of, so that when the BIFT is sent down to forwarding plane you can decide if currently used FRR-BIFT can be switched back to the main BIFT?

Also consider the following:

  1.  At moment T you switch to FRR BIFT for nbr X
  2.  At moment T+1ms a new BIFT is calculated, which takes care of a remote failure but not nbr X (nbr X is still considered up in this calculation) – would you switch FRR BIFT to the newly calculated main BIFT? If you don’t, the remote failure could lead to packet losses until the new main BIFT is used. If you do, you only get FRR protection for nbr X for 1ms.

Jeffrey

From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of Huaimo Chen
Sent: Thursday, March 25, 2021 5:06 PM
To: Tony Przygienda <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: BIER WG <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

[External Email. Be cautious of content]

Hi Everyone,

    Michael, Steffan, Huaimo and Mike met to discuss the merge and we are in agreement that if draft-chen-bier-frr is adopted we will expand it to include a framework along with the tunnel and LFA based solutions.

Best Regards,
Huaimo
________________________________
From: BIER <[email-masked]<mailto:[email-masked]>> on behalf of Tony Przygienda <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 16, 2021 6:08 AM
To: zhang.zheng <[email-masked]<mailto:[email-masked]>>
Cc: BIER WG <[email-masked]<mailto:[email-masked]>>; BIER WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] WG adoption call for draft-chen-bier-frr-02

+1

I think it's a good addition within the architecture for the case IGP is not used for signalling, e.g. when controller or static programming.

The draft must however explain in what scenarios it is used and quote the according IGP drafts to guarantee loop-free behavior (well, BIER will tie-break loops but we'll have 1x microloop & possibly not deliver payload if BIER FRR is not properly computed/intsalled). With that the draft should also pay attention to how the function is deployed/updated network-wide if IGP is not present

thanks

-- tony

On Tue, Mar 16, 2021 at 7:41 AM <[email-masked]<mailto:[email-masked]>> wrote:

A 2-week WG adoption call begins for the following draft:

https://datatracker.ietf.org/doc/draft-chen-bier-frr/<https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=DiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F$>

Please indicate your support or objection by March 30th, 2021.

Authors, please respond to the list indicating whether you are aware of any IPR that applies to this draft.

Thanks,

Sandy (As WG secretary, on behalf of Greg/Tony)

Juniper Business Use Only

---

From: Greg Shepherd <[email-masked]>
Date: Thu, 1 Apr 2021 10:38:26 -0700

BIER WG,

>From my chair, there is clear WG consensus to merge the two drafts:

We will have an adoption call on the new draft once published. The name of
the new draft isn't all that important, other than it should
accurately reflect the content of the draft. The author's name gets dropped
once adopted anyway, so I'm not certain why there would be concern for
who's 'taking' who's work. Especially since the discussion and
documentation of the described mechanisms have a history in the WG:

   1. When draft-chen was first presented, it was pointed out that
   draft-merling was already there:
   http://www.youtube.com/watch?v=AuzdpgePomA&t=33m51s and it was suggested
   to have a combined draft.
   2. While draft-merling does not talk about LFA based, the authors and
   some vendors/operators discussed  LFA based FRR back in 2019.  Michael
   mentioned it in this email
   https://mailarchive.ietf.org/arch/msg/bier/VRYfB7S7g7xuooIwV9XQDAW56hU/,
   and it was already covered in their paper
   https://atlas.informatik.uni-tuebingen.de/~menth/papers/Menth20c.pdf
   (the link was in that email as well).

Considering this history, the honest approach would be to submit the
combined draft as a new submission.

This new draft should be as all inclusive as possible of the FRR mechanisms
for BIER. If there is nothing documented on the wire then the draft should
be Informational. And as an Informational draft on FRR for BIER, there
needs to be a section on how the BIER architecture relies on unicast
reachability; ie, BFIB is built from the UFIB, and any FRR mechanism for
unicast will be inherited by BIER. Then the case, and mechanisms described
for non-IGP based BFIB will have context, and the draft will be a one-stop,
comprehensive Informational document on BIER-FRR.

The recommendation to have Jeffrey hold the pen as Editor, was rooted in
this expectation of a comprehensive draft. And to date, only Jeffrey Zhang
and Greg Mirsky have constantly expressed this same goal of including a
section documenting current IGP-based FRR mechanisms inherited by BIER. I
have not discussed this with Greg, but I'm putting his name out there as
another potential Editor/Author to assist in meeting the WG goals of a
comprehensive draft. Pick one or not (if they are willing to help..), the
WG goals for the draft remain.

Eventually the Authors' list will need to be edited, but that is not
required for adoption, of course. Again, pick now, or pick later. It will
be up to the list of combined Authors to decide who stays at the top. The
recommendation to keep the Authors' names at the top from filling the page
should be nothing new to anyone who has gone through the draft->publish
process in the IETF.

I hope this clarifies the recommended direction for this work and these
drafts. Thank you all for staying engaged and contributing to the process.

Cheers,
Shep
(Chairs)

On Tue, Mar 30, 2021 at 9:10 AM Greg Shepherd <[email-masked]> wrote:

> I agree with Jeffrey. The two drafts should be merged into a new draft,
> which we will then call to adopt. I suggest that the authors of each of the
> two docs:
>
> On Mon, Mar 29, 2021 at 7:26 PM Jeffrey (Zhaohui) Zhang <
> [email-masked]> wrote:
>
>> In fact, the essence of draft-chen is the multiple per-nbr FRR BIFTs,
>> which I don’t think should be included in the merged draft at all, for the
>> following problems:
>>
>>
>>
>>    1. Scaling – we need one extra BIFT for each <neighbor, BIFT>. This
>>    not only means extra memory, but also additional processing overhead
>>    including downloading the tables to the forwarding plane.
>>    2. If two neighbors fail simultaneously yet both can be protected by
>>    a 3rd neighbor, per-nbr FRR BIFTs can only give protection for one of
>>    the first two neighbors. This is not an unusual situation – you could have
>>    two neighbors reached by the same link or the same line card, and the
>>    link/card fails.
>> Does that mean for each computation, you need to know and mark which
>> failed neighbor that it takes care of, so that when the BIFT is sent down
>> to forwarding plane you can decide if currently used FRR-BIFT can be
>> switched back to the main BIFT?
>>
>>
>>
>>    2. At moment T+1ms a new BIFT is calculated, which takes care of a
>>    remote failure but not nbr X (nbr X is still considered up in this
>>    calculation) – would you switch FRR BIFT to the newly calculated main BIFT?
>>    If you don’t, the remote failure could lead to packet losses until the new
>>    main BIFT is used. If you do, you only get FRR protection for nbr X for 1ms.
>>
>>
>>
>> Jeffrey
>>
>>
>>
>> *From:* BIER <[email-masked]> *On Behalf Of * Huaimo Chen
>> *Sent:* Thursday, March 25, 2021 5:06 PM
>> *To:* Tony Przygienda <[email-masked]>; [email-masked] <
>> [email-masked]>
>> *Cc:* BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
>> *Subject:* Re: [Bier] WG adoption call for draft-chen-bier-frr-02
>>
>>
>>
>> *[External Email. Be cautious of content]*
>>
>>
>>
>> Hi Everyone,
>>
>>
>>
>>     Michael, Steffan, Huaimo and Mike met to discuss the merge and we are
>> in agreement that if draft-chen-bier-frr is adopted we will expand it to
>> include a framework along with the tunnel and LFA based solutions.
>>
>>
>>
>> Best Regards,
>>
>> Huaimo
>> ------------------------------
>>
>> *From:* BIER <[email-masked]> on behalf of Tony Przygienda <
>> [email-masked]>
>> *Sent:* Tuesday, March 16, 2021 6:08 AM
>> *To:* zhang.zheng <[email-masked]>
>> *Cc:* BIER WG <[email-masked]>; BIER WG Chairs <[email-masked]>
>> *Subject:* Re: [Bier] WG adoption call for draft-chen-bier-frr-02
>>
>>
>>
>> +1
>>
>>
>>
>> I think it's a good addition within the architecture for the case IGP is
>> not used for signalling, e.g. when controller or static programming.
>>
>>
>>
>> The draft must however explain in what scenarios it is used and quote the
>> according IGP drafts to guarantee loop-free behavior (well, BIER will
>> tie-break loops but we'll have 1x microloop & possibly not deliver payload
>> if BIER FRR is not properly computed/intsalled). With that the draft should
>> also pay attention to how the function is deployed/updated network-wide if
>> IGP is not present
>>
>>
>>
>> thanks
>>
>>
>>
>> -- tony
>>
>>
>>
>> On Tue, Mar 16, 2021 at 7:41 AM <[email-masked]> wrote:
>>
>> https://datatracker.ietf.org/doc/draft-chen-bier-frr/
>> <https://urldefense.com/v3/__https:/nam11.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-chen-bier-frr*2F&data=04*7C01*7Chuaimo.chen*40futurewei.com*7C79ac63710b47427a558d08d8e8638df2*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C1*7C637514861570555970*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=DiHvux0ZUYEJru10lVQ4mXvpYx3l8ujGInm7uEjjxTw*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!NEt6yMaO-gk!TtAnkZJhg9BEJjANzO6CusX7i7eQqvTJHdhaH0qrrPdtcykRPrUybhZeavPA3X4F$>
>>