Subject: [Bier] I-D Action: draft-ietf-bier-te-arch-12.txt

From: [email-masked]
Date: Fri, 28 Jan 2022 08:56:59 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Bit Indexed Explicit Replication WG of the IETF.

        Title           : Tree Engineering for Bit Index Explicit Replication (BIER-TE)
        Authors         : Toerless Eckert
                          Michael Menth
                          Gregory Cauchie
	Filename        : draft-ietf-bier-te-arch-12.txt
	Pages           : 67
	Date            : 2022-01-28

Abstract:
   This memo describes per-packet stateless strict and loose path
   steered replication and forwarding for "Bit Index Explicit
   Replication" (BIER, RFC8279) packets.  It is called BIER Tree
   Engineering (BIER-TE) and is intended to be used as the path steering
   mechanism for Traffic Engineering with BIER.

   BIER-TE introduces a new semantic for "bit positions" (BP).  They
   indicate adjacencies of the network topology, as opposed to (non-TE)
   BIER in which BPs indicate "Bit-Forwarding Egress Routers" (BFER).  A
   BIER-TE packets BitString therefore indicates the edges of the (loop-
   free) tree that the packet is forwarded across by BIER-TE.  BIER-TE
   can leverage BIER forwarding engines with little changes.  Co-
   existence of BIER and BIER-TE forwarding in the same domain is
   possible, for example by using separate BIER "sub-domains" (SDs).
   Except for the optional routed adjacencies, BIER-TE does not require
   a BIER routing underlay, and can therefore operate without depending
   on an "Interior Gateway Routing protocol" (IGP).

   As it operates on the same per-packet stateless forwarding
   principles, BIER-TE can also be a good fit to support multicast path
   steering in "Segment Routing" (SR) networks.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-bier-te-arch/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-bier-te-arch-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-bier-te-arch-12

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 28 Jan 2022 18:17:03 +0100

This -12 revision of the draft should incooperate fixes for all IESG and directorate reviews.
Hopefully i have missed no reviewers reply. If you did provide a reply that you expect
feedback from and you don't see your name listed in aknowledgement and/or didn't receive
a reply to your email, pls. yell here!

Thanks a lot for all reviews & comments!

Toerless