Subject: Re: [Bier] WGLC: draft-ietf-bier-ospfv3-extensions

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Sat, 8 Jan 2022 02:06:12 +0000

Hi Peter,

To follow up on our offline discussions, we agreed that routers MAY do the optimizations listed below. Perhaps new text can be introduced in the next revision?

Thanks.
Jeffrey

From: Jeffrey (Zhaohui) Zhang
Sent: Tuesday, December 7, 2021 9:14 AM
To: Peter Psenak <[email-masked]>; BIER WG <[email-masked]>
Subject: RE: [Bier] WGLC: draft-ietf-bier-ospfv3-extensions

Hi Peter,

Sorry it’s a bit late but let me put it here anyway.

Without considering BIER, for LFA and TI-LFA, would we ever FRR or tunnel beyond area borders?

If the answer is no, then the inter-area redistribution could be simplified/reduced:

  *   BIER encapsulation information do not seem to be needed beyond the area border
  *   Prefixes for transit BFRs (those w/o non-zero BFR-IDs) do not need to be redistributed with BIER sub-TLV at all

I think the second optimization is especially more important.

Thanks.
Jeffrey

From: BIER <[email-masked]<mailto:[email-masked]>> On Behalf Of Greg Shepherd
Sent: Monday, November 22, 2021 11:50 AM
To: BIER WG <[email-masked]<mailto:[email-masked]>>
Subject: [Bier] WGLC: draft-ietf-bier-ospfv3-extensions

[External Email. Be cautious of content]

This email begins a 2 week WGLC for draft-ietf-bier-ospfv3-extensions. Please read and respond with/without your support:

https://datatracker.ietf.org/doc/draft-ietf-bier-ospfv3-extensions/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bier-ospfv3-extensions/__;!!NEt6yMaO-gk!WHYwedbYdxD9GRq-rJxLHBKsgw5Yv17kWGspsAcOZFz359K8WQ4QWPEHE1G68IUe$>

We will also need a doc Shepherd to progress this work.

Thanks,
- Shep
(Chairs)

Juniper Business Use Only

---

From: Peter Psenak <[email-masked]>
Date: Mon, 10 Jan 2022 08:42:20 +0100

Hi Jeffrey,

On 08/01/2022 03:06, Jeffrey (Zhaohui) Zhang wrote:
> Hi Peter,
> 
> To follow up on our offline discussions, we agreed that routers MAY do 
> the optimizations listed below. Perhaps new text can be introduced in 
> the next revision?

sure, but I do not own the pen.

thanks,
Peter

> 
> Thanks.
> Jeffrey
> 
> *From:* Jeffrey (Zhaohui) Zhang
> *Sent:* Tuesday, December 7, 2021 9:14 AM
> *To:* Peter Psenak <[email-masked]>; BIER WG <[email-masked]>
> *Subject:* RE: [Bier] WGLC: draft-ietf-bier-ospfv3-extensions
> 
> Hi Peter,
> 
>   * Prefixes for transit BFRs (those w/o non-zero BFR-IDs) do not need
>     to be redistributed with BIER sub-TLV at all
> 
> *From:* BIER <[email-masked] <mailto:[email-masked]>> *On 
> Behalf Of *Greg Shepherd
> *Sent:* Monday, November 22, 2021 11:50 AM
> *To:* BIER WG <[email-masked] <mailto:[email-masked]>>
> *Subject:* [Bier] WGLC: draft-ietf-bier-ospfv3-extensions
> 
> *[External Email. Be cautious of content]*
> 
> This email begins a 2 week WGLC for draft-ietf-bier-ospfv3-extensions. 
> Please read and respond with/without your support:
> 
> https://datatracker.ietf.org/doc/draft-ietf-bier-ospfv3-extensions/ 
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-bier-ospfv3-extensions/__;!!NEt6yMaO-gk!WHYwedbYdxD9GRq-rJxLHBKsgw5Yv17kWGspsAcOZFz359K8WQ4QWPEHE1G68IUe$>
>