Subject: [BLISS] Minutes from MLA meeting:08.02.12

From: Shida Schubert <[email-masked]>
Date: Thu, 14 Feb 2008 11:43:41 -0800

I have attached the minutes from MLA design team meeting
we had on Tuesday.

Date/Time:
-------------------------------------------------
2008.02.12 08:00-09:00 PST

Attendees:
-------------------------------------------------
Alan Johnston
Andy Hutton
Bill Mitchell
Derek McDonald
Martin Dolly
Michael Proctor
Raj Jain
Shida Schubert

Agenda:
-------------------------------------------------
1. Consultation Hold
2. State reconciliation
3. Race-conditions
4. Interop with normal UA
5. Action Items
6. Next Meeting

Discussion:
-------------------------------------------------

*1. Consultation Hold/Call **********************

- Wants to avoid allocation of another appearance or
 seizing of appearance when doing a consultation hold/call
 on dialog that has appearance number assigned. Rather
 want to re-use the already assigned appearance.

- Questions: 2 calls are associated with the appearance?
  >> Yes.

- I think the requirement is to have appearance within
 an appearance.
  >> If the UA is capable managing appearance on its own,
     it's not a problem. Don't see it impacts the draft.

- Having the ability of a UA to change the dialog associated with
 an appearance it has been assigned, would it be the requirement that
 would address this?
  >> No comment

- It's a single line sharing, and it has nothing to do
 with multiple appearance.

- May be text needs to be added on how single line
 sharing needs no further extension.

- Andy will re-attempt to address the use-cases, which
 will show how it affects the multiple appearances.

*2. Race Condition **********************************
- Debate about the INVITE Join race condition.
 >> Alan will look at the case where conference
  bridge is in the picture.

- What to do if an entity doesn't support INVITE/Replaces?
 >> If Replaces is not supported use 3PCC.
 >> Debate about the complexity.
 >> Alan expressed he wants to look at Join instead of
   Replaces.
 >> Debate, many disinclined to look further.
 Conclusion: Will mandate far end (Carol) to support Replaces,
    and tackle the race condition when using Replaces
    on the list.

*3. State Reconcilliation ****************************

- Discussion about adding a new requirement.
  Should be able to allow the appearance agent to
  assign an alternate appearance if appearance requested
  is not available.
- Following appearance assignment request comes to mind.
  >> Give me any
  >> Give me the one requested, if not available, you pick.
  >> Give me the one requested or nothing.
  >> Give me appearance within the range(1-5 etc).
- Seems to need more flexibility than simple range.
 >> SUBSCRIBE + filter ?
- No one opposed to the requirement.
- Do we want single mechanism to support all of them?
 - Many agreed. >> Need to see if it's possible.

*4. Use of term proxy in the draft. *******************
- Proxy in the draft is asked to more than RFC 3261, if additional
 functionality is necessary, AA should be the one to take on.
- What to do about UA that supports all the primitives but doesn't
 understand the appearance number.
 >> No conclusion.
- Section 7 has many open issues, need to read and discuss.

*5. Action Items **************************************
1) Andy will submit another use-case about consultation-hold/call
  in conjunction with multiple appearance.
2) Alan will look at the race-condition when conference bridge
  is in the picture and submit comments to the list.
3) Text needs to be added about mandating far end to support
  Replaces or call take/pickup will fail
4) Continue the discussion about the race conditions on the list.
5) New requirement about appearance assignment needs to be
  considered and added to the draft.
6) Single solution to address all 4 cases of appearance assignment
  should be contemplated.
7) Clarification of term proxy in the draft needs to be
  clarified or restated(the draft imposes more than RFC 3261).
8) Everybody reads section 7 and comment.
9) Alan will update the draft before next week's call.

*6. Next Meeting **************************************
Feb 19th, 08:00-09:00 PST.
_______________________________________________
BLISS mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/bliss

---

From: "Chaney, Charles (SNL US)" <[email-masked]>
Date: Wed, 20 Feb 2008 04:41:42 -0800

Hi,

Can you tell me where I can find the MLA draft work (draft) as its not
on the Bliss status pages? 

Thanks
Chuck Chaney 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of ext Shida Schubert
> Sent: Thursday, February 14, 2008 2:44 PM
> To: [email-masked]
> Subject: [BLISS] Minutes from MLA meeting:08.02.12
> 
>

---

From: Alan Johnston <[email-masked]>
Date: Wed, 20 Feb 2008 08:54:52 -0600

Chuck,

The new version of the draft will be available Monday.  Here is the 
older version of the draft:

     http://tools.ietf.org/html/draft-johnston-bliss-mla-req

The updated draft will include text from:

     http://tools.ietf.org/html/draft-anil-sipping-bla-04

Thanks,
Alan