Subject: [BLISS] Initial ringtones for draft-alexeitsev-bliss-alert-info-urns

From: Adam Roach <[email-masked]>
Date: Tue, 28 Jul 2009 14:30:20 +0200

There are a number of additional tones that are probably worth
considering as part of the initial set of symbols. If you look at
TIA/EIA-41-D and 3GPP2 A.S0014, you'll find quite a few tone
designations that are used in other standards.

A.S0014 defines:

   1. Normal Alerting
   2. Inter-group Alerting
   3. Special/Priority Alerting
   4. Ping Ring (abbreviated alert)
   5. Abbreviated intercept
   6. Abbreviated reorder

I think #1 and #4 are covered in the current document, but the others
aren't clearly represented.

If you throw in the TIA/EIA values, you also have things like:

   1. Long (Normal)
   2. Short-Short
   3. Short-Short-Long
   4. Short-Short2
   5. Short-Long-Short
   6. Short-Short-Short-Short
   7. PBX Long (Normal)
   8. PBX Short-Short
   9. PBX Short-Short-Long
  10. PBX Short-Long-Short
  11. PBX Short-Short-Short-Short

Additionally, A.S0014 allows indication of pitch (high, normal, low) as
part of the ringtone designation. It would be nice if we could tack this
pitch data on to the end of the existing tokens (e.g.,
"normal.short.low"). I note that this points to a combinatorial
explosion of IANA values -- perhaps we need to re-think how we're
representing the registry.

/a

---

From: <[email-masked]>
Date: Tue, 28 Jul 2009 17:59:22 +0200

Adam,

The intent of the draft is to provide a general mechanism, to register the template and to do initial registration for tones and service tones which we know that people intend to use now and have interoperability problems. I don't think we should now register every tone in every national specification, which possible nobbody intends to use.  
If, over time, people need additional tones or service tones, they can use the general mechanism and template are free to register their own tones.  

Or do you see a problem with this approach?

Thanks a lot
Laura

Mit freundlichen Grüßen
Laura Liess

Deutsche Telekom Netzproduktion GmbH 
Zentrum Technik Einführung 
Laura Liess 
Heinrich-Hertz-Straße 3-7, 64295 Darmstadt 
+49 6151 628-2761 (Tel.) 
+49 6151 628-3395 (Fax) 
+49 175 2961015 (Mobil) 
[email-masked] (E-mail)
http://www.telekom.com 

Deutsche Telekom Netzproduktion GmbH 
Aufsichtsrat: Timotheus Höttges (Vorsitzender) 
Geschäftsführung: Dr. Bruno Jacobfeuerborn (Vorsitzender), Albert Matheis, Klaus Peren 
Handelsregister: Amtsgericht Bonn HRB 14190 
Sitz der Gesellschaft: Bonn 
USt-IdNr.: DE 814645262

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Adam Roach
> Sent: Tuesday, July 28, 2009 2:30 PM
> To: [email-masked]
> Subject: [BLISS] Initial ringtones for 
> draft-alexeitsev-bliss-alert-info-urns
> 
> _______________________________________________
> BLISS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bliss
>

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 29 Jul 2009 06:49:59 -0500

It seems to me that if a specific national body requires the use
of national-specific ringback tones, they would then have to register
their own URN space for it.

Hopefully we wouldn't go that route, but the option is definitively
there if required. 

> On Behalf Of [email-masked]
> Sent: Tuesday, July 28, 2009 08:59
> To: [email-masked]; [email-masked]
> Subject: Re: [BLISS] Initial ringtones 
> fordraft-alexeitsev-bliss-alert-info-urns
> 
> Adam,
> 
> The intent of the draft is to provide a general mechanism, to 
> register the template and to do initial registration for 
> tones and service tones which we know that people intend to 
> use now and have interoperability problems. I don't think we 
> should now register every tone in every national 
> specification, which possible nobbody intends to use.  
> If, over time, people need additional tones or service tones, 
> they can use the general mechanism and template are free to 
> register their own tones.  
> 
> Handelsregister: Amtsgericht Bonn HRB 14190 Sitz der 
> Gesellschaft: Bonn
> USt-IdNr.: DE 814645262
> 
>  
> 
> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Adam Roach
> > Additionally, A.S0014 allows indication of pitch (high, 
> normal, low) 
> > as part of the ringtone designation. It would be nice if we 
> could tack 
> > this pitch data on to the end of the existing tokens (e.g.,

---

From: <[email-masked]>
Date: Thu, 30 Jul 2009 11:25:56 +0200

Francois,

They would have to use the alredy registered alert urn template and to register new alert-URN indications for "tone" or "service" , e.g. internal.short-short-short. It's a similar process as for the Emergency Service URN (5031). 

My personal opinion is that many of the tones defined in national documents will be not longer used when PSTN moves to VoIP. 

Regards
Laura

> From: Francois Audet [mailto:[email-masked]] 
> Sent: Wednesday, July 29, 2009 1:50 PM
> To: Liess, Laura; [email-masked]; [email-masked]
> Subject: RE: [BLISS] Initial ringtones

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 30 Jul 2009 14:49:17 +0100

We should at least try to avoid having two or more URNs with the same semantics, coming from different countries. Furthermore, we should try to register names that reflect the meaning, rather than the representation, of a tone, so that it can be rendered in the appropriate way for the locale concerned. For example "internal.short-short-short" tells me nothing about the meaning (other than that it is internal). If it is intended to denote three short bursts of tone, this could convey different meanings (or confusion) to a user outside the locale where it originated.

John

> Sent: 30 July 2009 10:26
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [BLISS] Initial 
> ringtonesfordraft-alexeitsev-bliss-alert-info-urns
> 
> 
> Francois,
> 
> They would have to use the alredy registered alert urn 
> template and to register new alert-URN indications for "tone" 
> or "service" , e.g. internal.short-short-short. It's a 
> similar process as for the Emergency Service URN (5031). 
> 
> My personal opinion is that many of the tones defined in 
> national documents will be not longer used when PSTN moves to VoIP. 
> 
> Regards
> Laura
> 
> 
> 
>