Subject: Re: [BLISS] WGLC for draft-ietf-bliss-call-completion-07 -- 2007 Requirement in 6.1, 6.2

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 28 Oct 2010 20:58:18 -0400

In section 6.1 is "The caller's agent MUST record the From URI and MAY
record ...".  I think we want "... and SHOULD record ...", as that
recording will increase the chance of successful operation.

In section 6.2 is " The caller's agent MAY add an 'm' parameter to
these URIs."  I think this should be "... SHOULD add ...", as that
will increase the chance of successful operation (and all envisioned
applications will be able to do this).

Dale

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 29 Oct 2010 14:56:45 +0200

There are enough "SHOULD" statements in this document already. Before creating any more I think we need a more detailed discussion of the effect.

Lets start with the maxim that every "SHOULD" should be followed by a sentence that states the cases or situations where we would consider it either possible or impossible to ignore the requirements.

And we also need to look for cases where we really mean "If <case> then xxxx MUST..."

regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Worley, Dale R (Dale)
> Sent: Friday, October 29, 2010 1:58 AM
> To: Shida Schubert; BLISS
> Subject: Re: [BLISS] WGLC for 
> draft-ietf-bliss-call-completion-07 -- 2007 Requirement in 6.1, 6.2
> 
> In section 6.1 is "The caller's agent MUST record the From 
> URI and MAY record ...".  I think we want "... and SHOULD 
> record ...", as that recording will increase the chance of 
> successful operation.
> 
> In section 6.2 is " The caller's agent MAY add an 'm' 
> parameter to these URIs."  I think this should be "... SHOULD 
> add ...", as that will increase the chance of successful 
> operation (and all envisioned applications will be able to do this).
> 
> Dale
> _______________________________________________
> BLISS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bliss
>