Subject: [Blockchain-interop] Cactus vs ODAP

From: Michael McBride <[email-masked]>
Date: Tue, 2 Nov 2021 16:43:20 +0000

Hello all,

Has anyone compared HL Cactus and ODAP? I'm on an IEEE call right now discussing interop and I mentioned ODAP to them. It would be helpful to have a comparison. If one doesn't exist I may give it a go.

Thanks,
mike

---

From: Rafael Belchior <[email-masked]>
Date: Tue, 02 Nov 2021 20:30:15 +0000

Hello Mike, 

Cactus is concerned with the technological infrastructure (technical
layer) that supports business logic. It implements software that can
utilize blockchains (i.e., the connectors). ODAP is a protocol (running
at the semantic layer) that can benefit from Cactus as an
infrastructure. For more info on the layers, check Figure 3, page 8 of
https://arxiv.org/pdf/2005.14282.pdf.  

In short, ODAP can be built on top of Cactus, which in fact is being
done: https://github.com/hyperledger/cactus/pull/1275 

There is also a Hyperledger blog post comparing Cactus to other
interoperability projects that can shed some light on Cactus'
capabilities.   

Cheers, 

Rafael 

-- 
-- Rafael Belchior 

Ph.D. student in Computer Science and Engineering, Blockchain - Técnico
Lisboa
https://rafaelapb.github.io/
https://www.linkedin.com/in/rafaelpbelchior/

---

From: Michael McBride <[email-masked]>
Date: Wed, 3 Nov 2021 22:32:55 +0000

This is extremely helpful, thank you Rafael.

mike

From: Rafael Belchior <[email-masked]>
Sent: Tuesday, November 02, 2021 1:30 PM
To: Michael McBride <[email-masked]>
Cc: [email-masked]
Subject: Re: [Blockchain-interop] Cactus vs ODAP

Hello Mike,

Cactus is concerned with the technological infrastructure (technical layer) that supports business logic. It implements software that can utilize blockchains (i.e., the connectors). ODAP is a protocol (running at the semantic layer) that can benefit from Cactus as an infrastructure. For more info on the layers, check Figure 3, page 8 of https://arxiv.org/pdf/2005.14282.pdf<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Farxiv.org%2Fpdf%2F2005.14282.pdf&data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C29f58ce9b9fe4aac534a08d99e3f977a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637714818236121216%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=gYRe8gky9ydlL0J1X%2FCU59TYiR5JyBK7yPOtZMpI%2Bs4%3D&reserved=0>.

In short, ODAP can be built on top of Cactus, which in fact is being done: https://github.com/hyperledger/cactus/pull/1275<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fhyperledger%2Fcactus%2Fpull%2F1275&data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C29f58ce9b9fe4aac534a08d99e3f977a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637714818236131303%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=0fVor1Igf5enyCFYQdSFvYY214aN4yFrncD2NK8oIFY%3D&reserved=0>

There is also a Hyperledger blog post comparing Cactus to other interoperability projects that can shed some light on Cactus' capabilities.

Cheers,

Rafael

Thanks,
mike

--
-- Rafael Belchior

Ph.D. student in Computer Science and Engineering, Blockchain - Técnico Lisboa
https://rafaelapb.github.io/
https://www.linkedin.com/in/rafaelpbelchior/