Subject: Re: [Blockchain-interop] [saag] IETF112 Side Meeting on DLT Gateway Interop protocol

From: Michael Richardson <[email-masked]>
Date: Mon, 01 Nov 2021 10:15:41 -0400

Have you seen, btw, that MATTER is using a ledger for distribution of
Endorsements for their remote attestation system?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Thomas Hardjono <[email-masked]>
Date: Mon, 1 Nov 2021 16:13:57 +0000

Hi Michael,

I have not heard about Matter specifically, but there has been some discussion in the TCG and the Global Semiconductor Alliance of using a DLT to help validate endorsements from the manufacturers.

In context of RATS WG and Endorsements, the challenge is not just about validating signatures over SBOM files and firmware/software files,  but also ensuring that "integrity measurements" for specific hardwares (e.g. TPM PCRs) are correct.

BTW. Here is a link to a presentation from Intel about using DLTs for Endorsements (I think there is also al older RSA and NIST presentations):

https://trustedcomputinggroup.org/wp-content/uploads/Session-3-TSC-Intel-JRF-WS2020_RV.pdf

--thomas

________________________________________
From: Michael Richardson [[email-masked]]
Sent: Monday, November 1, 2021 10:15 AM
To: Thomas Hardjono
Cc: [email-masked]; [email-masked]; [email-masked]; Martin Hargreaves
Subject: Re: [saag] IETF112 Side Meeting on DLT Gateway Interop protocol

---

From: Thomas Hardjono <[email-masked]>
Date: Thu, 11 Nov 2021 15:19:23 +0000

Folks,

Just a reminder of Friday's Side-Meeting on DLT Gateways, and a minor correction to the Zoom information.

We will be observing the IETF rules on Public Side Meetings and the IETF IPR Rules (Note Well slide). 

https://www.ietf.org/how/meetings/side-meetings/

-- The meeting will not be recorded.

-- No attendance registration required (i.e. no blue sheet).

https://trac.ietf.org/trac/ietf/meeting/wiki/112sidemeetings

Here are the logistics of the meeting:

(a) Name of group:  DLT Gateway Interop protocol

(b) Date: Friday 12 November 2021.

(c) Time:  16:00 PM UTC/London (shortly after RATS WG).

(d) Duration:  2 hours.

(e) Zoom link: https://bit.ly/3C1Jshc

(f) Zoom Meeting ID: 875 3224 7380.

(g) Meeting Material (GitHub):  https://bit.ly/3c4Ajtv

(h) Mailing-list:  https://www.ietf.org/mailman/listinfo/blockchain-interop

Best

Martin Hargreaves
Thomas Hardjono

________________________________________
From: Thomas Hardjono
Sent: Sunday, October 31, 2021 10:15 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Martin Hargreaves
Subject: IETF112 Side Meeting on DLT Gateway Interop protocol

Folks,

We are planning to have a public Side Meeting at the coming IETF112 to report on the work we have been conducting in the group over the past year (since our introduction to the problem scope in SecDispath in IETF109).

We have tried to select a time-slot that does not conflict with any SEC Area working group meetings.

https://trac.ietf.org/trac/ietf/meeting/wiki/112sidemeetings

The details of Side Meeting is as follows:

(a) Name of group:  DLT Gateway Interop protocol

(b) Date: Friday 12 November.

(c) Time:  16:00 PM UTC/London (shortly after RATS WG)

(d) Duration:  2 hours.

(e) The zoom information is here:  https://bit.ly/3mjvDWF

The preliminary reading is here:

-- https://datatracker.ietf.org/doc/draft-hardjono-blockchain-interop-arch/

-- https://datatracker.ietf.org/doc/draft-hargreaves-odap/

-- The IETF109 slides defining problem-scope is here: https://bit.ly/3GDHqXU

Looking forward to getting your inputs and to a great discussion.

Best

Martin Hargreaves
Thomas Hardjono

---

From: "Dirk Kutscher" <[email-masked]>
Date: Fri, 12 Nov 2021 19:32:56 +0100

Michael,

do you have a pointer?

Thanks,
Dirk

On 1 Nov 2021, at 15:15, Michael Richardson wrote:

> _______________________________________________
> Din mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/din

---

From: Michael Richardson <[email-masked]>
Date: Fri, 12 Nov 2021 18:48:06 -0500

> do you have a pointer?

MATTER has not yet released their document.
There are presentations at IOTOPS (last IETF), and a few things on youtube.