Subject: RE: [bmwg] Updates to MPLS Protection Meth/Term draft- Request forcomments/review

From: <[email-masked]>
Date: Fri, 9 Mar 2007 12:16:03 +0800

I'd like to comment on the questions posed below.
 
Using accurate packet timestamping mechanisms it is feasible to measure data plane convergence much more accurately, modern measurement tools have timestamp resolution down to 10ns resolution. When using packet timestamps, the resolution and accuracy of a convergence or switchover measurement will be mostly limited by the packet frequency on the link. 1,000,000 packets per sec will provide a resolution of 1us for a data plane convergence measurement if packet timestamps are used, requiring about 50% of a GbE link's available bandwidth. 
 
I believe 1ms is an appropriate sampling interval for data plane switchover and convergence tests. This is feasible in most scenarios, and better matches the high availability expectations of modern services.
 
Regards,
Cary Wright
 
________________________________

*	To: <bmwg at ietf.org <mailto:[email-masked]> > 
*	Subject: RE: [bmwg] Updates to MPLS Protection Meth/Term draft- Request forcomments/review 
*	From: "Samir Vapiwala \(svapiwal\)" <svapiwal at cisco.com <mailto:[email-masked]> > 
*	Date: Thu, 8 Mar 2007 09:28:28 -0500 
 
Further to Rajiv's earlier email we as MPLS Protection benchmarking Author team would like to seek input to the following unaddressed items on the mailing list so that we can get closure on these open items prior to the BMWG meeting:
 
 Since the packet smapling interval recommended in the "draft-ietf-bmwg-igp-dataplane-conv-meth-12.txt,  section 3.2.5 Convergence Time Metrics" may not be applicable to the MPLS FRR scenario where failover times have to be below 45ms, here are some of our thoughts or questions to the list: 

1.	We would like to adapt similar approach the IGP convergence as this defiinition applies to current work item 
2.	We feel that 100ms is large for MPLS FRR application, under which the target is always keeping the failover times below 45ms. 
3.	We are considering changing this number to 10ms, and would expect test tool to offer this smapling interval

Please provide your input to this suggested value so that we can have a conclusion before the next meeting.

Regards,
 
MPLS Protection Benchmarking Author Team
 
_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: "Jay Karthik \(jakarthi\)" <[email-masked]>
Date: Fri, 9 Mar 2007 21:55:53 -0500

Thanks Cary. 

1 ms sounds like a reasonable sampling interval for MPLS Protection
Benchmarking. Let's get a consensus on whether this interval is adequate
or too aggressive for a 'Testing Tool' from others on the list as well.
We'll include this question as an open issue for the presentation in
Prague and request feedback from the working group.

Cheers,
Jay  

	From: [email-masked] [mailto:[email-masked]] 
	Sent: Thursday, March 08, 2007 11:16 PM
	To: [email-masked]
	Subject: RE: [bmwg] Updates to MPLS Protection Meth/Term draft-
Requestforcomments/review 

	Using accurate packet timestamping mechanisms it is feasible to
measure data plane convergence much more accurately, modern measurement
tools have timestamp resolution down to 10ns resolution. When using
packet timestamps, the resolution and accuracy of a convergence or
switchover measurement will be mostly limited by the packet frequency on
the link. 1,000,000 packets per sec will provide a resolution of 1us for
a data plane convergence measurement if packet timestamps are used,
requiring about 50% of a GbE link's available bandwidth. 
	 
	I believe 1ms is an appropriate sampling interval for data plane
switchover and convergence tests. This is feasible in most scenarios,
and better matches the high availability expectations of modern
services.
	 
	Regards,
	Cary Wright

			*	To: <bmwg at ietf.org
<mailto:[email-masked]> > 
	*	Subject: RE: [bmwg] Updates to MPLS Protection Meth/Term
draft- Request forcomments/review 
	*	From: "Samir Vapiwala \(svapiwal\)" <svapiwal at
cisco.com <mailto:[email-masked]> > 
	*	Date: Thu, 8 Mar 2007 09:28:28 -0500 
	 
	Further to Rajiv's earlier email we as MPLS Protection
benchmarking Author team would like to seek input to the following
unaddressed items on the mailing list so that we can get closure on
these open items prior to the BMWG meeting:
	 
	 Since the packet smapling interval recommended in the
"draft-ietf-bmwg-igp-dataplane-conv-meth-12.txt,  section 3.2.5
Convergence Time Metrics" may not be applicable to the MPLS FRR scenario
where failover times have to be below 45ms, here are some of our
thoughts or questions to the list: 

	1.	We would like to adapt similar approach the IGP
convergence as this defiinition applies to current work item 
	2.	We feel that 100ms is large for MPLS FRR application,
under which the target is always keeping the failover times below 45ms. 
	3.	We are considering changing this number to 10ms, and
would expect test tool to offer this smapling interval

	Please provide your input to this suggested value so that we can
have a conclusion before the next meeting.

	Regards,