Subject: RE: [bmwg] Updates to MPLS Protection Meth/Term draft- Request forcomments/review

From: "Samir Vapiwala \(svapiwal\)" <[email-masked]>
Date: Thu, 8 Mar 2007 09:28:28 -0500

Further to Rajiv's earlier email we as MPLS Protection benchmarking
Author team would like to seek input to the following unaddressed items
on the mailing list so that we can get closure on these open items prior
to the BMWG meeting:
 
 Since the packet smapling interval recommended in the
"draft-ietf-bmwg-igp-dataplane-conv-meth-12.txt,  section 3.2.5
Convergence Time Metrics" may not be applicable to the MPLS FRR scenario
where failover times have to be below 45ms, here are some of our
thoughts or questions to the list: 

1.	We would like to adapt similar approach the IGP convergence as
this defiinition applies to current work item 
2.	We feel that 100ms is large for MPLS FRR application, under
which the target is always keeping the failover times below 45ms. 
3.	We are considering changing this number to 10ms, and would
expect test tool to offer this smapling interval

Please provide your input to this suggested value so that we can have a
conclusion before the next meeting.

Regards,
 
MPLS Protection Benchmarking Author Team

________________________________

From: Rajiv Papneja [mailto:[email-masked]] 
Sent: Wednesday, March 07, 2007 4:58 PM
To: [email-masked]
Subject: [bmwg] Updates to MPLS Protection Meth/Term draft- Request
forcomments/review

BMWG-ers,

The updated drafts (term is still in the process of being published) for
the MPLS Protection benchmarking work item has been submitted. Please
review the drafts, and post any comments on the mailing list. I am
providing brief overview of the changes done to the latest versions by
the team in the light of comments received during the previous meeting
and subsequently:

Highlights of the latest versions:

1. draft-ietf-bmwg-protection-meth-01.txt (
http://www.ietf.org/internet-drafts/draft-ietf-bmwg-protection-meth-01.t
xt
<http://www.ietf.org/internet-drafts/draft-ietf-bmwg-protection-meth-01.
txt> )

1.	Shortened the Abstract to make it more to the point 

2.	Refined, and edited Introduction to improve the flow of the
document, and rearranged the paragraphs. 

3.	Editorial review of the entire version-00, and made changes to
the text 

4.	Deleted figure 4.9 and edited section 5.5 to reduce the number
of test cases to 2 

5.	New boilerplate changes 

6.	Attempted to address the discussion from the previous meeting -
"Duration of Failure" vs "Time taken for pakets to be switched to backup
path", and hence added 1) packet based loss method 2) Time based loss
method for computing failover times. 

     Note: We seek input from the list on recommendations for the Packet
sampling interval since section 3.2.5 of
draft-ietf-bmwg-igp-dataplane-conv-meth-12.txt suggests sampling
interval of 100ms, which for MPLS FRR scenarios is  high. 

 2. draft-itef-bmwg-protection-term-01.txt
(http://www.ietf.org/internet-drafts/draft-ietf-bmwg-protection-term-01.
txt
<http://www.ietf.org/internet-drafts/draft-ietf-bmwg-protection-term-01.
txt> ) 

  a. No major changes from the previous version

  b. new boilerplate changes 

We look forward to active discussions on the mailing list. 

Regards,

MPLS Protection Benchmarking Author Team

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: <[email-masked]>
Date: Tue, 13 Mar 2007 11:45:48 +0800

I'd like to comment on the questions posed below.
 
Using accurate packet timestamping mechanisms it is feasible to measure data plane convergence much more accurately, modern measurement tools have timestamp resolution down to 10ns resolution. When using packet timestamps, the resolution and accuracy of a convergence or switchover measurement will be mostly limited by the packet frequency on the link. 1,000,000 packets per sec will provide a resolution of 1us for a data plane convergence measurement if packet timestamps are used, requiring about 50% of a GbE link's available bandwidth. 
 
I believe 1ms is an appropriate sampling interval for data plane switchover and convergence tests. This is feasible in most scenarios, and better matches the high availability expectations of modern services.
 
Regards,
Cary Wright

*	To: <bmwg at ietf.org <mailto:[email-masked]> > 
*	Subject: RE: [bmwg] Updates to MPLS Protection Meth/Term draft- Request forcomments/review 
*	From: "Samir Vapiwala \(svapiwal\)" <svapiwal at cisco.com <mailto:[email-masked]> > 
*	Date: Thu, 8 Mar 2007 09:28:28 -0500 
 
Further to Rajiv's earlier email we as MPLS Protection benchmarking Author team would like to seek input to the following unaddressed items on the mailing list so that we can get closure on these open items prior to the BMWG meeting:
 
 Since the packet smapling interval recommended in the "draft-ietf-bmwg-igp-dataplane-conv-meth-12.txt,  section 3.2.5 Convergence Time Metrics" may not be applicable to the MPLS FRR scenario where failover times have to be below 45ms, here are some of our thoughts or questions to the list: 

1.	We would like to adapt similar approach the IGP convergence as this defiinition applies to current work item 
2.	We feel that 100ms is large for MPLS FRR application, under which the target is always keeping the failover times below 45ms. 
3.	We are considering changing this number to 10ms, and would expect test tool to offer this smapling interval

Please provide your input to this suggested value so that we can have a conclusion before the next meeting.

Regards,