Subject: [bmwg] draft-akhter-bmwg-mpls-meth-03.txt

From: "Samir Vapiwala (svapiwal)" <[email-masked]>
Date: Thu, 29 Nov 2007 11:10:37 -0500

Hi Rajiv/Aamer
 
This is good MPLS forwarding benchmarking draft which should have come
in early phases of MPLS. I do support it. 
 
There are some of cases are important for MPLS forwarding verification
as below, Let us know what is your opinion on it.
 
- You have covered most of label forwarding path, Is there any reason
you are not covering IP to IP path with mpls application such as one hop
TE tunnel, back to back PE services for L2 and L3 VPNs.
- Explicit-Null cases
- MPLS packet Fragmentation cases
- MPLS Load balancing (per packet and per destination)
- Multiple label stack up to 4, FRR protection draft covers all possible
combination of label stack
http://www.ietf.org/internet-drafts/draft-ietf-bmwg-protection-meth-02.t
xt, You may want to refer our draft 
  for test scenario and define procedure in your draft. 

26.6, What kind of Hardware and software reset type are you suggesting,
You should mention some of recommended reset types. 

Thanks
Samir
_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Thu, 29 Nov 2007 12:49:25 -0500

Hi Samir,

Thanks a lot for your support, careful review and suggestion.

This document focusses only on MPLS forwarding benchmarking independent
of MPLS applications. Another document will cover benchmarking related
to the MPLS applications such as TE tunnels, VPNs etc. This scoping very
much helps for our progress.

> - MPLS packet Fragmentation cases

The -02 version indeed included the exp-null and fragmentation cases,
but -03 version didn't on purpose. The intention was to first cover the
most common cases (based on the deployment need) and pave the way for
quicker readability and review by the WG.

We intend to add cases incrementally in forthcoming versions, based on
your feedback.

> - MPLS Load balancing (per packet and per destination)

Good suggestion. However, I didn't think that the testtool had the
ability to receive flows on different ports and still validate them. Is
that not the case?

> - Multiple label stack up to 4, FRR protection draft covers 
> all possible combination of label stack  
> http://www.ietf.org/internet-drafts/draft-ietf-bmwg-protection
> -meth-02.txt, You may want to refer our draft 

Multiple label stacks come into play with MPLS applications, hence, will
be covered in another document. Will surely refer to yours then.

> 
> 26.6, What kind of Hardware and software reset type are you 
> suggesting, You should mention some of recommended reset types. 

Good suggestion. Although RFC2544 doesn't offer any guideline on this, I
would think that the following to be inferred at minimum -

	hardware reset - RouteProcessor card resetting
	software reset - reset initiated through a CLI (e.g. reload)

We will include this clarification (as examples) in the next version of
the document.

Thanks again.

Cheers,
Rajiv 

> -----Original Message-----
> From: Samir Vapiwala (svapiwal) 
> Sent: Thursday, November 29, 2007 11:11 AM
> To: [email-masked]'; Rajiv Asati (rajiva); Aamer Akhter (aakhter)
> Subject: draft-akhter-bmwg-mpls-meth-03.txt
> 
> Hi Rajiv/Aamer
>  
> This is good MPLS forwarding benchmarking draft which should 
> have come in early phases of MPLS. I do support it. 
>  
> There are some of cases are important for MPLS forwarding 
> verification as below, Let us know what is your opinion on it.
>  
> - You have covered most of label forwarding path, Is there 
> any reason you are not covering IP to IP path with mpls 
> application such as one hop TE tunnel, back to back PE 
> services for L2 and L3 VPNs.
> - Explicit-Null cases
> - Multiple label stack up to 4, FRR protection draft covers 
> all possible combination of label stack  
> http://www.ietf.org/internet-drafts/draft-ietf-bmwg-protection
> -meth-02.txt, You may want to refer our draft 
> 26.6, What kind of Hardware and software reset type are you 
> suggesting, You should mention some of recommended reset types. 
>  
>  
> Thanks
> Samir
>

---

From: "Samir Vapiwala (svapiwal)" <[email-masked]>
Date: Thu, 29 Nov 2007 14:06:12 -0500

Hi Rajiv

See inline *Samir 

-----Original Message-----
From: Rajiv Asati (rajiva) 
Sent: Thursday, November 29, 2007 12:49 PM
To: Samir Vapiwala (svapiwal); [email-masked]'; Aamer Akhter (aakhter)
Cc: Rajiv Asati (rajiva)
Subject: RE: draft-akhter-bmwg-mpls-meth-03.txt

Hi Samir,

*Samir - I'm not sure that was right thing to do. It may not be possible
for reviewer to review every version, so it is better to add at once.

*Samir - I believe that you can aggregate 2 port at receiving end of
test tool. But in such case you may account for control plan packets
too.

Thanks
Samir

> - Multiple label stack up to 4, FRR protection draft covers all 
> possible combination of label stack 

Thanks again.

Cheers,
Rajiv 

> you are not covering IP to IP path with mpls application such as one 
> hop TE tunnel, back to back PE services for L2 and L3 VPNs.
> - Explicit-Null cases
> - Multiple label stack up to 4, FRR protection draft covers all 
> possible combination of label stack