Subject: Re: [bmwg] draft-cerveny-bmwg-ipv6-nd

From: Marius Georgescu <[email-masked]>
Date: Mon, 16 Mar 2015 12:07:28 +0900

I think this draft is a very good initiative and I support its adoption. I also have a question/comment.

I understand that the draft is targeting the ND resilience problems described by RFC6583. However, I was wondering if it wouldn’t be beneficial to add benchmarking tests that can cover the performance of some other functions of ND devices (as presented in RFC4861), such as: Duplicate Address Detection (may be very useful for mobile IPv6) or Neighbor Unreachability Detection. 

Best regards,
Marius Georgescu 

On Mar 1, 2015, at 5:55, MORTON, ALFRED C (AL) <[email-masked]> wrote:

> Hi Bill and Ron,
> 
> I made some time to read your latest update on a plane ride.
> This draft seems to have a few areas for further
> development, but otherwise in very good shape.
> 
> I attach my comments,
> Al
> (as a participant)
> 
> 
> 
> <draft-cerveny-bmwg-ipv6-nd-06review.txt>_______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg

---

From: "Marius Georgescu" <[email-masked]>
Date: Mon, 16 Mar 2015 23:13:11 +0900

Hello Bill,

Regarding DAD, I was thinking something like DAD Delay (time during which the Tentative Address is not

usable) can be considered a performance benchmark. An analytical performance study  for the most popular DAD strategies is presented in:  <http://www.researchgate.net/publication/4316259_Fast_Duplicate_Address_Detection_for_Mobile_IPv6> http://www.researchgate.net/publication/4316259_Fast_Duplicate_Address_Detection_for_Mobile_IPv6 

Best regards,

Marius Georgescu

From: Cerveny, Bill [mailto:[email-masked]] 
Sent: Monday, March 16, 2015 9:26 PM
To: Marius Georgescu
Cc: MORTON, ALFRED C (AL); [email-masked]; [email-masked]
Subject: Re: [bmwg] draft-cerveny-bmwg-ipv6-nd

Hi Marius,

Thanks for your comments. I had been reluctant to expand the scope beyond that described by RFC6583, at least partially to keep the document focused and perhaps to help expedite the document's publication. 

A question I have though ... what performance benchmarks would there be for DAD or NUD? One of the challenges we've had regarding draft-cerveny-bmwg-ipv6-nd is to confirm that the tests are reporting performance and not compliance ...

Thanks,

Bill Cerveny

On Sun, Mar 15, 2015 at 11:07 PM, Marius Georgescu <[email-masked] <mailto:[email-masked]> > wrote:

Best regards,
Marius Georgescu

> [email-masked] <mailto:[email-masked]>

---

From: "Cerveny, Bill" <[email-masked]>
Date: Mon, 16 Mar 2015 08:25:32 -0400

Hi Marius,

Thanks for your comments. I had been reluctant to expand the scope beyond
that described by RFC6583, at least partially to keep the document focused
and perhaps to help expedite the document's publication.

A question I have though ... what performance benchmarks would there be for
DAD or NUD? One of the challenges we've had regarding
draft-cerveny-bmwg-ipv6-nd is to confirm that the tests are reporting
performance and not compliance ...

Thanks,

Bill Cerveny

On Sun, Mar 15, 2015 at 11:07 PM, Marius Georgescu <
[email-masked]> wrote:

> I understand that the draft is targeting the ND resilience problems
> described by RFC6583. However, I was wondering if it wouldn’t be beneficial
> to add benchmarking tests that can cover the performance of some other
> functions of ND devices (as presented in RFC4861), such as: Duplicate
> Address Detection (may be very useful for mobile IPv6) or Neighbor
> Unreachability Detection.
>
> Best regards,
> Marius Georgescu
>

---

From: Ron Bonica <[email-masked]>
Date: Mon, 16 Mar 2015 18:39:17 +0000

Hi Marius,

I agree with both of you. OTOH, we should restrict the scope of the current draft. OTOH, it would be a very good idea to start a new draft to benchmark DAD and NUD.

                                                                                                                   Ron

From: Cerveny, Bill [mailto:[email-masked]]
Sent: Monday, March 16, 2015 8:26 AM
To: Marius Georgescu
Cc: MORTON, ALFRED C (AL); [email-masked]; [email-masked]
Subject: Re: [bmwg] draft-cerveny-bmwg-ipv6-nd

Hi Marius,

Thanks,

Bill Cerveny

On Sun, Mar 15, 2015 at 11:07 PM, Marius Georgescu <[email-masked]<mailto:[email-masked]>> wrote:
I think this draft is a very good initiative and I support its adoption. I also have a question/comment.

Best regards,
Marius Georgescu

On Mar 1, 2015, at 5:55, MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:

> [email-masked]<mailto:[email-masked]>