Subject: Re: [bmwg] draft-kishjac-bmwg-pbbevpn

From: Iftekhar Hussain <[email-masked]>
Date: Wed, 23 Nov 2016 18:39:47 +0000

Hi Sudhin,

Please see my comments in-line. cced [email-masked]<mailto:[email-masked]> and Jorge (one of the authors of the RFC7432).

From: Sudhin Jacob [mailto:[email-masked]]
Sent: Wednesday, November 23, 2016 2:53 AM
To: Iftekhar Hussain
Cc: Kishore Tiruveedhula
Subject: RE: draft-kishjac-bmwg-pbbevpn

Hi Iftekhar,

Let me thank you for the review, Kindly find the updates. May I humbly request if you  have any queries could you please include [email-masked]<mailto:[email-masked]> @ CC to capture the comments.

Regards,
Sudhin

From: Sudhin Jacob
Sent: Monday, November 21, 2016 8:09 AM
To: 'Iftekhar Hussain' <[email-masked]<mailto:[email-masked]>>
Cc: Kishore Tiruveedhula <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-kishjac-bmwg-pbbevpn

Hi Iftekhar,

Let me thank you for the comment, now the 2 drafts are combined to one as per the community request, now onwards PBB-EVPN and EVPN will be covered in the below draft.

https://datatracker.ietf.org/doc/draft-kishjac-bmwg-evpntest/

I will get back.

Regards,
Sudhin

From: Iftekhar Hussain [mailto:[email-masked]]
Sent: Monday, November 21, 2016 4:11 AM
To: Sudhin Jacob <[email-masked]<mailto:[email-masked]>>; Kishore Tiruveedhula <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-kishjac-bmwg-pbbevpn

Resend. Earlier messed failed to some MS office issues.

From: Iftekhar Hussain
Sent: Sunday, November 20, 2016 2:38 PM
To: [email-masked]'
Subject: draft-kishjac-bmwg-pbbevpn

Hi Jacob and Kishore,

It was nice meeting Jacob at the IETF97. I had a look at your draft and have following comments:

*         Why the draft scope does not explicitly mentions/includes RFC7432?
Sudhin>> it is updated in the latest combined draft.

[Iftekhar] Thanks. Please take a look at informative reference RFC7412. Is this a typo? Should it be RFC7432?

*         What is the impact on system performance (ARP memory for storing IP prefixes, lookups etc) and reliability (e.g., packet loss if any) when ARP-proxy is enabled (disabled)? Shouldn't your draft cover those metrics on reduction (or increase) in flooding
Sudhin>>  Could you please let me know if you want to add arp scaling as parameter, we will do it. The reliability section community told us not to do it, there is a section we added named convergence to check how fast the DUT converge in terms of failure.

[Iftekhar] Yes, some scaling parameter would make sense to me.

in BUM traffic due to ARP-proxy enabling(disabling)?

*         What is the performance metric for PE-CE load balancing (active-active)? Shouldn't this be covered in the draft?
Sudhin>>> I think that is a functional parameter, functional parameters are not supported by this workgroup.

[Iftekhar] I am thinking there should be some metric to measure the level of load balancing  between PE-CE and PE-PE. Let us see what other folks have any opinion on this.

Thanks,
Iftekhar

I support this work and believe this work would be useful for EVPN multi-vendor deployment scenarios.

Thanks
Iftekhar

---

From: "Rabadan, Jorge (Nokia - US)" <[email-masked]>
Date: Thu, 24 Nov 2016 12:27:07 +0000

Hi Iftekhar,

Thank you for sharing. I’m not really an author of RFC7432, I just made a bit of contribution…
About this:

·         What is the performance metric for PE-CE load balancing (active-active)? Shouldn’t this be covered in the draft?
Sudhin>>> I think that is a functional parameter, functional parameters are not supported by this workgroup.
[Iftekhar] I am thinking there should be some metric to measure the level of load balancing  between PE-CE and PE-PE. Let us see what other folks have any opinion on this.

I think it does not add much value to measure load-balancing and it is challenging to test it in an objective way – there are many factors involved like the type of flows, hashing algorithms, etc. nothing of that is described in the relevant RFCs.

Thanks.
Jorge

On 11/23/16, 7:39 PM, "Iftekhar Hussain" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Sudhin,

Hi Iftekhar,

Regards,
Sudhin

From: Sudhin Jacob

Hi Iftekhar,

I will get back.

Regards,
Sudhin

From: Iftekhar Hussain

Hi Jacob and Kishore,

·         Why the draft scope does not explicitly mentions/includes RFC7432?
Sudhin>> it is updated in the latest combined draft.

·         What is the impact on system performance (ARP memory for storing IP prefixes, lookups etc) and reliability (e.g., packet loss if any) when ARP-proxy is enabled (disabled)? Shouldn’t your draft cover those metrics on reduction (or increase) in flooding
Sudhin>>  Could you please let me know if you want to add arp scaling as parameter, we will do it. The reliability section community told us not to do it, there is a section we added named convergence to check how fast the DUT converge in terms of failure.

·         What is the performance metric for PE-CE load balancing (active-active)? Shouldn’t this be covered in the draft?
Sudhin>>> I think that is a functional parameter, functional parameters are not supported by this workgroup.

Thanks,
Iftekhar

Thanks
Iftekhar

---

From: Sudhin Jacob <[email-masked]>
Date: Mon, 28 Nov 2016 03:43:21 +0000

Hi Jorge and Iftekhar,

Yes thanks for the input, we have taken in to consideration. Could you please go through the draft and let us know any other additions required that would a great help for us.

Regards,
Sudhin

From: Rabadan, Jorge (Nokia - US) [mailto:[email-masked]]
Sent: Thursday, November 24, 2016 5:57 PM
To: Iftekhar Hussain <[email-masked]>; Sudhin Jacob <[email-masked]>
Cc: Kishore Tiruveedhula <[email-masked]>; [email-masked]
Subject: Re: draft-kishjac-bmwg-pbbevpn

Hi Iftekhar,

Thanks.
Jorge

Hi Sudhin,

Hi Iftekhar,

Regards,
Sudhin

From: Sudhin Jacob

Hi Iftekhar,

I will get back.

Regards,
Sudhin

From: Iftekhar Hussain

Hi Jacob and Kishore,

Thanks,
Iftekhar

Thanks
Iftekhar

---

From: Sudhin Jacob <[email-masked]>
Date: Mon, 28 Nov 2016 03:44:18 +0000

Hi Iftekhar,

Apologies for the typo we will correct in the new revision.

Regards,
Sudhin

From: Iftekhar Hussain [mailto:[email-masked]]
Sent: Thursday, November 24, 2016 12:10 AM
To: Sudhin Jacob <[email-masked]>
Cc: Kishore Tiruveedhula <[email-masked]>; [email-masked]; Rabadan, Jorge (Nokia - US) <[email-masked]>
Subject: RE: draft-kishjac-bmwg-pbbevpn

Hi Sudhin,

Hi Iftekhar,

Regards,
Sudhin

From: Sudhin Jacob

Hi Iftekhar,

I will get back.

Regards,
Sudhin

From: Iftekhar Hussain

Hi Jacob and Kishore,

Thanks,
Iftekhar

Thanks
Iftekhar