Subject: [bmwg] Out-going Liaison on draft-jacpra-bmwg-pmtest-02

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 14 Nov 2016 20:40:04 +0000

BMWG,

Since draft-jacpra-bmwg-pmtest-02 intends to benchmark
PM features based on ITU-T Recommendation Y.1731, it is
essential that we communicate with the relevant 
ITU-T Study Groups and obtain their perspective before 
proceeding further.

The draft text of the Liaison is provided below, 
for BMWG comment prior to transmittal.

Please provide any comments before Nov 22, 2016.

regards,
Al
bmwg co-chair

---------------------------------------------------------------
To: ITU-T SG 15 and SG 11
TSBSG15, ITU ([email-masked])
TSBSG11, ITU ([email-masked])

From: IETF-BMWG
Al Morton, WG Co-Chair [email-masked]
Sarah Banks, WG Co-Chair [email-masked]
For Action/Comment
Deadline: March 1, 2017

Title: Proposal to Develop a Benchmarking Methodology for
ITU-T Recommendation Y.1731 OAM Performance 

The purpose of this Liaison is to inform you of a new work proposal
in the Benchmarking Methodology Working Group (BMWG) of the IETF, and seek
your comments and future plans regarding the subject work area.

BMWG has been presented with a new work proposal to benchmark the
Y.1731 OAM capabilities of network devices. Please see
the Internet Draft by Sudhin Jacob and Praveen Ananthasankaran:
https://tools.ietf.org/html/draft-jacpra-bmwg-pmtest-02
In this proposal, there is an intersection between IETF benchmarking
practice and ITU-T standardization and mandates.

The Internet-Draft seeks to characterize the accuracy of performance 
monitoring:
* under various traffic conditions, 
* during routing engine fail-over (High Availability), 
* during multiple OAM test sessions to characterize the scale/capacity, and 
* during long test intervals (Soak tests).

This Internet Draft is at an early stage, so considerable review
and development would be necessary, as with all work items.

The charter of BMWG strictly limits our work to laboratory characterization.
Therefore, live network performance testing, manageability, MIB module
development, and other operational/functional testing are beyond our scope.
https://datatracker.ietf.org/wg/bmwg/charter/

We recognize that ITU-T SG 15 is the maintainer of Rec. Y.1731, and that
compliance and interoperability specifications are the mandate of SG 11.
Therefore, prior to considering this work proposal further, 
we seek your respective comments on:
  - whether you see this topic as valuable to the Industry
  - whether your experience and knowledge of Y.1731 implementations
    is essential to complete this work with the necessary quality
  - whether there is overlapping work in ITU-T, planned or in-progress
  - the proposal details, as currently described, and
  - your preference on how to progress this work.

Replies received prior to our March 2017 meeting will be most appreciated.

-------------------------------------------------------------------------

---

From: Dan Romascanu <[email-masked]>
Date: Mon, 14 Nov 2016 23:25:58 +0200

Hi Al,

Can you explain shortly what is meant by:

'In this proposal, there is an intersection between IETF benchmarking
practice and ITU-T standardization and mandates.'

BMWG defined for the last two decades or so benchmarking methodologies that
referred performance metrics defined in the IETF and other industry
organizations including the ITU-T. AFAIK this was considered complementary
and added value work. Is this case different?

Just to be clear, I feel it's fine and even recommended to ask for review
and advice from the owners of Y.1731 - this is sound communication on the
technical plane. However, asking another organization about 'your
preference on how to progress this work' sounds different than previous
cases.

Thanks and Regards,

Dan

On Mon, Nov 14, 2016 at 10:40 PM, MORTON, ALFRED C (AL) <[email-masked]>
wrote:

> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 14 Nov 2016 23:15:11 +0000

Hi Dan,

SG 11’s Mandate is very broad, and I understand it has
expanded in the recent WTSA-16 concluding a few weeks ago.

AFAIK, BMWG hasn’t liaised with ITU-T before, and when we
liaised with other SDOs that had a relevant testing emphasis
or project in-progress, the SDO preferred to do the work
themselves. When there was no comparable work, BMWG was
able to proceed.

So, we’ll see what they say.
Al
bmwg co-chair

From: Dan Romascanu [mailto:[email-masked]]
Sent: Monday, November 14, 2016 4:26 PM
To: MORTON, ALFRED C (AL)
Cc: [email-masked]
Subject: Re: [bmwg] Out-going Liaison on draft-jacpra-bmwg-pmtest-02

Hi Al,

'In this proposal, there is an intersection between IETF benchmarking
practice and ITU-T standardization and mandates.'
BMWG defined for the last two decades or so benchmarking methodologies that referred performance metrics defined in the IETF and other industry organizations including the ITU-T. AFAIK this was considered complementary and added value work. Is this case different?
Just to be clear, I feel it's fine and even recommended to ask for review and advice from the owners of Y.1731 - this is sound communication on the technical plane. However, asking another organization about 'your preference on how to progress this work' sounds different than previous cases.
Thanks and Regards,
Dan

On Mon, Nov 14, 2016 at 10:40 PM, MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:
BMWG,

regards,
Al
bmwg co-chair

---------------------------------------------------------------
To: ITU-T SG 15 and SG 11
TSBSG15, ITU ([email-masked]<mailto:[email-masked]>)
TSBSG11, ITU ([email-masked]<mailto:[email-masked]>)

From: IETF-BMWG
Al Morton, WG Co-Chair [email-masked]<mailto:[email-masked]>
Sarah Banks, WG Co-Chair [email-masked]<mailto:[email-masked]>
For Action/Comment
Deadline: March 1, 2017

_______________________________________________
bmwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bmwg