Subject: [bmwg] Document Action: 'Benchmarking Methodology for SDN Controller Performance' to Informational RFC (draft-ietf-bmwg-sdn-controller-benchmark-meth-09.txt)

From: The IESG <[email-masked]>
Date: Fri, 25 May 2018 12:17:08 -0700

The IESG has approved the following document:
- 'Benchmarking Methodology for SDN Controller Performance'
  (draft-ietf-bmwg-sdn-controller-benchmark-meth-09.txt) as Informational RFC

This document is the product of the Benchmarking Methodology Working Group.

The IESG contact persons are Warren Kumari and Ignas Bagdonas.

A URL of this Internet Draft is:
https://datatracker.ietf.org/doc/draft-ietf-bmwg-sdn-controller-benchmark-meth/

Technical Summary

  These two documents (
  draft-ietf-bmwg-sdn-controller-benchmark-term and
  draft-ietf-bmwg-sdn-controller-benchmark-meth)
  specify the terminology, benchmark definitions 
  and methods for characterizing key performance aspects of 
  Software Defined Network (SDN) Controllers. Considering the 
  number of benchmarking and performance comparison studies that
  have been published prior to standards development, this is an 
  important area for new specifications and tools to implement them.
  These memos focus on the ability of SDN controllers to learn 
  topology, communicate with switches, and instantiate paths using
  both reactive and proactive techniques (including controller clusters).
  Further, requirements for test traffic and network emulation
  capabilities of the test devices are specified. The memos approach
  this problem in a generic way (Openflow specific procedures are
  included in an Appendix) for broader applicability and longevity.

Working Group Summary

 Consensus for these drafts required several WGLC which prompted
 careful review and further comments. However, the process to achieve 
  consensus was smooth, and at no time was there sustained controversy.

Document Quality

   There are existing implementations of the methods described here,
  both full and partial, and many are available as Open Source tools.
  Tools are tied to specific versions of Northbound and Southbound
  protocols, but the memo avoids this dependency (and redundancy with
  other industry efforts) by defining benchmarks for generic SDN 
  controller functions (as suggested in https://mailarchive.ietf.org/arch/msg/bmwg/Glchqbvg6F7vOUc0ug3ACyztcNg ).
  The document benefits from review in the NFVRG, and from interactions
  with the Open Platform for Network Function Virtualization (OPNFV) "CPerf"
  project team (which includes members from Open Daylight Integration
  test team, ETSI NFV Test and Open Source WG, and other Linux Foundation
  and independent Open Source projects related to SDN performance).

Personnel

  Al Morton is the Document Shepherd
  Warren Kumari is RAD!

RFC Editor Note

The documents draft-ietf-bmwg-sdn-controller-benchmark-term and 
draft-ietf-bmwg-sdn-controller-benchmark-meth should progress together.

It would be nice if they could have sequential RFC Numbers.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 25 May 2018 19:45:42 +0000

Congratulations to the SDN Controller author team,
and Bhuvan in particular for leading the IETF/IESG comment 
responses.

These drafts were the last items on our "old" charter,
and BMWG can begin anew with new milestones to achieve.

regards,
Al
bmwg co-chair

> -----Original Message-----
> From: The IESG [mailto:[email-masked]]
> Sent: Friday, May 25, 2018 3:17 PM
> To: IETF-Announce <[email-masked]>
> Cc: [email-masked]; The IESG
> <[email-masked]>; [email-masked]; MORTON, ALFRED C (AL)
> <[email-masked]>; MORTON, ALFRED C (AL) <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]
> Subject: Document Action: 'Benchmarking Methodology for SDN Controller
> Performance' to Informational RFC (draft-ietf-bmwg-sdn-controller-
> benchmark-meth-09.txt)
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dbmwg-2Dsdn-2Dcontroller-
> 2Dbenchmark-2Dmeth_&d=DwICaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=E1ZjpTM8KSoH0KzjCIzI7j1eBcF74
> ddfHUgI5JQADIc&s=wQWYBgLAaypvz5nKtqC-zzUtYsekma9rK__oyZk7RGs&e=
> 
> 
> 
> 
> 
> Technical Summary
> 
>   These two documents (
>   controller functions (as suggested in
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__mailarchive.ietf.org_arch_msg_bmwg_Glchqbvg6F7vOUc0ug3ACyztcNg&d=DwICa
> Q&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=E1ZjpTM8KSoH0KzjCIzI7j1eBcF74
> ddfHUgI5JQADIc&s=qmB_8prKT83I7M9AI4TGE-FE63c5XQxsl27qZ6sSnh8&e= ).

---

From: Bhuvaneswaran.Vengainathan <[email-masked]>
Date: Mon, 28 May 2018 14:43:33 +0530

Thank you Al for the wishes and your continued support/guidance in driving both the drafts within BMWG.

We also would like to thank Warren, ADs and BMWG members who reviewed and provided valuable feedback on these drafts.

Thanks & Regards,

Bhuvan
 
-----Original Message----- 
> From: "MORTON, ALFRED C (AL)" <[email-masked]> 
> To: [email-masked], [email-masked] 
> Date: 05/26/18 04:18 
> Subject: Re: [bmwg] Document Action: 'Benchmarking Methodology for SDN Controller Performance' to Informational RFC (draft-ietf-bmwg-sdn-controller-benchmark-meth-09.txt) 
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg