Subject: [bmwg] RFC 8456 on Benchmarking Methodology for Software-Defined Networking (SDN) Controller Performance

From: [email-masked]
Date: Tue, 30 Oct 2018 16:01:21 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 8456

        Title:      Benchmarking Methodology for Software-Defined
                    Networking (SDN) Controller Performance 
        Author:     V. Bhuvaneswaran,
                    A. Basil,
                    M. Tassinari,
                    V. Manral,
                    S. Banks
        Status:     Informational
        Stream:     IETF
        Date:       October 2018
        Mailbox:    [email-masked], 
                    [email-masked], 
                    [email-masked],
                    [email-masked], 
                    [email-masked]
        Pages:      64
        Characters: 125850
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-bmwg-sdn-controller-benchmark-meth-09.txt

        URL:        https://www.rfc-editor.org/info/rfc8456

        DOI:        10.17487/RFC8456

This document defines methodologies for benchmarking the
control-plane performance of Software-Defined Networking (SDN)
Controllers.  The SDN Controller is a core component in the SDN
architecture that controls the behavior of the network.  SDN
Controllers have been implemented with many varying designs in order
to achieve their intended network functionality.  Hence, the authors
of this document have taken the approach of considering an SDN
Controller to be a black box, defining the methodology in a manner
that is agnostic to protocols and network services supported by
controllers.  This document provides a method for measuring the
performance of all controller implementations.

This document is a product of the Benchmarking Methodology Working Group of the IETF.

INFORMATIONAL: This memo provides information for the Internet community.
It does not specify an Internet standard of any kind. Distribution of
this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://www.ietf.org/mailman/listinfo/ietf-announce
  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see https://www.rfc-editor.org/search
For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 31 Oct 2018 11:40:11 +0000

Congratulations to the Authors!

after many rounds of comments, a job well done,
Al
bmwg co-chair

> -----Original Message-----
> From: bmwg [mailto:[email-masked]] On Behalf Of rfc-editor@rfc-
> editor.org
> Sent: Tuesday, October 30, 2018 7:01 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [bmwg] RFC 8456 on Benchmarking Methodology for Software-Defined
>         URL:        https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.rfc-2Deditor.org_info_rfc8456&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrSbmL81uSb5IE-
> TBD8WJY_ljiM216JrjZbul4xr27A&s=cH3wrlqyElNxiIP5wO6g87TSiU56kz3WVE1SmQ_LGxI
> &e=
> 
>         DOI:        10.17487/RFC8456
> 
>   https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_ietf-2Dannounce&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrSbmL81uSb5IE-
> TBD8WJY_ljiM216JrjZbul4xr27A&s=-
> QAiPA58pHMYodL2WjceOMt3r8SxJczsVywAb4RhqRc&e=
>   https://urldefense.proofpoint.com/v2/url?u=https-3A__mailman.rfc-
> 2Deditor.org_mailman_listinfo_rfc-2Ddist&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrSbmL81uSb5IE-
> TBD8WJY_ljiM216JrjZbul4xr27A&s=F6PQKVOhb-
> 9udfNdsA67hP5qkiXPDP_vfJ15v7kePJA&e=
> 
> For searching the RFC series, see
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.rfc-
> 2Deditor.org_search&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrSbmL81uSb5IE-
> TBD8WJY_ljiM216JrjZbul4xr27A&s=MIWLLmOw9l5R__5Az2K5hylfiRcOzskPwZZ_eQ_2Y4o
> &e=
> For downloading RFCs, see
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.rfc-
> 2Deditor.org_retrieve_bulk&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrSbmL81uSb5IE-
> TBD8WJY_ljiM216JrjZbul4xr27A&s=43Yd9xxMj2ss9Ik4SiPq1m1ksj3E-
> FkQtrZIDhPdEtg&e=
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bmwg&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=CrSbmL81uSb5IE-
> TBD8WJY_ljiM216JrjZbul4xr27A&s=-eVaFsnUWaOEnAvDLSi-
> qpW9FRf7xuiT8xnPE9GDztI&e=

---

From: Bhuvaneswaran.Vengainathan <[email-masked]>
Date: Wed, 31 Oct 2018 17:25:07 +0530

Hi Al,
 
Thank you very much for your guidance and support in shaping the drafts to RFC.
Best Regards,
Bhuvan

From: MORTON, ALFRED C (AL) ([email-masked])
Date: 10/31/18 17:17
To: [email-masked]
Subject: Re: [bmwg] RFC 8456 on Benchmarking Methodology for Software-Defined Networking (SDN) Controller Performance

_______________________________________________
bmwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bmwg