Subject: Re: [bmwg] Call for adoption: draft-balarajah-bmwg-ngfw-performance

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sun, 21 Oct 2018 18:42:03 +0000

BMWG,

As we consider this draft, I have the following administrative
questions to discuss.

Al
bmwg co-chair

Benchmarking Methodology Working Group                      B. Balarajah
Internet-Draft                                           C. Rossenhoevel
Intended status: Informational                                  EANTC AG
Expires: January 3, 2019                                    July 2, 2018
[acm]
Admin questions: 
Will this draft Update or Replace or make Obsolete RFC3511?
The WG should be clear about this aspect, it can't be omitted IMO.
(question, is any part of 3511 referenced here?)
Will this work benefit from Early SEC-DIR review?
WIll this work benefit from early APPS-DIR review? (especially HTTPS/browser aspects)
Will this work benefit from TSV-AREA review? (TCP aspects, other transport...)

> -----Original Message-----
> From: MORTON, ALFRED C (AL)
> Sent: Sunday, October 21, 2018 2:39 PM
> To: [email-masked]
> Subject: Call for adoption: draft-balarajah-bmwg-ngfw-performance
> 
> BMWG,
> 
> At our three meetings so far this year, the BMWG reviewed a version of
> the Internet Draft on
> 
> Benchmarking Methodology for Network Security Device Performance
>    https://tools.ietf.org/html/draft-balarajah-bmwg-ngfw-performance-05
> 
> The BMWG has already adopted a milestone on our charter:
> 
> Aug 2018 	Methodology for Next-Gen Firewall Benchmarking to IESG Review
> (in retrospect, this milestone was quite aspirational!)
> 
> This message, therefore, starts a call for adoption on:
> 
> Benchmarking Methodology for Network Security Device Performance
>    https://tools.ietf.org/html/draft-balarajah-bmwg-ngfw-performance-05
> 
> to run until Friday, November 9, 2018.
> 
> Please reply to [email-masked] indicating:
> 
> (1) whether you support the adoption of the draft
>    as the basis document for the existing milestone
> 
> (2) whether you commit to reviewing the WG document if adopted
> 
> 
> thanks for your consideration of the draft, and regards,
> 
> Al
> bmwg co-chair

---

From: "Brian Monkman" <[email-masked]>
Date: Thu, 25 Oct 2018 09:30:03 -0400

Al,

My comments are inline below.

Brian

-----Original Message-----
From: bmwg <[email-masked]> On Behalf Of MORTON, ALFRED C (AL)
Sent: October 21, 2018 2:42 PM
To: [email-masked]
Subject: Re: [bmwg] Call for adoption: draft-balarajah-bmwg-ngfw-performance

BMWG,

As we consider this draft, I have the following administrative questions to
discuss.

Al
bmwg co-chair

[bpm] We view this as somewhat separate from RFC3511. Most of RFC3511 is
still valid when it comes to basic network firewalls. This proposed draft is
meant to go well beyond that by addressing the needs to NGFWs. Since basic
firewalling technologies are still in active use RFC3511 is still valid.

The WG should be clear about this aspect, it can't be omitted IMO.
(question, is any part of 3511 referenced here?) Will this work benefit from
Early SEC-DIR review?
WIll this work benefit from early APPS-DIR review? (especially HTTPS/browser
aspects) Will this work benefit from TSV-AREA review? (TCP aspects, other
transport...)

[bpm] May people were involved in the development of this proposal, with a
very wide scope of knowledge and expertise. Folks form security product
vendors, test labs and test tool vendors. I don't think having other areas
review this wold be of benefit if it is going to lengthen the review
process. 

> thanks for your consideration of the draft, and regards,

_______________________________________________
bmwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bmwg

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 25 Oct 2018 14:46:55 +0000

Thanks for the clarification on RFC3511, Brian,
and sharing your view on the review process.

Although requesting early review is an exception,
this would take place after adoption and before
WG consensus, so it should not lengthen the process
unnecessarily. We would receive reviews from these
Directorate teams anyway, during IETF Last Call, and 
this may be more efficient (ideally).

It also occurs to me that we had some interest from the
opsec WG - I will cross-post the call for adoption there.

Al
bmwg co-chair

> From: Brian Monkman [mailto:[email-masked]]
> Sent: Thursday, October 25, 2018 9:30 AM
> To: MORTON, ALFRED C (AL) <[email-masked]>; [email-masked]
> Subject: RE: [bmwg] Call for adoption: draft-balarajah-bmwg-ngfw-
> performance
> 
> Al,
> 
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dbalarajah-2Dbmwg-2Dngfw-2Dperformance-
> 2D05&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-
> e_hOm0BhY7aIpA58dd19Z9qGQsr8-
> 6zYMI&m=SnQDPuXNkU4lpz0K_xDQPKNQZ8LfDDYIHf55M9-
> 0gEM&s=k9ra4_IYee8XZHNoEVpIs4VzmBJv4I_94p1o5CKmkqk&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dbalarajah-2Dbmwg-2Dngfw-2Dperformance-
> 2D05&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-
> e_hOm0BhY7aIpA58dd19Z9qGQsr8-
> 6zYMI&m=SnQDPuXNkU4lpz0K_xDQPKNQZ8LfDDYIHf55M9-
> 0gEM&s=k9ra4_IYee8XZHNoEVpIs4VzmBJv4I_94p1o5CKmkqk&e=
> >
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bmwg&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-
> 6zYMI&m=SnQDPuXNkU4lpz0K_xDQPKNQZ8LfDDYIHf55M9-
> 0gEM&s=ZoAskSYmre8HJxrixoOVquJ1WJZ7GSPcWxsi4C5-aNM&e=