Subject: [Bridge-mib] Pre-last-call review

From: "Harrington, David" <[email-masked]>
Date: Mon, 12 Apr 2004 12:31:11 -0400

Hi,

We need reviews of the documents approaching last call. I am seeking
volunteers to commit to providing specific types of reviews for each
document over the next two weeks.

We need for each document:
1) a spelling and grammar check
2) an ID NITs check
3) a boilerplate check (as called for in
draft-ietf-ops-mib-review-guidelines-02)
4) a libsmi and/or smicng compiler check (as in
draft-ietf-ops-mib-review-guidelines-02)
5) a mib review guidelines check (thorough
draft-ietf-ops-mib-review-guidelines-02)
6) an IEEE/IETF sync review - have the IEEE designs changed such that
these mibs are no longer appropriate?
7) a design review - do the tables/indexing make sense?

Part of the goal here is to determine that there is wide support for
these documents to move forward, so I'm looking for a number of
reviewers from different companies.  

Once this has been done, we'll change and republish the documents if
necessary.
Then we'll do a WG last call.

The documents are:
draft-ietf-bridge-bridgemib-smiv2-06 
draft-ietf-bridge-rstpmib-04
draft-ietf-bridge-ext-v2-02
draft-ietf-bridge-8021x-03

The documents are available at
http://www.rfc-editor.org/cgi-bin/idsearch.pl

Thanks,
Dbh

David Harrington            
[email-masked]
co-chair, IETF SNMPv3 WG, concluded
Acting co-chair, IETF Bridge WG

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "C. M. Heard" <[email-masked]>
Date: Tue, 13 Apr 2004 09:21:48 -0700 (PDT)

On Mon, 12 Apr 2004, Harrington, David wrote:

> We need reviews of the documents approaching last call. I am
> seeking volunteers to commit to providing specific types of
> reviews for each document over the next two weeks.

One of the documents in your list was draft-ietf-bridge-8021x-03.txt
I've posted quite a few comments on this document to this list in
the past and have done much of what you request.  There are a few
as-yet unresolved comments from myself and Bert Wijnen;  please see

http://www1.ietf.org/mail-archive/working-groups/bridge/current/msg00275.html

and the references/followups.

> 1) a spelling and grammar check

I did not do this.

> 2) an ID NITs check

I think I did this, but another pair of eyes would help.

> draft-ietf-ops-mib-review-guidelines-02)

See comments referenced above ... Bert and I have asked
that the boilerplate be updated.

> draft-ietf-ops-mib-review-guidelines-02)

Done.

> draft-ietf-ops-mib-review-guidelines-02)

Done to the extent that it is applicable.
Note that this document is a republication
of a MIB module from an existing IEEE standard,
and so there are some points in the MIB review
guidelines that do not apply.  In particular,
the standard copyright notices do not apply
(we had a LONG discussion about that, it
would be a shame to go through it again because
people forgot about it, or some reviewer was
not aware of it).  Also, we are not in a position
to fix design problems, since we are just
republishing an existing module.  Indeed, The
only changes that were made were some things of
a technical nature that were  needed to get the
module to compile.

> 6) an IEEE/IETF sync review - have the IEEE
> designs changed such that these mibs are no
> longer appropriate?

I have verified that the module matches the one
on the IEEE web site, modulo the changes put in
that were needed to make it compile.  However,
the IEEE was working on an update while this
was going on.  I don't know the status of tat
effort, but if the IEEE has finished that
work, then we should probably republishe the
new version, not this one.

> 7) a design review - do the tables/indexing make sense?

I don't think that's applicable in the case of a
republication of an existing IEEE module.  In any
case I have not done that.

Mike Heard