Subject: [Bridge-mib] FW: Bridge wg charter

From: "Harrington, David" <[email-masked]>
Date: Fri, 16 Apr 2004 17:10:16 -0400

Hi,
 
I have revised the charter to focus on the four outstanding documents,
and then to work out how the IETF Bridge WG will work with the IEEE
802.1 WG for future mib work. If the WG finds this rewrite acceptable,
we can try to get it in the IESG docket next week.

Comments, please.

dbh

> -----Original Message-----
> From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
> Sent: Thursday, April 15, 2004 6:19 PM
> To: Harrington, David; Romascanu, Dan (Dan); Les Bell
> Cc: David Kessens (E-mail)
> Subject: RE: Bridge wg charter
> 
> Thanks for the initiative Dave.
> 
> So when you write a milestone like "Submit an ID...."
> do you them mean "submit to IESG or AD" ??
> Or is that just posting it as an I-D in internet-drafts
> repository. Pls make that clear. 
> And most important, I need dates by when you think to 
> "request publication" i.e. when you submit it to AD or IESG for
> publication.
> 
> I am also confused by milestones:
>    Jun 04    Submit the SMIv2 version of RFC 1493 
>              (draft-ietf-bridge-bridgemib-smiv2) for publication
>              as a Proposed Standard. 
>    Jul 04    Evaluate status of RFC 1493 and get WG consensus if
>              advancement or other status change should be requested 
> 
> So does that mean that "evaluation starts after the SMIv2 
> version of the 
> ID has been "submitted" (whatever that means)? But even then, 
> the ID is for
> PS and this is to evaluate if 1493 needs to be advanced.
> 
> Maybe it is just me.
> 
> I also think we should write something about how we think we're going
> to interact with and get involvement  from IEEE 802.1, no?
> (pls make sure we get proepr IEEE people involved in teh review)
> 
> But pls adapt that a bit to make it clearer, and then feel free to
> discuss on WG mailing list. If we have a feel for how well it
> is supported next week, then I can put it on IESG agenda. I then need
> it by Wednesday at the latest.
> 
> Pls also keep Bernard up to date, he is now generic IETF 
> liasion to IEEE
> 802, so it is good if he stays informed.
> 
> Thanks,
> Bert 
> 
> > -----Original Message-----
> > From: Harrington, David [mailto:[email-masked]]
> > Sent: donderdag 15 april 2004 19:30
> > To: Romascanu, Dan (Dan); Les Bell; [email-masked]
> > Subject: RE: Bridge wg charter
> > 
> > 
> > Hi Bert,
> > 
> > Dan and Les have looked over this charter revision. They also 
> > pushed for
> > later dates on the milestones, so I pushed them out. Are you OK with
> > this revision?
> > 
> > We are in agreement that it doesn't make sense to publish a mirror
> > 802.1X, but a pointer document would probably be good. We 
> > haven't run it
> > by the WG yet.
> > 
> > dbh
> > 
> > > -----Original Message-----
> > > From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
> > > Sent: Thursday, April 15, 2004 1:05 PM
> > > To: Harrington, David; Les Bell
> > > Subject: RE: Bridge wg charter
> > > 
> > > David,
> > > 
> > > You did not send an updated charter, but if it is the old one 
> > > with updated schedules I am fine. 
> > > 
> > > I am OK with an informational RFC. I would keep then separate 
> > > at this stage. The reason is that the situation with 802.3 
> > > MIBs for example is different - mainly because the IEEE 802.3 
> > > WG took in the past a different approach than 802.1. 
> > > 
> > > yes, they are calling themselves Working Groups. 
> > > 
> > > Regards,
> > > 
> > > Dan
> > > 
> > > 
> > > 
> > > > -----Original Message-----
> > > > From: Harrington, David [mailto:[email-masked]]
> > > > Sent: 15 April, 2004 7:56 PM
> > > > To: Les Bell; Romascanu, Dan (Dan)
> > > > Subject: RE: Bridge wg charter
> > > > 
> > > > 
> > > > Hi,
> > > > 
> > > > I've updated the milestones with new dates. If you're 
> > > > satisfied with it,
> > > > and Bert is satisfied with it, we can send it to the WG for 
> > > > discussion.
> > > > While I have discussed finalizing the documents with the 
> > editors, I
> > > > would like to have the editors make a public commitment 
> > to finalize
> > > > within the milestone dates.
> > > > 
> > > > I agree that it doesn't make sense to publish 802.1X, but 
> > I think we
> > > > need to run this through the consensus process. Part of my 
> > > > "survey", my
> > > > proposed charter wording, and the request for a "sync" review 
> > > > was meant
> > > > to make this apparent.
> > > > 
> > > > Do you think we should have an informational rfc for 802.1 
> > > > mibs, another
> > > > 802.3, etc., or just one with pointers to IEEE mib pages 
> > for various
> > > > subgroups/areas (what DO they call these in IEEE)? If we 
> > do this for
> > > > IEEE, other SDOs may want similar treatment, so one rfc 
> > might be the
> > > > simplest approach.
> > > > 
> > > > It would be good if the RFC search engine could find keys 
> > > > such as 802.1,
> > > > 802.3, 802.11, 802 and IEEE to find the relevant rfc(s).
> > > > 
> > > > dbh
> > > > 
> > > > > -----Original Message-----
> > > > > From: Les Bell [mailto:[email-masked]] 
> > > > > Sent: Wednesday, April 14, 2004 8:08 AM
> > > > > To: Romascanu, Dan (Dan)
> > > > > Cc: Harrington, David
> > > > > Subject: RE: Bridge wg charter
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > Thanks.
> > > > > 
> > > > > I agree with Dan that you should allow another month for each 
> > > > > of the dates
> > > > > listed, unless you believe that the drafts currently issued 
> > > > > are ready for last
> > > > > call now.  If not you will need to persuade those on the 
> > > > > mailing list to submit
> > > > > comments, apply appropriate edits, and release a new draft 
> > > > > before going to last
> > > > > call.  This could easily take more than the 6 weeks up to the 
> > > > > end of May.
> > > > > 
> > > > > I think there is no longer any point in submitting the draft 
> > > > > that duplicates the
> > > > > original 802.1X MIB with corrections applied.  This MIB is 
> > > > > due to be superseded
> > > > > with the revised publication of the 802.1X standard, which 
> > > > > includes the
> > > > > corrections made in the current internet-draft, plus a number 
> > > > > of other changes
> > > > > required by changes to the 802.1X standard itself.  Perhaps 
> > > > > you should poll the
> > > > > mailing list for opinions on this.
> > > > > 
> > > > > I think it may be worthwhile generating an Informational RFC 
> > > > > pointing to the
> > > > > 802.1 web site for the 802.1 MIBs, the 802.3 web-site for the 
> > > > > LACP MIB, and any
> > > > > other MIBs that may be available.  (I believe 802.11 
> > > > > generated some MIBs, but I
> > > > > do not know about their content or availability.)
> > > > > 
> > > > > Les...
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > "Romascanu, Dan (Dan)" <[email-masked]> on 
> > 14/04/2004 09:52:26
> > > > > 
> > > > > Sent by:  "Romascanu, Dan (Dan)" <[email-masked]>
> > > > > 
> > > > > 
> > > > > To:   Les Bell/GB/3Com, "Harrington, David" 
> <[email-masked]>
> > > > > cc:
> > > > > Subject:  RE: Bridge wg charter
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > Regards,
> > > > > 
> > > > > Dan
> > > > > 
> > > > > 
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: Les Bell [mailto:[email-masked]]
> > > > > > Sent: 14 April, 2004 11:48 AM
> > > > > > To: Harrington, David
> > > > > > Cc: Romascanu, Dan (Dan)
> > > > > > Subject: RE: Bridge wg charter
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > Hi David,
> > > > > >
> > > > > > I did not receive the updated charter mentioned in 
> this email
> > > > > > trail.  Could you
> > > > > > send it to me again please.
> > > > > >
> > > > > > Les...
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > "Harrington, David" <[email-masked]> on 
> 13/04/2004 22:48:59
> > > > > >
> > > > > > Sent by:  "Harrington, David" <[email-masked]>
> > > > > >
> > > > > >
> > > > > > To:   "Romascanu, Dan \, Les Bell/GB/3Com
> > > > > > cc:
> > > > > > Subject:  RE: Bridge wg charter
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > Hi,
> > > > > >
> > > > > > Of course it's basically the same; I'm not trying to change 
> > > > > what we're
> > > > > > doing, just trying to clarify the goals and set some
> > > > > > milestones to shoot
> > > > > > for. I found the current documents and the milestones 
> > > > > didn't match up
> > > > > > well, and wanted to better reflect the current documents and
> > > > > > what needs
> > > > > > to be done. I can push up the dates if you think that's 
> > > > > prudent, but I
> > > > > > do want to see this work done asap; my initial pass 
> had April
> > > > > > 04 dates,
> > > > > > and I changed them to May at Bert's request.
> > > > > >
> > > > > > We do have editors. The documents are close to complete. KC 
> > > > > and Vivian
> > > > > > will continue to finalize the documents, as they can. If the
> > > > > > work drags
> > > > > > on, they won't. Tom Petch has offered to help edit. David 
> > > > > Levi offered
> > > > > > to review the RSTP document. Mike already did some 
> > review of the
> > > > > > documents. I think we should have adequate personnel to 
> > > > achieve our
> > > > > > goals.
> > > > > >
> > > > > > I asked for the multiple types of reviews because I want to 
> > > > > gauge the
> > > > > > level of interest from the members of the WG in completing
> > > > > > these tasks.
> > > > > > If they have no interest in completing the work, we can 
> > > > > check with the
> > > > > > IEEE to see if they have enough interest to complete the 
> > > > > documents. If
> > > > > > not, then we can probably just throw the documents away. 
> > > > I came into
> > > > > > this role with the expectation that such might be 
> the result.
> > > > > >
> > > > > > It is possible there will be little interest because some 
> > > > > of the work
> > > > > > that has been done is largely editorial, e.g. converting 
> > > > rfc1493 to
> > > > > > SMIv2 format, and much of the work to be done is related to
> > > > > > publication
> > > > > > standards not technology standards, e.g. meeting the 
> > mib review
> > > > > > guidelines CLRs, or is simply formalizing in a MIB what has
> > > > > > already been
> > > > > > defined clearly enough by the IEEE. The IETF really could 
> > > > > use a "good
> > > > > > enough" status for documents. There isn't much in these 
> > > > > documents that
> > > > > > stimulates me as an NMS vendor, even though the IEEE 
> > technology
> > > > > > interests me as a hardware vendor. We'll see whether the
> > > > > > industry/mailinglist is really interested in these 
> > mibs or not.
> > > > > >
> > > > > > dbh
> > > > > >
> > > > > > > -----Original Message-----
> > > > > > > From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> > > > > > > Sent: Tuesday, April 13, 2004 4:28 PM
> > > > > > > To: Harrington, David; Les Bell
> > > > > > > Subject: RE: Bridge wg charter
> > > > > > >
> > > > > > > Basically it's the same as the existing charter, 
> isn't it? I
> > > > > > > would write part of the text differently, but it's at
> > > > > > > wordsmithing level and I am not sure it's worth 
> the effort.
> > > > > > > Maybe if we say - 'it's just the previous charter, we just
> > > > > > > try to wrap-up and update schedules' we may be in 
> > > better shape.
> > > > > > >
> > > > > > > Talking about schedules I do not think that they are
> > > > > > > realistic. Did we identify editors and reviewers? Just
> > > > > > > running the Charter through the IETF would push 
> us in May. I
> > > > > > > would suggest at least to push ahead each milestone by 
> > > > one month.
> > > > > > >
> > > > > > > Regards,
> > > > > > >
> > > > > > > Dan
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > > -----Original Message-----
> > > > > > > > From: Harrington, David [mailto:[email-masked]]
> > > > > > > > Sent: 13 April, 2004 11:14 PM
> > > > > > > > To: Romascanu, Dan (Dan); Les Bell
> > > > > > > > Subject: Bridge wg charter
> > > > > > > >
> > > > > > > >
> > > > > > > > Hi Dan and Les,
> > > > > > > >
> > > > > > > > I'd like to rewrite the charter to reflect only what is
> > > > > > > still needed.
> > > > > > > > Can you look at this proposed charter and see 
> if you feel
> > > > > > > it is a good
> > > > > > > > approach, and covers everything that still needs 
> > to be done?
> > > > > > > >
> > > > > > > > Dan, Les sent me a rundown of the previous 
> > milestones; I'll
> > > > > > > > forward that
> > > > > > > > to you.
> > > > > > > >
> > > > > > > > Thanks,
> > > > > > > >
> > > > > > > > David Harrington
> > > > > > > > [email-masked]
> > > > > > > > Director, Network Management Architecture
> > > > > > > > Office of the CTO, Enterasys Networks
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > 
> > > 
> > > 
> > 
> 
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 20 Apr 2004 08:51:25 +0200

as technical contributer

By the way... would it make sense to bring 
   draft-ietf-ops-vlanid-tc-mib-xx.txt
into this WG instead of trying to run it as an 
individual doc in "ops" area?

I personally think it would. I will offer to continue to edit 
the document if the WG agrees.

If there is support, then maybe it can be included in the new charter

Thanks,
Bert 

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib