Subject: RE: PROPOSAL: CAP Error codes definition and handling

From: "lisal" <[email-masked]>
Date: Thu, 20 May 1999 07:40:53 -0700

Comments on needing text for debugging...

> -----Original Message-----
> From: Frank Dawson/CAM/Lotus [mailto:[email-masked]]
> Sent: Wednesday, May 19, 1999 10:50 AM
> 
> It sounds like you are talking about a scenario of where you 
> are debugging
> an implementation. This sounds like it can be non-conformant 
> to the base
> CAP spec without any big deal. For example, you go into your 
> server and
> turn-on the "super duper text feature" and kickout the 
> debugging text, even
> though its not conformant. 

Yes, exactly, although note that if my client application and your
server application have an interopability problem, and we want to debug
it, we want my client application to be able to successfully ignore the
"super duper" debugging text produced by your server (rather than do
anything differently which might affect reproducing the problem).  This
requires support for arbitrary text in the response text field in the
protocol standard.

Lisa

---

From: Alexander Taler <[email-masked]>
Date: Thu, 20 May 1999 20:22:39 -0400

> requires support for arbitrary text in the response text field in the

Not to mention that if we are debugging a production server, 
we don't want to break any other clients that are using it.  
Debugging doesn't stop once something is installed, in fact
that's when it really gets going. :-)

So I think we agree that the text should be optional, and
that the CUA should either ignore it or log it.

The only question that remains is whether the text should be 
specified in the spec or entirely up to the implementor.
Leaving it up to the implementor means that more useful
information can be transmitted, and since it's optional
and ignored by the CUA it cannot break the CUA.

Any more objections to Andre's original proposal (minus 
reference to USASCII, with clarification that it can be any
string):

> <statuscode>;<text>
> 
> Where:
> 
> statuscode is the error code defined in the status code table
> in the draft.
> 
> text may be any string, for diagnostics purposes, that
> is not to be displayed by the CUA.
> 

Alex