Subject: Re: How to use CAP for scheduling events.

From: Doug Royer <[email-masked]>
Date: Mon, 24 May 1999 17:44:10 -0700 (PDT)

> Date: Mon, 24 May 1999 20:09:15 -0400
> From: Alexander Taler <[email-masked]>
> 
> However, I feel that there is a need for an inbox at the 
> protocol level.  If CAP incorporates iTIP, then it must support
> COUNTERs.  Clearly COUNTERs cannot be automatically accepted, 
> so they must go somewhere else.  That somewhere else has to
> be accessible to whichever CUA I use, and therefore has to
> be in CAP.

But they can be automatically rejected - so there is no NEED for
an inbox - again - I see it as an implementation detail.

> In the cases that you mention, where my CS doesn't actually
> store anything in an inbox, queries to the inbox will always
> report that it is empty.

If you are saying that the CUA must be able to ask the CS
for anything that needs action - there is a way already. No
inbox needed.

Simply query for all components that are marked NEEDS-ACTION.
If you decide that your implementation wants to store those
in an INBOX - okay. Please don't force me to do the same.

What if you have an existing appointment in a shared calendar between
you and your administrator and its state is ACCEPTED.  Then a conflict
arises and your administrator changes the status of that existing 
appointment to NEEDS-ACTION in addition to the new one that is in
conflict. Are you planning to remove it from the calendar and move it into
some INBOX? If not - then your will have to do the same thing twice.
Once for the INBOX and another query for NEEDS-ACTION.

-Doug
-------------------------------------------------------------------
[email-masked]		http://playground.sun.com/~dougr
Pager:				[email-masked]
801 W. El Camino #131		Work:   (650)786-7599
Mountain View, CA 94040		Ham Radio: N6AAW, Aviation: PP-ASEL

---

From: Alexander Taler <[email-masked]>
Date: Sun, 30 May 1999 13:28:20 -0400

> an inbox - again - I see it as an implementation detail.

Doug, if I invite someone to an event, and they want to send me 
a COUNTER, how do they do it?  All they have is my cap:// 
caladdress from the organizer property.

Alex