Subject: RE: **YOU'RE INPUT NEEDED** Termination for SENDDATA command

From: [email-masked]
Date: Mon, 17 May 1999 09:51:49 -0400

My position: We go with termination sequence <CRLF>.<CRLF>
or whatever else.

Andre Courtemanche
CS&T

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, May 14, 1999 5:13 PM
To: John Stracke
Cc: [email-masked]
Subject: **YOU'RE INPUT NEEDED** Termination for SENDDATA command

All,

My comments are below.

We need to nail this point and move on. I'm interested in the opinion of
others.  Shall we
do byte counts or not?

-Steve

John Stracke wrote:

> Steve Mansour wrote:
>
> > It seems a whole lot easier than what is described below.
>
> I don't understand what you're considering to be difficult.  I described
how a sender
> would implement byte counts under three different approaches for
implementing the
> sender.  The only implementation approach that made byte counts difficult
was one that
> nobody would use (I included it only for completenes).  Do you have a
fourth
> implementation approach in mind?

None of the options you described are difficult. I pointed out that it is
easier to stream
the data out without counting bytes than it is to count bytes in any of the
ways you
described.

In order to support attachments and ALTREP variants of text, code will have
to be written to
count bytes. Attachments could be large. Altreps could be large. As you
point out, it can be
done.  But there is overhead.

The overhead in parsing the '.' seems small.

> > Seems like it would scale well too.
> But there are cases where it will not scale as well as byte counts--for
example, in
> proxies.  A proxy should be able to buffer blindly, without having to
parse its input at
> all.

This is true. The parsing seems trivial, but the point is taken.

> > Also, note that the keywords and line folding in iCal are such that '.'
is never the
> > first character of the line. The only time it could happen is when we
have other mime
> > parts (attachments, etc.).
>
> Which are an extremely important case.  eCal may be unable to adopt CAP at
all unless we
> can have attachments (since our customers are Web sites, who want their
ads delivered to
> the users).

This is a non-issue. You can easily quote the '.' so attachments are not a
problem.

---

From: "Goodman, Stephen R (Rob), ALSVC" <[email-masked]>
Date: Tue, 18 May 1999 12:37:16 -0400

Amen, Pat, Amen!  :-)  <crlf> <crlf>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 18, 1999 11:08 AM
To: Dave Crocker
Cc: [email-masked]
Subject: Re: **YOU'RE INPUT NEEDED** Termination for SENDDATA command

Looks like there appears to be some rough concensus on <crlf>.<crlf>. Plus
it's an established practice.  I think we should put this one to bed.

---

From: Frank Dawson/CAM/Lotus <[email-masked]>
Date: Tue, 18 May 1999 17:54:58 GMT

Pat:

Thanks for stepping in on this. We were spending far too many cycles on a
continuing debate of a topic that already appeared closed.

I agree with the use of the CRLF PERIOD CRLF character sequence. AND...I
was the original individual that had brought up this issue!

- - Frank Dawson