Subject: Re: How to use CAP for scheduling events.

From: Doug Royer <[email-masked]>
Date: Tue, 1 Jun 1999 12:26:28 -0700 (PDT)

> Date: Sun, 30 May 1999 13:28:20 -0400
> From: Alexander Taler <[email-masked]>
> 
> Doug Royer wrote:
> > 
> > > Date: Mon, 24 May 1999 20:09:15 -0400
> > > From: Alexander Taler <[email-masked]>
> > >
> > > However, I feel that there is a need for an inbox at the
> > > protocol level.  If CAP incorporates iTIP, then it must support
> > > COUNTERs.  Clearly COUNTERs cannot be automatically accepted,
> > > so they must go somewhere else.  That somewhere else has to
> > > be accessible to whichever CUA I use, and therefore has to
> > > be in CAP.
> > 
> > But they can be automatically rejected - so there is no NEED for
> > an inbox - again - I see it as an implementation detail.
> 
> Doug, if I invite someone to an event, and they want to send me 
> a COUNTER, how do they do it?  All they have is my cap:// 
> caladdress from the organizer property.

CAP you an object that is an iTIP REPLY. And you can store it in any
way your implementation desires. No need to mandate an INBOX.
If your CS supports iTIP, you will need to know what to do with
it anyway as if it came from directly iMIP. 

If someone iMIP's your a COUNTER to your EMAIL-ADDRESS. How
will you be inserting it into your CS? I think via CAP.

-Doug
-------------------------------------------------------------------
[email-masked]		http://playground.sun.com/~dougr
Pager:				[email-masked]
801 W. El Camino #131		Work:   (650)786-7599
Mountain View, CA 94040		Ham Radio: N6AAW, Aviation: PP-ASEL

---

From: Alexander Taler <[email-masked]>
Date: Tue, 01 Jun 1999 17:03:09 -0400

> will you be inserting it into your CS? I think via CAP.

If someone sends me a counter via iMIP it goes into my 
mail server from which I download it using whichever 
protocol I prefer.  After cracking it open I figure out
what it means and then apply changes to my calendar
store as need be.

When you CAP me an iTIP COUNTER, how do I get this from
the calendar store?  Where and how in the calendar
store is this information kept?  I must be able to use
CAP to retrieve this information from the calendar store,
and it must not change any events in my calendar.

I agree that how it is stored in my CUA is an 
implementation detail, but how it travels from the CS
to my CUA is not.

Alex