Subject: Question : VDATA goal

From: Philippe Lesage <[email-masked]>
Date: Tue, 2 Nov 1999 12:04:40 -0800

I don t understand the goal of the VDATA component : When sould the CAP server
use a VDATA inside a VCALENDAR, and when should he just answer with a "normal"
VCALENDAR component  ?

thanks in advance.

regards,

Philippe.

---

From: Doug Royer <[email-masked]>
Date: Tue, 02 Nov 1999 12:44:13 -0800

It is written badly :-(   As I recall it...

The idea was that if you get a reply that contains a VDATA and
that VDATA DOES NOT contain any VCALENDAR data, then you know that the
query worked. However nothing matched or you do not have permission
to access the data (same difference to a CUA). The example in CAP-01
(and shown below) has NO VCALENDAR data at all. We also failed
to describe the fact that there could have been multiple VCALENDAR
objects inside of the VDATA.

A CS would use a VCALENDAR component not wrapped with VDATA only when
replying using scheduling commands (an iTIP method where the iTIP
restriction tables apply specifying what MUST be in the VCALENDAR object).
And the METHOD would be REPLY (not RESPONSE).

A CS would use a VDATA component whenever the data returned
from a query might be an empty set. Or whenever it might
have more than one result. And the METHOD would be RESPONSE.

>From CAP-01:
   If the UPN has no access to any events at all, the response will
   simply be an empty data set. The response looks the same if there are
   particular events to which the requester has been denied access.
 
   S: 2.0 cap://bobo.ex.com/sally
   S: Content-type:text/calendar; Method=RESPONSE;Component=VDATA;
   S:   Optinfo=VERSION:2.1
   S: Content-Transfer-Encoding: 7bit
   S:
   S: BEGIN:VCALENDAR
   S: VERSION:2.1
   S: BEGIN:VDATA
   S: END:VDATA
   S: END:VCALENDAR
   S: .