Subject: RE: SKiCal component property extension - PROMO

From: [email-masked]
Date: Thu, 1 Feb 2001 13:29:53 -0600

> We based PROMO on ATTACH, which is basically a URI place 
> holder. Looking
> again at ATTACH it appears to me that there is no method for 
> describing what
> the attachment actually contains.  Though you can say what type of
> attachment it is - you can not say "what it is about".
> 
Greg:

Are you looking for a comment about the attachment? Or are you looking for a
plain/text alternative to a richer content contained in the attachment?

For the former, you could use the existing COMMENT property. For the latter
you could use the ALTREP on the ATTACH property.

If you are worried about what format the attachment is in, then on your HTTP
request you would issue ACCEPT header to specify what format you can accept.

-- Frank

---

From: "Greg FitzPatrick" <[email-masked]>
Date: Fri, 2 Feb 2001 11:58:34 +0100

Frank

Would not that cause problems - using ALTREP on ATTACH?

Frank wrote:

:Are you looking for a comment about the attachment? Or are you looking for
a
:plain/text alternative to a richer content contained in the attachment?

:For the former, you could use the existing COMMENT property. For the latter
:you could use the ALTREP on the ATTACH property.