Subject: SV: SV: iptel and iCalendar

From: Pär Lannerö <[email-masked]>
Date: Tue, 27 Feb 2001 13:22:21 +0100

John Stracke wrote:
> Greg FitzPatrick wrote:
> > In our case the motivation is that as it stands 2445 can only "recur" one
> > thing - one meeting, in which all variables are fixed with the exception of
> > the recurrence dates.
>
> Sounds to me like a cleaner solution would be to create a subcomponent inside the
> VEVENT (or an associated VEVENT, or something) that describes the recurrence of some
> other characteristic.  Then you can reuse the RRULE, EXRULE, etc. properties by
> reference, without having to worry about copy-and-paste problems.

I agree, that sounds "cleaner", but is there a way to include and refer
to subcomponents inside a VEVENT? Would not that entail specifying a 
new construct similar to VTIMEZONE/TZID?

A VTIMESPEC component to specify time and recurrence rules for anything,
and a TSPECID property to refer to that component?

Like this:

BEGIN:VCALENDAR

BEGIN:VTIMESPEC
TSPECID:"Happy hours"
DTSTART:20010309T180000
DTEND:20010309T220000
END:VTIMESPEC

BEGIN:VEVENT
SUMMARY:My Club
DTSTART:20010309T180000
DTSTART:20010310T030000
EXT-SKI-PRICE;TSPECID="Happy hours";LABEL="Reduced entrance fee if you
 come early":40
EXT-SKI-PRICE:100
END:VEVENT

END:VCALENDAR

Is this what you mean John?

--
Pär Lannerö, Infostructure developer, Metamatrix AB, Stockholm
Mail: <[email-masked]>  Cellphone: +46 739 44 20 43
Work web: www.metamatrix.se   Personal web: www.lannero.com/p/

---

From: John Stracke <[email-masked]>
Date: Tue, 27 Feb 2001 10:50:00 -0500

> new construct similar to VTIMEZONE/TZID?

Sure.  Why not?

> [example]

> Is this what you mean John?

Yes.  It lets you use the same recurrence syntax for the extra metadata as for the event
itself.  In addition, if you have two bits of metadata that apply at the same time (e.g.,
happy hour and when hot food is served), then you can have them point at the same
VTIMESPEC, instead of having to duplicate the data.  It saves on bandwidth, and a smart
UI can use it to make the presentation clearer: tell the user, "In this time range, A and
B are true" instead of saying, "In this time range, A is true; in this time range, B is
true" (in which case you have to leave it up to the user to recognize that the two time
ranges are the same).

--
/==============================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own.|
|Chief Scientist |=============================================|
|eCal Corp.      |But this one goes to 11x.                    |
[email-masked]|                                             |
\==============================================================/