Subject: Ambiguous DATE-TIME values when clocks go back

From: Damon Chaplin <[email-masked]>
Date: Sun, 25 Mar 2001 02:42:05 +0100

I've just noticed there is no way to differentiate between the duplicated
times when clocks go back.

When clocks go back, say from 2am to 1am, you get the same hour
twice. So having a DTSTART like this is ambiguous:

   DTSTART;TZID=Europe/London:20011028T013000

It could be 1:30am local standard time or 1:30am daylight saving time.

(And similarly for any timezone change where the time is shifted back.)

Damon

---

From: Eric Busboom <[email-masked]>
Date: Tue, 27 Mar 2001 15:21:03 -0800 (PST)

> It could be 1:30am local standard time or 1:30am daylight saving time.

Perhaps we can declare that in cases like this DTSTART always falls on the
side of the shift that you are going to, and that DTEND is on the side of
the shift that you are coming from.  That is, the shift is always outside
the span of the event. This would keep events from crossing a shift if
they start or end on the shift.

So in your example, the time would be interpreted to be in Standard Time,
and if it was a DTEND, it would be interpreted to be in Daylight Savings
Time. 

eric.

---

From: Alan Davies <[email-masked]>
Date: Tue, 27 Mar 2001 22:16:05 -0500

>they start or end on the shift.

This wouldn't help events that start and end within the
time shift- if an event runs from 1:30 am to 1:40 am on
the night in question, is that 10 or 50 minutes, and if
it's ten minutes, which ten minutes (before or after the
shift)?

This may not seem important, but for some applications it
is vital. I once worked on a system where messages were
sent relating to the state of an Electricity Distribution
Network, regarding when and where operators where working.
If someone threw a switch 1 hour early, peoples lives
could be put in danger.

All possibly ambiguous times had to be qualified as to whether
they were 'Daylight' or 'Standard', it may only be 1 hour
per year, but it's a problem that could come back with a nasty bite
sometime if ignored.

--Alan