Subject: Re: Ambiguous DATE-TIME values when clocks go back

From: "Graham Gilmore" <[email-masked]>
Date: Tue, 27 Mar 2001 19:42:52 -0500

----- Original Message -----
From: "Eric Busboom" <[email-masked]>
To: "Damon Chaplin" <[email-masked]>
Cc: <[email-masked]>
Sent: 27 March, 2001 18:21
Subject: Re: Ambiguous DATE-TIME values when clocks go back

> On Sun, 25 Mar 2001, Damon Chaplin wrote:
>
> > When clocks go back, say from 2am to 1am, you get the same hour
> > twice. So having a DTSTART like this is ambiguous:
> >
> >    DTSTART;TZID=Europe/London:20011028T013000
> >
> > It could be 1:30am local standard time or 1:30am daylight saving
time.
>
> Perhaps we can declare that in cases like this DTSTART always falls on
the
> side of the shift that you are going to, and that DTEND is on the side
of
> the shift that you are coming from.  That is, the shift is always
outside
> the span of the event. This would keep events from crossing a shift if
> they start or end on the shift.
>
> So in your example, the time would be interpreted to be in Standard
Time,
> and if it was a DTEND, it would be interpreted to be in Daylight
Savings
> Time.

    I think disallowing events from starting at certain times is worse
than having the ambiguity.  Why not something like this:

DTSTART;TZID=Europe/London;TZTYPE=DAYLIGHT:20011028T013000

    which would specify 1:30 am daylight time, or

DTSTART;TZID=Europe/London;TZTYPE=STANDARD:20011028T013000

    which would specify 1:30 am standard time.

    Graham

---

From: Eric Busboom <[email-masked]>
Date: Wed, 28 Mar 2001 11:49:24 -0800 (PST)

> DTSTART;TZID=Europe/London;TZTYPE=DAYLIGHT:20011028T013000

Right. My suggestion made no sense. sorry. 

Even though I feels wrong to have to add a new paramter that can only be
use for one hour out of a year, I suspect there is no other choice. 

Although we could name the parameter after the similar one in the POSIX
time structure: DST=TRUE and DST=FALSE. 

eric.

---

From: Alan Davies <[email-masked]>
Date: Wed, 28 Mar 2001 15:27:18 -0500

This one might seem even more absurd, but what about
times that can't exist when the clocks go forward?

Normally what happens I believe is that the time
00:59:59 is immediately followed by the time 02:00:00
(or similar) when the clocks move forward. How should
01:30:00 on this date be treated?

This time could be considered as invalid by all
implementations if it is associated with a timezone,
but in iCalendar it's possible to express a floating
time (RFC 2445 4.3.5), with no guarantee that the time
will exist in all timezones.

Absurd case? Yes. Worth an explanatory sentence in the
RFC so that we all handle it consistently? Maybe...?

--Alan

---

From: Mark Tearle <[email-masked]>
Date: Thu, 29 Mar 2001 12:54:54 +0800 (WST)

> time structure: DST=TRUE and DST=FALSE.
Another spurious question, is Daylight savings consistently the same
amount of time around the world? (ie forward one hour in summer)

Yours
Mark
-- 
Mark Tearle - [email-masked]

"Will I survive, who will give a damn if no-one knows who I am?"
                                                       - Jekyll & Hyde

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 29 Mar 2001 07:36:39 +0200

>amount of time around the world? (ie forward one hour in summer)

No, not on the southern hemisphere. But, on the other hand, depends 
on what you mean by summer -- because summer is not the same time on 
all places on the planet.

   paf

---

From: Timothy Carl Buchheim <[email-masked]>
Date: Wed, 28 Mar 2001 22:16:01 -0800 (PST)

> amount of time around the world? (ie forward one hour in summer)

nope, it's only 30 minutes in at least one place. (Lord Howe Island,
Australia)

here's a list of daylight saving time transitions during the first half of
2001:

http://www.timeanddate.com/time/dst2001a.html

-- 

Tourist, Rincewind decided, meant "idiot".
        -- (Terry Pratchett, The Colour of Magic)

 ----------------------------------
 Tim Buchheim        [email-masked]
 HMC Computer Science Student Staff

---

From: Jonathan Lennox <[email-masked]>
Date: Thu, 29 Mar 2001 04:04:48 -0500 (EST)

> amount of time around the world? (ie forward one hour in summer)

Though I don't believe this occurs anywhere currently, historically there
have been regions that had "double" daylight time for part of the
summer (typically during wartime).  On the principle the TZ group uses ("any
crazy thing that legislatures have come up with in the past, someone's
likely to do again, so we need to support it"), a single
"standard"/"daylight" distinction isn't always sufficient to distinguish DST
rules.

-- 
Jonathan Lennox
[email-masked]