Subject: RE: Duration: Does 1 day == 24 hours?

From: [email-masked]
Date: Tue, 27 Mar 2001 18:40:30 -0600

I didn't think there was a problem with this.

If you specify a duration of 1 day, then it ends at the end of the day,
right? 

In the US, DST/ST jumps are set for a time period beginning early in the
morning (e.g., between 1 and 3 AM).

So, is this really a problem?

-- Frank

> One of the Reefknot developers noticed that iCalendar is ambiguous
> regarding how DURATION interacts with daylight savings time 
> changes. In
> particular, if you have an event with an end time that is 
> specified as a
> duration of 1 day, and the event crosses a daylight savings 
> time change,
> when does the event end?
> 
> Does it end 24 hours after the start time or 23 or 25 hours after the
> start time?
> 
> I'd suspect that the right things to do is to define 1 day to 
> mean "at the
> same time tomorrow" or something like that. 
> 
>

---

From: "Graham Gilmore" <[email-masked]>
Date: Tue, 27 Mar 2001 19:49:50 -0500

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: 27 March, 2001 19:40
Subject: RE: Duration: Does 1 day == 24 hours?

> If you specify a duration of 1 day, then it ends at the end of the
day,

    Do you mean to say that if I specify a meeting at 11:50 pm with a
duration of 1 day, it should be interpreted to end 10 minutes later?

    Graham