Subject: Re: Updates to appointments - clarification

From: Andrew Proud <[email-masked]>
Date: Thu, 1 Mar 2001 10:28:59 +0000 (GMT)

To clarify as requested.

I was thinking of the situation where an ics file is
received either by e-mail or openned directly from a
web page. (or a combination)

Example

- User visits Company A's website to find dates/times
of an event. 
- He downloads the details into his PIM directly from
the site.
- Company 'A' changes the date/time of the meeting. 

They now need some way of informing the user that the
details have changed. (Perhaps they collected his
e-mail address during the download process. )

The desired aproach from the company would be to
e-mail the user a new ics file. Then simply by
openeing the file the user would receive the new
dates/times.

It would be great if these new details could update
the old event details, rather than just be treated as
a new entry. If they do not, the user is forced to go
into his PIM and manually delete the original entry.

Andy

--- [email-masked] wrote: > John replied:
> >> If the event was created by importing an
> Icalendar
> >> file, there will be a unique ID. If a new event
> was
> >> sent with the same ID, could this not update the
> >> original event ?
> >
> >Might.  It'd be up to the implementation.
> 
> Guess Id have to ask Andrew "What do you mean by new
> event?" before I 
> could really answer.  If its already in the store
> then its not new now is 
> it?  New as in the user created a new entry and
> somehow the UID given it 
> matches?  New as in the user imported another
> iCalendar file and the same 
> UID was used?  Assumptions tend to bite our
> collective behinds in the long 
> run...
> 
> Andrew, could you clarify what you meant by "new
> event was sent"?
> 
> Bruce
>
===========================================================================
> Bruce Kahn                                INet:
> [email-masked]
> Iris Associates                          Phone:
> 978.392.5335
> Westford, MA, USA 01886                    FAX: and
> nothing but the FAX...
> Standard disclaimers apply, even where prohibited by
> law...
> 

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie

---

From: John Stracke <[email-masked]>
Date: Thu, 01 Mar 2001 09:03:33 -0500

> web page. (or a combination)

Right.  If the updated iCalendar has the same UID as the original, then the
recipient's CUA can match them up and replace the old one with the new.  The
CUA probably should not do this if the new iCalendar's SEQUENCE number is less
than the old one's.  However, again, "import an iCalendar" is not a defined
operation, so what the CUA does with the iCalendar is
implementation-dependent.  It could interpret it as the time at which to spam
the world with pictures of the user cavorting with naked tractors...though it
probably won't.  ;-)

Now, if the original iCalendar was an iTIP PUBLISH message, and the CUA
implements iTIP and accepts the iCalendar as an iTIP message, then, yes, the
updated message will cause the CUA to overwrite the old one (if the SEQUENCE
number is greater).

--
/===============================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own. |
|Chief Scientist |==============================================|
|eCal Corp.      |Some days, it just doesn't pay to gnaw through|
[email-masked]|the straps.                                   |
\===============================================================/