Subject: RE: Duration: Does 1 day == 24 hours?

From: [email-masked]
Date: Fri, 30 Mar 2001 09:07:12 -0600

> At 08.27 -0600 01-03-30, [email-masked] wrote:
> >Patrik:
> >
> >Good comments on this point. Did you take into account that 
> DTSTART can have
> >a purely date value, not just a date-time value? In this 
> case, changing the
> >DURATION to seconds (or clock time) would not make any sense. FYI.
> 
> This has nothing to do (from my point of view) with what I wrote.
> 
> I talked about the need for pointing out the danger of translating 
> one unit in the duration to another. For example from Minute to 
> Seconds, or Month to Days.
> 
I read into your note that you mentioned translation of a DURATION of months
or days into a seconds clock scale of the DTSTART. I was merely pointing
that no translation may be needed if DURATION is in DAYS and DSTART uses
";VALUE=DATE" parameter value. Unless you are comments on my comment that
you provided good comments ;-)

> >In any case, I concur with Graham that restricting DTSTART and
> >DTEND/DURATION to be values with the same calendar/clock 
> scale makes sense.
> >There appears to be no explicit requirement to maintain this 
> flexibility and
> >the limitation will minimize the complexity of comparisons 
> and will probably
> >assist in facilitating interoperability.
> 
> Can you have a recurrent event with a duration?

"Can you have", as in does RFC2445 allow it. Yep. Recurrence is specified
separately from DSTART and DTEND/DURATION. Recurrence is specified in the
RDATE/RRULE/EXDATE/EXRULE properties.

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 30 Mar 2001 20:06:53 +0200

>you provided good comments ;-)

He he he...ok, I should have read your note more carefully.

Danger when translation of units is the key issue though.

   paf