Subject: Re: UID & RECURRENCE-ID

From: "John Stracke" <[email-masked]>
Date: Fri, 8 Mar 2002 12:16:17 -0500

>You also need to be extremely careful when sending out itip requests to
>new attendees or canceling existing events.

Er? Can't you send out the REQUEST with the extra recurrence included?

/=========================================================\
|John Stracke                    |Principal Engineer      |
[email-masked]   |Incentive Systems, Inc. |
|http://www.incentivesystems.com |My opinions are my own. |
|=========================================================|
|I am Homer of Borg. Prepare to be assi... Mmm, doughnuts!|
\=========================================================/

---

From: JP Rosevear <[email-masked]>
Date: 08 Mar 2002 12:51:47 -0500

> Er? Can't you send out the REQUEST with the extra recurrence included?

Yes, but you need to recognize that.  Similarly for updating any common
properties, like summary.

-JP 
-- 
--
=======================================================================
JP Rosevear				[email-masked]
Ximian Inc.				http://www.ximian.com

---

From: Doug Royer <[email-masked]>
Date: Fri, 08 Mar 2002 11:20:06 -0700

> properties, like summary.

Summary can be unique per instance:

	BEGIN:VCALENDAR
	METHOD:REQUEST
	UID:1
	...
	BEGIN:VEVENT
	SUMMARY:summary 1
	DTSTART:...<today>....
	...
	RRULE:...every Friday...
	END:VEVENT
	END:VCALENDAR

Then later you add to UID:1 an instance for Tuesday:

	BEGIN:VEVENT
	METHOD:ADD
	UID:1
	...
	BEGIN:VEVENT
	SUMMARY:summary 2 unique to this instance
	DTSTART:...next-tue...
	END:VEVENT
	END:VCALEDAR