Subject: vQuery LIKE question

From: "ericp" <[email-masked]>
Date: Tue, 12 Mar 2002 08:26:48 -0500

Good Morning,

I've been going over Draft 7 of the CAP
specification, specifically the new LIKE
clause. Where performing comparisons
on a text property (for example DESCRIPTION 
or LOCATION), the draft indicates the LIKE 
comparisons are to be case insensitive.

SELECT * FROM VEVENT
WHERE LOCATION LIKE 'a%'

Would or should the comparison return a match 
if there is an accented version of the character
(i.e. à á â ã ä å)?

Or would the vQuery have to specify all cases
with an OR

SELECT * FROM VEVENT
WHERE LOCATION LIKE 'a%'
OR LOCATION LIKE 'à%'
OR LOCATION LIKE 'á%'
...etc...

Thanks,
Eric

-------------------------------
Eric R. Plamondon
Steltor - Chief Web Architect
2000 Peel Street, 4th Floor
Montreal, Quebec
mailto:[email-masked]
http://www.steltor.com

---

From: Doug Royer <[email-masked]>
Date: Tue, 12 Mar 2002 11:04:31 -0700

> Or would the vQuery have to specify all cases

I would think that 'a' would not match any of à á â ã ä or å.
As we modeled it after the SQL LIKE. It should do the same.

I am also not sure that those can be assumed to mean that they
are simply accented versions of the character in all languages.
But I am not an expert on languages.

---

From: "Shannon J. Clark" <[email-masked]>
Date: Tue, 12 Mar 2002 12:34:43 -0600

I think that this is something to look at in terms of internationalization
wit two parts of the SQL stuff that comes to mind.

one - the issue of LIKE that has been raised (are accented characters "like"
their non-accented versions?)

and

two - any instance where we might use a SORT - ideally the sort should then
be doable in the locale in question

Shannon

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Doug Royer
Sent: Tuesday, March 12, 2002 12:05 PM
Cc: [email-masked]
Subject: Re: vQuery LIKE question