Subject: CAP 10-17FEB03: Stored VAGENDAs?

From: [email-masked]
Date: Thu, 20 Feb 2003 18:05:53 -0500

I thought we reached WG agreement last month to remove the concept of 
stored VAGENDAs in CAP 1.0.  In the latest draft I still see them in the 
text:

3.2.  Calendar Store Object Model
[iCAL] describes components such as events, todos, alarms, and timezones. 
[CAP] requires additional object infrastructure. In particular, detailed 
definitions of the containers for events and todos (calendars), access 
control objects, and a query language. 
The conceptual model for a calendar store is shown below. The calendar 
store (VCALSTORE - section 9.2) contains "VCAR"s, "VQUERY"s, "VTIMEZONE"s, 
"VAGENDA"s and calendar store properties. 
Calendars (VAGENDAs) contain "VEVENT"s, "VTODO"s, "VJOURNAL"s, "VCAR"s, 
"VTIMEZONE"s, "VFREEBUSY", "VQUERY"s and calendar properties. 
[Snip]
Calendar Store

VCALSTORE
|
+-- properties
+-- VCARs
+-- VQUERYs
+-- VTIMEZONEs
+-- VAGENDA
|     |
|     +--properties
|     +--VEVENTs
|     |    |
|     |    +--VALARMs
|     +--VTODOs
|     |    |
|     |    +--VALARMs
|     +--VJOURNALs
|     +--VCARs
|     +--VTIMEZONEs
|     +--VQUERYs

Please chalk removing this up for the next draft.

Bruce
===========================================================================
Bruce Kahn                                INet: 
[email-masked]
Messaging & Collaboration                 Phone: 978.399.6496
IBM Software Group                         FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: [email-masked]
Date: Fri, 21 Feb 2003 11:49:13 -0500

If we reached agreement to remove it, then why do we need to wait a month 
to remove it?  Why not remove it now.

[email-masked]
Sent by: [email-masked]
02/20/2003 18:05

        To:     [email-masked]
        cc: 
        Subject:        CAP 10-17FEB03: Stored VAGENDAs?

store (VCALSTORE - section 9.2) contains "VCAR"s, "VQUERY"s, "VTIMEZONE"s, "VAGENDA"s and calendar store 
properties. 

VCALSTORE
|
+-- properties
+-- VCARs
+-- VQUERYs
+-- VTIMEZONEs
+-- VAGENDA
|     |
|     +--properties
|     +--VEVENTs
|     |    |
|     |    +--VALARMs
|     +--VTODOs
|     |    |
|     |    +--VALARMs
|     +--VJOURNALs
|     +--VCARs
|     +--VTIMEZONEs
|     +--VQUERYs

Bruce