Subject: REPLY to SEARCH [Was: CAP 10: CREATE Command and ordering of responses.]

From: Andrea Campi <[email-masked]>
Date: Mon, 10 Mar 2003 14:55:15 +0100

Sorry for not answering before, I'm really busy at the moment and I
can't give the topics we are discussing the attention the deserve.
However, I think I should at least answer this one.

On Tue, Feb 18, 2003 at 05:43:05PM -0500, [email-masked] wrote:
> > Uhm yes sorry I overlooked that (maybe because SEARCH doesn't behave 
> like
> > that: all commands return one match per VREPLY, apart from SEARCH where
> > it's not clear); but I think I got it right in the code ;-)
> 
> Please point out the unclearness in the draft so we can fix that!  Clarity 
> good, uncertainty bad!!

In 10.8 we have this text:

 The data in each result contains an iCalendar object composed of all
 the selected components enclosed in a "VREPLY" component.

First of all, I'm not sure this text is ok because SEARCH can select
"things" which are not components - and this sentence should be changed
to reflect that.

Apart from this, and assuming a query like SELECT * FROM VEVENT WHERE ....,
am I right in assuming I'll get back all selected VEVENT inside one VREPLY
(inside one VCALENDAR per target/method, as usual)? That is

BEGIN:VCALENDAR
BEGIN:VREPLY
BEGIN:VEVENT
...
END:VEVENT
BEGIN:VEVENT
...
END:VEVENT
END:VREPLY
END:VCALENDAR

and not:

BEGIN:VCALENDAR
BEGIN:VREPLY
BEGIN:VEVENT
...
END:VEVENT
END:VREPLY
BEGIN:VREPLY
BEGIN:VEVENT
...
END:VEVENT
END:VREPLY
END:VCALENDAR

I was just wondering whether this is intentional, given that this is
different from all commands (except GENERATE-UID).

Above all, this doesn't sound very useful when used with queries like
SELECT UID,ATTENDEE FROM VEVENT WHERE ...

If I'm just misunderstanding, then I think that sentence must be
clarified.

Bye,
	Andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A. - BT Ignite                  http://www.inet.it
Technical Dept. - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Mon, 10 Mar 2003 10:11:43 -0700

> "things" which are not components - and this sentence should be changed

Correct and thanks - I changed the text to be:

      The data in each result set contains one or more iCalendar components
      composed of all the selected results enclosed in a single "VREPLY"
      component per "QUERY".

      Only "REQUEST-STATUS" property and the properties mentioned in the
      "SELECT" clause of the QUERY are included in the components.
      Each "VCALENDAR" component is tagged with the "TARGET" property.

> (inside one VCALENDAR per target/method, as usual)? That is

I updated the reply text of the example that matched the text you
quoted above from CAP to be:

      Here the request was successful, however one of the "VEVENT" components
      contents were not accessible (4.1).

    S: Content-Type: text/calendar
    S:
    S: BEGIN:VCALENDAR
    S: TARGET:relcalid
    S: CMD:REPLY
    S: VERSION:2.0
    S: PRODID:-//someone's prodid
    S: BEGIN:VREPLY
    S: BEGIN:VEVENT
    S: REQUEST-STATUS:4.1
    S: END:VEVENT
    S: BEGIN:VEVENT
    S: REQUEST-STATUS:2.0
    S: UID:123
    S: DTEND:19990310T080000Z
    S: DSTART:19990310T190000Z
    S: SUMMARY: Big meeting
    S: END:VEVENT
    S: END:VREPLY
    S: END:VCALENDAR

-- 

  Doug Royer                     |   http://INET-Consulting.com
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards