Subject: Re: Charset

From: [email-masked]
Date: Fri, 07 Mar 2003 00:31:26 -0600

The original spec (RFC2445) required that the fidelity of the iCalendar 
object be maintained even after all of the MIME information was stripped 
off. The interpretation was that if something (e.g., Clipboard) took the 
object and repackaged and retransmitted it, it would remain unchanged 
between (inclusive)

BEGIN:VCALENDAR
...
END:VCALENDAR

So even though the spec was for MIME-encoded transmission of calendar 
objects, the MIME/message header was not to contain anything necessary to 
interpret the object. Unless and until changed, I would take that to mean 
that after the message is decoded, it would be back to UTF-8 or US ASCII. 
The spec was for "over-the-wire" transmission but the iCalendar object 
itself contained the specified parameter tags and values necessary to 
recreate the event by the receiving application.

Regards,
Ralph Patterson
LAN-ACES, Inc.
http://WWW.LAN-ACES.COM
*** End of comment ***

On Thursday, March 06, 2003  9:00 AM, Mark Swanson wrote:
>
>Date: Thu, 6 Mar 2003 10:00:22 -0500
>From: Mark Swanson
>To: "[email-masked]" <[email-masked]>
>Subject: Re: Charset
>
>On March 6, 2003 09:14 am, John Stracke wrote:
>> Doug Royer wrote:
>> > Why should we care if you can [...]
>> > Copy/Paste and object or not?
>>
>> Well, obviously, somebody cared when 2445 was written.  From the Abstract:
>>
>>    In
>>    addition, the content type is useful as an object for interactions
>>    between desktop applications using the operating system clipboard,
>
>Excellent quote!
>
>--
>Schedule your world with ScheduleWorld.com
>http://www.ScheduleWorld.com/
>Java Web Start:
>http://www.ScheduleWorld.com/sw/ScheduleWorld.jnlp
>
>

---

From: John Stracke <[email-masked]>
Date: Fri, 07 Mar 2003 10:15:42 -0500

[email-masked] wrote:

>off.
Can you cite a section, please?

-- 
/=================================================================\
|John Stracke      [email-masked]                          |
|Principal Engineer|http://www.centive.com                        |
|Centive           |My opinions are my own.                       |
|=================================================================|
|"We can't duplicate the bug." "Have you tried the Xerox machine?"|
\=================================================================/