Subject: Re: free-busy QUERY

From: [email-masked]
Date: Thu, 24 Jul 2003 14:56:12 -0400

Craig, this sounds well thought out.  Bruce, do you agree?  List, is this 
the right way to go.  I agree - let's work with our own standards.

"Craig Johnson" <[email-masked]>
Sent by: [email-masked]
07/24/2003 14:47

        To:     <[email-masked]>, <[email-masked]>
        cc: 
        Subject:        Re: free-busy QUERY

B Kahn Wrote:
 
> FWIW: CAP appears to be divergent from iTIP in doing 
> VFREEBUSY REQUEST/REPLYs given what I've read so far 
> in these recent threads.
 
YES!! YES!!  Thank-you! Thank-you!  That's one of the points I've been 
making (or trying to).
 
The ability to deal with free-busy information is fundamental to 
Calendaring & Scheduling.  It was so fundamental that the VFREEBUSY object 
was established to handle it.  Two key purposes of the VFREEBUSY object 
are (1) request busy time information, and (2) reply to a request with busy time information.
 
As previously noted, the CAP spec (-10) does NOT define how to request 
free-busy information.  So why doesn't CAP use the VFREEBUSY object to 
make the request?  It seems so obvious.  I do not understand the 
resistance toward using this Working Group's own standards to address this 
issue.
 
Instead, to bolster a VQUERY method, there has been flurry of new "spec 
text" generated and suggestions that appear to compromise CAP's support 
for iTIP.  This makes me uneasy (especially with final call approaching).  
Using VQUERY for free-busy requests is divergent from the Working Group's 
own standards.
 
Again, I propose that CAP use VFREEBUSY to make a request for free-busy 
information.  It could be done using SEARCH:
 
C: BEGIN:VCALENDAR
C: VERSION:2.0
C: PRODID:-//Someone's Prodid
C: CMD;ID=FB001:SEARCH
C: TARGET:usera
C: TARGET:userb
C: BEGIN:VFREEBUSY
C: DTSTART:startrange
C: DTEND:endrange
C: END:VFREEBUSY
C: END:VCALENDAR
 
Or we could give it its own command:
 
C: BEGIN:VCALENDAR
C: VERSION:2.0
C: PRODID:-//Someone's Prodid
C: CMD;ID=FB001:GET-FREEBUSY
C: TARGET:usera
C: TARGET:userb
C: BEGIN:VFREEBUSY
C: DTSTART:startrange
C: DTEND:endrange
C: END:VFREEBUSY
C: END:VCALENDAR
 
In either case, the CS dynamically provides the return information.  The 
request is simple.  It is unambiguous to the CS what data needs to be 
returned.  Consistency and continuity with the Working Group's previous 
standards are upheld.  Consistency between an iTIP vs CAP free-busy is 
secured.

---

From: Doug Royer <[email-masked]>
Date: Thu, 24 Jul 2003 13:48:50 -0600

Except for Graig's proposal is also not iTIP compliant and adds a
new component that is also called VFREEBUSY and does not look
like an iTIP VFREEBUSY.

[email-masked] wrote:
> 
> Craig, this sounds well thought out.  Bruce, do you agree?  List, is 
> this the right way to go.  I agree - let's work with our own standards.
> 
>
-- 

  Doug Royer                     |   http://INET-Consulting.com
  -------------------------------|-----------------------------
  [email-masked]                 | Office: (208)612-INET
  http://Royer.com/People/Doug   |    Fax: (866)594-8574
                                 |   Cell: (208)520-4044

                 We Do Standards - You Need Standards