Subject: [Ietf-calsify] DTEND clarification in draft-ietf-calsify-rfc2445bis-00.txt

From: PStephenson at gw.novell.com (Preston Stephenson)
Date: Thu Nov 17 08:31:12 2005

In section 7.1 Event Component, it states:
  The "DTEND" property for a "VEVENT" calendar component specifies
the non-inclusive end of the event.

In section 7.4  Free/Busy Component, it states:
  the "DTSTART" and "DTEND" properties specify an inclusive time
window
  that surrounds the busy time information;

It would seem that this implies DTEND is inclusive not
non-inclusive.
Isn't DTEND non-inclusive in this case?

In section 8.2.15.2  Date/Time End, it states:
   Description: Within the "VEVENT" calendar component, this
property
   defines the date and time by which the event ends.  The value MUST
be
   later in time than the value of the "DTSTART" property.

but in section 7.1.  Event Component it states:
   For cases where a "VEVENT" calendar component 
   specifies a "DTSTART" property with a DATE-TIME data type but no
   "DTEND" property, the event ends on the same calendar date and
time
   of day specified by the "DTSTART" property.

and also section 10.  Recommended Practices it states:
   2.  A calendar entry with a "DTSTART" property but no "DTEND"
   property does not take up any time.  It is intended to represent
an
   event that is associated with a given calendar date and time of
day,
   such as an anniversary.  Since the event does not take up any
time,
   it MUST NOT be used to record busy time no matter what the value
for
   the "TRANSP" property.

If not having a DTEND, it is defined to be the same as DTSTART,
why can't DTEND be defined to be the same as DTEND?

Or is it a matter of clarifying that you either have a DTEND
or you can't have a DTEND, if DTEND is the same as DTSTART?

Just my two bits.
Thanks.
Preston

---

From: Robert_Ransdell at notesdev.ibm.com (Robert Ransdell)
Date: Thu Nov 17 08:38:14 2005

My current thinking for Notes is as follows:

When there is no DTEND
     DTSTART is date   --- all day event
     DTSTART has a time component -- treat as alarm -- no busy time

             "Preston                                                      
             Stephenson"                                                   
             <[email-masked]                                          To 
             ovell.com>                <[email-masked]>    
             Sent by:                                                   cc 
             ietf-calsify-boun                                             
             ces@osafoundation                                     Subject 
             .org                      [Ietf-calsify] DTEND clarification  
                                       in                                  
                                       draft-ietf-calsify-rfc2445bis-00.tx 
             11/17/2005 11:31          t                                   
             AM                                                            

Just my two bits.
Thanks.
Preston

_______________________________________________
Ietf-calsify mailing list
[email-masked]
http://lists.osafoundation.org/mailman/listinfo/ietf-calsify