Subject: [Ietf-calsify] Propose to close issues 37, 38, 39

From: lear at cisco.com (Eliot Lear)
Date: Fri Sep 8 03:11:36 2006

Each of these issues has proposed text and there has been no objection
to it.

37
	4.6.1 Event Component: eventprop

 >  eventprop  = *(
 >
 >             ; the following are both REQUIRED,
 >             ; but MUST NOT occur more than once
 >
 >             dtstamp / dtstart / uid /
 >
 >             ; the following are optional,
 >             ; but MUST NOT occur more than once

	No objections.
38
	VTODO todoprop

 >  todoprop  = *(
 >
 >            ; the following are both REQUIRED,
 >            ; but MUST NOT occur more than once
 >
 >            dtstamp / uid /
 >
 >            ; the following are optional,
 >            ; but MUST NOT occur more than once
 >
 >            ...

	No objections.
39
	VJOURNAL journalprop

 >  jourprop = *(
 >
 >           ; the following are both REQUIRED,
 >           ; but MUST NOT occur more than once
 >
 >           dtstamp / uid /
 >
 >           ; the following are optional,
 >           ; but MUST NOT occur more than once

	No objections.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osafoundation.org/pipermail/ietf-calsify/attachments/20060908/c751c620/attachment.htm

---

From: mvl at exedo.nl (Michiel van Leeuwen)
Date: Wed Sep 13 13:58:02 2006

>  >             dtstamp / dtstart / uid /

The text speaks of 'both', while there are three items. Shouldn't that 
be 'all three' then?

Michiel

---

From: sandy at WEIJax.com (Sandy Wills)
Date: Wed Sep 13 14:10:37 2006

> The text speaks of 'both', while there are three items. Shouldn't that 

The "both" refers to having two requirements, not to how many items are 
on the list.

<expansion>
The following list (no matter how long) has both of these requirements:
   A) all items in the list are REQUIRED, and
   B) each item MUST NOT occur more than once.
List items: dtstamp, dtstart, uid
</expansion>

-- 
Unable to locate coffee.
Operator halted.

---

From: sroberts at uniserve.com (Sam Roberts)
Date: Wed Sep 13 16:38:25 2006

> The "both" refers to having two requirements, not to how many items are 

I thought the phrasing was a bit confusing, too. It might even be
ungrammatical, usually people say "both this AND that".

Anyhow, the "both" and the "but" are unncessary, may I suggest:

  "the following are REQUIRED and MUST NOT occur more than once"

This kind of text show up a lot, isn't it the same wording everywhere?

Cheers,
Sam

---

From: lear at cisco.com (Eliot Lear)
Date: Wed Sep 13 22:48:34 2006

> The text speaks of 'both', while there are three items. Shouldn't that

Yes, this seems to be more appropriate.

Eliot