Subject: [calsify] When is DUE;VALUE=DATE:2022-01-23 overdue?

From: Dilyan Palauzov <[email-masked]>
Date: Sun, 23 Jan 2022 06:09:56 +0000

Hello,

calendar/task applications have the notion to highlight overdue tasks  
somehow, e.g. by colouring them in red or spelling the word “overdue”.

When shall an application mark DUE;VALUE=DATE:2022-01-23 as overdue?

A) When the midnight 22/23 January passes.  At 2022-01-22T23:59:59 it  
is not overdue.  At 2022-01-23T00:00:01 it is overdue.
B) When the midnight 23/24 January passes.  At 2022-01-23T23:59:59 it  
is not overdue.  At 2022-01-24T00:00:01 it is overdue.

https://datatracker.ietf.org/doc/html/rfc5545#page-57 contains an  
example of such a task.  For some readers this example is not clear  
enough which midnight is meant (the 30 Apr/1 May midnight, or the 1/2  
may Midnight).

Some task applications take the A) approach, others take the B) approach.

I will ask the same question in a completely different way.

https://datatracker.ietf.org/doc/html/rfc5545#section-3.8.2.2 says for  
VTODO: the value of the "DUE" property must be later in time than the  
value of the "DTSTART" property.

An event which lasts only today, is written as:
BEGIN:VEVENT
DTSTART;VALUE=DATE:20220123
DTEND;VALUE=DATE:20220124
END:VEVENT

How do you write a task, which starts today (may not be performed  
yesterday) and must be completed on the day it started?
C)
BEGIN:VTODO
DTSTART;VALUE=DATE:20220123
DUE;VALUE=DATE:20220124
END:VTODO

or D)
BEGIN:VTODO
DTSTART;VALUE=DATE:20220123
DUE;VALUE=DATE:20220123
END:VTODO

C) is very close to how “one whole day event” is written. D) violates  
«the value of the "DUE" property must be later in time than the value  
of the "DTSTART" property» rule.

Some applications implement C), others implement D).

Greetings
   Дилян

---

From: [email-masked]
Date: Sun, 23 Jan 2022 16:51:35 -0800

In this instance I would set DTSTART and DUE to use a date _and_ time, with DTSTART using time 00:00:00 on that day and DUE using 23:59:59 on that day. You could, of course, use the beginning and ending of an organization's work hours instead

Tim Hare
Interested Bystander, Non-Inc.

-----Original Message-----
From: Dilyan Palauzov <[email-masked]>
To: [email-masked]
Sent: Sat, 22 Jan 2022 22:09
Subject: [calsify] When is DUE;VALUE=DATE:2022-01-23 overdue?

Hello,

or D)
BEGIN:VTODO

Greetings
   Дилян

_______________________________________________
calsify mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/calsify