Subject: [calsify] «For a given pair of "UID" and "SEQUENCE" property values, the "RECURRENCE-ID" value for a recurrence instance is fixed.»

From: Dilyan Palauzov <[email-masked]>
Date: Mon, 03 Jan 2022 18:20:50 +0000

Hello,

https://datatracker.ietf.org/doc/html/rfc5545#page-113 says for  
RECURRENCE-ID: «For a given pair of "UID" and "SEQUENCE" property  
values, the "RECURRENCE-ID" value for a recurrence instance is fixed.»

Consider this iCalendar object:

BEGIN:VCALENDAR
VERSION:2.0
BEGIN:VEVENT
UID:123
SEQUENCE:1
DTSTART:20211201T221500Z
DTEND:20211201T223000Z
SUMMARY:ANNA NANA ANAN NANA
RRULE:FREQ=DAILY;COUNT=14
END:VEVENT
BEGIN:VEVENT
UID:123
SEQUENCE:2
DTSTART:20211208T221500Z
DTEND:20211208T223000Z
SUMMARY:Exception
RECURRENCE-ID:20211208T221500Z
END:VEVENT
BEGIN:VEVENT
UID:123
SEQUENCE:2
DTSTART:20211213T103000Z
DTEND:20211213T230000Z
SUMMARY:Another exception
RECURRENCE-ID:20211213T221500Z
END:EVENT
END:VCALENDAR

As can be seen, the last two VEVENTs have the same UID and SEQUENCE,  
but different RECURRENCE-ID.  So for a given UID and SEQUENCE, the  
RECURRENCE-ID is not fixed in that file.

Is the VCALENDAR valid or invalid?

Greetings
   Дилян

---

From: "Neil Jenkins" <[email-masked]>
Date: Thu, 06 Jan 2022 16:33:24 +1100

> values, the "RECURRENCE-ID" value for a recurrence instance is fixed.»

Given the text above, I'm pretty sure that "for a recurrence instance" means a specific instance of a recurring event. This seems a bit tautological to me, as the recurrence id by definition is unique for a specific recurrence instance of a particualr UID, regardless of SEQUENCE. I'm not sure what the authors really intended to say there, but my reading is this statement doesn't really mean anything.

> Is the VCALENDAR valid or invalid?

So based on the above, my view is that this is valid.

—Neil