Subject: [Captive-portals] today's BoF

From: Erik Kline <[email-masked]>
Date: Mon, 14 Nov 2016 13:36:44 +0900

All,

I wasn't able to get everything, and I started late.  What follows is
a raw dump of what I was able to capture.

-Erik

=====

Met in Park Ballroom 1
Note Well applies (Warren displayed it on is phone to the room :-)

--
Partial attendees list:

Margaret Cullen
Mariko Kobayashi
Barry Leiba
Hugo Benichi
Tommy Pauly
David Schinazi
Warren Kumari
Erik Kline
Lorenzo Colitti
Dan Gilmor
Mark Donnelley
Mikael Abrahamsson

Notably absent:
- David Bird
--

Everyone familiar with RFC 7710

HTTP code 511, RFC 6585

Mariko Kobayashi volunteers to write industry survey of captive portals!

Abrahamsson: there is lots of overlap with alto working group

Desirable to solve:
- automatic login, with credentials
- time left on the clock / expiration time
- agree to legal terms? clients cache hashes of known acceptable terms
of service?
- hotel room number and last name style login?
- different categories of service
- agree on simple authentication mechanism
- data allotment (usage based)
- query current status (maintain a persistent connection?)
- what to do when provisioning is done: use as is, teardown and re-associate
    - a la provisioning APNs

Apple and Android watch don't have browsers, so can't login into captive portals

Margaret and Donnelley volunteer to write a document proposing a REST API
- Use 7710
- call REST API on 7710 URI
- includes what you need to do to access the portal
- want to include expiration time...

Coova chili has a REST API
- open source captive portal
- should look at this for comparison/...

Schinazi: in France any public wifi requires name, email and terms of service

Some discussion of the ICMP messages.

Usage-based captive portals.

Barry volunteers to discuss being a co-chair

---

From: David Bird <[email-masked]>
Date: Sun, 13 Nov 2016 21:34:51 -0800

> - David Bird
Sorry I couldn't make it, I'm not at IETF.

> - automatic login, with credentials
Sounds like HS2.0

> - time left on the clock / expiration time
Can be signaled with ICMP I-D

> - agree to legal terms? clients cache hashes of known acceptable terms
This seems out of place for the W.G. I suggest we focus on networking, not
application, issues.

> - hotel room number and last name style login?
Same here

> - different categories of service
signaling the existence of additional classes of service (e.g. you are
currently at a low QoS, but can go higher?), or?

> - agree on simple authentication mechanism
WISPr? :)

Why query when ICMP informs...

> - what to do when provisioning is done: use as is, teardown and
HS2.0?

> - call REST API on 7710 URI

I think it is a tall order to ask this API to give you a complete picture
of your captivity. Will it will return a list of all resources you can
freely access within the walled garden, for example? (That would tell the
user a lot about your network and partnerships...)  My though is that the
station should, for the most part, assume it can access resources until it
is told it can't ... learning the bounds of it's captivity on a need to
know basis.

> Some discussion of the ICMP messages.
I believe :) the CP ICMP I-D is a simple signal, with a similar purpose to
existing ICMP messages for packet drop signaling, that, together with
RFC7710, solves some of the mentioned issues, and a big one not mentioned
in the list: fixing the HTTPS "home page" problem.

> _______________________________________________
> Captive-portals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/captive-portals
>

---

From: <[email-masked]>
Date: Mon, 14 Nov 2016 06:40:06 +0000

Hi Eric

Thanks for taking notes during the BoF. 
I added several lines. 
See inline (prefixed with a +).

Emile

-----Original Message-----
From: Captive-portals [mailto:[email-masked]] On Behalf Of Erik Kline
Sent: lundi 14 novembre 2016 05:37
To: [email-masked]
Subject: [Captive-portals] today's BoF

All,

I wasn't able to get everything, and I started late.  What follows is a raw dump of what I was able to capture.

-Erik

=====

Met in Park Ballroom 1

--
Partial attendees list:

Margaret Cullen
Mariko Kobayashi
Barry Leiba
Hugo Benichi
Tommy Pauly
David Schinazi
Warren Kumari
Erik Kline
Lorenzo Colitti
Dan Gilmor
Mark Donnelley
Mikael Abrahamsson
+Emile Stephan

Notably absent:
- David Bird
--

HTTP code 511, RFC 6585

Desirable to solve:
- agree to legal terms? clients cache hashes of known acceptable terms of service?
+ ~same as above with mobile attachment (mobile use cases).

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: mariko kobayashi <[email-masked]>
Date: Mon, 14 Nov 2016 22:48:06 +0900

Hi all,

I am so glad that many people joined capport lunch BoF. Thank you!
Let's discuss actively on the mailing lists,  publish drafts,
and have an official meeting in the next IETF.

 >Erik
Thank you so much for your note taking!

Thanks,
Mariko

-- 
------------------------------------------------⭐︎

　Mariko Kobayashi([email-masked])
　Keio Univ. SFC B4
   Jun Murai Lab./WIDE1854/ao(あお)
　
---------------------------⭐︎