Subject: [Captive-portals] Draft Agenda for IETF 98

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Mar 2017 11:51:33 +1100

I've just uploaded an agenda for the meeting.  Those who are
identified here, please get me your slides before the meeting starts
(ideally before the 26th, for all except the last, which I don't
expect to need a presentation).  Plan on no more than 10 minutes of
presenting so that we can have some discussion and questions while we
also keep to schedule.

https://datatracker.ietf.org/doc/agenda-98-capport/
~~~
Captive Portals (capport, [email-masked])

IETF 98 Chicago
2017-03-28 1450-1620 Zurich D

Administrivia                          Chair(s)          10m

Japanese Survey                        Mariko Kobayashi  15m

draft-larose-capport-architecture-00   Kyle Larose       15m

draft-bruneau-pvd-00                   Tommy Pauly       15m

Hackathon Report                       Kyle Larose       10m

---

From: Margaret Cullen <[email-masked]>
Date: Mon, 13 Mar 2017 19:23:15 -0400

Hi Martin,

We just published a draft that specifies a CAPPORT API (see below).  I wrote to the chairs a couple of weeks back (before the scheduling deadline) to give you a heads up that this was coming.  It took a little longer than we expected, in part due to changes we made to align more closely with the CAPPORT Architecture document.

Ideally, we’d like to present this document in Chicago.

Thanks,
Margaret

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-donnelly-capport-detection-00.txt
> Date: March 13, 2017 at 7:07:28 PM EDT
> To: "Mark Donnelly" <[email-masked]>, "Margaret Cullen" <[email-masked]>
> 
> 
> A new version of I-D, draft-donnelly-capport-detection-00.txt
> has been successfully submitted by Mark Donnelly and posted to the
> IETF repository.
> 
> Name:		draft-donnelly-capport-detection
> Revision:	00
> Title:		Captive Portal Detection and Interaction
> Document date:	2017-03-13
> Group:		Individual Submission
> Pages:		13
> URL:            https://www.ietf.org/internet-drafts/draft-donnelly-capport-detection-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-donnelly-capport-detection/
> Htmlized:       https://tools.ietf.org/html/draft-donnelly-capport-detection-00
> 
> 
> Abstract:
>   This document describes an HTTP API that allows User Equipment to
>   detect the existence of a Captive Portal on the local network,
>   determine the properties of the Captive Portal, and satisfy
>   requirements for network access.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

> On Mar 12, 2017, at 8:51 PM, Martin Thomson <[email-masked]> wrote:
> 
> _______________________________________________
> Captive-portals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/captive-portals

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Mar 2017 10:36:46 +1100

It turns out that we had a little time spare.  I've updated the agenda:

IETF 98 Chicago

draft-donnelly-capport-detection-00    Margaret Cullen   15m

On 14 March 2017 at 10:23, Margaret Cullen <[email-masked]> wrote:
>
> Hi Martin,
>
> We just published a draft that specifies a CAPPORT API (see below).  I wrote
> to the chairs a couple of weeks back (before the scheduling deadline) to
> give you a heads up that this was coming.  It took a little longer than we
> expected, in part due to changes we made to align more closely with the
> CAPPORT Architecture document.
>
> URL:
> https://www.ietf.org/internet-drafts/draft-donnelly-capport-detection-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-donnelly-capport-detection/
> Htmlized:
> https://tools.ietf.org/html/draft-donnelly-capport-detection-00
>
>
> Abstract:

---

From: Margaret Cullen <[email-masked]>
Date: Mon, 13 Mar 2017 19:58:11 -0400

Thanks, Martin!  

I just submitted a -01 version to change the title of the document (to make it clear that it defines a CAPPORT API, as defined in the Architecture Document.  We had already changed the text, but I forgot to change the actual title :-)).  I also fixed a few typos that slipped through the first time.  So, we will actually be presenting the -01 version in Chicago.

It is great to see this group finally moving along!!

Margaret

> On Mar 13, 2017, at 7:36 PM, Martin Thomson <[email-masked]> wrote:
>

---

From: Warren Kumari <[email-masked]>
Date: Tue, 14 Mar 2017 15:58:49 +0100

> It is great to see this group finally moving along!!

Indeed. Thanks to everyone who has contributed text, is willing to
present, and the hackathon organizing...

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf