Subject: [Captive-portals] Follow up on hackathon results

From: Kyle Larose <[email-masked]>
Date: Wed, 29 Mar 2017 20:21:30 +0000

Hello everyone,

It was pointed out to me at the meeting yesterday that I hadn’t posted to the capport mailing list the code and such that we worked on during the hackathon. 
Since I encouraged people to continue hacking on it, I probably should. ☺

Here it is.

• Coova chilli: https://github.com/coova/coova-chilli/tree/capport-icmp
   - This is the captive portal enforcement platform

• Icmpd and DHCP client work: https://github.com/klarose/capport_98
   - The DHCP stuff only talks about how to do it right now.

• REST API: https://github.com/darshakthakore/capport-detection
   - This is intended to run on the same host as the captive portal enforcement platform

• Wireshark: https://code.wireshark.org/review/#/c/20584/1
• Tcpdump: https://github.com/ThreadedThinking/tcpdump

If anyone has worked on this since then/has newer locations or stuff, please let the mailing list know!

As an aside, we're planning on presenting our work at Bits and Bytes. So if you're interested in seeing it in action, please drop by the hackathon booth!

Thanks,

Kyle

---

From: Michael Richardson <[email-masked]>
Date: Wed, 29 Mar 2017 17:14:49 -0400

> please let the mailing list know!

Hi, I sure hope you have pcap files with the captured new ICMPs, for the
tcpdump tests/ subdirectory.  Please touch ".devel" and run "make check"
And please send pull request; your code looks well formed to me.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-