Subject: [Captive-portals] Capport project at the IETF 98 hackathon

From: Kyle Larose <[email-masked]>
Date: Thu, 2 Mar 2017 16:17:42 +0000

Hello everyone,

I've put up some ideas for hackathon projects related to captive portal on the hackathon wiki (https://www.ietf.org/registration/MeetingWiki/wiki/doku.php?id=98hackathon)

* Champion(s)
   o Kyle Larose [email-masked]
   o Others welcome. :)
* Project(s)
   o Finish up the icmp I-D (https://tools.ietf.org/html/draft-wkumari-capport-icmp-unreach-01) in coova-chili
   o Try out various client solutions for consuming the icmp message.
   o Try to find security holes in the icmp I-D, and plug them (the output being suggestions to improve the I-D)
   o Work on defining and implementing a REST API for https://tools.ietf.org/html/rfc7710.

I doubt I'll actually be able to work on all of these over the weekend, so if anyone wants to contribute, let me know.

Looking forward to hacking away!

Kyle

---

From: Martin Thomson <[email-masked]>
Date: Fri, 3 Mar 2017 10:56:17 +1100

Thanks for arranging this Kyle.  I'll be floating around the
hackathon, at least on Saturday and would be happy to lend a hand.

On 3 March 2017 at 03:17, Kyle Larose <[email-masked]> wrote:
> _______________________________________________
> Captive-portals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/captive-portals

---

From: Alexis La Goutte <[email-masked]>
Date: Wed, 8 Mar 2017 06:57:49 +0100

Hi,

It is possible to follow the hackathon by remote ?
I can help for implement icmp I-D (https://tools.ietf.org/html/
draft-wkumari-capport-icmp-unreach-01) in Wireshark

Cheers

On Fri, Mar 3, 2017 at 12:56 AM, Martin Thomson <[email-masked]>
wrote:

> > I've put up some ideas for hackathon projects related to captive portal
> on the hackathon wiki (https://www.ietf.org/registration/MeetingWiki/wiki/
> doku.php?id=98hackathon)
> >
> > * Champion(s)
> >    o Finish up the icmp I-D (https://tools.ietf.org/html/
> draft-wkumari-capport-icmp-unreach-01) in coova-chili
> >    o Try to find security holes in the icmp I-D, and plug them (the
> output being suggestions to improve the I-D)
> > I doubt I'll actually be able to work on all of these over the weekend,
> so if anyone wants to contribute, let me know.
> >

---

From: Kyle Larose <[email-masked]>
Date: Wed, 8 Mar 2017 14:16:38 +0000

BCC the lists and others.

Sure! Some extra help would be great, and being able to analyze the packets would also be nice.

Regarding remote participation, if anyone has suggestions on collaboration technology that has been used effectively in the past for hackathons, please let me know.

To keep things in sync, we should probably do our work in git. I'll set up github repos for the three major parts:
 * A fork of coova-chili to work on the icmp I-D
 * A new repo to play around with client side stuff
 * A repo for the rest API work

Had you planned on implementing the icmp stuff in wireshark as a plugin? If so, I can create a repo for you as well (though you can yourself if you want. :))

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexis La Goutte
Sent: Wednesday, March 08, 2017 12:58 AM
To: Martin Thomson
Cc: Kyle Larose; [email-masked]; [email-masked]
Subject: Re: [Captive-portals] Capport project at the IETF 98 hackathon

Hi,
It is possible to follow the hackathon by remote ?
I can help for implement icmp I-D (https://tools.ietf.org/html/draft-wkumari-capport-icmp-unreach-01) in Wireshark
Cheers

On Fri, Mar 3, 2017 at 12:56 AM, Martin Thomson <[email-masked]> wrote:
Thanks for arranging this Kyle.  I'll be floating around the
hackathon, at least on Saturday and would be happy to lend a hand.

---

From: David Bird <[email-masked]>
Date: Thu, 9 Mar 2017 20:10:48 -0800

Hi Kyle,

Thanks for organizing this! I would be happy to help out with the
hackathon... I will be there both days.

See you there

On Thu, Mar 2, 2017 at 8:17 AM, Kyle Larose <[email-masked]> wrote:

> Hello everyone,
>
> I've put up some ideas for hackathon projects related to captive portal on
> the hackathon wiki (https://www.ietf.org/registration/MeetingWiki/wiki/
> doku.php?id=98hackathon)
>
> * Champion(s)
> I doubt I'll actually be able to work on all of these over the weekend, so
> if anyone wants to contribute, let me know.
>