Subject: [Captive-portals] Not good....

From: David Bird <[email-masked]>
Date: Fri, 31 Mar 2017 12:27:12 -0700

Wi-Fi at Chicago O'Hare Airport defeating Chome captive portal check. They
also require using their DHCP assigned DNS (why don't they just DNAT DNS to
their server, I don't know -- chilli will do that :)

It is impossible for my to get the portal using Android...

GET /generate_204 HTTP/1.1
Host: captive-portal-check.appspot.com
Connection: keep-alive
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3)
AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Accept: */*
Accept-Encoding: gzip, deflate, sdch
Accept-Language: en-US,en;q=0.8

HTTP/1.1 302 Found
Location: https://via.boingohotspot.net/login
Connection: close
Content-Type: text/html; charset=utf-8
Content-Length: 343

<!--<?xml version="1.0" encoding="UTF-8"?><WISPAccessGatewayParam
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:noNamespaceSchemaLocation="
http://www.acmewisp.com/WISPAccessGatewayParam.xsd"><Redirect><LoginURL>
https://via.boingohotspot.net/login
</LoginURL><MessageType>100</MessageType></Redirect></WISPAccessGatewayParam>-->

---

From: David Bird <[email-masked]>
Date: Fri, 31 Mar 2017 12:33:16 -0700

Sorry, the true issue is just the DNS. The capport detection should be
working in this case... But, the DNS limitation is what is preventing my
laptop and android from getting capport notification.

On Fri, Mar 31, 2017 at 12:27 PM, David Bird <[email-masked]> wrote:

> xsi:noNamespaceSchemaLocation="http://www.acmewisp.com/
> WISPAccessGatewayParam.xsd"><Redirect><LoginURL>https://
> via.boingohotspot.net/login</LoginURL><MessageType>100</
> MessageType></Redirect></WISPAccessGatewayParam>-->
>

---

From: Erik Kline <[email-masked]>
Date: Fri, 31 Mar 2017 14:34:27 -0500

Android should absolutely be using the supplied DNS servers.  Unless
something really strange is going on...

On 31 March 2017 at 14:33, David Bird <[email-masked]> wrote:

>> Wi-Fi at Chicago O'Hare Airport defeating Chome captive portal check.
>> They also require using their DHCP assigned DNS (why don't they just DNAT
>> DNS to their server, I don't know -- chilli will do that :)
>>
>> xsi:noNamespaceSchemaLocation="http://www.acmewisp.com/WISPA
>> ccessGatewayParam.xsd"><Redirect><LoginURL>https://via.
>> boingohotspot.net/login</LoginURL><MessageType>100</MessageT
>> ype></Redirect></WISPAccessGatewayParam>-->
>>
>
>
> _______________________________________________
> Captive-portals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/captive-portals
>
>

---

From: David Bird <[email-masked]>
Date: Fri, 31 Mar 2017 13:05:35 -0700

On further inspection (monitor mode wireshark capture from laptop) reveals
that my Droid never gets a DHCP response. It looks to me that they are not
allowing any phones to connect, only laptops. Why, I do not know.

On Mar 31, 2017 2:34 PM, "Erik Kline" <[email-masked]> wrote:

>>> ccessGatewayParam.xsd"><Redirect><LoginURL>https://via.boing
>>> ohotspot.net/login</LoginURL><MessageType>100</MessageType><
>>> /Redirect></WISPAccessGatewayParam>-->
>>>
>>
>>

---

From: David Bird <[email-masked]>
Date: Fri, 31 Mar 2017 13:15:32 -0700

http://articles.chicagotribune.com/2013-05-23/business/chi-ohare-midway-free-wifi-20130522_1_free-wi-fi-chicago-airports-andolino

Worth noting, it seems that they intend for some resources to be freely
accessible within the walled garden. But, capport detection is often all or
nothing... Would be nice if that was more granular.