Subject: Re: [Captive-portals] Follow up on hackathon results

From: David Bird <[email-masked]>
Date: Sat, 1 Apr 2017 13:13:10 -0700

Thanks Kyle for getting this organized and focused! It was a lot of fun
too..

On Wed, Mar 29, 2017 at 1:21 PM, Kyle Larose <[email-masked]> wrote:

> Hello everyone,
>
> It was pointed out to me at the meeting yesterday that I hadn’t posted to
> the capport mailing list the code and such that we worked on during the
> hackathon.
> Since I encouraged people to continue hacking on it, I probably should. ☺
>
> Here it is.
>
> • Coova chilli: https://github.com/coova/coova-chilli/tree/capport-icmp
>    - This is the captive portal enforcement platform
>
> • Icmpd and DHCP client work: https://github.com/klarose/capport_98
>    - The DHCP stuff only talks about how to do it right now.
>
> • REST API: https://github.com/darshakthakore/capport-detection
>    - This is intended to run on the same host as the captive portal
> enforcement platform
>
> • Wireshark: https://code.wireshark.org/review/#/c/20584/1
> • Tcpdump: https://github.com/ThreadedThinking/tcpdump
>
> If anyone has worked on this since then/has newer locations or stuff,
> please let the mailing list know!
>
> As an aside, we're planning on presenting our work at Bits and Bytes. So
> if you're interested in seeing it in action, please drop by the hackathon
> booth!
>
> Thanks,
>
>
> Kyle
>
> _______________________________________________
> Captive-portals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/captive-portals
>

---

From: Darshak Thakore <[email-masked]>
Date: Sun, 2 Apr 2017 18:52:12 +0000

Likewise. It was certainly worthwhile.

Darshak

From: Captive-portals <[email-masked]> on behalf of David Bird <[email-masked]>
Date: Saturday, April 1, 2017 at 2:13 PM
To: Kyle Larose <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Captive-portals] Follow up on hackathon results

Thanks Kyle for getting this organized and focused! It was a lot of fun too..

On Wed, Mar 29, 2017 at 1:21 PM, Kyle Larose <[email-masked]<mailto:[email-masked]>> wrote:
Hello everyone,

It was pointed out to me at the meeting yesterday that I hadn’t posted to the capport mailing list the code and such that we worked on during the hackathon.
Since I encouraged people to continue hacking on it, I probably should. ☺

Here it is.

• REST API: https://github.com/darshakthakore/capport-detection
   - This is intended to run on the same host as the captive portal enforcement platform

If anyone has worked on this since then/has newer locations or stuff, please let the mailing list know!

As an aside, we're planning on presenting our work at Bits and Bytes. So if you're interested in seeing it in action, please drop by the hackathon booth!

Thanks,

Kyle

_______________________________________________
Captive-portals mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/captive-portals