Subject: [Capwap] Additions #12 - Future Wireless Technologies

From: "Saravanan Govindan" <[email-masked]>
Date: Wed, 23 Feb 2005 17:57:56 +0800

Additions #12 - Future Wireless Technologies

Issue: 

Replace subsections as full objectives so they can be reviewed independently. Replace
subsection-5.2.4i-'Enable Support for Future Wireless Technologies' as a separate objective titled
'Support for Future Wireless Technologies'.

Proposed change: 

Classification: Architecture                                                 

Priority: Desirable                                                             

Description: 

The rapid pace of technology developments means that new advances need to be catered for in current
analyses. Among these is the support for new wireless technologies within the CAPWAP protocol, such
as IEEE 802.16. The protocol should therefore not rely on specifics of IEEE 802.11 technology.

Protocol Requirement: The CAPWAP protocol must be applicable for IEEE 802.11 and other wireless
technologies.                                                                         

Motivation and Protocol Benefits: 

There are many benefits to an extensible protocol. It allows for application in different networks
and provides greater scope. Furthermore, service providers require WLAN solutions that will be able
to meet current and future market requirements.

Relation to Problem Statement: 

The Problem Statement describes some of the advances taking place in other standards bodies like the
IEEE. It is important for the CAPWAP protocol to reflect the advances and provide a framework in
which they can be supported.  

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: subrata goswami <[email-masked]>
Date: Wed, 23 Feb 2005 08:24:20 -0800

Very sensible requirement !

---

From: "James Kempf" <[email-masked]>
Date: Wed, 23 Feb 2005 09:00:41 -0800

This requirement is really vague. It doesn't really constrain the protocol
development at all. What is meant by support for other wireless technologies
in addition to 802.11?

            jak

---

From: subrata goswami <[email-masked]>
Date: Wed, 23 Feb 2005 09:10:43 -0800

Seems clear to me that CAPWAP should handle 802.16,802.20 , 802.15.x  
etc. in addition to 802.11.  If CAPWAP is only
for 802.11, then  it should be addressed in the 802.11 WG in IEEE.

Dr. Subrata Goswami

James Kempf wrote:

>>Replace subsections as full objectives so they can be reviewed
>>    
>>
>independently. Replace
>  
>
>>subsection-5.2.4i-'Enable Support for Future Wireless Technologies' as a
>>    
>>
>separate objective titled
>  
>
>>The rapid pace of technology developments means that new advances need to
>>    
>>
>be catered for in current
>  
>
>>analyses. Among these is the support for new wireless technologies within
>>    
>>
>the CAPWAP protocol, such
>  
>
>>as IEEE 802.16. The protocol should therefore not rely on specifics of
>>    
>>
>IEEE 802.11 technology.
>  
>
>>
>>Protocol Requirement: The CAPWAP protocol must be applicable for IEEE
>>    
>>
>802.11 and other wireless
>  
>
>>technologies.
>>
>>
>>There are many benefits to an extensible protocol. It allows for
>>    
>>
>application in different networks
>  
>
>>and provides greater scope. Furthermore, service providers require WLAN
>>    
>>
>solutions that will be able
>  
>
>>The Problem Statement describes some of the advances taking place in other
>>    
>>
>standards bodies like the
>  
>
>>IEEE. It is important for the CAPWAP protocol to reflect the advances and
>>    
>>
>provide a framework in
>  
>

---

From: "James Kempf" <[email-masked]>
Date: Wed, 23 Feb 2005 09:30:00 -0800

I'm not arguing with the requirement, I just want it to be more specific.
Right now, it isn't. Here is an example of what I think would be a more
specific requirement:

"In all cases where the CAPWAP protocol messages contain specific Layer 2
information elements, the definition of the protocol needs to provide for
extensibility so that these elements can be defined for wireless protocols
other than 802.11."

There may be additional such requirements involving architecture, transport,
etc.

If we can't get a set of specific requirements that constrain the protocol
in this area, then I think this requirement should be dropped. In the past,
such vague, motherhood and apple pie requirements have not had much success
in passing IESG muster, to say nothing of providing any helpful guidance in
protocol development.

            jak

---

From: subrata goswami <[email-masked]>
Date: Wed, 23 Feb 2005 09:43:15 -0800

i see, see if you like my rewording inline below.

"In all cases where the CAPWAP protocol messages contain specific Layer 2
information elements, the definition of the protocol needs to provide for
extensibility so that these elements can be defined for specific 
layer 2 wireless protocols (e.g. 802.11, 802.16, 802.15.x etc). This may
entail assigning a layer 2 wireless protocol type and version field to the
message PDU. "

>>>This requirement is really vague. It doesn't really constrain the
>>>      
>>>
>protocol
>  
>
>>>development at all. What is meant by support for other wireless
>>>      
>>>
>technologies
>  
>
>>>in addition to 802.11?
>>>
>>>           jak
>>>
>>>
>>>>The rapid pace of technology developments means that new advances need
>>>>        
>>>>
>to
>  
>
>>>>        
>>>>
>>>>analyses. Among these is the support for new wireless technologies
>>>>        
>>>>
>within
>  
>
>>>>        
>>>>
>>>>The Problem Statement describes some of the advances taking place in
>>>>        
>>>>
>other
>  
>
>>>>        
>>>>
>>>>IEEE. It is important for the CAPWAP protocol to reflect the advances
>>>>        
>>>>
>and
>  
>
>>>>        
>>>>
>>>provide a framework in
>>>
>>>
>>>      
>>>

---

From: "James Kempf" <[email-masked]>
Date: Wed, 23 Feb 2005 09:57:13 -0800

> layer 2 wireless protocols (e.g. 802.11, 802.16, 802.15.x etc). This may

The problem with mentioning these is it might be construed to exclude
others. If you want to include specific reference, I'd suggest adding a
sentence at the end of the paragraph that says something like:

"Examples of other wireless protocols that might be supported include but
are not limited to 802.16e, 802.15.x, etc.

> entail assigning a layer 2 wireless protocol type and version field to the

Hmm, well, that's a bit too specific for a requirement. But, off the top of
my head, I can't think of any other way one could do this, so I suppose it's
OK.

            jak

---

From: "Saravanan Govindan" <[email-masked]>
Date: Thu, 24 Feb 2005 17:42:45 +0800

Hi Subrata, James,

Thank you for your comments and suggestions. 

In summary, the suggestion is to clearly specify what the CAPWAP protocol needs in terms of
applicability to 802.11 and non-802.11 technologies.  

Please consider the following text which combines the proposals from James and Subrata.

-------
(Include the following in Description)

"In all cases where the CAPWAP protocol messages contain specific Layer 2 information elements, the
definition of the protocol needs to provide for extensibility so that these elements can be defined
for specific layer 2 wireless protocols. This may entail assigning a layer 2 wireless protocol type
and version field to the message PDU. Examples of other wireless protocols that might be supported
include but are not limited to 802.16e, 802.15.x, etc." 
----XXXX----

Cheers,

Saravanan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of James Kempf
> Sent: Thursday, February 24, 2005 1:57 AM
> To: subrata goswami; [email-masked]
> > >"In all cases where the CAPWAP protocol messages contain specific 
> > >Layer 2 information elements, the definition of the 
> protocol needs to 
> > >provide for extensibility so that these elements can be 
> defined for 
> > >wireless
> protocols
> > >other than 802.11."
> > >
> > >
> >
> > "In all cases where the CAPWAP protocol messages contain specific 
> > Layer 2 information elements, the definition of the 
> protocol needs to 
> > provide for extensibility so that these elements can be defined for 
> > specific layer 2 wireless protocols (e.g. 802.11, 802.16, 802.15.x 
> > etc). This may
> 
> The problem with mentioning these is it might be construed to 
> exclude others. If you want to include specific reference, 
> I'd suggest adding a sentence at the end of the paragraph 
> that says something like:
> 
> "Examples of other wireless protocols that might be supported 
> include but are not limited to 802.16e, 802.15.x, etc.
> 
> > entail assigning a layer 2 wireless protocol type and 
> version field to 
> > the message PDU. "
> >
> 
> Hmm, well, that's a bit too specific for a requirement. But, 
> off the top of my head, I can't think of any other way one 
> could do this, so I suppose it's OK.
> 
>             jak
> 
> 
>

---

From: subrata goswami <[email-masked]>
Date: Thu, 24 Feb 2005 08:33:05 -0800

Saravanan , seems okay to me.

Subrata

---

From: "James Kempf" <[email-masked]>
Date: Thu, 24 Feb 2005 10:24:11 -0800

Looks fine.

        jak

----- Original Message ----- 
From: "Saravanan Govindan" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, February 24, 2005 1:42 AM
Subject: RE: [Capwap] Additions #12 - Future Wireless Technologies

> "In all cases where the CAPWAP protocol messages contain specific Layer 2
information elements, the

---

From: "James Kempf" <[email-masked]>
Date: Thu, 24 Feb 2005 10:25:52 -0800

I don't recall seeing anything about independence of IP version. I think
CAPWAP needs to be defined such that it will run on IPv4 or IPv6.

            jak