Subject: [Capwap] Additions #19 - CAPWAP Protocol Security

From: "Saravanan Govindan" <[email-masked]>
Date: Wed, 23 Feb 2005 18:20:44 +0800

Additions #19 - CAPWAP Protocol Security

Issue: 

Additional text clarifying mutual authentication of AC and WTPs. Proposed changes are for
Objective-5.2.10-'CAPWAP Protocol Security'.

Proposed change: 

Priority: Mandatory

Description: 

(Replace first sentence of first paragraph) 
The CAPWAP protocol must first ensure that the participating entities - centralized controller and
WTPs - are mutually authenticated. Once this has been established, the information exchanges between
them must be secured against various security threats. 

As such, it must provide ......

Protocol Requirement: 

The CAPWAP protocol must support mutual authentication of WTPs and the centralized controller. It
must also ensure that information exchanges between them are secured. 

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "James Kempf" <[email-masked]>
Date: Wed, 23 Feb 2005 09:06:37 -0800

I would additionally suggest adding to this that the key distribution
protocol must be designed so as to minimize the possibility of future
compromises after the keys are distributed.

            jak

---

From: Dan Harkins <[email-masked]>
Date: Wed, 23 Feb 2005 09:45:52 -0800

The words "key distribution" seem to preclude a key agreement
protocol like Diffie-Hellman so I'd suggest not using them.

  In addition, I'd like to suggest that asymmetric, non-mutual, 
authentication be possible in the CAPWAP protocol. Not that it's
the default or even the mandatory-to-implement, just that it's
not forbidden.

  Dan.

On Wed, 23 Feb 2005 09:06:37 PST you wrote

---

From: "James Kempf" <[email-masked]>
Date: Wed, 23 Feb 2005 09:59:12 -0800

Dan,

Actually, I wanted to include authenticated Diffie-Hellman. Can you suggest
some way that might be changed? Perhaps "negotiation of keying material"?

            jak

----- Original Message ----- 
From: "Dan Harkins" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: "Saravanan Govindan" <[email-masked]>; <[email-masked]>
Sent: Wednesday, February 23, 2005 9:45 AM
Subject: Re: [Capwap] Additions #19 - CAPWAP Protocol Security

> > > Additional text clarifying mutual authentication of AC and WTPs.
Proposed
> > changes are for
> > > The CAPWAP protocol must first ensure that the participating
entities -
> > centralized controller and

---

From: Dan Harkins <[email-masked]>
Date: Wed, 23 Feb 2005 09:58:18 -0800

How about "key establishment protocol" that doesn't say how you
establish it-- could be an RSA key exchange, or a Diffie-Hellman.

  Dan.

On Wed, 23 Feb 2005 09:59:12 PST you wrote

---

From: "James Kempf" <[email-masked]>
Date: Wed, 23 Feb 2005 10:05:49 -0800

Sounds fine.

            jak

----- Original Message ----- 
From: "Dan Harkins" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: "Saravanan Govindan" <[email-masked]>; <[email-masked]>
Sent: Wednesday, February 23, 2005 9:58 AM
Subject: Re: [Capwap] Additions #19 - CAPWAP Protocol Security

> > > > > WTPs - are mutually authenticated. Once this has been established,
the
> > > > information exchanges between
> > > > > The CAPWAP protocol must support mutual authentication of WTPs and
the
> > > > centralized controller. It

---

From: "Saravanan Govindan" <[email-masked]>
Date: Thu, 24 Feb 2005 17:41:34 +0800

Hi James, Dan,

Thank you for your suggestions. 

Summarising the issue, the suggestion is to specify that the CAPWAP protocol must not be compromised
after key establishment. 

Please consider the following text combining suggestions from James and Dan.

----
(Insert in Description)

"Additionally, the key establishment protocol for authentication and securing CAPWAP exchanges must
be designed to minimize the possibility of future compromises after the keys are established.

While mutual authentication is necessary for CAPWAP, the protocol should not prevent the use of
asymmetric, non-mutual authentication. The security considerations of such asymmetric authentication
are described in the Security Considerations section." 
----XXXX----

Cheers,

Saravanan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of James Kempf
> Sent: Thursday, February 24, 2005 2:06 AM
> To: Dan Harkins
> Cc: Saravanan Govindan; [email-masked]
> > > Actually, I wanted to include authenticated 
> Diffie-Hellman. Can you
> suggest

---

From: "James Kempf" <[email-masked]>
Date: Thu, 24 Feb 2005 10:23:57 -0800

Looks fine.

            jak