Subject: [Capwap] Additions #14 - End-user Transparency

From: "Saravanan Govindan" <[email-masked]>
Date: Wed, 23 Feb 2005 18:08:05 +0800

Additions #14 - End-user Transparency

Issue: 

Replace subsections as full objectives so they can be reviewed independently. Replace
subsection-5.2.4iii-'User(Client) Access Requirement' as a separate objective titled 'End-user
Transparency'.

Proposed change: 

Classification: Architecture

Priority: Mandatory

Description: 

The CAPWAP protocol will be used between a centralized controller and a number of WTPs. Its
operations should be independent of the wireless end-user. The end-users should not be required to
be aware of the existence of the CAPWAP protocol.                            

Protocol Requirement: End-users should not be required to recognize the CAPWAP protocol.

Motivation and Protocol Benefits: 

IEEE 802.11 based end-user devices are mature and wide-spread. It would be beneficial for CAPWAP not
to impose new requirements on these numerous devices.                                            

Relation to Problem Statement: 

The Problem Statement highlights the challenges faced by large WLANs consisting of many WTPs. Since
it does not refer to end-user operations, this objective is necessary to emphasize this
independence. 

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "James Kempf" <[email-masked]>
Date: Wed, 23 Feb 2005 09:03:44 -0800

Isn't the issue here the devices and not the users? I think the requirement
should be phrased in terms of the device. Sure, users need to deal with any
additional software or configuration, but I think what the requirement is
trying to get at is that there should be no need to install additional
software specifically for CAPWAP on a host with a wireless interface if the
interface is linked to a wireless network running CAPWAP.

            jak

---

From: "Saravanan Govindan" <[email-masked]>
Date: Thu, 24 Feb 2005 17:43:09 +0800

Hi James,

It is true that transparency here is in terms of the 'device'. 

Consider the following changes to the Additions #14

----
Title: Wireless Terminal Transparency

Description: The CAPWAP protocol will be used between a centralized controller and a number of WTPs.
Its operations should be independent of the wireless terminal. The wireless terminals should not be
required to be aware of the existence of the CAPWAP protocol.

Protocol Requirement: Wireless terminals should not be required to recognize the
CAPWAP protocol.

Motivation and Protocol Benefits: IEEE 802.11 based wireless terminals are mature and wide-spread.
It would be beneficial for CAPWAP not to impose new requirements on these wireless terminals.

Relation to Problem Statement: The Problem Statement highlights the challenges faced by large WLANs
consisting of many WTPs. Since it does not refer to the operations of wireless terminals, this
objective is necessary to emphasize this independence.
----XXXX----

Cheers,

Saravanan

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]] 
> Sent: Thursday, February 24, 2005 1:04 AM
> To: Saravanan Govindan; [email-masked]
> Subject: Re: [Capwap] Additions #14 - End-user Transparency
> 
> Isn't the issue here the devices and not the users? I think 
> the requirement should be phrased in terms of the device. 
> Sure, users need to deal with any additional software or 
> configuration, but I think what the requirement is trying to 
> get at is that there should be no need to install additional 
> software specifically for CAPWAP on a host with a wireless 
> interface if the interface is linked to a wireless network 
> running CAPWAP.
> 
>             jak
> 
> > The CAPWAP protocol will be used between a centralized 
> controller and a
> number of WTPs. Its
> > operations should be independent of the wireless end-user. 
> The end-users
> should not be required to
> > Protocol Requirement: End-users should not be required to 
> recognize the
> CAPWAP protocol.
> >
> >
> >
> > IEEE 802.11 based end-user devices are mature and 
> wide-spread. It would be
> beneficial for CAPWAP not
> > it does not refer to end-user operations, this objective is 
> necessary to
> emphasize this
> > independence.
> >

---

From: "James Kempf" <[email-masked]>
Date: Thu, 24 Feb 2005 10:24:22 -0800

Looks fine.

        jak