Subject: [Capwap] Additions #20 - Key Distribution

From: "Saravanan Govindan" <[email-masked]>
Date: Wed, 23 Feb 2005 18:23:20 +0800

Additions #20 - Key Distribution

Issue: 

Proposal for key distribution as part of IEEE 802.11i considerations for CAPWAP. Proposed changes
are for Objective-5.2.15-'IEEE 802.11i considerations'.

Proposed change: 

Priority: Mandatory                                                                       

Description: 

(Insert after first paragraph) 
For key distribution, CAPWAP must be made aware of IEEE 802.11i exchanges and the location of the
authenticator and encryption points. This need not be explicit but rather an implicit distinction
made during initial configuration of WTPs. This way, CAPWAP can be made to include operations for
handling key exchanges in the different cases, i.e. authenticator, encryption at AC or at WTP.

Protocol Requirement: The CAPWAP protocol is to be made aware of the location of the IEEE 802.11i
authenticator and encryption points.                                     

_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Sadot, Emek (Emek)" <[email-masked]>
Date: Thu, 24 Feb 2005 22:12:02 -0500

Saravanan,

Clearly the location of the authenticator should be known to the CAPWAP,
however the linkage between the CAPWAP and the 802.11i, and exchanges
protocol in particular, is not clear to me.
In my mind the authentication protocol should not be tied with the
CAPWAP protocol nor the specific exchanges protocol. 802.11i is one
instance, other authentication protocol may become handy.

Emek

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Saravanan Govindan
Sent: Wednesday, February 23, 2005 5:23 AM
To: [email-masked]
Subject: [Capwap] Additions #20 - Key Distribution

Issue: 

Proposal for key distribution as part of IEEE 802.11i considerations for
CAPWAP. Proposed changes are for Objective-5.2.15-'IEEE 802.11i
considerations'.

Proposed change: 

Priority: Mandatory

Description: 

(Insert after first paragraph)
For key distribution, CAPWAP must be made aware of IEEE 802.11i
exchanges and the location of the authenticator and encryption points.
This need not be explicit but rather an implicit distinction made during
initial configuration of WTPs. This way, CAPWAP can be made to include
operations for handling key exchanges in the different cases, i.e.
authenticator, encryption at AC or at WTP.

Protocol Requirement: The CAPWAP protocol is to be made aware of the
location of the IEEE 802.11i
authenticator and encryption points.